<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Elizabeth &#039;Bette&#039; Gambino, 85 | RiverheadLOCAL</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="pingback" href="https://riverheadlocal.com/xmlrpc.php" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<link rel="icon" type="image/png" href="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/favicon.png">

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Elizabeth &#039;Bette&#039; Gambino, 85 | RiverheadLOCAL" />
<meta property="og:description" content="Elizabeth &#8220;Bette&#8221; Gambino died at Peconic Bay Medical Center on May 13, 2020. She was 85 years old. She was born on Dec. 16, 1934 in Brooklyn to Margaret (Jennings) and Thomas Casey. She worked as a tax examiner for the IRS in Yaphank. She was predeceased by her husband Ernest. She is survived by &hellip;" />
<meta property="og:url" content="https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/" />
<meta property="og:site_name" content="RiverheadLOCAL" />
<meta property="article:section" content="Obituaries" />
<meta property="article:published_time" content="2020-05-16T12:48:51+00:00" />
<meta property="article:modified_time" content="2020-05-16T12:48:57+00:00" />
<meta property="og:updated_time" content="2020-05-16T12:48:57+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Elizabeth &#8220;Bette&#8221; Gambino died at Peconic Bay Medical Center on May 13, 2020. She was 85 years old. She was born on Dec. 16, 1934 in Brooklyn to Margaret (Jennings) and Thomas Casey. She worked as a tax examiner for the IRS in Yaphank. She was predeceased by her husband Ernest. She is survived by [&hellip;]" />
<meta name="twitter:title" content="Elizabeth &#039;Bette&#039; Gambino, 85 | RiverheadLOCAL" />
<meta name="twitter:image" content="http://eastendlocal.com/wp-content/uploads/2014/09/LOCAL-300x91.png" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://riverheadlocal.com/#website","url":"https://riverheadlocal.com/","name":"RiverheadLOCAL","inLanguage":"en-US","description":"News and events for Riverhead, New York","potentialAction":[{"@type":"SearchAction","target":"https://riverheadlocal.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"WebPage","@id":"https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/#webpage","url":"https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/","name":"Elizabeth &#039;Bette&#039; Gambino, 85 | RiverheadLOCAL","isPartOf":{"@id":"https://riverheadlocal.com/#website"},"inLanguage":"en-US","datePublished":"2020-05-16T12:48:51+00:00","dateModified":"2020-05-16T12:48:57+00:00","author":{"@id":"https://riverheadlocal.com/#/schema/person/d176783e504eaed24b0e395623cb4932"},"potentialAction":[{"@type":"ReadAction","target":["https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/"]}]},{"@type":["Person"],"@id":"https://riverheadlocal.com/#/schema/person/d176783e504eaed24b0e395623cb4932","name":"RiverheadLOCAL","image":{"@type":"ImageObject","@id":"https://riverheadlocal.com/#authorlogo","inLanguage":"en-US","url":"https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/Local_Black_Flat_130.png?fit=96%2C34&quality=100&ssl=1","caption":"RiverheadLOCAL"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Feed" href="https://riverheadlocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Comments Feed" href="https://riverheadlocal.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='kb-membership-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-membership/inc/style.css?ver=6.1.991' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/jquery-ui-dialog.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fc-form-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/Formcraft/assets/css/form.min.css?ver=3.2.27' type='text/css' media='all' />
<link rel='stylesheet' id='kb-liveblog-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-liveblog/style.css?ver=6.0.200' type='text/css' media='all' />
<link rel='stylesheet' id='public_notices_css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-public-notices/kb-public-notices.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-top-stories-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-top-stories/style.css?ver=1.1.735' type='text/css' media='all' />
<link rel='stylesheet' id='trans-frontend-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-translation/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-min-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/icons/css/weather-icons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-wind-min-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/icons/css/weather-icons-wind.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-weather-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/css/kb-weather.css?ver=1.7.434' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/Newsmag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/style.css?ver=5.0.0213' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C100%2C100italic%2C200%2C200italic%2C300italic%2C400italic%2C500%2C500italic%2C600italic%2C700italic%2C800%2C800italic%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C100%2C100italic%2C200%2C200italic%2C500%2C500italic%2C600%2C600italic%2C800%2C800italic&#038;ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1125px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1124px){
.a2a_floating_style.a2a_default_style{display:none;}
}
.a2a_floating_style {
    padding: 20px;
    border-radius: 0;
    border: 1px solid #bbbbbb;
}
</style>
<link rel='stylesheet' id='js_composer_front-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/style.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-membership/inc/button.js?ver=6.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-liveblog/scripts.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/js/modernizr.custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/js/summary-box.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.25'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/common-scripts.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/popup-menu-fix.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://riverheadlocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverheadlocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverheadlocal.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://riverheadlocal.com/?p=135483' />
<link rel="alternate" type="application/json+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color = "#A0A0A0";

a2a_config.templates = {
    email: {
        subject: "RiverheadLOCAL: ${title}",
        body: "Check out this story on RiverheadLOCAL: \n${title}\n${link}"
    }
};

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      }; 
})(jQuery);
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>


<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Elizabeth &#039;Bette&#039; Gambino, 85 | RiverheadLOCAL","pagePostType":"post","pagePostType2":"single-post","pageCategory":["obituaries"],"pagePostAuthor":"RiverheadLOCAL","pagePostDate":"May 16, 2020, 8:48 am","pagePostDateYear":"2020","pagePostDateMonth":"05","pagePostDateDay":"16"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N97RFZC');//]]>
</script>


<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<script src="https://use.fontawesome.com/b3fb28acc8.js"></script><meta property="fb:app_id" content="105130769527571" /><meta name="google-site-verification" content="7jViI0XrkgkIYGyQD0GNoWcify30WyzN3o4ZHzUGfdo" /><script data-ad-client="ca-pub-6009741394491678" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var adSlotLeaderboard = googletag.defineSlot('/21874054635/Sitewide', [728, 90], 'div-gpt-ad-leaderboard');
    adSlotLeaderboard.addService(googletag.pubads());
    adSlotLeaderboard.setTargeting('position', ['leaderboard']);
    var adSlotSidebar1= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-1');
	    adSlotSidebar1.addService(googletag.pubads());
	    adSlotSidebar1.setTargeting('position', ['sidebar']);
	    var adSlotSidebar2= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-2');
	    adSlotSidebar2.addService(googletag.pubads());
	    adSlotSidebar2.setTargeting('position', ['sidebar']);
	    var adSlotSidebar3= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-3');
	    adSlotSidebar3.addService(googletag.pubads());
	    adSlotSidebar3.setTargeting('position', ['sidebar']);
	    var adSlotSidebar4= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-4');
	    adSlotSidebar4.addService(googletag.pubads());
	    adSlotSidebar4.setTargeting('position', ['sidebar']);
	    var adSlotSidebar5= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-5');
	    adSlotSidebar5.addService(googletag.pubads());
	    adSlotSidebar5.setTargeting('position', ['sidebar']);
	    var adSlotSidebar = googletag.defineSlot('/21874054635/Sitewide', ['fluid'], 'div-gpt-ad-lead-sidebar');
    adSlotSidebar.addService(googletag.pubads());
    adSlotSidebar.setTargeting('position', ['lead-sidebar']);
    
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://riverheadlocal.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '82fba20f-da37-4c38-a7fe-ee7dbe081e0f';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://riverheadlocal.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.370dd028-ab8a-4720-9087-4e2c917686de";
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_ajax_url="https:\/\/riverheadlocal.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=4.3";
var td_get_template_directory_uri="https:\/\/riverheadlocal.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e12025";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=32%2C32&#038;quality=100&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>
<body class="post-template-default single single-post postid-135483 single-format-standard author-riverheadlocal elizabeth-bette-gambino-85 global-block-template-1 white-menu wpb-js-composer js-comp-ver-6.1 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N97RFZC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '105130769527571',
      xfbml      : true,
      version    : 'v2.9'
    });
    FB.AppEvents.logPageView();
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div class="td-mobile-container">

<div class="kb-menu-socials-wrap">

<div class="kb-menu-socials">
</div>
</div>

<div class="kb-mobile-search-container"><form method="get" class="td-search-form-widget" action="https://riverheadlocal.com/">
<div role="search" class="kb-mobile-search">
<button class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit"><i class="td-icon-search"></i></button>
<div class="kb-search-input-wrap"><input class="td-widget-search-input" type="text" value="Search" name="s" id="s" onfocus="if (this.value=='Search') this.value='';" onblur="if (this.value=='') this.value='Search';" /></div>
</div>
</form>
</div>

<div class="td-mobile-content">
<div class="menu-mobile-container"><ul id="menu-mobile" class="td-mobile-main-menu"><li id="menu-item-116721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-116721"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100685" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100685"><a href="https://riverheadlocal.com/news/">News</a></li>
<li id="menu-item-100683" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100683"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a></li>
<li id="menu-item-100686" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-100686"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100687" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100687"><a href="https://riverheadlocal.com/community/">Community</a></li>
<li id="menu-item-100693" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-100693"><a href="http://eastendlocal.com">Events</a></li>
<li id="menu-item-100688" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100688"><a href="https://riverheadlocal.com/schools/">Schools</a></li>
<li id="menu-item-100684" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100684"><a href="https://riverheadlocal.com/business/business-news/">Business</a></li>
<li id="menu-item-100691" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100691"><a href="https://riverheadlocal.com/living/">Living</a></li>
<li id="menu-item-100692" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100692"><a href="https://riverheadlocal.com/opinion/">Opinion</a></li>
<li id="menu-item-100694" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100694"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-108418" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108418"><a href="https://classifieds.eastendlocal.com">Classifieds</a></li>
<li id="menu-item-100695" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-100695"><a href="https://riverheadlocal.com/contact/">Contact RiverheadLOCAL</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div id="kb-overlay"></div>
<div class="td-header-wrap td-header-style-3">
<div class="td-top-menu-full">
<div class="td-header-row td-header-top-menu td-make-full">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-100681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-100681"><a href="https://riverheadlocal.com/contact/">Contact</a></li>
<li id="menu-item-130976" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-130976"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-100680" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100680"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-24924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24924"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-116691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116691"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-24925" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24925"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/classifieds/">Classifieds</a></li>
<li id="menu-item-129406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129406"><a href="https://riverheadlocal.com/support-local-journalism/">Membership</a></li>
</ul></div></div> </div>

</div>
</div>

<div class="td-header-container">
<div class="td-header-logo-wrap">
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
<span class="td-visual-hidden">RiverheadLOCAL</span>
</a>
</div>
<div class="td-header-right-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-main-menu">
<div class="td-header-menu-wrap-sub">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-header-right-header mobile-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main" class="sf-menu"><li id="menu-item-100668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-100668"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100671" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100671"><a href="https://riverheadlocal.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_5ec01319ab3b2 = new tdBlock();
block_td_uid_1_5ec01319ab3b2.id = "td_uid_1_5ec01319ab3b2";
block_td_uid_1_5ec01319ab3b2.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"103","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5ec01319ab3b2_rand","tdc_css_class":"td_uid_1_5ec01319ab3b2_rand","tdc_css_class_style":"td_uid_1_5ec01319ab3b2_rand_style"}';
block_td_uid_1_5ec01319ab3b2.td_column_number = "3";
block_td_uid_1_5ec01319ab3b2.block_type = "td_block_mega_menu";
block_td_uid_1_5ec01319ab3b2.post_count = "5";
block_td_uid_1_5ec01319ab3b2.found_posts = "6272";
block_td_uid_1_5ec01319ab3b2.header_color = "";
block_td_uid_1_5ec01319ab3b2.ajax_pagination_infinite_stop = "";
block_td_uid_1_5ec01319ab3b2.max_num_pages = "1255";
tdBlocksArray.push(block_td_uid_1_5ec01319ab3b2);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_1_5ec01319ab3b2_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_5ec01319ab3b2"><div id=td_uid_1_5ec01319ab3b2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/15/a-heros-homecoming-for-riverhead-cop-seriously-injured-in-line-of-duty-crash-march-31/" rel="bookmark" class="td-image-wrap" title="A hero&#8217;s homecoming for Riverhead cop seriously injured in line-of-duty crash March 31"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sproston-homecoming.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="A hero&#8217;s homecoming for Riverhead cop seriously injured in line-of-duty crash March 31" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/15/a-heros-homecoming-for-riverhead-cop-seriously-injured-in-line-of-duty-crash-march-31/" rel="bookmark" title="A hero&#8217;s homecoming for Riverhead cop seriously injured in line-of-duty crash March 31">A hero&#8217;s homecoming for Riverhead cop seriously injured in line-of-duty crash March 31</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/15/new-york-will-open-state-beaches-next-friday-with-restrictions/" rel="bookmark" class="td-image-wrap" title="New York will open state beaches next Friday &#8211; with restrictions"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="New York will open state beaches next Friday &#8211; with restrictions" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/15/new-york-will-open-state-beaches-next-friday-with-restrictions/" rel="bookmark" title="New York will open state beaches next Friday &#8211; with restrictions">New York will open state beaches next Friday &#8211; with restrictions</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/15/new-york-on-pause-is-extended-until-may-29/" rel="bookmark" class="td-image-wrap" title="&#8216;New York on Pause&#8217; is extended until May 29"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="&#8216;New York on Pause&#8217; is extended until May 29" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/15/new-york-on-pause-is-extended-until-may-29/" rel="bookmark" title="&#8216;New York on Pause&#8217; is extended until May 29">&#8216;New York on Pause&#8217; is extended until May 29</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/14/n-y-state-issues-criteria-for-pediatric-inflammatory-syndrome-associated-with-covid-19/" rel="bookmark" class="td-image-wrap" title="N.Y. State issues criteria for pediatric inflammatory syndrome thought to be associated with COVID-19, CDC issues health advisory"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_sick_child_fever.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="N.Y. State issues criteria for pediatric inflammatory syndrome thought to be associated with COVID-19, CDC issues health advisory" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/14/n-y-state-issues-criteria-for-pediatric-inflammatory-syndrome-associated-with-covid-19/" rel="bookmark" title="N.Y. State issues criteria for pediatric inflammatory syndrome thought to be associated with COVID-19, CDC issues health advisory">N.Y. State issues criteria for pediatric inflammatory syndrome thought to be associated with COVID-19, CDC issues health advisory</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/14/riverhead-town-2020-beach-parking-permits-on-sale-friday-and-saturday/" rel="bookmark" class="td-image-wrap" title="Riverhead Town 2020 beach parking permits on sale Friday and Saturday"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0122_Jamesport-town-beach-July-2019-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead Town 2020 beach parking permits on sale Friday and Saturday" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/14/riverhead-town-2020-beach-parking-permits-on-sale-friday-and-saturday/" rel="bookmark" title="Riverhead Town 2020 beach parking permits on sale Friday and Saturday">Riverhead Town 2020 beach parking permits on sale Friday and Saturday</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_5ec01319ab3b2" id="td_uid_2_5ec01319b194f" data-td_block_id="td_uid_1_5ec01319ab3b2" data-td_filter_value="" href="https://riverheadlocal.com/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_5ec01319ab3b2" id="td_uid_3_5ec01319b19c2" data-td_block_id="td_uid_1_5ec01319ab3b2" data-td_filter_value="105" href="https://riverheadlocal.com/news/local-news/">Local News</a><a class="mega-menu-sub-cat-td_uid_1_5ec01319ab3b2" id="td_uid_4_5ec01319b1a45" data-td_block_id="td_uid_1_5ec01319ab3b2" data-td_filter_value="32" href="https://riverheadlocal.com/news/local-news/health/">Health</a><a class="mega-menu-sub-cat-td_uid_1_5ec01319ab3b2" id="td_uid_5_5ec01319b1ab0" data-td_block_id="td_uid_1_5ec01319ab3b2" data-td_filter_value="16007" href="https://riverheadlocal.com/news/local-news/weekly-roundup/">Weekly Roundup</a><a class="mega-menu-sub-cat-td_uid_1_5ec01319ab3b2" id="td_uid_6_5ec01319b1b57" data-td_block_id="td_uid_1_5ec01319ab3b2" data-td_filter_value="108" href="https://riverheadlocal.com/news/public-notices/">Public Notices</a><a class="mega-menu-sub-cat-td_uid_1_5ec01319ab3b2" id="td_uid_7_5ec01319b1bca" data-td_block_id="td_uid_1_5ec01319ab3b2" data-td_filter_value="104" href="https://riverheadlocal.com/news/town-hall-notebook/">Town Hall Notebook</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5ec01319ab3b2" data-td_block_id="td_uid_1_5ec01319ab3b2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5ec01319ab3b2" data-td_block_id="td_uid_1_5ec01319ab3b2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100669" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100669"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_8_5ec01319cd31e = new tdBlock();
block_td_uid_8_5ec01319cd31e.id = "td_uid_8_5ec01319cd31e";
block_td_uid_8_5ec01319cd31e.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_8_5ec01319cd31e_rand","tdc_css_class":"td_uid_8_5ec01319cd31e_rand","tdc_css_class_style":"td_uid_8_5ec01319cd31e_rand_style"}';
block_td_uid_8_5ec01319cd31e.td_column_number = "3";
block_td_uid_8_5ec01319cd31e.block_type = "td_block_mega_menu";
block_td_uid_8_5ec01319cd31e.post_count = "5";
block_td_uid_8_5ec01319cd31e.found_posts = "2411";
block_td_uid_8_5ec01319cd31e.header_color = "";
block_td_uid_8_5ec01319cd31e.ajax_pagination_infinite_stop = "";
block_td_uid_8_5ec01319cd31e.max_num_pages = "483";
tdBlocksArray.push(block_td_uid_8_5ec01319cd31e);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_8_5ec01319cd31e_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_8_5ec01319cd31e"><div id=td_uid_8_5ec01319cd31e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/14/information-sought-on-five-fires-in-pine-barrens-since-mid-april/" rel="bookmark" class="td-image-wrap" title="Information sought on five fires in Pine Barrens since mid-April"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=912%2C682&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Information sought on five fires in Pine Barrens since mid-April" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/14/information-sought-on-five-fires-in-pine-barrens-since-mid-april/" rel="bookmark" title="Information sought on five fires in Pine Barrens since mid-April">Information sought on five fires in Pine Barrens since mid-April</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/14/police-search-for-missing-runaway/" rel="bookmark" class="td-image-wrap" title="Police search for missing runaway"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_Sam_Farid.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_Sam_Farid.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_Sam_Farid.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_Sam_Farid.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_Sam_Farid.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_Sam_Farid.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_Sam_Farid.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Police search for missing runaway" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/14/police-search-for-missing-runaway/" rel="bookmark" title="Police search for missing runaway">Police search for missing runaway</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/05/riverhead-man-charged-in-wading-river-burglary/" rel="bookmark" class="td-image-wrap" title="Riverhead man charged in Wading River burglary"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead man charged in Wading River burglary" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/05/riverhead-man-charged-in-wading-river-burglary/" rel="bookmark" title="Riverhead man charged in Wading River burglary">Riverhead man charged in Wading River burglary</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/05/wild-fire-burns-manorville-woods/" rel="bookmark" class="td-image-wrap" title="Wild fire burns Manorville woods"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=912%2C682&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-05-05_Manorville-Ridge_Brush_Fire-Lambui_D850_103_of_205-copy.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Wild fire burns Manorville woods" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/05/wild-fire-burns-manorville-woods/" rel="bookmark" title="Wild fire burns Manorville woods">Wild fire burns Manorville woods</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/04/police-search-for-runaways-from-riverhead-childrens-home/" rel="bookmark" class="td-image-wrap" title="Police search for runaways from Riverhead children&#8217;s home"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=687%2C512&#038;quality=100&#038;ssl=1 687w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2929-0504-missing-boys.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Police search for runaways from Riverhead children&#8217;s home" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/04/police-search-for-runaways-from-riverhead-childrens-home/" rel="bookmark" title="Police search for runaways from Riverhead children&#8217;s home">Police search for runaways from Riverhead children&#8217;s home</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_8_5ec01319cd31e" id="td_uid_9_5ec01319d142f" data-td_block_id="td_uid_8_5ec01319cd31e" data-td_filter_value="" href="https://riverheadlocal.com/police-fire/">All</a><a class="mega-menu-sub-cat-td_uid_8_5ec01319cd31e" id="td_uid_10_5ec01319d14af" data-td_block_id="td_uid_8_5ec01319cd31e" data-td_filter_value="42" href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a><a class="mega-menu-sub-cat-td_uid_8_5ec01319cd31e" id="td_uid_11_5ec01319d1507" data-td_block_id="td_uid_8_5ec01319cd31e" data-td_filter_value="41" href="https://riverheadlocal.com/police-fire/police-blotter/">Police Reports</a><a class="mega-menu-sub-cat-td_uid_8_5ec01319cd31e" id="td_uid_12_5ec01319d158a" data-td_block_id="td_uid_8_5ec01319cd31e" data-td_filter_value="43" href="https://riverheadlocal.com/police-fire/riverhead-justice-court/">Riverhead Justice Court</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_8_5ec01319cd31e" data-td_block_id="td_uid_8_5ec01319cd31e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_8_5ec01319cd31e" data-td_block_id="td_uid_8_5ec01319cd31e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100672" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-100672"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100673" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100673"><a href="https://riverheadlocal.com/community/">Community</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_13_5ec01319e4a3f = new tdBlock();
block_td_uid_13_5ec01319e4a3f.id = "td_uid_13_5ec01319e4a3f";
block_td_uid_13_5ec01319e4a3f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"113","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_5ec01319e4a3f_rand","tdc_css_class":"td_uid_13_5ec01319e4a3f_rand","tdc_css_class_style":"td_uid_13_5ec01319e4a3f_rand_style"}';
block_td_uid_13_5ec01319e4a3f.td_column_number = "3";
block_td_uid_13_5ec01319e4a3f.block_type = "td_block_mega_menu";
block_td_uid_13_5ec01319e4a3f.post_count = "5";
block_td_uid_13_5ec01319e4a3f.found_posts = "3837";
block_td_uid_13_5ec01319e4a3f.header_color = "";
block_td_uid_13_5ec01319e4a3f.ajax_pagination_infinite_stop = "";
block_td_uid_13_5ec01319e4a3f.max_num_pages = "768";
tdBlocksArray.push(block_td_uid_13_5ec01319e4a3f);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_13_5ec01319e4a3f_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_5ec01319e4a3f"><div id=td_uid_13_5ec01319e4a3f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/16/peconic-bay-medical-center-golf-classic-rescheduled-to-september/" rel="bookmark" class="td-image-wrap" title="Peconic Bay Medical Center Golf Classic rescheduled to September"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2015/06/38746331_s.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2015/06/38746331_s.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2015/06/38746331_s.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Peconic Bay Medical Center Golf Classic rescheduled to September" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/16/peconic-bay-medical-center-golf-classic-rescheduled-to-september/" rel="bookmark" title="Peconic Bay Medical Center Golf Classic rescheduled to September">Peconic Bay Medical Center Golf Classic rescheduled to September</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/16/town-of-southampton-2020-beach-permits-are-available-for-purchase/" rel="bookmark" class="td-image-wrap" title="Town of Southampton 2020 beach permits are available for purchase"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Coopers_Beach_Southampton.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Town of Southampton 2020 beach permits are available for purchase" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/16/town-of-southampton-2020-beach-permits-are-available-for-purchase/" rel="bookmark" title="Town of Southampton 2020 beach permits are available for purchase">Town of Southampton 2020 beach permits are available for purchase</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/15/sheriffs-office-honors-health-care-workers-with-parade/" rel="bookmark" class="td-image-wrap" title="Sheriff&#8217;s Office honors health care workers with parade"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0515_sheriff_drive_by-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Sheriff&#8217;s Office honors health care workers with parade" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/15/sheriffs-office-honors-health-care-workers-with-parade/" rel="bookmark" title="Sheriff&#8217;s Office honors health care workers with parade">Sheriff&#8217;s Office honors health care workers with parade</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/14/flanders-church-offers-drive-through-super-market-thursday-from-1-to-2-p-m/" rel="bookmark" class="td-image-wrap" title="Flanders church offers drive-through &#8216;super market&#8217; Thursday from 1 to 2 p.m."><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0514_Blaze-Church-food-distribution.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Flanders church offers drive-through &#8216;super market&#8217; Thursday from 1 to 2 p.m." /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/14/flanders-church-offers-drive-through-super-market-thursday-from-1-to-2-p-m/" rel="bookmark" title="Flanders church offers drive-through &#8216;super market&#8217; Thursday from 1 to 2 p.m.">Flanders church offers drive-through &#8216;super market&#8217; Thursday from 1 to 2 p.m.</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/13/what-to-do-in-a-medical-emergency-pbmc-doctors-in-facebook-live-event/" rel="bookmark" class="td-image-wrap" title="What to do in a medical emergency: PBMC doctors in Facebook Live event"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-13-at-5.08.02-AM.png?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-13-at-5.08.02-AM.png?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-13-at-5.08.02-AM.png?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-13-at-5.08.02-AM.png?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-13-at-5.08.02-AM.png?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-13-at-5.08.02-AM.png?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-13-at-5.08.02-AM.png?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="What to do in a medical emergency: PBMC doctors in Facebook Live event" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/13/what-to-do-in-a-medical-emergency-pbmc-doctors-in-facebook-live-event/" rel="bookmark" title="What to do in a medical emergency: PBMC doctors in Facebook Live event">What to do in a medical emergency: PBMC doctors in Facebook Live event</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_5ec01319e4a3f" id="td_uid_14_5ec01319eaeb3" data-td_block_id="td_uid_13_5ec01319e4a3f" data-td_filter_value="" href="https://riverheadlocal.com/community/">All</a><a class="mega-menu-sub-cat-td_uid_13_5ec01319e4a3f" id="td_uid_15_5ec01319eaf2e" data-td_block_id="td_uid_13_5ec01319e4a3f" data-td_filter_value="128" href="https://riverheadlocal.com/community/announcements/">Announcements</a><a class="mega-menu-sub-cat-td_uid_13_5ec01319e4a3f" id="td_uid_16_5ec01319eaf8c" data-td_block_id="td_uid_13_5ec01319e4a3f" data-td_filter_value="126" href="https://riverheadlocal.com/community/community-news/">Community News</a><a class="mega-menu-sub-cat-td_uid_13_5ec01319e4a3f" id="td_uid_17_5ec01319eb016" data-td_block_id="td_uid_13_5ec01319e4a3f" data-td_filter_value="127" href="https://riverheadlocal.com/community/event-photos/">Event Photos</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_5ec01319e4a3f" data-td_block_id="td_uid_13_5ec01319e4a3f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_5ec01319e4a3f" data-td_block_id="td_uid_13_5ec01319e4a3f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100674" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100674"><a href="https://riverheadlocal.com/schools/">Schools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_18_5ec0131a0eb4f = new tdBlock();
block_td_uid_18_5ec0131a0eb4f.id = "td_uid_18_5ec0131a0eb4f";
block_td_uid_18_5ec0131a0eb4f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"185","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_5ec0131a0eb4f_rand","tdc_css_class":"td_uid_18_5ec0131a0eb4f_rand","tdc_css_class_style":"td_uid_18_5ec0131a0eb4f_rand_style"}';
block_td_uid_18_5ec0131a0eb4f.td_column_number = "3";
block_td_uid_18_5ec0131a0eb4f.block_type = "td_block_mega_menu";
block_td_uid_18_5ec0131a0eb4f.post_count = "5";
block_td_uid_18_5ec0131a0eb4f.found_posts = "1801";
block_td_uid_18_5ec0131a0eb4f.header_color = "";
block_td_uid_18_5ec0131a0eb4f.ajax_pagination_infinite_stop = "";
block_td_uid_18_5ec0131a0eb4f.max_num_pages = "361";
tdBlocksArray.push(block_td_uid_18_5ec0131a0eb4f);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_18_5ec0131a0eb4f_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_18_5ec0131a0eb4f"><div id=td_uid_18_5ec0131a0eb4f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/13/outgoing-school-board-member-looks-back-on-12-year-tenure-i-have-no-regrets-about-anything/" rel="bookmark" class="td-image-wrap" title="Outgoing school board member  looks back on 12-year tenure: &#8216;I have no regrets about anything&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0513_Greg-Meyer-Feb.-25-2020-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Outgoing school board member  looks back on 12-year tenure: &#8216;I have no regrets about anything&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/13/outgoing-school-board-member-looks-back-on-12-year-tenure-i-have-no-regrets-about-anything/" rel="bookmark" title="Outgoing school board member  looks back on 12-year tenure: &#8216;I have no regrets about anything&#8217;">Outgoing school board member looks back on 12-year tenure: &#8216;I have no regrets about anything&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/12/riverhead-school-board-adopts-147-1-million-proposed-budget-schedules-may-26-public-hearing/" rel="bookmark" class="td-image-wrap" title="Riverhead school board adopts $147.1 million proposed budget, schedules May 26 public hearing"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0512_school-board.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0512_school-board.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0512_school-board.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0512_school-board.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0512_school-board.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0512_school-board.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0512_school-board.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0512_school-board.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead school board adopts $147.1 million proposed budget, schedules May 26 public hearing" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/12/riverhead-school-board-adopts-147-1-million-proposed-budget-schedules-may-26-public-hearing/" rel="bookmark" title="Riverhead school board adopts $147.1 million proposed budget, schedules May 26 public hearing">Riverhead school board adopts $147.1 million proposed budget, schedules May 26 public hearing</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/11/nine-vie-for-three-open-school-board-seats-in-june-9-mail-in-balloting/" rel="bookmark" class="td-image-wrap" title="Nine vie for three open school board seats in June 9 mail-in balloting"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?w=1024&#038;quality=100&#038;ssl=1 1024w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Pulaski-Street-School-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Nine vie for three open school board seats in June 9 mail-in balloting" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/11/nine-vie-for-three-open-school-board-seats-in-june-9-mail-in-balloting/" rel="bookmark" title="Nine vie for three open school board seats in June 9 mail-in balloting">Nine vie for three open school board seats in June 9 mail-in balloting</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/08/school-board-candidate-nominations-due-monday-virtual-budget-hearing-set-for-may-26-ahead-of-june-9-vote/" rel="bookmark" class="td-image-wrap" title="School board candidate nominations due Monday, virtual budget hearing set for May 26 ahead of June 9 vote"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0508_mail-in-ballot.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="School board candidate nominations due Monday, virtual budget hearing set for May 26 ahead of June 9 vote" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/08/school-board-candidate-nominations-due-monday-virtual-budget-hearing-set-for-may-26-ahead-of-june-9-vote/" rel="bookmark" title="School board candidate nominations due Monday, virtual budget hearing set for May 26 ahead of June 9 vote">School board candidate nominations due Monday, virtual budget hearing set for May 26 ahead of June 9 vote</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/08/riverhead-will-hold-virtual-graduation-ceremony-for-class-of-2020/" rel="bookmark" class="td-image-wrap" title="Riverhead will hold virtual graduation ceremony for Class of 2020"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2014_0628_graduation_28.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2014_0628_graduation_28.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2014_0628_graduation_28.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2014_0628_graduation_28.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2014_0628_graduation_28.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2014_0628_graduation_28.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2014_0628_graduation_28.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead will hold virtual graduation ceremony for Class of 2020" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/08/riverhead-will-hold-virtual-graduation-ceremony-for-class-of-2020/" rel="bookmark" title="Riverhead will hold virtual graduation ceremony for Class of 2020">Riverhead will hold virtual graduation ceremony for Class of 2020</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_18_5ec0131a0eb4f" id="td_uid_19_5ec0131a12ad9" data-td_block_id="td_uid_18_5ec0131a0eb4f" data-td_filter_value="" href="https://riverheadlocal.com/schools/">All</a><a class="mega-menu-sub-cat-td_uid_18_5ec0131a0eb4f" id="td_uid_20_5ec0131a12b57" data-td_block_id="td_uid_18_5ec0131a0eb4f" data-td_filter_value="187" href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a><a class="mega-menu-sub-cat-td_uid_18_5ec0131a0eb4f" id="td_uid_21_5ec0131a12bb1" data-td_block_id="td_uid_18_5ec0131a0eb4f" data-td_filter_value="190" href="https://riverheadlocal.com/schools/mcgann-mercy-junior-senior-high-school/">McGann-Mercy Junior-Senior High School</a><a class="mega-menu-sub-cat-td_uid_18_5ec0131a0eb4f" id="td_uid_22_5ec0131a12c46" data-td_block_id="td_uid_18_5ec0131a0eb4f" data-td_filter_value="15377" href="https://riverheadlocal.com/schools/peconic-community-school/">Peconic Community School</a><a class="mega-menu-sub-cat-td_uid_18_5ec0131a0eb4f" id="td_uid_23_5ec0131a12cce" data-td_block_id="td_uid_18_5ec0131a0eb4f" data-td_filter_value="201" href="https://riverheadlocal.com/schools/riverhead-central-school-district/">Riverhead Central School District</a><a class="mega-menu-sub-cat-td_uid_18_5ec0131a0eb4f" id="td_uid_24_5ec0131a12d4f" data-td_block_id="td_uid_18_5ec0131a0eb4f" data-td_filter_value="199" href="https://riverheadlocal.com/schools/riverhead-central-school-district/aquebogue-elementary-school/">Aquebogue Elementary School</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_5ec0131a0eb4f" data-td_block_id="td_uid_18_5ec0131a0eb4f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_18_5ec0131a0eb4f" data-td_block_id="td_uid_18_5ec0131a0eb4f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-120667" class="tablet-hidden menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-120667"><a href="https://riverheadlocal.com/business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_25_5ec0131a2e425 = new tdBlock();
block_td_uid_25_5ec0131a2e425.id = "td_uid_25_5ec0131a2e425";
block_td_uid_25_5ec0131a2e425.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"205","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_25_5ec0131a2e425_rand","tdc_css_class":"td_uid_25_5ec0131a2e425_rand","tdc_css_class_style":"td_uid_25_5ec0131a2e425_rand_style"}';
block_td_uid_25_5ec0131a2e425.td_column_number = "3";
block_td_uid_25_5ec0131a2e425.block_type = "td_block_mega_menu";
block_td_uid_25_5ec0131a2e425.post_count = "5";
block_td_uid_25_5ec0131a2e425.found_posts = "482";
block_td_uid_25_5ec0131a2e425.header_color = "";
block_td_uid_25_5ec0131a2e425.ajax_pagination_infinite_stop = "";
block_td_uid_25_5ec0131a2e425.max_num_pages = "97";
tdBlocksArray.push(block_td_uid_25_5ec0131a2e425);
</script><div class="td_block_wrap td_block_mega_menu td_uid_25_5ec0131a2e425_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_25_5ec0131a2e425"><div id=td_uid_25_5ec0131a2e425 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/13/suffolks-sales-tax-receipts-plunge-nearly-27-in-april-as-economic-impact-of-pandemic-takes-root/" rel="bookmark" class="td-image-wrap" title="Suffolk&#8217;s sales tax receipts plunge nearly 27% in April, as economic impact of pandemic takes root"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_closed_sign.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Suffolk&#8217;s sales tax receipts plunge nearly 27% in April, as economic impact of pandemic takes root" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/13/suffolks-sales-tax-receipts-plunge-nearly-27-in-april-as-economic-impact-of-pandemic-takes-root/" rel="bookmark" title="Suffolk&#8217;s sales tax receipts plunge nearly 27% in April, as economic impact of pandemic takes root">Suffolk&#8217;s sales tax receipts plunge nearly 27% in April, as economic impact of pandemic takes root</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/04/peconic-bay-medical-center-foundation-acquires-mcgann-mercy-high-school-property/" rel="bookmark" class="td-image-wrap" title="Peconic Bay Medical Center Foundation acquires McGann-Mercy High School property"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?w=1024&#038;quality=100&#038;ssl=1 1024w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0504_McGann-Mercy_PBMC-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Peconic Bay Medical Center Foundation acquires McGann-Mercy High School property" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/04/peconic-bay-medical-center-foundation-acquires-mcgann-mercy-high-school-property/" rel="bookmark" title="Peconic Bay Medical Center Foundation acquires McGann-Mercy High School property">Peconic Bay Medical Center Foundation acquires McGann-Mercy High School property</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/02/reopening-the-east-ends-tourism-economy-its-complicated/" rel="bookmark" class="td-image-wrap" title="Reopening the East End&#8217;s tourism economy? It&#8217;s complicated"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0502_Reeves_Beach-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Reopening the East End&#8217;s tourism economy? It&#8217;s complicated" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/02/reopening-the-east-ends-tourism-economy-its-complicated/" rel="bookmark" title="Reopening the East End&#8217;s tourism economy? It&#8217;s complicated">Reopening the East End&#8217;s tourism economy? It&#8217;s complicated</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/19/marinas-and-boatyards-are-cleared-to-open-in-new-york-connecticut-and-new-jersey/" rel="bookmark" class="td-image-wrap" title="Marinas and boatyards are cleared to open in New York, Connecticut and New Jersey"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2018_0419_east_creek_marina_07.20.2019.dc-.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Marinas and boatyards are cleared to open in New York, Connecticut and New Jersey" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/19/marinas-and-boatyards-are-cleared-to-open-in-new-york-connecticut-and-new-jersey/" rel="bookmark" title="Marinas and boatyards are cleared to open in New York, Connecticut and New Jersey">Marinas and boatyards are cleared to open in New York, Connecticut and New Jersey</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/18/golf-still-non-essential-but-private-courses-may-allow-golfers-access-with-strict-adherence-to-social-distancing-rules/" rel="bookmark" class="td-image-wrap" title="Golf still &#8216;non-essential&#8217; but — private courses may allow golfers access with strict adherence to social distancing rules"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=1832%2C1374&#038;quality=100&#038;ssl=1 1832w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=1376%2C1032&#038;quality=100&#038;ssl=1 1376w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Cherry-Creek-Golf-Coure.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Golf still &#8216;non-essential&#8217; but — private courses may allow golfers access with strict adherence to social distancing rules" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/18/golf-still-non-essential-but-private-courses-may-allow-golfers-access-with-strict-adherence-to-social-distancing-rules/" rel="bookmark" title="Golf still &#8216;non-essential&#8217; but — private courses may allow golfers access with strict adherence to social distancing rules">Golf still &#8216;non-essential&#8217; but — private courses may allow golfers access with strict adherence to social distancing rules</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5ec0131a2e425" data-td_block_id="td_uid_25_5ec0131a2e425"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_25_5ec0131a2e425" data-td_block_id="td_uid_25_5ec0131a2e425"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100676" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100676"><a href="https://riverheadlocal.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_26_5ec0131a32ee6 = new tdBlock();
block_td_uid_26_5ec0131a32ee6.id = "td_uid_26_5ec0131a32ee6";
block_td_uid_26_5ec0131a32ee6.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"81","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_26_5ec0131a32ee6_rand","tdc_css_class":"td_uid_26_5ec0131a32ee6_rand","tdc_css_class_style":"td_uid_26_5ec0131a32ee6_rand_style"}';
block_td_uid_26_5ec0131a32ee6.td_column_number = "3";
block_td_uid_26_5ec0131a32ee6.block_type = "td_block_mega_menu";
block_td_uid_26_5ec0131a32ee6.post_count = "5";
block_td_uid_26_5ec0131a32ee6.found_posts = "897";
block_td_uid_26_5ec0131a32ee6.header_color = "";
block_td_uid_26_5ec0131a32ee6.ajax_pagination_infinite_stop = "";
block_td_uid_26_5ec0131a32ee6.max_num_pages = "180";
tdBlocksArray.push(block_td_uid_26_5ec0131a32ee6);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_26_5ec0131a32ee6_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_26_5ec0131a32ee6"><div id=td_uid_26_5ec0131a32ee6 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/16/a-message-to-the-community-from-peconic-bay-medical-center-we-want-you-back/" rel="bookmark" class="td-image-wrap" title="A message to the community from Peconic Bay Medical Center: We want you back"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/heroes-sign-PBMC-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="A message to the community from Peconic Bay Medical Center: We want you back" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/16/a-message-to-the-community-from-peconic-bay-medical-center-we-want-you-back/" rel="bookmark" title="A message to the community from Peconic Bay Medical Center: We want you back">A message to the community from Peconic Bay Medical Center: We want you back</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/15/new-yorks-reopening-guidelines-are-arbitrary-and-politically-motivated/" rel="bookmark" class="td-image-wrap" title="New York&#8217;s reopening guidelines are arbitrary — and politically motivated"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0507_cuomo_briefing.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="New York&#8217;s reopening guidelines are arbitrary — and politically motivated" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/15/new-yorks-reopening-guidelines-are-arbitrary-and-politically-motivated/" rel="bookmark" title="New York&#8217;s reopening guidelines are arbitrary — and politically motivated">New York&#8217;s reopening guidelines are arbitrary — and politically motivated</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/09/looking-into-the-eyes-of-health-care-workers-as-they-face-the-coronavirus/" rel="bookmark" class="td-image-wrap" title="Looking into the eyes of health care workers as they face the coronavirus"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Looking into the eyes of health care workers as they face the coronavirus" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/09/looking-into-the-eyes-of-health-care-workers-as-they-face-the-coronavirus/" rel="bookmark" title="Looking into the eyes of health care workers as they face the coronavirus">Looking into the eyes of health care workers as they face the coronavirus</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/03/wild-turkeys-wonder-of-nature-or-annoying-pest/" rel="bookmark" class="td-image-wrap" title="Wild turkeys: Wonder of nature or annoying pest?"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2011/11/2011_1119_wild_turkey_1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2011/11/2011_1119_wild_turkey_1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2011/11/2011_1119_wild_turkey_1.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="2011_1119_wild_turkey_1" title="Wild turkeys: Wonder of nature or annoying pest?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/03/wild-turkeys-wonder-of-nature-or-annoying-pest/" rel="bookmark" title="Wild turkeys: Wonder of nature or annoying pest?">Wild turkeys: Wonder of nature or annoying pest?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/29/state-senators-pledge-support-for-nursing-homes/" rel="bookmark" class="td-image-wrap" title="State senators pledge support for nursing homes"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0423_empty-wheelchair.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="State senators pledge support for nursing homes" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/29/state-senators-pledge-support-for-nursing-homes/" rel="bookmark" title="State senators pledge support for nursing homes">State senators pledge support for nursing homes</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_26_5ec0131a32ee6" id="td_uid_27_5ec0131a34b7f" data-td_block_id="td_uid_26_5ec0131a32ee6" data-td_filter_value="" href="https://riverheadlocal.com/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_26_5ec0131a32ee6" id="td_uid_28_5ec0131a34bea" data-td_block_id="td_uid_26_5ec0131a32ee6" data-td_filter_value="91" href="https://riverheadlocal.com/opinion/civiletti/">Denise Civiletti</a><a class="mega-menu-sub-cat-td_uid_26_5ec0131a32ee6" id="td_uid_29_5ec0131a34c70" data-td_block_id="td_uid_26_5ec0131a32ee6" data-td_filter_value="12894" href="https://riverheadlocal.com/opinion/greg-blass/">Greg Blass</a><a class="mega-menu-sub-cat-td_uid_26_5ec0131a32ee6" id="td_uid_30_5ec0131a34cc5" data-td_block_id="td_uid_26_5ec0131a32ee6" data-td_filter_value="99" href="https://riverheadlocal.com/opinion/in-my-opinion/">In My Opinion</a><a class="mega-menu-sub-cat-td_uid_26_5ec0131a32ee6" id="td_uid_31_5ec0131a34d17" data-td_block_id="td_uid_26_5ec0131a32ee6" data-td_filter_value="98" href="https://riverheadlocal.com/opinion/java-scripts/">Java Scripts</a><a class="mega-menu-sub-cat-td_uid_26_5ec0131a32ee6" id="td_uid_32_5ec0131a34d90" data-td_block_id="td_uid_26_5ec0131a32ee6" data-td_filter_value="16086" href="https://riverheadlocal.com/opinion/katie-blasl/">Katie Blasl</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_26_5ec0131a32ee6" data-td_block_id="td_uid_26_5ec0131a32ee6"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_26_5ec0131a32ee6" data-td_block_id="td_uid_26_5ec0131a32ee6"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100677" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100677"><a href="https://riverheadlocal.com/living/">Living</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_33_5ec0131a4ad68 = new tdBlock();
block_td_uid_33_5ec0131a4ad68.id = "td_uid_33_5ec0131a4ad68";
block_td_uid_33_5ec0131a4ad68.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9530","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_33_5ec0131a4ad68_rand","tdc_css_class":"td_uid_33_5ec0131a4ad68_rand","tdc_css_class_style":"td_uid_33_5ec0131a4ad68_rand_style"}';
block_td_uid_33_5ec0131a4ad68.td_column_number = "3";
block_td_uid_33_5ec0131a4ad68.block_type = "td_block_mega_menu";
block_td_uid_33_5ec0131a4ad68.post_count = "5";
block_td_uid_33_5ec0131a4ad68.found_posts = "573";
block_td_uid_33_5ec0131a4ad68.header_color = "";
block_td_uid_33_5ec0131a4ad68.ajax_pagination_infinite_stop = "";
block_td_uid_33_5ec0131a4ad68.max_num_pages = "115";
tdBlocksArray.push(block_td_uid_33_5ec0131a4ad68);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_33_5ec0131a4ad68_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_33_5ec0131a4ad68"><div id=td_uid_33_5ec0131a4ad68 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/10/lets-celebrate-and-encourage-moms-especially-now/" rel="bookmark" class="td-image-wrap" title="Let&#8217;s celebrate — and encourage — moms, especially now"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0510-child-giving-flowers-to-mom.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Let&#8217;s celebrate — and encourage — moms, especially now" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/10/lets-celebrate-and-encourage-moms-especially-now/" rel="bookmark" title="Let&#8217;s celebrate — and encourage — moms, especially now">Let&#8217;s celebrate — and encourage — moms, especially now</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/09/looking-into-the-eyes-of-health-care-workers-as-they-face-the-coronavirus/" rel="bookmark" class="td-image-wrap" title="Looking into the eyes of health care workers as they face the coronavirus"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0509-health-care-worker-mask.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Looking into the eyes of health care workers as they face the coronavirus" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/09/looking-into-the-eyes-of-health-care-workers-as-they-face-the-coronavirus/" rel="bookmark" title="Looking into the eyes of health care workers as they face the coronavirus">Looking into the eyes of health care workers as they face the coronavirus</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/05/09/life-in-the-fifth-season-brings-new-perspective/" rel="bookmark" class="td-image-wrap" title="Life in the &#8216;fifth season&#8217; brings new perspective"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/woman-walking-on-beach.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Life in the &#8216;fifth season&#8217; brings new perspective" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/05/09/life-in-the-fifth-season-brings-new-perspective/" rel="bookmark" title="Life in the &#8216;fifth season&#8217; brings new perspective">Life in the &#8216;fifth season&#8217; brings new perspective</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/26/adjusting-to-the-new-normal/" rel="bookmark" class="td-image-wrap" title="Adjusting to &#8216;the new normal&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2014_0713_LOP_wildflowers.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2014_0713_LOP_wildflowers.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2014_0713_LOP_wildflowers.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2014_0713_LOP_wildflowers.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2014_0713_LOP_wildflowers.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2014_0713_LOP_wildflowers.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2014_0713_LOP_wildflowers.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Adjusting to &#8216;the new normal&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/26/adjusting-to-the-new-normal/" rel="bookmark" title="Adjusting to &#8216;the new normal&#8217;">Adjusting to &#8216;the new normal&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/12/easter-sunday-the-divine-reset/" rel="bookmark" class="td-image-wrap" title="Easter Sunday: the divine reset"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/empty-tomb.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Easter Sunday: the divine reset" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/12/easter-sunday-the-divine-reset/" rel="bookmark" title="Easter Sunday: the divine reset">Easter Sunday: the divine reset</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_33_5ec0131a4ad68" id="td_uid_34_5ec0131a4c204" data-td_block_id="td_uid_33_5ec0131a4ad68" data-td_filter_value="" href="https://riverheadlocal.com/living/">All</a><a class="mega-menu-sub-cat-td_uid_33_5ec0131a4ad68" id="td_uid_35_5ec0131a4c272" data-td_block_id="td_uid_33_5ec0131a4ad68" data-td_filter_value="100" href="https://riverheadlocal.com/living/bits-and-pieces/">Bits and Pieces</a><a class="mega-menu-sub-cat-td_uid_33_5ec0131a4ad68" id="td_uid_36_5ec0131a4c2cc" data-td_block_id="td_uid_33_5ec0131a4ad68" data-td_filter_value="94" href="https://riverheadlocal.com/living/laurie-nigro/">Laurie Nigro</a><a class="mega-menu-sub-cat-td_uid_33_5ec0131a4ad68" id="td_uid_37_5ec0131a4c35e" data-td_block_id="td_uid_33_5ec0131a4ad68" data-td_filter_value="38" href="https://riverheadlocal.com/living/life-on-purpose/">Life On Purpose</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_33_5ec0131a4ad68" data-td_block_id="td_uid_33_5ec0131a4ad68"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_33_5ec0131a4ad68" data-td_block_id="td_uid_33_5ec0131a4ad68"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-76334" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76334"><a target="_blank" href="http://eastendlocal.com/events">Events</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
<div class="breaking-menu-wrap">
<div class="menu-coronavirus-container"><ul id="menu-coronavirus" class="breaking-menu sf-menu"><li id="menu-item-134795" class="breaking-main menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-134795"><a href="https://riverheadlocal.com/coronavirus/">Coronavirus</a></li>
<li id="menu-item-134924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-134924"><a href="https://riverheadlocal.com/coronavirus/#latest-news">Live updates</a></li>
<li id="menu-item-134797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134797"><a href="https://riverheadlocal.com/coronavirus/">Maps &#038; charts</a></li>
<li id="menu-item-134798" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134798"><a href="https://riverheadlocal.com/coronavirus-businesses-still-open/">What&#8217;s still open?</a></li>
</ul></div> </div>
</div>
</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap broadstreet banner ">
<div class="kb-header-ad"><span class="text"></span> <div class="textwidget"><broadstreet-zone zone-id="68458" count="1"></broadstreet-zone></div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-container td-post-template-3">
<div class="td-container-border">
<article id="post-135483" class="post-135483 post type-post status-publish format-standard hentry category-obituaries author-riverheadlocal" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header td-pb-padding-side">
<ul class="td-category"><li class="entry-category"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li></ul>
<header>
<h1 class="entry-title">Elizabeth &#8216;Bette&#8217; Gambino, 85</h1>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://riverheadlocal.com/author/rlocal/" title="Posts by RiverheadLOCAL" class="author url fn" rel="author">RiverheadLOCAL</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-05-16T08:48:51+00:00">May 16, 2020, 8:48 am</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-content td-pb-padding-side">
<p>Elizabeth &#8220;Bette&#8221; Gambino died at Peconic Bay Medical Center on May 13, 2020. She was 85 years old. </p>
<p>She was born on Dec. 16, 1934 in Brooklyn to Margaret (Jennings) and Thomas Casey. </p>
<p>She worked as a tax examiner for the IRS in Yaphank. </p>
<p>She was predeceased by her husband Ernest. She is survived by her children Michael (Margaret) and Jeanne (Michael) Carver, grandchildren Mariel, Matthew, Megan Carver and Christopher Carver and one great-grandchild. </p>
<p>Private interment will be held at Calverton National Cemetery. A memorial service will be planned at a later date. Memorial donations can be made to St. Lawrence the Martyr Church in Sayville, New York. Friends and family may leave a message for the family on the <a href="https://www.manganofh.com/obituaries/Elizabeth--Gambino-?obId=13184734#/obituaryInfo">funeral home website</a>. </p>
<p>Funeral arrangements are entrusted to Tuthill-Mangano Funeral Home. </p>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<div class="google-mobile-ad"><ins class="adsbygoogle mobile-only" data-ad-client="ca-pub-6009741394491678" data-ad-slot="1558404070" data-ad-format="auto" data-full-width-responsive="true"></ins></div>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div id='jp-relatedposts' class='jp-relatedposts'>
</div> </div>
<footer>
<div class="td-post-source-tags td-pb-padding-side">
</div>
<div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-twitter" style="overflow: visible;"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/" data-text="Elizabeth &#8216;Bette&#8217; Gambino, 85" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li class="td-classic-facebook" style="overflow: visible;"><div class="fb-like" data-href="https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/" data-layout="button_count" data-action="like" data-show-faces="false"></div></li></ul></div></div> <div class="author-box-wrap"><a href="https://riverheadlocal.com/author/rlocal/"><img src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/Local_Black_Flat_130.png?fit=96%2C34&quality=100&ssl=1" width="96" height="34" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://riverheadlocal.com/author/rlocal/">RiverheadLOCAL</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="datePublished" content="2020-05-16T08:48:51+00:00"><meta itemprop="dateModified" content="2020-05-16T08:48:57-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png"></span><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="headline " content="Elizabeth &#039;Bette&#039; Gambino, 85"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/themes/Newsmag/images/no-thumb/td_meta_replacement.png"><meta itemprop="width" content="1068"><meta itemprop="height" content="580"></span> </footer>
<div class="fb-comments" data-href="https://riverheadlocal.com/2020/05/16/elizabeth-bette-gambino-85/" data-width="100%" data-mobile="true" data-numposts="10" data-order-by="social" data-colorscheme="light"></div> </div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><broadstreet-zone zone-id="57454" count="1"></broadstreet-zone><broadstreet-zone zone-id="57455" count="1"></broadstreet-zone><broadstreet-zone zone-id="57456" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone><broadstreet-zone zone-id="57463" count="1"></broadstreet-zone>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div>
</div> 


<div class="td-footer-container td-container td-footer-template-10">
<div class="footer-social-wrap td-social-style2 td-footer-full">
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer1-container"><ul id="menu-footer1" class="td-subfooter-menu"><li id="menu-item-132939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-132939"><a href="https://riverheadlocal.com/copyright-notice/">© 2010-2020 East End Local Media Corp</a></li>
<li id="menu-item-132941" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132941"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-132940" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132940"><a href="https://riverheadlocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-132944" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132944"><a href="https://riverheadlocal.com/comments-policy/">Comments Policy</a></li>
<li id="menu-item-132945" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132945"><a href="https://riverheadlocal.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
<div class="td-pb-span4 td-sub-footer-copy">
<div class="td-pb-padding-side">
</div>
</div>
</div>
</div>
</div>
</div>
<div class="a2a_kit a2a_kit_size_36 a2a_floating_style a2a_vertical_style" style="left:0px;top:400px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;left:5px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F05%2F16%2Felizabeth-bette-gambino-85%2F&amp;linkname=Elizabeth%20%26%23039%3BBette%26%23039%3B%20Gambino%2C%2085%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><a rel="nofollow" style="display:none;" href="https://riverheadlocal.com/?blackhole=3bece155e7" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','obituaries','elizabeth-bette-gambino-85','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["obituaries","elizabeth-bette-gambino-85","post"],"url":"elizabeth-bette-gambino-85"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({"useAltZone":767,"altZoneWhitelist":[71281],"networkId":"4821","targets":{"pagetype":["post","not_home_page"],"category":["obituaries","elizabeth-bette-gambino-85","post"],"url":"elizabeth-bette-gambino-85"}});
 });</script>

<script type="text/javascript">(function($) {
  $.fn.almComplete = function(alm){
    
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");


      

    var $pageNumber;
    if ($('.kb-alm-wrap-page-3').length) {
        $pageNumber = 3; 
       // console.log("We're on page 3");
    } else if ($('.kb-alm-wrap-page-2').length) {
        $pageNumber = 2;
        // console.log("We're on page 2");
    } else {
        $pageNumber = 1;
        // console.log("We're on page 1");
    }
    
    // Parse FB comments code
    
    var $newContainerString = '.alm-page-' + $pageNumber;
    var $newContainer = $($newContainerString).parent();

    FB.XFBML.parse($newContainer[0]);
    
    // Append alm button to wrapper
    
    var $new_name = '.kb-alm-wrap-page-' + $pageNumber;
    // $('.alm-btn-wrap').detach();
    // $('.alm-btn-wrap').appendTo($new_name);
  
    // console.log("Button moved!");
    
    for ( var i = 0; i < tdSmartSidebar.items.length; i++ ) {
                    if ( 'case_3_bottom_of_content' === tdSmartSidebar.items[ i ].sidebar_state ) {
                        tdSmartSidebar.items[ i ].sidebar_state = 'case_1_fixed_down';
                       //  console.log("fixed down!");
                    }
                }
                
    var base_url = "https://riverheadlocal.com";
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.js" );
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js" );
//    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/jquery-3.1.1.min.js" );

   // console.log("Alm complte!");
   var jigs = jQuery('.justified-image-grid');
    if(jigs.length !== 0){
       jigs.data('justifiedImageGrid').createGallery('resize');
    }
  };
})(jQuery);

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");
    
 /*  $( 'body' ).on( 'post-load', function() {
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      } ); 
    // type = From which addon (previous-post | seo)
    // permalink = the updated url
    console.log("URL updated to " + permalink + '- dispatched from the '+ type + ' add-on.'); */
  }; 
})(jQuery);

(function($) {
    $(window).load(function(){
  // $('.alm-btn-wrap').appendTo($('.kb-alm-wrap'));
   // console.log("Button moved!");
});
})(jQuery);</script> 
<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-aJ5TJKLfrG9cB",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-aJ5TJKLfrG9cB.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<link rel='stylesheet' id='photoswipe-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/css/photoswipe4.css?ver=4.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/wpdialog.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/sticky-kit.js?ver=1.0.6'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"5bc04959f9","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/photoswipe4.min.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/jquery.dotdotdot.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js?ver=3.9.5'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://riverheadlocal.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202020.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'77146263',post:'135483',tz:'-4',srv:'riverheadlocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '77146263', '135483' ]);
</script>
</body>
</html>