<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs | RiverheadLOCAL</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="pingback" href="https://riverheadlocal.com/xmlrpc.php" />
<meta name='robots' content='max-image-preview:large' />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<meta property="og:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?fit=800%2C533&quality=100&ssl=1" /><link rel="icon" type="image/png" href="https://riverheadlocal.com/wp-content/uploads/2021/06/Pindot-fav.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://riverheadlocal.com/wp-content/uploads/2021/06/Pindot-White-BG.jpeg" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://riverheadlocal.com/wp-content/uploads/2021/06/Pindot-White-BG.jpeg" />

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs | RiverheadLOCAL" />
<meta property="og:description" content="The red-hot real estate market on the East End continues to push home prices higher and break revenue records for the Peconic Bay Community Preservation Fund, which is generated by a 2% tax on real estate transfers in the five East End towns. High demand in the luxury markets on both forks continues to drive the growth." />
<meta property="og:url" content="https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/" />
<meta property="og:site_name" content="RiverheadLOCAL" />
<meta property="article:tag" content="Community Preservation Fund" />
<meta property="article:tag" content="Coronavirus" />
<meta property="article:tag" content="featured" />
<meta property="article:section" content="Real Estate" />
<meta property="article:published_time" content="2021-06-28T12:36:27+00:00" />
<meta property="article:modified_time" content="2021-06-28T13:02:52+00:00" />
<meta property="og:updated_time" content="2021-06-28T13:02:52+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The red-hot real estate market on the East End continues to push home prices higher and break revenue records for the Peconic Bay Community Preservation Fund, which is generated by a 2% tax on real estate transfers in the five East End towns. High demand in the luxury markets on both forks continues to drive the growth." />
<meta name="twitter:title" content="Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs | RiverheadLOCAL" />
<meta name="twitter:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?fit=800%2C533&#038;quality=100&#038;ssl=1" />
<meta name="twitter:creator" content="@civiletti" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://riverheadlocal.com/#website","url":"https://riverheadlocal.com/","name":"RiverheadLOCAL","inLanguage":"en-US","description":"News and events for Riverhead, New York","potentialAction":[{"@type":"SearchAction","target":"https://riverheadlocal.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?fit=800%2C533&quality=100&ssl=1","width":800,"height":533},{"@type":"WebPage","@id":"https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/#webpage","url":"https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/","name":"Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs | RiverheadLOCAL","isPartOf":{"@id":"https://riverheadlocal.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/#primaryimage"},"datePublished":"2021-06-28T12:36:27+00:00","dateModified":"2021-06-28T13:02:52+00:00","author":{"@id":"https://riverheadlocal.com/#/schema/person/0a12b5636fa3908dcd3ed4af34d1ae3d"},"potentialAction":[{"@type":"ReadAction","target":["https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/"]}]},{"@type":["Person"],"@id":"https://riverheadlocal.com/#/schema/person/0a12b5636fa3908dcd3ed4af34d1ae3d","name":"Denise Civiletti","image":{"@type":"ImageObject","@id":"https://riverheadlocal.com/#authorlogo","inLanguage":"en-US","url":"https://riverheadlocal.com/wp-content/uploads/2018/09/DC-avatar.png","caption":"Denise Civiletti"},"description":"Denise is a veteran local reporter, editor,  attorney and former Riverhead Town councilwoman. Her work has been recognized with numerous awards, including investigative reporting and writer of the year awards from the N.Y. Press Association. She is a founder, owner and co-publisher of this website.<a href=\"mailto:denise@riverheadlocal.com\">Email Denise.</a>","sameAs":["https://twitter.com/@civiletti"]}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Feed" href="https://riverheadlocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Comments Feed" href="https://riverheadlocal.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='kb-membership-style-css' href='https://riverheadlocal.com/wp-content/plugins/kb-membership/inc/style.css?ver=6.2.01' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://riverheadlocal.com/wp-includes/css/dashicons.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='https://riverheadlocal.com/wp-includes/css/jquery-ui-dialog.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://riverheadlocal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fc-form-css-css' href='https://riverheadlocal.com/wp-content/plugins/Formcraft/assets/css/form.min.css?ver=3.2.27' type='text/css' media='all' />
<link rel='stylesheet' id='kb-liveblog-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-liveblog/style.css?ver=6.0.200' type='text/css' media='all' />
<link rel='stylesheet' id='public_notices_css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-public-notices/kb-public-notices.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='kb-top-stories-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-top-stories/style.css?ver=3.0.12' type='text/css' media='all' />
<link rel='stylesheet' id='trans-frontend-css' href='https://riverheadlocal.com/wp-content/plugins/kb-translation/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-min-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/icons/css/weather-icons.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-wind-min-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/icons/css/weather-icons-wind.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='kb-weather-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/css/kb-weather.css?ver=3.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://riverheadlocal.com/wp-content/themes/Newsmag/style.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css?ver=5.0.03' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C100%2C100italic%2C200%2C200italic%2C300italic%2C400italic%2C500%2C500italic%2C600italic%2C700italic%2C800%2C800italic%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C100%2C100italic%2C200%2C200italic%2C500%2C500italic%2C600%2C600italic%2C800%2C800italic&#038;ver=4.3&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://riverheadlocal.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1125px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1124px){
.a2a_floating_style.a2a_default_style{display:none;}
}
.a2a_floating_style {
    padding: 20px;
    border-radius: 0;
    border: 1px solid #bbbbbb;
}
</style>
<link rel='stylesheet' id='js_composer_front-css' href='https://riverheadlocal.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://riverheadlocal.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-membership/inc/button.js?ver=6.0.1' id='kb-membership-button-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.7.1' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-liveblog/scripts.js?ver=5.7.1' id='liveblog_scripts-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-weather/js/modernizr.custom.js?ver=5.7.1' id='modernizr_custom-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-weather/js/summary-box.js?ver=5.7.1' id='summary-box-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.29' id='stop-user-enumeration-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.13.1' id='gtm4wp-form-move-tracker-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/common-scripts.js?ver=1.1.0' id='common_scripts-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/popup-menu-fix.js?ver=5.7.1' id='popup-menu-fix-js'></script>
<link rel="https://api.w.org/" href="https://riverheadlocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://riverheadlocal.com/wp-json/wp/v2/posts/140900" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverheadlocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverheadlocal.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://riverheadlocal.com/?p=140900' />
<link rel="alternate" type="application/json+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color = "#A0A0A0";

a2a_config.templates = {
    email: {
        subject: "RiverheadLOCAL: ${title}",
        body: "Check out this story on RiverheadLOCAL: \n${title}\n${link}"
    }
};

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      }; 
})(jQuery);
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs | RiverheadLOCAL","pagePostType":"post","pagePostType2":"single-post","pageCategory":["local-news","real-estate-news"],"pageAttributes":["community-preservation-fund","coronavirus-outbreak-latest-news","featured"],"pagePostAuthorID":4246,"pagePostAuthor":"Denise Civiletti","pagePostDate":"Jun 28, 2021, 8:36 am","pagePostDateYear":"2021","pagePostDateMonth":"06","pagePostDateDay":"28","postID":140900};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N97RFZC');//]]>
</script>

<script src="https://use.fontawesome.com/b3fb28acc8.js"></script><script src="https://cdn.jsdelivr.net/npm/chart.js@2.8.0"></script><meta property="fb:app_id" content="105130769527571" /><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://riverheadlocal.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '82fba20f-da37-4c38-a7fe-ee7dbe081e0f';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://riverheadlocal.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.370dd028-ab8a-4720-9087-4e2c917686de";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_ajax_url="https:\/\/riverheadlocal.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=4.3";
var td_get_template_directory_uri="https:\/\/riverheadlocal.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e12025";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=32%2C32&#038;quality=100&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>
<body class="post-template-default single single-post postid-140900 single-format-standard author-denise-civiletti pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs global-block-template-1 white-menu wpb-js-composer js-comp-ver-6.6.0 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N97RFZC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '105130769527571',
      autoLogAppEvents : true,
      xfbml      : true,
      version    : 'v10.0'
    });
};
</script>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js"></script>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div class="td-mobile-container">

<div class="kb-menu-socials-wrap">

<div class="kb-menu-socials">
</div>
</div>

<div class="kb-mobile-search-container"><form method="get" class="td-search-form-widget" action="https://riverheadlocal.com/">
<div role="search" class="kb-mobile-search">
<button class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit"><i class="td-icon-search"></i></button>
<div class="kb-search-input-wrap"><input class="td-widget-search-input" type="text" value="Search" name="s" id="s" onfocus="if (this.value=='Search') this.value='';" onblur="if (this.value=='') this.value='Search';" /></div>
</div>
</form>
</div>

<div class="td-mobile-content">
<div class="menu-mobile-container"><ul id="menu-mobile" class="td-mobile-main-menu"><li id="menu-item-116721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-116721"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100685" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-100685"><a href="https://riverheadlocal.com/news/">News</a></li>
<li id="menu-item-100683" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100683"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a></li>
<li id="menu-item-100686" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100686"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100692" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100692"><a href="https://riverheadlocal.com/opinion/">Opinion</a></li>
<li id="menu-item-100687" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100687"><a href="https://riverheadlocal.com/community/">Community</a></li>
<li id="menu-item-100693" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-100693"><a href="http://eastendlocal.com">Events</a></li>
<li id="menu-item-100688" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100688"><a href="https://riverheadlocal.com/schools/">Schools</a></li>
<li id="menu-item-100684" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100684"><a href="https://riverheadlocal.com/business/business-news/">Business</a></li>
<li id="menu-item-108418" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108418"><a href="https://classifieds.eastendlocal.com">Classifieds</a></li>
<li id="menu-item-136097" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-136097"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-100694" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100694"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-139558" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-139558"><a href="https://riverheadlocal.com/newsletter/">Newsletter</a></li>
<li id="menu-item-100695" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-100695"><a href="https://riverheadlocal.com/contact/">Contact RiverheadLOCAL</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div id="kb-overlay"></div>
<div class="td-header-wrap td-header-style-3">
<div class="td-top-menu-full">
<div class="td-header-row td-header-top-menu td-make-full">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-100681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-100681"><a href="https://riverheadlocal.com/contact/">Contact</a></li>
<li id="menu-item-130976" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-130976"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-100680" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100680"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-24924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24924"><a target="_blank" rel="noopener" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-116691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116691"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-24925" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24925"><a target="_blank" rel="noopener" href="http://eastendlocal.com/classifieds/">Classifieds</a></li>
<li id="menu-item-129406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129406"><a href="https://riverheadlocal.com/support-local-journalism/">Membership</a></li>
</ul></div></div> </div>

</div>
</div>

<div class="td-header-container">
<div class="td-header-logo-wrap">
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="riverhead local logo" title="riverhead local logo" />
<span class="td-visual-hidden">RiverheadLOCAL</span>
</a>
</div>
<div class="td-header-right-header">
<div class="td-header-right ">
<div class="textwidget"><h3>Support local journalism.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-main-menu">
<div class="td-header-menu-wrap-sub">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-header-right-header mobile-header">
<div class="td-header-right ">
<div class="textwidget"><h3>Support local journalism.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="riverhead local logo" title="riverhead local logo" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main" class="sf-menu"><li id="menu-item-100668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-100668"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100671" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-mega-menu menu-item-100671"><a href="https://riverheadlocal.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_60da36270e503 = new tdBlock();
block_td_uid_1_60da36270e503.id = "td_uid_1_60da36270e503";
block_td_uid_1_60da36270e503.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"103","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_60da36270e503_rand","tdc_css_class":"td_uid_1_60da36270e503_rand","tdc_css_class_style":"td_uid_1_60da36270e503_rand_style"}';
block_td_uid_1_60da36270e503.td_column_number = "3";
block_td_uid_1_60da36270e503.block_type = "td_block_mega_menu";
block_td_uid_1_60da36270e503.post_count = "5";
block_td_uid_1_60da36270e503.found_posts = "6989";
block_td_uid_1_60da36270e503.header_color = "";
block_td_uid_1_60da36270e503.ajax_pagination_infinite_stop = "";
block_td_uid_1_60da36270e503.max_num_pages = "1398";
tdBlocksArray.push(block_td_uid_1_60da36270e503);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_1_60da36270e503_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_60da36270e503"><div id=td_uid_1_60da36270e503 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/" rel="bookmark" class="td-image-wrap" title="Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/" rel="bookmark" title="Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs">Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/25/state-approves-36-mw-solar-facility-on-275-acres-in-calverton/" rel="bookmark" class="td-image-wrap" title="State approves 36 MW solar facility on 275 acres in Calverton"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/12/2020-1201-solar-array.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="State approves 36 MW solar facility on 275 acres in Calverton" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/25/state-approves-36-mw-solar-facility-on-275-acres-in-calverton/" rel="bookmark" title="State approves 36 MW solar facility on 275 acres in Calverton">State approves 36 MW solar facility on 275 acres in Calverton</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/25/navy-has-no-intentions-of-dissolving-community-advisory-group-for-grumman-calverton-cleanup-spokesman-says/" rel="bookmark" class="td-image-wrap" title="Navy has &#8216;no intentions&#8217; of dissolving community advisory group for Grumman/Calverton cleanup, spokesman says"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0204_Navy_meeting_01292020-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Navy has &#8216;no intentions&#8217; of dissolving community advisory group for Grumman/Calverton cleanup, spokesman says" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/25/navy-has-no-intentions-of-dissolving-community-advisory-group-for-grumman-calverton-cleanup-spokesman-says/" rel="bookmark" title="Navy has &#8216;no intentions&#8217; of dissolving community advisory group for Grumman/Calverton cleanup, spokesman says">Navy has &#8216;no intentions&#8217; of dissolving community advisory group for Grumman/Calverton cleanup, spokesman says</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/24/nys-state-of-emergency-to-end-cuomo-says-citing-dramatic-progress-against-covid-19/" rel="bookmark" class="td-image-wrap" title="NY&#8217;s state of emergency to end, Cuomo says, citing &#8216;dramatic progress&#8217; against COVID-19"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623-Cuomo.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623-Cuomo.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623-Cuomo.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623-Cuomo.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623-Cuomo.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623-Cuomo.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623-Cuomo.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623-Cuomo.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="NY&#8217;s state of emergency to end, Cuomo says, citing &#8216;dramatic progress&#8217; against COVID-19" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/24/nys-state-of-emergency-to-end-cuomo-says-citing-dramatic-progress-against-covid-19/" rel="bookmark" title="NY&#8217;s state of emergency to end, Cuomo says, citing &#8216;dramatic progress&#8217; against COVID-19">NY&#8217;s state of emergency to end, Cuomo says, citing &#8216;dramatic progress&#8217; against COVID-19</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/23/thiele-and-palumbo-pass-bill-allowing-east-end-towns-to-collect-0-5-transfer-tax-for-affordable-housing-fund/" rel="bookmark" class="td-image-wrap" title="Thiele and Palumbo pass bill allowing East End towns to collect 0.5% transfer tax for affordable housing fund"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/home-sold-sign-2-.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/home-sold-sign-2-.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/home-sold-sign-2-.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/home-sold-sign-2-.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/home-sold-sign-2-.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/home-sold-sign-2-.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/home-sold-sign-2-.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/home-sold-sign-2-.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Thiele and Palumbo pass bill allowing East End towns to collect 0.5% transfer tax for affordable housing fund" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/23/thiele-and-palumbo-pass-bill-allowing-east-end-towns-to-collect-0-5-transfer-tax-for-affordable-housing-fund/" rel="bookmark" title="Thiele and Palumbo pass bill allowing East End towns to collect 0.5% transfer tax for affordable housing fund">Thiele and Palumbo pass bill allowing East End towns to collect 0.5% transfer tax for affordable housing fund</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_60da36270e503" id="td_uid_2_60da362716609" data-td_block_id="td_uid_1_60da36270e503" data-td_filter_value="" href="https://riverheadlocal.com/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_60da36270e503" id="td_uid_3_60da36271669d" data-td_block_id="td_uid_1_60da36270e503" data-td_filter_value="105" href="https://riverheadlocal.com/news/local-news/">Local News</a><a class="mega-menu-sub-cat-td_uid_1_60da36270e503" id="td_uid_4_60da362716704" data-td_block_id="td_uid_1_60da36270e503" data-td_filter_value="32" href="https://riverheadlocal.com/news/local-news/health/">Health</a><a class="mega-menu-sub-cat-td_uid_1_60da36270e503" id="td_uid_5_60da362716779" data-td_block_id="td_uid_1_60da36270e503" data-td_filter_value="108" href="https://riverheadlocal.com/news/public-notices/">Public Notices</a><a class="mega-menu-sub-cat-td_uid_1_60da36270e503" id="td_uid_6_60da36271681c" data-td_block_id="td_uid_1_60da36270e503" data-td_filter_value="13" href="https://riverheadlocal.com/news/real-estate-news/">Real Estate</a><a class="mega-menu-sub-cat-td_uid_1_60da36270e503" id="td_uid_7_60da36271687b" data-td_block_id="td_uid_1_60da36270e503" data-td_filter_value="104" href="https://riverheadlocal.com/news/town-hall-notebook/">Town Hall Notebook</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_60da36270e503" data-td_block_id="td_uid_1_60da36270e503"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_60da36270e503" data-td_block_id="td_uid_1_60da36270e503"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100669" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100669"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_8_60da362750d29 = new tdBlock();
block_td_uid_8_60da362750d29.id = "td_uid_8_60da362750d29";
block_td_uid_8_60da362750d29.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_8_60da362750d29_rand","tdc_css_class":"td_uid_8_60da362750d29_rand","tdc_css_class_style":"td_uid_8_60da362750d29_rand_style"}';
block_td_uid_8_60da362750d29.td_column_number = "3";
block_td_uid_8_60da362750d29.block_type = "td_block_mega_menu";
block_td_uid_8_60da362750d29.post_count = "5";
block_td_uid_8_60da362750d29.found_posts = "2548";
block_td_uid_8_60da362750d29.header_color = "";
block_td_uid_8_60da362750d29.ajax_pagination_infinite_stop = "";
block_td_uid_8_60da362750d29.max_num_pages = "510";
tdBlocksArray.push(block_td_uid_8_60da362750d29);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_8_60da362750d29_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_8_60da362750d29"><div id=td_uid_8_60da362750d29 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/24/shots-fired-into-trout-brook-lane-home-last-night-prompts-investigation/" rel="bookmark" class="td-image-wrap" title="Shots fired into Trout Brook Lane home last night prompts investigation"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Shots fired into Trout Brook Lane home last night prompts investigation" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/24/shots-fired-into-trout-brook-lane-home-last-night-prompts-investigation/" rel="bookmark" title="Shots fired into Trout Brook Lane home last night prompts investigation">Shots fired into Trout Brook Lane home last night prompts investigation</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/21/cops-man-drove-drunk-with-2-year-old-child-in-vehicle/" rel="bookmark" class="td-image-wrap" title="Cops: Man drove drunk with 2-year-old child in vehicle"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Cops: Man drove drunk with 2-year-old child in vehicle" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/21/cops-man-drove-drunk-with-2-year-old-child-in-vehicle/" rel="bookmark" title="Cops: Man drove drunk with 2-year-old child in vehicle">Cops: Man drove drunk with 2-year-old child in vehicle</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/19/car-crashes-through-front-of-main-street-restaurant-late-friday-night/" rel="bookmark" class="td-image-wrap" title="Car crashes through front of Main Street restaurant late Friday night"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0619_Dark-Horse-crash_1-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Car crashes through front of Main Street restaurant late Friday night" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/19/car-crashes-through-front-of-main-street-restaurant-late-friday-night/" rel="bookmark" title="Car crashes through front of Main Street restaurant late Friday night">Car crashes through front of Main Street restaurant late Friday night</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/16/woman-21-charged-in-stabbing-of-16-year-old-male/" rel="bookmark" class="td-image-wrap" title="Woman, 21, charged in stabbing of 16-year-old male"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/police-line-lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/police-line-lights.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/police-line-lights.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/police-line-lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/police-line-lights.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/police-line-lights.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/police-line-lights.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/police-line-lights.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Woman, 21, charged in stabbing of 16-year-old male" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/16/woman-21-charged-in-stabbing-of-16-year-old-male/" rel="bookmark" title="Woman, 21, charged in stabbing of 16-year-old male">Woman, 21, charged in stabbing of 16-year-old male</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/15/cops-man-who-stole-cigarettes-used-stolen-getaway-vehicle-tracked-by-k-9-unit-and-arrested/" rel="bookmark" class="td-image-wrap" title="Cops: Man who stole cigarettes, used stolen getaway vehicle tracked by K-9 unit and arrested"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Cops: Man who stole cigarettes, used stolen getaway vehicle tracked by K-9 unit and arrested" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/15/cops-man-who-stole-cigarettes-used-stolen-getaway-vehicle-tracked-by-k-9-unit-and-arrested/" rel="bookmark" title="Cops: Man who stole cigarettes, used stolen getaway vehicle tracked by K-9 unit and arrested">Cops: Man who stole cigarettes, used stolen getaway vehicle tracked by K-9 unit and arrested</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_8_60da362750d29" id="td_uid_9_60da3627543b5" data-td_block_id="td_uid_8_60da362750d29" data-td_filter_value="" href="https://riverheadlocal.com/police-fire/">All</a><a class="mega-menu-sub-cat-td_uid_8_60da362750d29" id="td_uid_10_60da36275442c" data-td_block_id="td_uid_8_60da362750d29" data-td_filter_value="42" href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a><a class="mega-menu-sub-cat-td_uid_8_60da362750d29" id="td_uid_11_60da362754499" data-td_block_id="td_uid_8_60da362750d29" data-td_filter_value="41" href="https://riverheadlocal.com/police-fire/police-blotter/">Police Reports</a><a class="mega-menu-sub-cat-td_uid_8_60da362750d29" id="td_uid_12_60da362754531" data-td_block_id="td_uid_8_60da362750d29" data-td_filter_value="43" href="https://riverheadlocal.com/police-fire/riverhead-justice-court/">Riverhead Justice Court</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_8_60da362750d29" data-td_block_id="td_uid_8_60da362750d29"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_8_60da362750d29" data-td_block_id="td_uid_8_60da362750d29"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100672" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100672"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100673" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100673"><a href="https://riverheadlocal.com/community/">Community</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_13_60da36277ddfe = new tdBlock();
block_td_uid_13_60da36277ddfe.id = "td_uid_13_60da36277ddfe";
block_td_uid_13_60da36277ddfe.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"113","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_60da36277ddfe_rand","tdc_css_class":"td_uid_13_60da36277ddfe_rand","tdc_css_class_style":"td_uid_13_60da36277ddfe_rand_style"}';
block_td_uid_13_60da36277ddfe.td_column_number = "3";
block_td_uid_13_60da36277ddfe.block_type = "td_block_mega_menu";
block_td_uid_13_60da36277ddfe.post_count = "5";
block_td_uid_13_60da36277ddfe.found_posts = "4071";
block_td_uid_13_60da36277ddfe.header_color = "";
block_td_uid_13_60da36277ddfe.ajax_pagination_infinite_stop = "";
block_td_uid_13_60da36277ddfe.max_num_pages = "815";
tdBlocksArray.push(block_td_uid_13_60da36277ddfe);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_13_60da36277ddfe_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_60da36277ddfe"><div id=td_uid_13_60da36277ddfe class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/27/in-heartfelt-personal-commentary-trailblazing-riverhead-detective-reflects-on-28-years-as-a-small-town-cop/" rel="bookmark" class="td-image-wrap" title="In heartfelt, personal commentary, trailblazing Riverhead detective reflects on 28 years as a small-town cop"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0627-Hobson-signs-off.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0627-Hobson-signs-off.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0627-Hobson-signs-off.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0627-Hobson-signs-off.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0627-Hobson-signs-off.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0627-Hobson-signs-off.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0627-Hobson-signs-off.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0627-Hobson-signs-off.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="In heartfelt, personal commentary, trailblazing Riverhead detective reflects on 28 years as a small-town cop" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/27/in-heartfelt-personal-commentary-trailblazing-riverhead-detective-reflects-on-28-years-as-a-small-town-cop/" rel="bookmark" title="In heartfelt, personal commentary, trailblazing Riverhead detective reflects on 28 years as a small-town cop">In heartfelt, personal commentary, trailblazing Riverhead detective reflects on 28 years as a small-town cop</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/26/congratulations-to-the-class-of-2021-an-inspiration-in-a-year-of-adversity/" rel="bookmark" class="td-image-wrap" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/26/congratulations-to-the-class-of-2021-an-inspiration-in-a-year-of-adversity/" rel="bookmark" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity">Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/24/got-stuff-riverhead-town-historian-seeks-photos-documents-books-and-more-on-upcoming-donation-day/" rel="bookmark" class="td-image-wrap" title="Got stuff? Riverhead town historian seeks photos, documents, books and more on upcoming donation day"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0624_Georgette-Case-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0624_Georgette-Case-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0624_Georgette-Case-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0624_Georgette-Case-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0624_Georgette-Case-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0624_Georgette-Case-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0624_Georgette-Case-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0624_Georgette-Case-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Got stuff? Riverhead town historian seeks photos, documents, books and more on upcoming donation day" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/24/got-stuff-riverhead-town-historian-seeks-photos-documents-books-and-more-on-upcoming-donation-day/" rel="bookmark" title="Got stuff? Riverhead town historian seeks photos, documents, books and more on upcoming donation day">Got stuff? Riverhead town historian seeks photos, documents, books and more on upcoming donation day</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/24/art-in-action-and-virtual-music-performance-websites-launched/" rel="bookmark" class="td-image-wrap" title="‘Art in Action’ and virtual music performance websites launched"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?w=1024&#038;quality=100&#038;ssl=1 1024w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/14329732-389B-45A3-A6F4-137B93D2882A.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="‘Art in Action’ and virtual music performance websites launched" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/24/art-in-action-and-virtual-music-performance-websites-launched/" rel="bookmark" title="‘Art in Action’ and virtual music performance websites launched">‘Art in Action’ and virtual music performance websites launched</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/23/this-little-building-offers-a-peek-into-riverhead-history-and-much-much-more/" rel="bookmark" class="td-image-wrap" title="This little building offers a peek into Riverhead history — and much, much more"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_Yellow-Barn-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_Yellow-Barn-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_Yellow-Barn-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_Yellow-Barn-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_Yellow-Barn-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_Yellow-Barn-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_Yellow-Barn-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_Yellow-Barn-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="This little building offers a peek into Riverhead history — and much, much more" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/23/this-little-building-offers-a-peek-into-riverhead-history-and-much-much-more/" rel="bookmark" title="This little building offers a peek into Riverhead history — and much, much more">This little building offers a peek into Riverhead history — and much, much more</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_60da36277ddfe" id="td_uid_14_60da362785524" data-td_block_id="td_uid_13_60da36277ddfe" data-td_filter_value="" href="https://riverheadlocal.com/community/">All</a><a class="mega-menu-sub-cat-td_uid_13_60da36277ddfe" id="td_uid_15_60da3627855d9" data-td_block_id="td_uid_13_60da36277ddfe" data-td_filter_value="128" href="https://riverheadlocal.com/community/announcements/">Announcements</a><a class="mega-menu-sub-cat-td_uid_13_60da36277ddfe" id="td_uid_16_60da3627856c6" data-td_block_id="td_uid_13_60da36277ddfe" data-td_filter_value="126" href="https://riverheadlocal.com/community/community-news/">Community News</a><a class="mega-menu-sub-cat-td_uid_13_60da36277ddfe" id="td_uid_17_60da36278576f" data-td_block_id="td_uid_13_60da36277ddfe" data-td_filter_value="127" href="https://riverheadlocal.com/community/event-photos/">Event Photos</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_60da36277ddfe" data-td_block_id="td_uid_13_60da36277ddfe"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_60da36277ddfe" data-td_block_id="td_uid_13_60da36277ddfe"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100674" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100674"><a href="https://riverheadlocal.com/schools/">Schools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_18_60da3627b80be = new tdBlock();
block_td_uid_18_60da3627b80be.id = "td_uid_18_60da3627b80be";
block_td_uid_18_60da3627b80be.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"185","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_60da3627b80be_rand","tdc_css_class":"td_uid_18_60da3627b80be_rand","tdc_css_class_style":"td_uid_18_60da3627b80be_rand_style"}';
block_td_uid_18_60da3627b80be.td_column_number = "3";
block_td_uid_18_60da3627b80be.block_type = "td_block_mega_menu";
block_td_uid_18_60da3627b80be.post_count = "5";
block_td_uid_18_60da3627b80be.found_posts = "1926";
block_td_uid_18_60da3627b80be.header_color = "";
block_td_uid_18_60da3627b80be.ajax_pagination_infinite_stop = "";
block_td_uid_18_60da3627b80be.max_num_pages = "386";
tdBlocksArray.push(block_td_uid_18_60da3627b80be);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_18_60da3627b80be_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_18_60da3627b80be"><div id=td_uid_18_60da3627b80be class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/26/congratulations-to-the-class-of-2021-an-inspiration-in-a-year-of-adversity/" rel="bookmark" class="td-image-wrap" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/26/congratulations-to-the-class-of-2021-an-inspiration-in-a-year-of-adversity/" rel="bookmark" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity">Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/21/riverhead-school-trustee-elect-is-first-democratic-socialist-party-member-to-win-elective-office-in-suffolk-county/" rel="bookmark" class="td-image-wrap" title="Riverhead school trustee-elect is first Democratic-Socialist member to win elective office in Suffolk County"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead school trustee-elect is first Democratic-Socialist member to win elective office in Suffolk County" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/21/riverhead-school-trustee-elect-is-first-democratic-socialist-party-member-to-win-elective-office-in-suffolk-county/" rel="bookmark" title="Riverhead school trustee-elect is first Democratic-Socialist member to win elective office in Suffolk County">Riverhead school trustee-elect is first Democratic-Socialist member to win elective office in Suffolk County</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/19/celebrating-the-class-of-2021-with-a-parade/" rel="bookmark" class="td-image-wrap" title="Celebrating the Class of 2021 with a parade"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0618_RHS-senior-parade_01-1-e1624113569104.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0618_RHS-senior-parade_01-1-e1624113569104.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0618_RHS-senior-parade_01-1-e1624113569104.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Celebrating the Class of 2021 with a parade" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/19/celebrating-the-class-of-2021-with-a-parade/" rel="bookmark" title="Celebrating the Class of 2021 with a parade">Celebrating the Class of 2021 with a parade</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/18/riverhead-school-district-receiving-18-million-in-federal-covid-relief-funds-seeks-community-input/" rel="bookmark" class="td-image-wrap" title="Riverhead school district receiving $18 million in federal COVID relief funds, seeks community input"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead school district receiving $18 million in federal COVID relief funds, seeks community input" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/18/riverhead-school-district-receiving-18-million-in-federal-covid-relief-funds-seeks-community-input/" rel="bookmark" title="Riverhead school district receiving $18 million in federal COVID relief funds, seeks community input">Riverhead school district receiving $18 million in federal COVID relief funds, seeks community input</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/11/elementary-peer-mediators-sworn-in/" rel="bookmark" class="td-image-wrap" title="Elementary peer mediators sworn in"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_06_Pulaski-mediators.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_06_Pulaski-mediators.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_06_Pulaski-mediators.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_06_Pulaski-mediators.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_06_Pulaski-mediators.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_06_Pulaski-mediators.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_06_Pulaski-mediators.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Elementary peer mediators sworn in" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/11/elementary-peer-mediators-sworn-in/" rel="bookmark" title="Elementary peer mediators sworn in">Elementary peer mediators sworn in</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_18_60da3627b80be" id="td_uid_19_60da3627bcdeb" data-td_block_id="td_uid_18_60da3627b80be" data-td_filter_value="" href="https://riverheadlocal.com/schools/">All</a><a class="mega-menu-sub-cat-td_uid_18_60da3627b80be" id="td_uid_20_60da3627bcea3" data-td_block_id="td_uid_18_60da3627b80be" data-td_filter_value="187" href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a><a class="mega-menu-sub-cat-td_uid_18_60da3627b80be" id="td_uid_21_60da3627bcf4f" data-td_block_id="td_uid_18_60da3627b80be" data-td_filter_value="190" href="https://riverheadlocal.com/schools/mcgann-mercy-junior-senior-high-school/">McGann-Mercy Junior-Senior High School</a><a class="mega-menu-sub-cat-td_uid_18_60da3627b80be" id="td_uid_22_60da3627bd047" data-td_block_id="td_uid_18_60da3627b80be" data-td_filter_value="15377" href="https://riverheadlocal.com/schools/peconic-community-school/">Peconic Community School</a><a class="mega-menu-sub-cat-td_uid_18_60da3627b80be" id="td_uid_23_60da3627bd137" data-td_block_id="td_uid_18_60da3627b80be" data-td_filter_value="201" href="https://riverheadlocal.com/schools/riverhead-central-school-district/">Riverhead Central School District</a><a class="mega-menu-sub-cat-td_uid_18_60da3627b80be" id="td_uid_24_60da3627bd231" data-td_block_id="td_uid_18_60da3627b80be" data-td_filter_value="199" href="https://riverheadlocal.com/schools/riverhead-central-school-district/aquebogue-elementary-school/">Aquebogue Elementary School</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_60da3627b80be" data-td_block_id="td_uid_18_60da3627b80be"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_18_60da3627b80be" data-td_block_id="td_uid_18_60da3627b80be"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-120667" class="tablet-hidden menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-120667"><a href="https://riverheadlocal.com/business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_25_60da3628016ab = new tdBlock();
block_td_uid_25_60da3628016ab.id = "td_uid_25_60da3628016ab";
block_td_uid_25_60da3628016ab.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"205","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_25_60da3628016ab_rand","tdc_css_class":"td_uid_25_60da3628016ab_rand","tdc_css_class_style":"td_uid_25_60da3628016ab_rand_style"}';
block_td_uid_25_60da3628016ab.td_column_number = "3";
block_td_uid_25_60da3628016ab.block_type = "td_block_mega_menu";
block_td_uid_25_60da3628016ab.post_count = "5";
block_td_uid_25_60da3628016ab.found_posts = "554";
block_td_uid_25_60da3628016ab.header_color = "";
block_td_uid_25_60da3628016ab.ajax_pagination_infinite_stop = "";
block_td_uid_25_60da3628016ab.max_num_pages = "111";
tdBlocksArray.push(block_td_uid_25_60da3628016ab);
</script><div class="td_block_wrap td_block_mega_menu td_uid_25_60da3628016ab_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_25_60da3628016ab"><div id=td_uid_25_60da3628016ab class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/27/deep-discount-german-grocer-lidl-readies-for-june-30-grand-opening-in-riverhead/" rel="bookmark" class="td-image-wrap" title="Deep-discount German grocer Lidl readies for June 30 grand opening in Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Deep-discount German grocer Lidl readies for June 30 grand opening in Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/27/deep-discount-german-grocer-lidl-readies-for-june-30-grand-opening-in-riverhead/" rel="bookmark" title="Deep-discount German grocer Lidl readies for June 30 grand opening in Riverhead">Deep-discount German grocer Lidl readies for June 30 grand opening in Riverhead</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/25/antigua-cafe-opens-in-downtown-riverhead/" rel="bookmark" class="td-image-wrap" title="Antigua Cafe opens in downtown Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-Antigua-Cafe-2.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-Antigua-Cafe-2.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-Antigua-Cafe-2.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-Antigua-Cafe-2.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-Antigua-Cafe-2.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-Antigua-Cafe-2.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-Antigua-Cafe-2.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-Antigua-Cafe-2.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Antigua Cafe opens in downtown Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/25/antigua-cafe-opens-in-downtown-riverhead/" rel="bookmark" title="Antigua Cafe opens in downtown Riverhead">Antigua Cafe opens in downtown Riverhead</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/23/southampton-tattoo-artist-plans-to-open-new-shop-on-east-main-street-next-month/" rel="bookmark" class="td-image-wrap" title="Southampton tattoo artist plans to open new shop on East Main Street next month"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_tattoo.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_tattoo.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_tattoo.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_tattoo.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_tattoo.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_tattoo.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_tattoo.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0623_tattoo.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Southampton tattoo artist plans to open new shop on East Main Street next month" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/23/southampton-tattoo-artist-plans-to-open-new-shop-on-east-main-street-next-month/" rel="bookmark" title="Southampton tattoo artist plans to open new shop on East Main Street next month">Southampton tattoo artist plans to open new shop on East Main Street next month</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/15/hamptons-estate-sales-firm-opening-consignment-warehouse-on-main-street/" rel="bookmark" class="td-image-wrap" title="Hamptons estate sales firm opening consignment warehouse on Main Street"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0615_Privet.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0615_Privet.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0615_Privet.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0615_Privet.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0615_Privet.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0615_Privet.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0615_Privet.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0615_Privet.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Hamptons estate sales firm opening consignment warehouse on Main Street" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/15/hamptons-estate-sales-firm-opening-consignment-warehouse-on-main-street/" rel="bookmark" title="Hamptons estate sales firm opening consignment warehouse on Main Street">Hamptons estate sales firm opening consignment warehouse on Main Street</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/15/new-york-ends-most-covid-restrictions-as-state-passes-vaccination-milestone/" rel="bookmark" class="td-image-wrap" title="New York ends most COVID restrictions as state passes vaccination milestone"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=687%2C520&#038;quality=100&#038;ssl=1 687w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020-0525_open-sign-in-shop.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="New York ends most COVID restrictions as state passes vaccination milestone" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/15/new-york-ends-most-covid-restrictions-as-state-passes-vaccination-milestone/" rel="bookmark" title="New York ends most COVID restrictions as state passes vaccination milestone">New York ends most COVID restrictions as state passes vaccination milestone</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_60da3628016ab" data-td_block_id="td_uid_25_60da3628016ab"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_25_60da3628016ab" data-td_block_id="td_uid_25_60da3628016ab"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100676" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100676"><a href="https://riverheadlocal.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_26_60da36280b95f = new tdBlock();
block_td_uid_26_60da36280b95f.id = "td_uid_26_60da36280b95f";
block_td_uid_26_60da36280b95f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"81","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_26_60da36280b95f_rand","tdc_css_class":"td_uid_26_60da36280b95f_rand","tdc_css_class_style":"td_uid_26_60da36280b95f_rand_style"}';
block_td_uid_26_60da36280b95f.td_column_number = "3";
block_td_uid_26_60da36280b95f.block_type = "td_block_mega_menu";
block_td_uid_26_60da36280b95f.post_count = "5";
block_td_uid_26_60da36280b95f.found_posts = "977";
block_td_uid_26_60da36280b95f.header_color = "";
block_td_uid_26_60da36280b95f.ajax_pagination_infinite_stop = "";
block_td_uid_26_60da36280b95f.max_num_pages = "196";
tdBlocksArray.push(block_td_uid_26_60da36280b95f);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_26_60da36280b95f_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_26_60da36280b95f"><div id=td_uid_26_60da36280b95f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/21/riverhead-must-address-its-litter-problem/" rel="bookmark" class="td-image-wrap" title="Riverhead must address its litter problem"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead must address its litter problem" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/21/riverhead-must-address-its-litter-problem/" rel="bookmark" title="Riverhead must address its litter problem">Riverhead must address its litter problem</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/21/constituent-responds-to-zeldin-newsletter/" rel="bookmark" class="td-image-wrap" title="Constituent responds to Zeldin newsletter"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Constituent responds to Zeldin newsletter" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/21/constituent-responds-to-zeldin-newsletter/" rel="bookmark" title="Constituent responds to Zeldin newsletter">Constituent responds to Zeldin newsletter</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/20/a-fathers-day-reflection-on-fatherhood/" rel="bookmark" class="td-image-wrap" title="A Father&#8217;s Day reflection on fatherhood"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="A Father&#8217;s Day reflection on fatherhood" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/20/a-fathers-day-reflection-on-fatherhood/" rel="bookmark" title="A Father&#8217;s Day reflection on fatherhood">A Father&#8217;s Day reflection on fatherhood</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/02/we-can-all-take-steps-to-help-protect-wildlife/" rel="bookmark" class="td-image-wrap" title="We can all take steps to help protect wildlife"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="We can all take steps to help protect wildlife" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/02/we-can-all-take-steps-to-help-protect-wildlife/" rel="bookmark" title="We can all take steps to help protect wildlife">We can all take steps to help protect wildlife</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/05/28/we-must-never-forget-what-happened-to-michael-and-why/" rel="bookmark" class="td-image-wrap" title="We must never forget what happened to Michael — and why"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="We must never forget what happened to Michael — and why" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/05/28/we-must-never-forget-what-happened-to-michael-and-why/" rel="bookmark" title="We must never forget what happened to Michael — and why">We must never forget what happened to Michael — and why</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_26_60da36280b95f" id="td_uid_27_60da36280e856" data-td_block_id="td_uid_26_60da36280b95f" data-td_filter_value="" href="https://riverheadlocal.com/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_26_60da36280b95f" id="td_uid_28_60da36280e8fc" data-td_block_id="td_uid_26_60da36280b95f" data-td_filter_value="91" href="https://riverheadlocal.com/opinion/civiletti/">Denise Civiletti</a><a class="mega-menu-sub-cat-td_uid_26_60da36280b95f" id="td_uid_29_60da36280e998" data-td_block_id="td_uid_26_60da36280b95f" data-td_filter_value="12894" href="https://riverheadlocal.com/opinion/greg-blass/">Greg Blass</a><a class="mega-menu-sub-cat-td_uid_26_60da36280b95f" id="td_uid_30_60da36280ea30" data-td_block_id="td_uid_26_60da36280b95f" data-td_filter_value="99" href="https://riverheadlocal.com/opinion/in-my-opinion/">In My Opinion</a><a class="mega-menu-sub-cat-td_uid_26_60da36280b95f" id="td_uid_31_60da36280eac7" data-td_block_id="td_uid_26_60da36280b95f" data-td_filter_value="98" href="https://riverheadlocal.com/opinion/java-scripts/">Java Scripts</a><a class="mega-menu-sub-cat-td_uid_26_60da36280b95f" id="td_uid_32_60da36280ef4a" data-td_block_id="td_uid_26_60da36280b95f" data-td_filter_value="16086" href="https://riverheadlocal.com/opinion/katie-blasl/">Katie Blasl</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_26_60da36280b95f" data-td_block_id="td_uid_26_60da36280b95f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_26_60da36280b95f" data-td_block_id="td_uid_26_60da36280b95f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100677" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100677"><a href="https://riverheadlocal.com/living/">Living</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_33_60da362842c4c = new tdBlock();
block_td_uid_33_60da362842c4c.id = "td_uid_33_60da362842c4c";
block_td_uid_33_60da362842c4c.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9530","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_33_60da362842c4c_rand","tdc_css_class":"td_uid_33_60da362842c4c_rand","tdc_css_class_style":"td_uid_33_60da362842c4c_rand_style"}';
block_td_uid_33_60da362842c4c.td_column_number = "3";
block_td_uid_33_60da362842c4c.block_type = "td_block_mega_menu";
block_td_uid_33_60da362842c4c.post_count = "5";
block_td_uid_33_60da362842c4c.found_posts = "3442";
block_td_uid_33_60da362842c4c.header_color = "";
block_td_uid_33_60da362842c4c.ajax_pagination_infinite_stop = "";
block_td_uid_33_60da362842c4c.max_num_pages = "689";
tdBlocksArray.push(block_td_uid_33_60da362842c4c);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_33_60da362842c4c_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_33_60da362842c4c"><div id=td_uid_33_60da362842c4c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/20/140802/" rel="bookmark" class="td-image-wrap" title=""><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?w=640&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/20/140802/" rel="bookmark" title=""></a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/20/you-can-decide-to-be-happy/" rel="bookmark" class="td-image-wrap" title="You can decide to be happy"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="You can decide to be happy" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/20/you-can-decide-to-be-happy/" rel="bookmark" title="You can decide to be happy">You can decide to be happy</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/12/its-time-to-recalibrate-normal/" rel="bookmark" class="td-image-wrap" title="It&#8217;s time to recalibrate &#8216;normal&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="It&#8217;s time to recalibrate &#8216;normal&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/12/its-time-to-recalibrate-normal/" rel="bookmark" title="It&#8217;s time to recalibrate &#8216;normal&#8217;">It&#8217;s time to recalibrate &#8216;normal&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/06/140522/" rel="bookmark" class="td-image-wrap" title=""><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?w=640&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/06/140522/" rel="bookmark" title=""></a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/06/life-lessons-learned-in-30-years-of-tending-gardens/" rel="bookmark" class="td-image-wrap" title="Life lessons learned in 30 years of tending gardens"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/backyard-garden.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/backyard-garden.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/backyard-garden.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/backyard-garden.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/backyard-garden.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/backyard-garden.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/backyard-garden.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/backyard-garden.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Life lessons learned in 30 years of tending gardens" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/06/life-lessons-learned-in-30-years-of-tending-gardens/" rel="bookmark" title="Life lessons learned in 30 years of tending gardens">Life lessons learned in 30 years of tending gardens</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_33_60da362842c4c" id="td_uid_34_60da362848cb1" data-td_block_id="td_uid_33_60da362842c4c" data-td_filter_value="" href="https://riverheadlocal.com/living/">All</a><a class="mega-menu-sub-cat-td_uid_33_60da362842c4c" id="td_uid_35_60da362848d52" data-td_block_id="td_uid_33_60da362842c4c" data-td_filter_value="100" href="https://riverheadlocal.com/living/bits-and-pieces/">Bits and Pieces</a><a class="mega-menu-sub-cat-td_uid_33_60da362842c4c" id="td_uid_36_60da362848dec" data-td_block_id="td_uid_33_60da362842c4c" data-td_filter_value="94" href="https://riverheadlocal.com/living/laurie-nigro/">Laurie Nigro</a><a class="mega-menu-sub-cat-td_uid_33_60da362842c4c" id="td_uid_37_60da362848ecd" data-td_block_id="td_uid_33_60da362842c4c" data-td_filter_value="38" href="https://riverheadlocal.com/living/life-on-purpose/">Life On Purpose</a><a class="mega-menu-sub-cat-td_uid_33_60da362842c4c" id="td_uid_38_60da362848f5f" data-td_block_id="td_uid_33_60da362842c4c" data-td_filter_value="119" href="https://riverheadlocal.com/living/town-crier/">Town Crier</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_33_60da362842c4c" data-td_block_id="td_uid_33_60da362842c4c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_33_60da362842c4c" data-td_block_id="td_uid_33_60da362842c4c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-76334" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76334"><a target="_blank" href="http://eastendlocal.com/events">Events</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
<div class="breaking-menu-wrap">
<div class="menu-coronavirus-container"><ul id="menu-coronavirus" class="breaking-menu sf-menu"><li id="menu-item-134795" class="breaking-main menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-134795"><a href="https://riverheadlocal.com/coronavirus/">Coronavirus</a></li>
<li id="menu-item-134924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-134924"><a href="https://riverheadlocal.com/coronavirus/#latest-news">Latest updates</a></li>
<li id="menu-item-134797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134797"><a href="https://riverheadlocal.com/coronavirus/">Maps &#038; charts</a></li>
<li id="menu-item-139226" class="menu-item menu-item-type-post_type menu-item-object-post td-menu-item td-normal-menu menu-item-139226"><a href="https://riverheadlocal.com/2021/03/13/covid-19-vaccinations-who-is-eligible-and-how-to-get-one/">Vaccines</a></li>
</ul></div> </div>
</div>
</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap broadstreet banner ">
<div class="kb-header-ad"><span class="text"></span> <div class="textwidget"><broadstreet-zone zone-id="83958" count="1"></broadstreet-zone></div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-container td-post-template-3">
<div class="td-container-border">
<article id="post-140900" class="post-140900 post type-post status-publish format-standard has-post-thumbnail hentry category-local-news category-real-estate-news tag-community-preservation-fund tag-coronavirus-outbreak-latest-news tag-featured author-denise-civiletti" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header td-pb-padding-side">
<ul class="td-category"><li class="entry-category"><a href="https://riverheadlocal.com/news/">News</a></li><li class="entry-category"><a href="https://riverheadlocal.com/news/local-news/">Local News</a></li><li class="entry-category"><a href="https://riverheadlocal.com/news/real-estate-news/">Real Estate</a></li></ul>
<header>
<h1 class="entry-title">Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs</h1>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://riverheadlocal.com/author/denise-2/" title="Posts by Denise Civiletti" class="author url fn" rel="author">Denise Civiletti</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2021-06-28T08:36:27+00:00">Jun 28, 2021, 8:36 am</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-featured-image"><figure><a href="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?fit=800%2C533&quality=100&ssl=1" data-caption="Home on Penny&#039;s Road in Riverhead, listed by Daniel Gale/Sotheby&#039;s International  for $1.65 million, is in contract. Courtesy photo: Daniel Gale/Sotheby&#039;s International. "><img width="681" height="454" class="entry-thumb td-modal-image" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=681%2C454&quality=100&ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?w=800&quality=100&ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=270%2C180&quality=100&ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=768%2C512&quality=100&ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=630%2C420&quality=100&ssl=1 630w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=640%2C426&quality=100&ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?resize=681%2C454&quality=100&ssl=1 681w" sizes="(max-width: 681px) 100vw, 681px" alt="" title="2021_0628_home for sale elliman" /></a><figcaption class="wp-caption-text">Home on Penny's Road in Riverhead, listed by Daniel Gale/Sotheby's International for $1.65 million, is in contract. Courtesy photo: Daniel Gale/Sotheby's International. </figcaption></figure></div>
<div class="td-post-content td-pb-padding-side">
<p>
<p>The red-hot real estate market on the East End continues to push home prices higher and break revenue records for the Peconic Bay Community Preservation Fund, which is generated by a 2% tax on real estate transfers in the five East End towns.<broadstreet-zone alt-zone-id="68459" class="mobile-ad" count="1"></broadstreet-zone>
<p>Community Preservation Fund revenues generated in the first five months of 2021 were double what was generated in the first five months of 2020 —&nbsp;and the January-May 2020 CPF tax receipts were already the highest five-month total in the history of the fund, which dates back to 1999.
<p>Overall, last year&#8217;s CPF revenues were higher than in any other year in the program’s history, thanks to rising home prices and high volume fueled by an exodus from New York City to the East End as the coronavirus pandemic swept through the New York metro region. The number of sales set records and the median home price on the North Fork surged by 23.8% in 2020 to a record of $805,000, according to a report prepared for Douglas Elliman Real Estate by Miller Samuel Real Estate Appraisers and Consultants. The median sales price in the Hamptons in 2020 climbed 54.5% to a record $1.4 million, according to Elliman.
<p>And in 2021, the trends continue, with the number of sales on the North Fork up nearly 60% in the first quarter of 2021 compared to the same period last year and median sale price climbing to $751,000 for the quarter, up 23.4% year over year, according to a report prepared for Douglas Elliman Real Estate by Miller Samuel Real Estate Appraisers and Consultants. The Hamptons saw &#8220;runaway growth&#8221; in the $1 million to $5 million range in the first quarter, an Elliman report said.<broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<p>According to the Assemblyman Fred Thiele, from January to May this year the fund generated a record-breaking $93.69 million, compared to $45.43 million in the first five months of 2020 —&nbsp;and that sum, a 54% increase over the first five months of 2019, was itself the highest-ever five-month total in the history of the CPF.
<p>Since its inception, the CPF has generated $1.694 billion.
<p>The CPF was established by voter referendum in 1998, approving legislation passed by Thiele and former State Sen. Ken LaValle, to finance farmland and open space preservation on the East End. In 2006 the CPF was extended from 2020 to 2030, and in 2016 it was extended to 2050. Voters in 2016 also authorized the expenditure of up to 20% of CPF revenues on water quality improvement projects. In each instance, the CPF referendum passed by wide margins among voters of the East End towns. Each town separately manages its fund and administers the programs it finances.<broadstreet-zone alt-zone-id="68459" class="mobile-ad" count="1"></broadstreet-zone>
<p>The town-by-town breakdown of CPF revenue generated January-May 2021, according to data provided by Thiele:
<figure class="wp-block-table"><table><tbody><tr><td>Town</td><td>2020</td><td>2021</td><td>Percent Increase</td></tr><tr><td>East Hampton</td><td>$12.34 million</td><td>$31.04 million</td><td>+151.6%</td></tr><tr><td>Riverhead</td><td>$1.71 million</td><td>$2.86 million</td><td>+67.3%</td></tr><tr><td>Shelter Island</td><td>$0.69 million</td><td>$2.31 million</td><td>+234.8%</td></tr><tr><td>Southampton</td><td>$27.6 million</td><td>$51.62 million</td><td>+87%</td></tr><tr><td>Southold</td><td>$3.08 million</td><td>$5.85 million</td><td>+90%</td></tr><tr><td>Total</td><td>$45.43 million</td><td>$95.68 million</td><td>+106.2%</td></tr></tbody></table></figure>
<div style="height:35px" aria-hidden="true" class="wp-block-spacer"></div>
<p>“Revenues for the CPF continue to reflect the significant increase in real estate activity on the East End since the advent of the COVID-19 pandemic,” Thiele said in a statement. “This marks the 10th straight month that revenues have exceeded $10 million per month. The last eight months have all exceeded $15 million per month.”
<p><em>Alek Lewis contributed reporting for this story.</em><broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<div class="kb-member-content-box"><p><strong><span style="font-size:20px; line-height: 40px;">Support local journalism.</span></strong><br />Now more than ever, the survival of quality local journalism depends on your support. Our community faces unprecedented economic disruption, and the future of many small businesses are under threat, including our own. It takes time and resources to provide this service. We are a small family-owned operation, and we will do everything in our power to keep it going. But today more than ever before, we will depend on your support to continue. <strong><a href="/support-local-journalism">Support RiverheadLOCAL today.</a></strong> You rely on us to stay informed and we depend on you to make our work possible.</p></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
</div> </div>
<footer>
<div class="td-post-source-tags td-pb-padding-side">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://riverheadlocal.com/topic/community-preservation-fund/">Community Preservation Fund</a></li><li><a href="https://riverheadlocal.com/topic/coronavirus-outbreak-latest-news/">Coronavirus</a></li><li><a href="https://riverheadlocal.com/topic/featured/">featured</a></li></ul> </div>
<div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-twitter" style="overflow: visible;"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/" data-text="Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li class="td-classic-facebook" style="overflow: visible;"><div class="fb-like" data-href="https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/" data-layout="button_count" data-action="like" data-show-faces="false"></div></li></ul></div></div> <div class="author-box-wrap"><a href="https://riverheadlocal.com/author/denise-2/"><img src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/09/DC-avatar.png?fit=96%2C96&quality=100&ssl=1" width="96" height="96" alt="Denise Civiletti" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://riverheadlocal.com/author/denise-2/">Denise Civiletti</a></span></div><div class="td-author-description">Denise is a veteran local reporter, editor, attorney and former Riverhead Town councilwoman. Her work has been recognized with numerous awards, including investigative reporting and writer of the year awards from the N.Y. Press Association. She is a founder, owner and co-publisher of this website.<a href="/cdn-cgi/l/email-protection#85e1e0ebecf6e0c5f7ecf3e0f7ede0e4e1e9eae6e4e9abe6eae8">Email Denise.</a></div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/civiletti" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Denise Civiletti"></span><meta itemprop="datePublished" content="2021-06-28T08:36:27+00:00"><meta itemprop="dateModified" content="2021-06-28T09:02:52-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png"></span><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="headline " content="Pandemic-fueled surge in East End real estate market pushes preservation tax revenues to new record highs"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0628_home-for-sale-elliman.jpeg?fit=800%2C533&quality=100&ssl=1"><meta itemprop="width" content="800"><meta itemprop="height" content="533"></span> </footer>
<div class="fb-comments" data-href="https://riverheadlocal.com/2021/06/28/pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs/" data-width="100%" data-mobile="true" data-numposts="10" data-order-by="social" data-colorscheme="light"></div> </div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68459" count="1"></broadstreet-zone></div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="kb-popout-content td-pb-row">
<div class="wpb_wrapper">
<div class="wpb_text_column block-header">
<p>Daily Newsletter</p>
</div>
<div class="wpb_wrapper wpb_text_column td-pb-border-top">
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://riverheadlocal.us6.list-manage.com/subscribe/post?u=47e88a318d72559c43e4b77bc&amp;id=8118172d70" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div class="mc-field-group first-name"><label for="mce-FNAME">First Name </label><br />
<input id="mce-FNAME" class="required" name="FNAME" type="text" value="" /></div>
<div class="mc-field-group last-name"><label for="mce-LNAME">Last Name </label><br />
<input id="mce-LNAME" class="required" name="LNAME" type="text" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_47e88a318d72559c43e4b77bc_8118172d70" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p>
</div>
</div>
</div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone></div>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div>
</div> 


<div class="td-footer-container td-container td-footer-template-10">
<div class="footer-social-wrap td-social-style2 td-footer-full">
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer1-container"><ul id="menu-footer1" class="td-subfooter-menu"><li id="menu-item-132941" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-132941"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-132940" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132940"><a href="https://riverheadlocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-132944" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132944"><a href="https://riverheadlocal.com/comments-policy/">Comments Policy</a></li>
<li id="menu-item-132945" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132945"><a href="https://riverheadlocal.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-138664" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-138664"><a href="https://riverheadlocal.com/correction-policy/">Correction Policy</a></li>
</ul></div> </div>
</div>
<div class="td-pb-span4 td-sub-footer-copy">
<div class="td-pb-padding-side">
&copy; <a href="https://riverheadlocal.com/copyright-notice/">2010-2021 East End Local Media Corp</a> </div>
</div>
</div>
</div>
</div>
</div>
<div class="a2a_kit a2a_kit_size_36 a2a_floating_style a2a_vertical_style" style="left:0px;top:400px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;left:5px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F06%2F28%2Fpandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs%2F&amp;linkname=Pandemic-fueled%20surge%20in%20East%20End%20real%20estate%20market%20pushes%20preservation%20tax%20revenues%20to%20new%20record%20highs%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><a rel="nofollow" style="display:none;" href="https://riverheadlocal.com/?blackhole=aa756bbedb" title="Do NOT follow this link or you will be banned from the site!">RiverheadLOCAL</a>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','local-news','news','real-estate-news','news','pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["local-news","news","real-estate-news","news","pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs","post"],"url":"pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({"useAltZone":767,"altZoneWhitelist":[71281],"networkId":"4821","targets":{"pagetype":["post","not_home_page"],"category":["local-news","news","real-estate-news","news","pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs","post"],"url":"pandemic-fueled-surge-in-east-end-real-estate-market-pushes-preservation-tax-revenues-to-new-record-highs"}});
 });</script>

<script type="text/javascript">(function($) {
  $.fn.almComplete = function(alm){
    
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");


      

    var $pageNumber;
    if ($('.kb-alm-wrap-page-3').length) {
        $pageNumber = 3; 
       // console.log("We're on page 3");
    } else if ($('.kb-alm-wrap-page-2').length) {
        $pageNumber = 2;
        // console.log("We're on page 2");
    } else {
        $pageNumber = 1;
        // console.log("We're on page 1");
    }
    
    // Parse FB comments code
    
    var $newContainerString = '.alm-page-' + $pageNumber;
    var $newContainer = $($newContainerString).parent();

    FB.XFBML.parse($newContainer[0]);
    
    // Append alm button to wrapper
    
    var $new_name = '.kb-alm-wrap-page-' + $pageNumber;
    // $('.alm-btn-wrap').detach();
    // $('.alm-btn-wrap').appendTo($new_name);
  
    // console.log("Button moved!");
    
    for ( var i = 0; i < tdSmartSidebar.items.length; i++ ) {
                    if ( 'case_3_bottom_of_content' === tdSmartSidebar.items[ i ].sidebar_state ) {
                        tdSmartSidebar.items[ i ].sidebar_state = 'case_1_fixed_down';
                       //  console.log("fixed down!");
                    }
                }
                
    var base_url = "https://riverheadlocal.com";
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.js" );
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js" );
//    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/jquery-3.1.1.min.js" );

   // console.log("Alm complte!");
   var jigs = jQuery('.justified-image-grid');
    if(jigs.length !== 0){
       jigs.data('justifiedImageGrid').createGallery('resize');
    }
  };
})(jQuery);

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");
    
 /*  $( 'body' ).on( 'post-load', function() {
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      } ); 
    // type = From which addon (previous-post | seo)
    // permalink = the updated url
    console.log("URL updated to " + permalink + '- dispatched from the '+ type + ' add-on.'); */
  }; 
})(jQuery);

(function($) {
    $(window).load(function(){
  // $('.alm-btn-wrap').appendTo($('.kb-alm-wrap'));
   // console.log("Button moved!");
});
})(jQuery);</script> 
<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-aJ5TJKLfrG9cB",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-aJ5TJKLfrG9cB.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<link rel='stylesheet' id='photoswipe-style-css' href='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/css/photoswipe4.min.css?ver=4.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id='jquery-ui-mouse-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.12.1' id='jquery-ui-resizable-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.12.1' id='jquery-ui-draggable-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/controlgroup.min.js?ver=1.12.1' id='jquery-ui-controlgroup-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/checkboxradio.min.js?ver=1.12.1' id='jquery-ui-checkboxradio-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/button.min.js?ver=1.12.1' id='jquery-ui-button-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.12.1' id='jquery-ui-dialog-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/wpdialog.min.js?ver=5.7.1' id='wpdialogs-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/sticky-kit.js?ver=1.0.6' id='sticky_kit-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.3' id='td-site-min-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/photoswipe4.min.js?ver=4.1.3' id='photoswipe-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/jquery.dotdotdot.js?ver=3.0.3' id='dotdotdot-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js?ver=4.1.1' id='justified-image-grid-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.7.1' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210604' id='jetpack_related-posts-js'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://riverheadlocal.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script src='https://stats.wp.com/e-202126.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8.1',blog:'77146263',post:'140900',tz:'-4',srv:'riverheadlocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '77146263', '140900' ]);
</script>
</body>
</html>
