<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Grassroots group donates 2,600 masks to Riverhead schools | RiverheadLOCAL</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="pingback" href="https://riverheadlocal.com/xmlrpc.php" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<meta property="og:image" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?fit=800%2C540&quality=100&ssl=1" /><link rel="icon" type="image/png" href="https://riverheadlocal.com/wp-content/uploads/2017/04/favicon.png">

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Grassroots group donates 2,600 masks to Riverhead schools | RiverheadLOCAL" />
<meta property="og:description" content="Masks for Students, a group  spearheaded by Riverhead PTSO officers, has organized a massive effort to buy, sew and collect masks for Riverhead kids." />
<meta property="og:url" content="https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/" />
<meta property="og:site_name" content="RiverheadLOCAL" />
<meta property="article:tag" content="Diane Tucci" />
<meta property="article:tag" content="Riverhead Central School District" />
<meta property="article:section" content="Community News" />
<meta property="article:published_time" content="2020-09-29T12:48:47+00:00" />
<meta property="article:modified_time" content="2020-09-29T12:49:01+00:00" />
<meta property="og:updated_time" content="2020-09-29T12:49:01+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Masks for Students, a group spearheaded by Riverhead PTSO officers, has organized a massive effort to buy, sew and collect masks for Riverhead kids." />
<meta name="twitter:title" content="Grassroots group donates 2,600 masks to Riverhead schools | RiverheadLOCAL" />
<meta name="twitter:image" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?fit=800%2C540&#038;quality=100&#038;ssl=1" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://riverheadlocal.com/#website","url":"https://riverheadlocal.com/","name":"RiverheadLOCAL","inLanguage":"en-US","description":"News and events for Riverhead, New York","potentialAction":[{"@type":"SearchAction","target":"https://riverheadlocal.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?fit=800%2C540&quality=100&ssl=1","width":800,"height":540},{"@type":"WebPage","@id":"https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/#webpage","url":"https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/","name":"Grassroots group donates 2,600 masks to Riverhead schools | RiverheadLOCAL","isPartOf":{"@id":"https://riverheadlocal.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/#primaryimage"},"datePublished":"2020-09-29T12:48:47+00:00","dateModified":"2020-09-29T12:49:01+00:00","author":{"@id":"https://riverheadlocal.com/#/schema/person/d176783e504eaed24b0e395623cb4932"},"potentialAction":[{"@type":"ReadAction","target":["https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/"]}]},{"@type":["Person"],"@id":"https://riverheadlocal.com/#/schema/person/d176783e504eaed24b0e395623cb4932","name":"RiverheadLOCAL","image":{"@type":"ImageObject","@id":"https://riverheadlocal.com/#authorlogo","inLanguage":"en-US","url":"https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/Local_Black_Flat_130.png?fit=96%2C34&quality=100&ssl=1","caption":"RiverheadLOCAL"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Feed" href="https://riverheadlocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Comments Feed" href="https://riverheadlocal.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='kb-membership-style-css' href='https://riverheadlocal.com/wp-content/plugins/kb-membership/inc/style.css?ver=6.1.991' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://riverheadlocal.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='https://riverheadlocal.com/wp-includes/css/jquery-ui-dialog.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://riverheadlocal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fc-form-css-css' href='https://riverheadlocal.com/wp-content/plugins/Formcraft/assets/css/form.min.css?ver=3.2.27' type='text/css' media='all' />
<link rel='stylesheet' id='kb-liveblog-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-liveblog/style.css?ver=6.0.200' type='text/css' media='all' />
<link rel='stylesheet' id='public_notices_css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-public-notices/kb-public-notices.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-top-stories-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-top-stories/style.css?ver=1.1.735' type='text/css' media='all' />
<link rel='stylesheet' id='trans-frontend-css' href='https://riverheadlocal.com/wp-content/plugins/kb-translation/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-min-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/icons/css/weather-icons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-wind-min-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/icons/css/weather-icons-wind.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-weather-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/css/kb-weather.css?ver=1.7.434' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://riverheadlocal.com/wp-content/themes/Newsmag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css?ver=5.0.0219' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C100%2C100italic%2C200%2C200italic%2C300italic%2C400italic%2C500%2C500italic%2C600italic%2C700italic%2C800%2C800italic%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C100%2C100italic%2C200%2C200italic%2C500%2C500italic%2C600%2C600italic%2C800%2C800italic&#038;ver=4.3&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css' href='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css' href='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css' href='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://riverheadlocal.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1125px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1124px){
.a2a_floating_style.a2a_default_style{display:none;}
}
.a2a_floating_style {
    padding: 20px;
    border-radius: 0;
    border: 1px solid #bbbbbb;
}
</style>
<link rel='stylesheet' id='js_composer_front-css' href='https://riverheadlocal.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://riverheadlocal.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-membership/inc/button.js?ver=6.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-liveblog/scripts.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-weather/js/modernizr.custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-weather/js/summary-box.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.25'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/common-scripts.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/popup-menu-fix.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://riverheadlocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverheadlocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverheadlocal.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://riverheadlocal.com/?p=137379' />
<link rel="alternate" type="application/json+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color = "#A0A0A0";

a2a_config.templates = {
    email: {
        subject: "RiverheadLOCAL: ${title}",
        body: "Check out this story on RiverheadLOCAL: \n${title}\n${link}"
    }
};

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      }; 
})(jQuery);
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>


<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Grassroots group donates 2,600 masks to Riverhead schools | RiverheadLOCAL","pagePostType":"post","pagePostType2":"single-post","pageCategory":["community-news"],"pageAttributes":["diane-tucci","riverhead-central-school-district"],"pagePostAuthor":"RiverheadLOCAL","pagePostDate":"Sep 29, 2020, 8:48 am","pagePostDateYear":"2020","pagePostDateMonth":"09","pagePostDateDay":"29"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N97RFZC');//]]>
</script>


<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<script src="https://use.fontawesome.com/b3fb28acc8.js"></script><meta property="fb:app_id" content="105130769527571" /><meta name="google-site-verification" content="7jViI0XrkgkIYGyQD0GNoWcify30WyzN3o4ZHzUGfdo" /><script data-ad-client="ca-pub-6009741394491678" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var adSlotLeaderboard = googletag.defineSlot('/21874054635/Sitewide', [728, 90], 'div-gpt-ad-leaderboard');
    adSlotLeaderboard.addService(googletag.pubads());
    adSlotLeaderboard.setTargeting('position', ['leaderboard']);
    var adSlotSidebar1= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-1');
	    adSlotSidebar1.addService(googletag.pubads());
	    adSlotSidebar1.setTargeting('position', ['sidebar']);
	    var adSlotSidebar2= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-2');
	    adSlotSidebar2.addService(googletag.pubads());
	    adSlotSidebar2.setTargeting('position', ['sidebar']);
	    var adSlotSidebar3= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-3');
	    adSlotSidebar3.addService(googletag.pubads());
	    adSlotSidebar3.setTargeting('position', ['sidebar']);
	    var adSlotSidebar4= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-4');
	    adSlotSidebar4.addService(googletag.pubads());
	    adSlotSidebar4.setTargeting('position', ['sidebar']);
	    var adSlotSidebar5= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-5');
	    adSlotSidebar5.addService(googletag.pubads());
	    adSlotSidebar5.setTargeting('position', ['sidebar']);
	    var adSlotSidebar = googletag.defineSlot('/21874054635/Sitewide', ['fluid'], 'div-gpt-ad-lead-sidebar');
    adSlotSidebar.addService(googletag.pubads());
    adSlotSidebar.setTargeting('position', ['lead-sidebar']);
    
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://riverheadlocal.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '82fba20f-da37-4c38-a7fe-ee7dbe081e0f';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://riverheadlocal.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.370dd028-ab8a-4720-9087-4e2c917686de";
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_ajax_url="https:\/\/riverheadlocal.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=4.3";
var td_get_template_directory_uri="https:\/\/riverheadlocal.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e12025";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=32%2C32&#038;quality=100&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>
<body class="post-template-default single single-post postid-137379 single-format-standard author-riverheadlocal grassroots-group-donates-2600-masks-to-riverhead-schools global-block-template-1 white-menu wpb-js-composer js-comp-ver-6.1 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N97RFZC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '105130769527571',
      xfbml      : true,
      version    : 'v2.9'
    });
    FB.AppEvents.logPageView();
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div class="td-mobile-container">

<div class="kb-menu-socials-wrap">

<div class="kb-menu-socials">
</div>
</div>

<div class="kb-mobile-search-container"><form method="get" class="td-search-form-widget" action="https://riverheadlocal.com/">
<div role="search" class="kb-mobile-search">
<button class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit"><i class="td-icon-search"></i></button>
<div class="kb-search-input-wrap"><input class="td-widget-search-input" type="text" value="Search" name="s" id="s" onfocus="if (this.value=='Search') this.value='';" onblur="if (this.value=='') this.value='Search';" /></div>
</div>
</form>
</div>

<div class="td-mobile-content">
<div class="menu-mobile-container"><ul id="menu-mobile" class="td-mobile-main-menu"><li id="menu-item-116721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-116721"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100685" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100685"><a href="https://riverheadlocal.com/news/">News</a></li>
<li id="menu-item-100683" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100683"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a></li>
<li id="menu-item-100686" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100686"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100687" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-100687"><a href="https://riverheadlocal.com/community/">Community</a></li>
<li id="menu-item-100693" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-100693"><a href="http://eastendlocal.com">Events</a></li>
<li id="menu-item-100688" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100688"><a href="https://riverheadlocal.com/schools/">Schools</a></li>
<li id="menu-item-100684" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100684"><a href="https://riverheadlocal.com/business/business-news/">Business</a></li>
<li id="menu-item-100691" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100691"><a href="https://riverheadlocal.com/living/">Living</a></li>
<li id="menu-item-100692" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100692"><a href="https://riverheadlocal.com/opinion/">Opinion</a></li>
<li id="menu-item-100694" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100694"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-108418" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108418"><a href="https://classifieds.eastendlocal.com">Classifieds</a></li>
<li id="menu-item-136097" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-136097"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-100695" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-100695"><a href="https://riverheadlocal.com/contact/">Contact RiverheadLOCAL</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div id="kb-overlay"></div>
<div class="td-header-wrap td-header-style-3">
<div class="td-top-menu-full">
<div class="td-header-row td-header-top-menu td-make-full">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-100681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-100681"><a href="https://riverheadlocal.com/contact/">Contact</a></li>
<li id="menu-item-130976" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-130976"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-100680" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100680"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-24924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24924"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-116691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116691"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-24925" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24925"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/classifieds/">Classifieds</a></li>
<li id="menu-item-129406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129406"><a href="https://riverheadlocal.com/support-local-journalism/">Membership</a></li>
</ul></div></div> </div>

</div>
</div>

<div class="td-header-container">
<div class="td-header-logo-wrap">
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
<span class="td-visual-hidden">RiverheadLOCAL</span>
</a>
</div>
<div class="td-header-right-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-main-menu">
<div class="td-header-menu-wrap-sub">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-header-right-header mobile-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main" class="sf-menu"><li id="menu-item-100668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-100668"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100671" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100671"><a href="https://riverheadlocal.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_5f735a011963f = new tdBlock();
block_td_uid_1_5f735a011963f.id = "td_uid_1_5f735a011963f";
block_td_uid_1_5f735a011963f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"103","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5f735a011963f_rand","tdc_css_class":"td_uid_1_5f735a011963f_rand","tdc_css_class_style":"td_uid_1_5f735a011963f_rand_style"}';
block_td_uid_1_5f735a011963f.td_column_number = "3";
block_td_uid_1_5f735a011963f.block_type = "td_block_mega_menu";
block_td_uid_1_5f735a011963f.post_count = "5";
block_td_uid_1_5f735a011963f.found_posts = "6498";
block_td_uid_1_5f735a011963f.header_color = "";
block_td_uid_1_5f735a011963f.ajax_pagination_infinite_stop = "";
block_td_uid_1_5f735a011963f.max_num_pages = "1300";
tdBlocksArray.push(block_td_uid_1_5f735a011963f);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_1_5f735a011963f_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_5f735a011963f"><div id=td_uid_1_5f735a011963f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/29/suffolk-legislators-this-week-to-consider-two-major-land-buys-in-riverhead-bias-driven-false-reports-to-police-and-zombie-homes/" rel="bookmark" class="td-image-wrap" title="Suffolk legislators this week to consider two major land buys in Riverhead, bias-driven false reports to police and zombie homes"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/06/2019_0616_suffolk_legislature-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/06/2019_0616_suffolk_legislature-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/06/2019_0616_suffolk_legislature-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/06/2019_0616_suffolk_legislature-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/06/2019_0616_suffolk_legislature-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/06/2019_0616_suffolk_legislature-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/06/2019_0616_suffolk_legislature-1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Suffolk legislators this week to consider two major land buys in Riverhead, bias-driven false reports to police and zombie homes" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/29/suffolk-legislators-this-week-to-consider-two-major-land-buys-in-riverhead-bias-driven-false-reports-to-police-and-zombie-homes/" rel="bookmark" title="Suffolk legislators this week to consider two major land buys in Riverhead, bias-driven false reports to police and zombie homes">Suffolk legislators this week to consider two major land buys in Riverhead, bias-driven false reports to police and zombie homes</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/29/hot-real-estate-market-driven-by-covid-exodus-sets-record-in-land-preservation-tax-collection/" rel="bookmark" class="td-image-wrap" title="Hot real estate market driven by COVID &#8216;exodus&#8217; sets record in land preservation tax collection"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_sold-sign-home.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Hot real estate market driven by COVID &#8216;exodus&#8217; sets record in land preservation tax collection" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/29/hot-real-estate-market-driven-by-covid-exodus-sets-record-in-land-preservation-tax-collection/" rel="bookmark" title="Hot real estate market driven by COVID &#8216;exodus&#8217; sets record in land preservation tax collection">Hot real estate market driven by COVID &#8216;exodus&#8217; sets record in land preservation tax collection</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/26/giglio-withdraws-proposal-to-require-updated-c-o-for-real-estate-sales/" rel="bookmark" class="td-image-wrap" title="Giglio withdraws proposal to require updated C.O. for real estate sales"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0109_Giglio-Dec-2019-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Giglio withdraws proposal to require updated C.O. for real estate sales" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/26/giglio-withdraws-proposal-to-require-updated-c-o-for-real-estate-sales/" rel="bookmark" title="Giglio withdraws proposal to require updated C.O. for real estate sales">Giglio withdraws proposal to require updated C.O. for real estate sales</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/25/riverhead-considers-requiring-owners-to-obtain-updated-c-o-s-before-selling-property/" rel="bookmark" class="td-image-wrap" title="Riverhead considers requiring owners to obtain updated C.O.s before selling property"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1028_for_sale_by_owner_sign_house.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="house for sale" title="Riverhead considers requiring owners to obtain updated C.O.s before selling property" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/25/riverhead-considers-requiring-owners-to-obtain-updated-c-o-s-before-selling-property/" rel="bookmark" title="Riverhead considers requiring owners to obtain updated C.O.s before selling property">Riverhead considers requiring owners to obtain updated C.O.s before selling property</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/25/riverhead-high-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" class="td-image-wrap" title="Riverhead High School staff member tests positive for COVID-19"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead High School staff member tests positive for COVID-19" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/25/riverhead-high-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" title="Riverhead High School staff member tests positive for COVID-19">Riverhead High School staff member tests positive for COVID-19</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_5f735a011963f" id="td_uid_2_5f735a01205ce" data-td_block_id="td_uid_1_5f735a011963f" data-td_filter_value="" href="https://riverheadlocal.com/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_5f735a011963f" id="td_uid_3_5f735a01206ab" data-td_block_id="td_uid_1_5f735a011963f" data-td_filter_value="105" href="https://riverheadlocal.com/news/local-news/">Local News</a><a class="mega-menu-sub-cat-td_uid_1_5f735a011963f" id="td_uid_4_5f735a0120747" data-td_block_id="td_uid_1_5f735a011963f" data-td_filter_value="32" href="https://riverheadlocal.com/news/local-news/health/">Health</a><a class="mega-menu-sub-cat-td_uid_1_5f735a011963f" id="td_uid_5_5f735a01207f5" data-td_block_id="td_uid_1_5f735a011963f" data-td_filter_value="16007" href="https://riverheadlocal.com/news/local-news/weekly-roundup/">Weekend Roundup</a><a class="mega-menu-sub-cat-td_uid_1_5f735a011963f" id="td_uid_6_5f735a01208f2" data-td_block_id="td_uid_1_5f735a011963f" data-td_filter_value="108" href="https://riverheadlocal.com/news/public-notices/">Public Notices</a><a class="mega-menu-sub-cat-td_uid_1_5f735a011963f" id="td_uid_7_5f735a01209ae" data-td_block_id="td_uid_1_5f735a011963f" data-td_filter_value="104" href="https://riverheadlocal.com/news/town-hall-notebook/">Town Hall Notebook</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5f735a011963f" data-td_block_id="td_uid_1_5f735a011963f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5f735a011963f" data-td_block_id="td_uid_1_5f735a011963f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100669" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100669"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_8_5f735a014f508 = new tdBlock();
block_td_uid_8_5f735a014f508.id = "td_uid_8_5f735a014f508";
block_td_uid_8_5f735a014f508.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_8_5f735a014f508_rand","tdc_css_class":"td_uid_8_5f735a014f508_rand","tdc_css_class_style":"td_uid_8_5f735a014f508_rand_style"}';
block_td_uid_8_5f735a014f508.td_column_number = "3";
block_td_uid_8_5f735a014f508.block_type = "td_block_mega_menu";
block_td_uid_8_5f735a014f508.post_count = "5";
block_td_uid_8_5f735a014f508.found_posts = "2456";
block_td_uid_8_5f735a014f508.header_color = "";
block_td_uid_8_5f735a014f508.ajax_pagination_infinite_stop = "";
block_td_uid_8_5f735a014f508.max_num_pages = "492";
tdBlocksArray.push(block_td_uid_8_5f735a014f508);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_8_5f735a014f508_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_8_5f735a014f508"><div id=td_uid_8_5f735a014f508 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/28/two-men-charged-in-violent-hold-up-at-jamesport-gas-station-sunday-night-police-say-third-suspect-remains-at-large/" rel="bookmark" class="td-image-wrap" title="Two men charged in violent hold-up at Jamesport gas station Sunday night, police say; third suspect remains at large"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_valero_Jamesport.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_valero_Jamesport.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_valero_Jamesport.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_valero_Jamesport.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_valero_Jamesport.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_valero_Jamesport.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_valero_Jamesport.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_valero_Jamesport.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Two men charged in violent hold-up at Jamesport gas station Sunday night, police say; third suspect remains at large" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/28/two-men-charged-in-violent-hold-up-at-jamesport-gas-station-sunday-night-police-say-third-suspect-remains-at-large/" rel="bookmark" title="Two men charged in violent hold-up at Jamesport gas station Sunday night, police say; third suspect remains at large">Two men charged in violent hold-up at Jamesport gas station Sunday night, police say; third suspect remains at large</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/27/police-riverhead-man-stabbed-in-flanders-early-sunday-morning/" rel="bookmark" class="td-image-wrap" title="Police: Riverhead man stabbed in Flanders early Sunday morning"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/07/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/07/2016_0726_police_car_lights.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/07/2016_0726_police_car_lights.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Police: Riverhead man stabbed in Flanders early Sunday morning" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/27/police-riverhead-man-stabbed-in-flanders-early-sunday-morning/" rel="bookmark" title="Police: Riverhead man stabbed in Flanders early Sunday morning">Police: Riverhead man stabbed in Flanders early Sunday morning</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/24/woman-surprises-burglar-uses-medical-alert-device-to-call-for-help/" rel="bookmark" class="td-image-wrap" title="Woman surprises burglar, uses medical alert device to call for help: cops"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1129-Southampton-Police-Headquarters-sign-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Woman surprises burglar, uses medical alert device to call for help: cops" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/24/woman-surprises-burglar-uses-medical-alert-device-to-call-for-help/" rel="bookmark" title="Woman surprises burglar, uses medical alert device to call for help: cops">Woman surprises burglar, uses medical alert device to call for help: cops</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/19/police-investigate-shooting-that-injured-two-males-friday-night-on-ostrander-avenue-near-middle-road/" rel="bookmark" class="td-image-wrap" title="Police investigate shooting that injured two males Friday night on Ostrander Avenue near Middle Road"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0919_Ostrander_Middle_Google-Earth.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Police investigate shooting that injured two males Friday night on Ostrander Avenue near Middle Road" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/19/police-investigate-shooting-that-injured-two-males-friday-night-on-ostrander-avenue-near-middle-road/" rel="bookmark" title="Police investigate shooting that injured two males Friday night on Ostrander Avenue near Middle Road">Police investigate shooting that injured two males Friday night on Ostrander Avenue near Middle Road</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/13/man-struck-by-train-in-riverhead-airlifted-to-stony-brook-with-serious-injury/" rel="bookmark" class="td-image-wrap" title="Man struck by train in Riverhead, airlifted to Stony Brook with serious injury"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Man struck by train in Riverhead, airlifted to Stony Brook with serious injury" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/13/man-struck-by-train-in-riverhead-airlifted-to-stony-brook-with-serious-injury/" rel="bookmark" title="Man struck by train in Riverhead, airlifted to Stony Brook with serious injury">Man struck by train in Riverhead, airlifted to Stony Brook with serious injury</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_8_5f735a014f508" id="td_uid_9_5f735a0153a69" data-td_block_id="td_uid_8_5f735a014f508" data-td_filter_value="" href="https://riverheadlocal.com/police-fire/">All</a><a class="mega-menu-sub-cat-td_uid_8_5f735a014f508" id="td_uid_10_5f735a0153af4" data-td_block_id="td_uid_8_5f735a014f508" data-td_filter_value="42" href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a><a class="mega-menu-sub-cat-td_uid_8_5f735a014f508" id="td_uid_11_5f735a0153b5f" data-td_block_id="td_uid_8_5f735a014f508" data-td_filter_value="41" href="https://riverheadlocal.com/police-fire/police-blotter/">Police Reports</a><a class="mega-menu-sub-cat-td_uid_8_5f735a014f508" id="td_uid_12_5f735a0153beb" data-td_block_id="td_uid_8_5f735a014f508" data-td_filter_value="43" href="https://riverheadlocal.com/police-fire/riverhead-justice-court/">Riverhead Justice Court</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_8_5f735a014f508" data-td_block_id="td_uid_8_5f735a014f508"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_8_5f735a014f508" data-td_block_id="td_uid_8_5f735a014f508"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100672" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100672"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100673" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-mega-menu menu-item-100673"><a href="https://riverheadlocal.com/community/">Community</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_13_5f735a016a378 = new tdBlock();
block_td_uid_13_5f735a016a378.id = "td_uid_13_5f735a016a378";
block_td_uid_13_5f735a016a378.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"113","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_5f735a016a378_rand","tdc_css_class":"td_uid_13_5f735a016a378_rand","tdc_css_class_style":"td_uid_13_5f735a016a378_rand_style"}';
block_td_uid_13_5f735a016a378.td_column_number = "3";
block_td_uid_13_5f735a016a378.block_type = "td_block_mega_menu";
block_td_uid_13_5f735a016a378.post_count = "5";
block_td_uid_13_5f735a016a378.found_posts = "3909";
block_td_uid_13_5f735a016a378.header_color = "";
block_td_uid_13_5f735a016a378.ajax_pagination_infinite_stop = "";
block_td_uid_13_5f735a016a378.max_num_pages = "782";
tdBlocksArray.push(block_td_uid_13_5f735a016a378);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_13_5f735a016a378_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_5f735a016a378"><div id=td_uid_13_5f735a016a378 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/" rel="bookmark" class="td-image-wrap" title="Grassroots group donates 2,600 masks to Riverhead schools"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Grassroots group donates 2,600 masks to Riverhead schools" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/" rel="bookmark" title="Grassroots group donates 2,600 masks to Riverhead schools">Grassroots group donates 2,600 masks to Riverhead schools</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/28/physicians-foundation-works-to-cure-diaper-need/" rel="bookmark" class="td-image-wrap" title="Physicians&#8217; foundation works to cure diaper need"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0928_diaper-donation-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Physicians&#8217; foundation works to cure diaper need" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/28/physicians-foundation-works-to-cure-diaper-need/" rel="bookmark" title="Physicians&#8217; foundation works to cure diaper need">Physicians&#8217; foundation works to cure diaper need</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/26/zoom-into-poetry-street-monthly-open-mic-venue-goes-virtual-in-pandemic/" rel="bookmark" class="td-image-wrap" title="Zoom into Poetry Street: monthly open-mic venue goes virtual in pandemic"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0926_Poetry-Street.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0926_Poetry-Street.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0926_Poetry-Street.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0926_Poetry-Street.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0926_Poetry-Street.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0926_Poetry-Street.jpg?resize=511%2C380&#038;quality=100&#038;ssl=1 511w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0926_Poetry-Street.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Zoom into Poetry Street: monthly open-mic venue goes virtual in pandemic" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/26/zoom-into-poetry-street-monthly-open-mic-venue-goes-virtual-in-pandemic/" rel="bookmark" title="Zoom into Poetry Street: monthly open-mic venue goes virtual in pandemic">Zoom into Poetry Street: monthly open-mic venue goes virtual in pandemic</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/23/pbmc-invites-community-to-unmasking-the-heroes-virtual-gala-friday-evening/" rel="bookmark" class="td-image-wrap" title="PBMC invites community to &#8216;Unmasking the Heroes&#8217; virtual gala Friday evening"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_PBMC_gala.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="PBMC invites community to &#8216;Unmasking the Heroes&#8217; virtual gala Friday evening" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/23/pbmc-invites-community-to-unmasking-the-heroes-virtual-gala-friday-evening/" rel="bookmark" title="PBMC invites community to &#8216;Unmasking the Heroes&#8217; virtual gala Friday evening">PBMC invites community to &#8216;Unmasking the Heroes&#8217; virtual gala Friday evening</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/21/the-greater-jamesport-civic-association-will-meet-on-sept-26/" rel="bookmark" class="td-image-wrap" title="The Greater Jamesport Civic Association will meet on Sept. 26"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/JMH-e1497981728167.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/JMH-e1497981728167.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/JMH-e1497981728167.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="The Greater Jamesport Civic Association will meet on Sept. 26" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/21/the-greater-jamesport-civic-association-will-meet-on-sept-26/" rel="bookmark" title="The Greater Jamesport Civic Association will meet on Sept. 26">The Greater Jamesport Civic Association will meet on Sept. 26</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_5f735a016a378" id="td_uid_14_5f735a0179f93" data-td_block_id="td_uid_13_5f735a016a378" data-td_filter_value="" href="https://riverheadlocal.com/community/">All</a><a class="mega-menu-sub-cat-td_uid_13_5f735a016a378" id="td_uid_15_5f735a017a080" data-td_block_id="td_uid_13_5f735a016a378" data-td_filter_value="128" href="https://riverheadlocal.com/community/announcements/">Announcements</a><a class="mega-menu-sub-cat-td_uid_13_5f735a016a378" id="td_uid_16_5f735a017a13e" data-td_block_id="td_uid_13_5f735a016a378" data-td_filter_value="126" href="https://riverheadlocal.com/community/community-news/">Community News</a><a class="mega-menu-sub-cat-td_uid_13_5f735a016a378" id="td_uid_17_5f735a017a1ee" data-td_block_id="td_uid_13_5f735a016a378" data-td_filter_value="127" href="https://riverheadlocal.com/community/event-photos/">Event Photos</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_5f735a016a378" data-td_block_id="td_uid_13_5f735a016a378"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_5f735a016a378" data-td_block_id="td_uid_13_5f735a016a378"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100674" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100674"><a href="https://riverheadlocal.com/schools/">Schools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_18_5f735a019f326 = new tdBlock();
block_td_uid_18_5f735a019f326.id = "td_uid_18_5f735a019f326";
block_td_uid_18_5f735a019f326.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"185","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_5f735a019f326_rand","tdc_css_class":"td_uid_18_5f735a019f326_rand","tdc_css_class_style":"td_uid_18_5f735a019f326_rand_style"}';
block_td_uid_18_5f735a019f326.td_column_number = "3";
block_td_uid_18_5f735a019f326.block_type = "td_block_mega_menu";
block_td_uid_18_5f735a019f326.post_count = "5";
block_td_uid_18_5f735a019f326.found_posts = "1839";
block_td_uid_18_5f735a019f326.header_color = "";
block_td_uid_18_5f735a019f326.ajax_pagination_infinite_stop = "";
block_td_uid_18_5f735a019f326.max_num_pages = "368";
tdBlocksArray.push(block_td_uid_18_5f735a019f326);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_18_5f735a019f326_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_18_5f735a019f326"><div id=td_uid_18_5f735a019f326 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/25/riverhead-high-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" class="td-image-wrap" title="Riverhead High School staff member tests positive for COVID-19"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead High School staff member tests positive for COVID-19" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/25/riverhead-high-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" title="Riverhead High School staff member tests positive for COVID-19">Riverhead High School staff member tests positive for COVID-19</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/23/covid-shutdown-did-not-feather-school-districts-nest-officials-say/" rel="bookmark" class="td-image-wrap" title="COVID shutdown did not feather school district&#8217;s nest, officials say"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="COVID shutdown did not feather school district&#8217;s nest, officials say" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/23/covid-shutdown-did-not-feather-school-districts-nest-officials-say/" rel="bookmark" title="COVID shutdown did not feather school district&#8217;s nest, officials say">COVID shutdown did not feather school district&#8217;s nest, officials say</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/22/riverhead-middle-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" class="td-image-wrap" title="Riverhead Middle School staff member tests positive for COVID-19"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead Middle School staff member tests positive for COVID-19" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/22/riverhead-middle-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" title="Riverhead Middle School staff member tests positive for COVID-19">Riverhead Middle School staff member tests positive for COVID-19</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/18/riverhead-mobile-school-pantry-to-re-open/" rel="bookmark" class="td-image-wrap" title="Riverhead Mobile School Pantry to re-open"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/12/2018_1031_LI_Cares_mobile_food_pantry_truck.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/12/2018_1031_LI_Cares_mobile_food_pantry_truck.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/12/2018_1031_LI_Cares_mobile_food_pantry_truck.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/12/2018_1031_LI_Cares_mobile_food_pantry_truck.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/12/2018_1031_LI_Cares_mobile_food_pantry_truck.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/12/2018_1031_LI_Cares_mobile_food_pantry_truck.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/12/2018_1031_LI_Cares_mobile_food_pantry_truck.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead Mobile School Pantry to re-open" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/18/riverhead-mobile-school-pantry-to-re-open/" rel="bookmark" title="Riverhead Mobile School Pantry to re-open">Riverhead Mobile School Pantry to re-open</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/16/riverhead-welcomes-new-middle-school-assistant-principal/" rel="bookmark" class="td-image-wrap" title="Riverhead welcomes new middle school assistant principal"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0916_RMS_principal_campbell.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead welcomes new middle school assistant principal" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/16/riverhead-welcomes-new-middle-school-assistant-principal/" rel="bookmark" title="Riverhead welcomes new middle school assistant principal">Riverhead welcomes new middle school assistant principal</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_18_5f735a019f326" id="td_uid_19_5f735a01a440b" data-td_block_id="td_uid_18_5f735a019f326" data-td_filter_value="" href="https://riverheadlocal.com/schools/">All</a><a class="mega-menu-sub-cat-td_uid_18_5f735a019f326" id="td_uid_20_5f735a01a44ec" data-td_block_id="td_uid_18_5f735a019f326" data-td_filter_value="187" href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a><a class="mega-menu-sub-cat-td_uid_18_5f735a019f326" id="td_uid_21_5f735a01a459c" data-td_block_id="td_uid_18_5f735a019f326" data-td_filter_value="190" href="https://riverheadlocal.com/schools/mcgann-mercy-junior-senior-high-school/">McGann-Mercy Junior-Senior High School</a><a class="mega-menu-sub-cat-td_uid_18_5f735a019f326" id="td_uid_22_5f735a01a46b3" data-td_block_id="td_uid_18_5f735a019f326" data-td_filter_value="15377" href="https://riverheadlocal.com/schools/peconic-community-school/">Peconic Community School</a><a class="mega-menu-sub-cat-td_uid_18_5f735a019f326" id="td_uid_23_5f735a01a47a0" data-td_block_id="td_uid_18_5f735a019f326" data-td_filter_value="201" href="https://riverheadlocal.com/schools/riverhead-central-school-district/">Riverhead Central School District</a><a class="mega-menu-sub-cat-td_uid_18_5f735a019f326" id="td_uid_24_5f735a01a4847" data-td_block_id="td_uid_18_5f735a019f326" data-td_filter_value="199" href="https://riverheadlocal.com/schools/riverhead-central-school-district/aquebogue-elementary-school/">Aquebogue Elementary School</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_5f735a019f326" data-td_block_id="td_uid_18_5f735a019f326"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_18_5f735a019f326" data-td_block_id="td_uid_18_5f735a019f326"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-120667" class="tablet-hidden menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-120667"><a href="https://riverheadlocal.com/business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_25_5f735a01d75bf = new tdBlock();
block_td_uid_25_5f735a01d75bf.id = "td_uid_25_5f735a01d75bf";
block_td_uid_25_5f735a01d75bf.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"205","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_25_5f735a01d75bf_rand","tdc_css_class":"td_uid_25_5f735a01d75bf_rand","tdc_css_class_style":"td_uid_25_5f735a01d75bf_rand_style"}';
block_td_uid_25_5f735a01d75bf.td_column_number = "3";
block_td_uid_25_5f735a01d75bf.block_type = "td_block_mega_menu";
block_td_uid_25_5f735a01d75bf.post_count = "5";
block_td_uid_25_5f735a01d75bf.found_posts = "517";
block_td_uid_25_5f735a01d75bf.header_color = "";
block_td_uid_25_5f735a01d75bf.ajax_pagination_infinite_stop = "";
block_td_uid_25_5f735a01d75bf.max_num_pages = "104";
tdBlocksArray.push(block_td_uid_25_5f735a01d75bf);
</script><div class="td_block_wrap td_block_mega_menu td_uid_25_5f735a01d75bf_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_25_5f735a01d75bf"><div id=td_uid_25_5f735a01d75bf class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/24/riverheads-unemployment-rate-drops-below-10-for-the-first-time-since-pandemic-struck/" rel="bookmark" class="td-image-wrap" title="Riverhead&#8217;s unemployment rate drops below 10% for the first time since pandemic struck"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead&#8217;s unemployment rate drops below 10% for the first time since pandemic struck" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/24/riverheads-unemployment-rate-drops-below-10-for-the-first-time-since-pandemic-struck/" rel="bookmark" title="Riverhead&#8217;s unemployment rate drops below 10% for the first time since pandemic struck">Riverhead&#8217;s unemployment rate drops below 10% for the first time since pandemic struck</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/15/coping-with-the-pandemic-and-new-ag-worker-labor-standards-local-farmers-worry-state-may-now-lower-threshold-for-overtime-pay/" rel="bookmark" class="td-image-wrap" title="Coping with the pandemic and new ag worker labor standards, local farmers worry state may now lower threshold for overtime pay"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Coping with the pandemic and new ag worker labor standards, local farmers worry state may now lower threshold for overtime pay" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/15/coping-with-the-pandemic-and-new-ag-worker-labor-standards-local-farmers-worry-state-may-now-lower-threshold-for-overtime-pay/" rel="bookmark" title="Coping with the pandemic and new ag worker labor standards, local farmers worry state may now lower threshold for overtime pay">Coping with the pandemic and new ag worker labor standards, local farmers worry state may now lower threshold for overtime pay</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/15/countys-online-portal-offers-employment-assistance-virtual-job-fairs/" rel="bookmark" class="td-image-wrap" title="County&#8217;s online portal offers employment assistance, virtual job fairs"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="County&#8217;s online portal offers employment assistance, virtual job fairs" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/15/countys-online-portal-offers-employment-assistance-virtual-job-fairs/" rel="bookmark" title="County&#8217;s online portal offers employment assistance, virtual job fairs">County&#8217;s online portal offers employment assistance, virtual job fairs</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/04/riverhead-gun-shop-gains-approval-for-indoor-testing-range/" rel="bookmark" class="td-image-wrap" title="Riverhead gun shop gains approval for indoor firearms testing range"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead gun shop gains approval for indoor firearms testing range" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/04/riverhead-gun-shop-gains-approval-for-indoor-testing-range/" rel="bookmark" title="Riverhead gun shop gains approval for indoor firearms testing range">Riverhead gun shop gains approval for indoor firearms testing range</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/03/after-news-that-suffolk-unemployment-rate-climbed-to-13-6-in-july-state-assembly-candidates-call-for-unemployment-benefit-reform/" rel="bookmark" class="td-image-wrap" title="After news that Suffolk unemployment rate climbed to 13.6% in July, State Assembly candidates call for unemployment benefit reform"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="After news that Suffolk unemployment rate climbed to 13.6% in July, State Assembly candidates call for unemployment benefit reform" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/03/after-news-that-suffolk-unemployment-rate-climbed-to-13-6-in-july-state-assembly-candidates-call-for-unemployment-benefit-reform/" rel="bookmark" title="After news that Suffolk unemployment rate climbed to 13.6% in July, State Assembly candidates call for unemployment benefit reform">After news that Suffolk unemployment rate climbed to 13.6% in July, State Assembly candidates call for unemployment benefit reform</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5f735a01d75bf" data-td_block_id="td_uid_25_5f735a01d75bf"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_25_5f735a01d75bf" data-td_block_id="td_uid_25_5f735a01d75bf"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100676" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100676"><a href="https://riverheadlocal.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_26_5f735a01e282a = new tdBlock();
block_td_uid_26_5f735a01e282a.id = "td_uid_26_5f735a01e282a";
block_td_uid_26_5f735a01e282a.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"81","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_26_5f735a01e282a_rand","tdc_css_class":"td_uid_26_5f735a01e282a_rand","tdc_css_class_style":"td_uid_26_5f735a01e282a_rand_style"}';
block_td_uid_26_5f735a01e282a.td_column_number = "3";
block_td_uid_26_5f735a01e282a.block_type = "td_block_mega_menu";
block_td_uid_26_5f735a01e282a.post_count = "5";
block_td_uid_26_5f735a01e282a.found_posts = "930";
block_td_uid_26_5f735a01e282a.header_color = "";
block_td_uid_26_5f735a01e282a.ajax_pagination_infinite_stop = "";
block_td_uid_26_5f735a01e282a.max_num_pages = "186";
tdBlocksArray.push(block_td_uid_26_5f735a01e282a);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_26_5f735a01e282a_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_26_5f735a01e282a"><div id=td_uid_26_5f735a01e282a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/26/giglio-c-o-proposal-is-withdrawn/" rel="bookmark" class="td-image-wrap" title="Giglio: C.O. proposal is withdrawn"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Giglio: C.O. proposal is withdrawn" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/26/giglio-c-o-proposal-is-withdrawn/" rel="bookmark" title="Giglio: C.O. proposal is withdrawn">Giglio: C.O. proposal is withdrawn</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/20/a-cashless-economy-will-hurt-the-working-poor/" rel="bookmark" class="td-image-wrap" title="A cashless economy will hurt the working poor"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="A cashless economy will hurt the working poor" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/20/a-cashless-economy-will-hurt-the-working-poor/" rel="bookmark" title="A cashless economy will hurt the working poor">A cashless economy will hurt the working poor</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/10/no-more-apartments-no-more-ida-tax-abatements/" rel="bookmark" class="td-image-wrap" title="No more apartments, no more IDA tax abatements"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2015/03/2015_0316_high_school_hallway.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2015/03/2015_0316_high_school_hallway.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2015/03/2015_0316_high_school_hallway.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2015/03/2015_0316_high_school_hallway.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="No more apartments, no more IDA tax abatements" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/10/no-more-apartments-no-more-ida-tax-abatements/" rel="bookmark" title="No more apartments, no more IDA tax abatements">No more apartments, no more IDA tax abatements</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/10/our-children-deserve-better/" rel="bookmark" class="td-image-wrap" title="Our children deserve better"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0910_students_class_masks.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Our children deserve better" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/10/our-children-deserve-better/" rel="bookmark" title="Our children deserve better">Our children deserve better</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/06/with-new-heavy-hitting-partners-shinnecock-nation-shows-its-serious-about-a-l-i-casino/" rel="bookmark" class="td-image-wrap" title="With new heavy-hitting partners, Shinnecock Nation shows it&#8217;s serious about a L.I. casino"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0908_casino_game.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="With new heavy-hitting partners, Shinnecock Nation shows it&#8217;s serious about a L.I. casino" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/06/with-new-heavy-hitting-partners-shinnecock-nation-shows-its-serious-about-a-l-i-casino/" rel="bookmark" title="With new heavy-hitting partners, Shinnecock Nation shows it&#8217;s serious about a L.I. casino">With new heavy-hitting partners, Shinnecock Nation shows it&#8217;s serious about a L.I. casino</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_26_5f735a01e282a" id="td_uid_27_5f735a01e7572" data-td_block_id="td_uid_26_5f735a01e282a" data-td_filter_value="" href="https://riverheadlocal.com/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_26_5f735a01e282a" id="td_uid_28_5f735a01e7646" data-td_block_id="td_uid_26_5f735a01e282a" data-td_filter_value="91" href="https://riverheadlocal.com/opinion/civiletti/">Denise Civiletti</a><a class="mega-menu-sub-cat-td_uid_26_5f735a01e282a" id="td_uid_29_5f735a01e7772" data-td_block_id="td_uid_26_5f735a01e282a" data-td_filter_value="12894" href="https://riverheadlocal.com/opinion/greg-blass/">Greg Blass</a><a class="mega-menu-sub-cat-td_uid_26_5f735a01e282a" id="td_uid_30_5f735a01e7807" data-td_block_id="td_uid_26_5f735a01e282a" data-td_filter_value="99" href="https://riverheadlocal.com/opinion/in-my-opinion/">In My Opinion</a><a class="mega-menu-sub-cat-td_uid_26_5f735a01e282a" id="td_uid_31_5f735a01e78fa" data-td_block_id="td_uid_26_5f735a01e282a" data-td_filter_value="98" href="https://riverheadlocal.com/opinion/java-scripts/">Java Scripts</a><a class="mega-menu-sub-cat-td_uid_26_5f735a01e282a" id="td_uid_32_5f735a01e79c0" data-td_block_id="td_uid_26_5f735a01e282a" data-td_filter_value="16086" href="https://riverheadlocal.com/opinion/katie-blasl/">Katie Blasl</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_26_5f735a01e282a" data-td_block_id="td_uid_26_5f735a01e282a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_26_5f735a01e282a" data-td_block_id="td_uid_26_5f735a01e282a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100677" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100677"><a href="https://riverheadlocal.com/living/">Living</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_33_5f735a021b6ff = new tdBlock();
block_td_uid_33_5f735a021b6ff.id = "td_uid_33_5f735a021b6ff";
block_td_uid_33_5f735a021b6ff.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9530","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_33_5f735a021b6ff_rand","tdc_css_class":"td_uid_33_5f735a021b6ff_rand","tdc_css_class_style":"td_uid_33_5f735a021b6ff_rand_style"}';
block_td_uid_33_5f735a021b6ff.td_column_number = "3";
block_td_uid_33_5f735a021b6ff.block_type = "td_block_mega_menu";
block_td_uid_33_5f735a021b6ff.post_count = "5";
block_td_uid_33_5f735a021b6ff.found_posts = "587";
block_td_uid_33_5f735a021b6ff.header_color = "";
block_td_uid_33_5f735a021b6ff.ajax_pagination_infinite_stop = "";
block_td_uid_33_5f735a021b6ff.max_num_pages = "118";
tdBlocksArray.push(block_td_uid_33_5f735a021b6ff);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_33_5f735a021b6ff_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_33_5f735a021b6ff"><div id=td_uid_33_5f735a021b6ff class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/27/more-than-ever-this-is-a-time-for-prayer/" rel="bookmark" class="td-image-wrap" title="More than ever, this is a time for prayer"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="More than ever, this is a time for prayer" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/27/more-than-ever-this-is-a-time-for-prayer/" rel="bookmark" title="More than ever, this is a time for prayer">More than ever, this is a time for prayer</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/13/can-america-regain-the-unity-that-prevailed-after-sept-11-2001/" rel="bookmark" class="td-image-wrap" title="Can America regain the unity that prevailed after Sept. 11, 2001?"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=1104%2C825&#038;quality=100&#038;ssl=1 1104w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Can America regain the unity that prevailed after Sept. 11, 2001?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/13/can-america-regain-the-unity-that-prevailed-after-sept-11-2001/" rel="bookmark" title="Can America regain the unity that prevailed after Sept. 11, 2001?">Can America regain the unity that prevailed after Sept. 11, 2001?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/12/learning-to-let-go-of-negativity/" rel="bookmark" class="td-image-wrap" title="Learning to let go of negativity"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Learning to let go of negativity" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/12/learning-to-let-go-of-negativity/" rel="bookmark" title="Learning to let go of negativity">Learning to let go of negativity</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/30/this-time-of-pause-offers-a-chance-to-reconnect-with-yourself-your-family-and-god/" rel="bookmark" class="td-image-wrap" title="This time of pause offers a chance to reconnect with yourself, your family and God"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/08/2016_0820_st_isidore_5.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/08/2016_0820_st_isidore_5.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/08/2016_0820_st_isidore_5.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/08/2016_0820_st_isidore_5.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="This time of pause offers a chance to reconnect with yourself, your family and God" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/30/this-time-of-pause-offers-a-chance-to-reconnect-with-yourself-your-family-and-god/" rel="bookmark" title="This time of pause offers a chance to reconnect with yourself, your family and God">This time of pause offers a chance to reconnect with yourself, your family and God</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/16/one-day-at-a-time-takes-on-new-meaning-in-pandemic-life/" rel="bookmark" class="td-image-wrap" title="One day at a time takes on new meaning in pandemic life"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="One day at a time takes on new meaning in pandemic life" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/16/one-day-at-a-time-takes-on-new-meaning-in-pandemic-life/" rel="bookmark" title="One day at a time takes on new meaning in pandemic life">One day at a time takes on new meaning in pandemic life</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_33_5f735a021b6ff" id="td_uid_34_5f735a021eb35" data-td_block_id="td_uid_33_5f735a021b6ff" data-td_filter_value="" href="https://riverheadlocal.com/living/">All</a><a class="mega-menu-sub-cat-td_uid_33_5f735a021b6ff" id="td_uid_35_5f735a021ebff" data-td_block_id="td_uid_33_5f735a021b6ff" data-td_filter_value="100" href="https://riverheadlocal.com/living/bits-and-pieces/">Bits and Pieces</a><a class="mega-menu-sub-cat-td_uid_33_5f735a021b6ff" id="td_uid_36_5f735a021ec94" data-td_block_id="td_uid_33_5f735a021b6ff" data-td_filter_value="94" href="https://riverheadlocal.com/living/laurie-nigro/">Laurie Nigro</a><a class="mega-menu-sub-cat-td_uid_33_5f735a021b6ff" id="td_uid_37_5f735a021ed74" data-td_block_id="td_uid_33_5f735a021b6ff" data-td_filter_value="38" href="https://riverheadlocal.com/living/life-on-purpose/">Life On Purpose</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_33_5f735a021b6ff" data-td_block_id="td_uid_33_5f735a021b6ff"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_33_5f735a021b6ff" data-td_block_id="td_uid_33_5f735a021b6ff"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-76334" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76334"><a target="_blank" href="http://eastendlocal.com/events">Events</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
<div class="breaking-menu-wrap">
<div class="menu-coronavirus-container"><ul id="menu-coronavirus" class="breaking-menu sf-menu"><li id="menu-item-134795" class="breaking-main menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-134795"><a href="https://riverheadlocal.com/coronavirus/">Coronavirus</a></li>
<li id="menu-item-134924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-134924"><a href="https://riverheadlocal.com/coronavirus/#latest-news">Latest updates</a></li>
<li id="menu-item-134797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134797"><a href="https://riverheadlocal.com/coronavirus/">Maps &#038; charts</a></li>
</ul></div> </div>
</div>
</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap broadstreet banner ">
<div class="kb-header-ad"><span class="text"></span> <div class="textwidget"><broadstreet-zone zone-id="68458" count="1"></broadstreet-zone></div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-container td-post-template-3">
<div class="td-container-border">
<article id="post-137379" class="post-137379 post type-post status-publish format-standard has-post-thumbnail hentry category-community-news tag-diane-tucci tag-riverhead-central-school-district author-riverheadlocal" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header td-pb-padding-side">
<ul class="td-category"><li class="entry-category"><a href="https://riverheadlocal.com/community/">Community</a></li><li class="entry-category"><a href="https://riverheadlocal.com/community/community-news/">Community News</a></li></ul>
<header>
<h1 class="entry-title">Grassroots group donates 2,600 masks to Riverhead schools</h1>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://riverheadlocal.com/author/rlocal/" title="Posts by RiverheadLOCAL" class="author url fn" rel="author">RiverheadLOCAL</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-09-29T08:48:47+00:00">Sep 29, 2020, 8:48 am</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-featured-image"><figure><a href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?fit=800%2C540&quality=100&ssl=1" data-caption="Courtesy photo: Masks for Students"><img width="681" height="460" class="entry-thumb td-modal-image" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=681%2C460&quality=100&ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?w=800&quality=100&ssl=1 800w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=270%2C182&quality=100&ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=768%2C518&quality=100&ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=622%2C420&quality=100&ssl=1 622w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=640%2C432&quality=100&ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?resize=681%2C460&quality=100&ssl=1 681w" sizes="(max-width: 681px) 100vw, 681px" alt="" title="2020_0929_masks for students_kids_1" /></a><figcaption class="wp-caption-text">Courtesy photo: Masks for Students</figcaption></figure></div>
<div class="td-post-content td-pb-padding-side">
<p>In an ongoing campaign to keep Riverhead students safe during the COVID-19 pandemic, a grassroots group of parents and community members has come together for an initial donation of 2,600 masks to the Riverhead Central School District.
<p>The masks, 80% of which are handmade, are being delivered to each principal of the district’s seven schools in late September to ensure every student’s back-to-school supplies include personal protection.
<p>The effort is spearheaded by Diane Tucci, parent, high school PTSO co-vice president and owner of Main Street Media, a Riverhead-based marketing, production and event management firm. Tucci formed Masks for Students after speaking with teachers about their concerns, including Keri Stromski, kindergarten teacher at Aquebogue Elementary School.<broadstreet-zone alt-zone-id="68459" class="mobile-ad" count="1"></broadstreet-zone>
<p>“I was concerned that some children would have fancy masks and different designs and others have the plain ones, which could make children feel bad about the type of masks they had,” Stromski said. “Being able to have all of the children have a special mask with designs, made for them by community members, not only helps them feel excited about the masks, but also lets them know that people care about them and their feelings,” she said.
<p>“This has been challenging for everyone, and to make a child feel special and loved is always a good thing.”
<figure class="wp-block-image size-large"><img src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students.jpeg?w=640&#038;quality=100&#038;ssl=1" alt="" class="wp-image-137380" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students.jpeg?w=799&amp;quality=100&amp;ssl=1 799w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students.jpeg?resize=270%2C177&amp;quality=100&amp;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students.jpeg?resize=200%2C130&amp;quality=100&amp;ssl=1 200w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students.jpeg?resize=768%2C504&amp;quality=100&amp;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students.jpeg?resize=640%2C420&amp;quality=100&amp;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students.jpeg?resize=681%2C447&amp;quality=100&amp;ssl=1 681w" sizes="(max-width: 640px) 100vw, 640px" data-recalc-dims="1" /><figcaption>Courtesy photo: Masks for Students</figcaption></figure>
<p>Tucci set up a <a href="https://www.gofundme.com/f/d5j56-masks-for-students" target="_blank" rel="noreferrer noopener" aria-label="GoFundMe site (opens in a new tab)">GoFundMe site</a> with a goal of raising $5,000 or 10,000 masks. Riverhead High School PTSO President Mary Maki and Riverhead Middle School PTO President Stephanie Burns have also been instrumental in the campaign.
<p>“Parents and teachers have enough to worry about,” said Tucci. “We want our kids to be safe and comfortable and realize this is going to be an ongoing need throughout the school year.”<broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<p>The response has been “amazing,” Tucci said. “It’s incredibly heartwarming to see the support. We have some people donating money or purchasing new masks for distribution while others are buying supplies and sewing the masks themselves. As of now, more than 63 people have been involved in some way.”
<p>Longtime resident and community activist Marilyn Winter, who helped gather donations, said, “As a mother, grandmother and neighbor, keeping the most vulnerable safe is near and dear to my heart. I felt in a small way I would help by pulling together those who have been making masks and those who would be able to donate. Our community joined together for our students and formed a committee of 63 willing hands of love.”
<p>The recipient of the first batch of donated masks was Phillips Avenue Elementary School.
<p>“The students at Phillips Avenue are truly grateful for the donation of masks,” principal Debra Rodgers said. “This initiative by Masks for Students is a true testament to our collective strength and influence.” Rodgers thanked the volunteers, donors, and businesses that made this donation possible.<broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<p>The group is delivering masks today to Riverhead High School, Roanoke Avenue Elementary School and Aquebogue Elementary School.
<p>Those interested in supporting Masks for Students can do so with a donation at the group&#8217;s <a href="https://www.gofundme.com/f/d5j56-masks-for-students" target="_blank" rel="noreferrer noopener" aria-label="GoFundMe site (opens in a new tab)">GoFundMe site</a> or drop off masks at Riverhead Vacuum Sewing Center at 31 East Main Street in Riverhead. Materials and supplies are also available for those willing to sew.
<p><em>Source: Masks for Students press release </em>
<div class="kb-member-content-box"><p><strong><span style="font-size:20px; line-height: 40px;">We need your help.</span></strong><br />Now more than ever, the survival of quality local journalism depends on your support. Our community faces unprecedented economic disruption, and the future of many small businesses are under threat, including our own. It takes time and resources to provide this service. We are a small family-owned operation, and we will do everything in our power to keep it going. But today more than ever before, we will depend on your support to continue. <strong><a href="/support-local-journalism">Support RiverheadLOCAL today.</a></strong> You rely on us to stay informed and we depend on you to make our work possible.</p></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
</div> </div>
<footer>
<div class="td-post-source-tags td-pb-padding-side">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://riverheadlocal.com/topic/diane-tucci/">Diane Tucci</a></li><li><a href="https://riverheadlocal.com/topic/riverhead-central-school-district/">Riverhead Central School District</a></li></ul> </div>
<div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-twitter" style="overflow: visible;"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/" data-text="Grassroots group donates 2,600 masks to Riverhead schools" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li class="td-classic-facebook" style="overflow: visible;"><div class="fb-like" data-href="https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/" data-layout="button_count" data-action="like" data-show-faces="false"></div></li></ul></div></div> <div class="author-box-wrap"><a href="https://riverheadlocal.com/author/rlocal/"><img src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/Local_Black_Flat_130.png?fit=96%2C34&quality=100&ssl=1" width="96" height="34" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://riverheadlocal.com/author/rlocal/">RiverheadLOCAL</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="datePublished" content="2020-09-29T08:48:47+00:00"><meta itemprop="dateModified" content="2020-09-29T08:49:01-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png"></span><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="headline " content="Grassroots group donates 2,600 masks to Riverhead schools"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0929_masks-for-students_kids_1.png?fit=800%2C540&quality=100&ssl=1"><meta itemprop="width" content="800"><meta itemprop="height" content="540"></span> </footer>
<div class="fb-comments" data-href="https://riverheadlocal.com/2020/09/29/grassroots-group-donates-2600-masks-to-riverhead-schools/" data-width="100%" data-mobile="true" data-numposts="10" data-order-by="social" data-colorscheme="light"></div> </div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68459" count="1"></broadstreet-zone></div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="kb-popout-content td-pb-row">
<div class="wpb_wrapper">
<div class="wpb_text_column block-header">
<p>Daily Newsletter</p>
</div>
<div class="wpb_wrapper wpb_text_column td-pb-border-top">
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://riverheadlocal.us6.list-manage.com/subscribe/post?u=47e88a318d72559c43e4b77bc&amp;id=8118172d70" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div class="mc-field-group first-name"><label for="mce-FNAME">First Name </label><br />
<input id="mce-FNAME" class="required" name="FNAME" type="text" value="" /></div>
<div class="mc-field-group last-name"><label for="mce-LNAME">Last Name </label><br />
<input id="mce-LNAME" class="required" name="LNAME" type="text" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_47e88a318d72559c43e4b77bc_8118172d70" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p>
</div>
</div>
</div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68461" count="1"></broadstreet-zone></div>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div>
</div> 


<div class="td-footer-container td-container td-footer-template-10">
<div class="footer-social-wrap td-social-style2 td-footer-full">
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer1-container"><ul id="menu-footer1" class="td-subfooter-menu"><li id="menu-item-132939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-132939"><a href="https://riverheadlocal.com/copyright-notice/">© 2010-2020 East End Local Media Corp</a></li>
<li id="menu-item-132941" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132941"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-132940" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132940"><a href="https://riverheadlocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-132944" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132944"><a href="https://riverheadlocal.com/comments-policy/">Comments Policy</a></li>
<li id="menu-item-132945" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132945"><a href="https://riverheadlocal.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
<div class="td-pb-span4 td-sub-footer-copy">
<div class="td-pb-padding-side">
</div>
</div>
</div>
</div>
</div>
</div>
<div class="a2a_kit a2a_kit_size_36 a2a_floating_style a2a_vertical_style" style="left:0px;top:400px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;left:5px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F09%2F29%2Fgrassroots-group-donates-2600-masks-to-riverhead-schools%2F&amp;linkname=Grassroots%20group%20donates%202%2C600%20masks%20to%20Riverhead%20schools%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><a rel="nofollow" style="display:none;" href="https://riverheadlocal.com/?blackhole=c2c3a21bc1" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','community-news','community','grassroots-group-donates-2600-masks-to-riverhead-schools','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["community-news","community","grassroots-group-donates-2600-masks-to-riverhead-schools","post"],"url":"grassroots-group-donates-2600-masks-to-riverhead-schools"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({"useAltZone":767,"altZoneWhitelist":[71281],"networkId":"4821","targets":{"pagetype":["post","not_home_page"],"category":["community-news","community","grassroots-group-donates-2600-masks-to-riverhead-schools","post"],"url":"grassroots-group-donates-2600-masks-to-riverhead-schools"}});
 });</script>

<script type="text/javascript">(function($) {
  $.fn.almComplete = function(alm){
    
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");


      

    var $pageNumber;
    if ($('.kb-alm-wrap-page-3').length) {
        $pageNumber = 3; 
       // console.log("We're on page 3");
    } else if ($('.kb-alm-wrap-page-2').length) {
        $pageNumber = 2;
        // console.log("We're on page 2");
    } else {
        $pageNumber = 1;
        // console.log("We're on page 1");
    }
    
    // Parse FB comments code
    
    var $newContainerString = '.alm-page-' + $pageNumber;
    var $newContainer = $($newContainerString).parent();

    FB.XFBML.parse($newContainer[0]);
    
    // Append alm button to wrapper
    
    var $new_name = '.kb-alm-wrap-page-' + $pageNumber;
    // $('.alm-btn-wrap').detach();
    // $('.alm-btn-wrap').appendTo($new_name);
  
    // console.log("Button moved!");
    
    for ( var i = 0; i < tdSmartSidebar.items.length; i++ ) {
                    if ( 'case_3_bottom_of_content' === tdSmartSidebar.items[ i ].sidebar_state ) {
                        tdSmartSidebar.items[ i ].sidebar_state = 'case_1_fixed_down';
                       //  console.log("fixed down!");
                    }
                }
                
    var base_url = "https://riverheadlocal.com";
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.js" );
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js" );
//    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/jquery-3.1.1.min.js" );

   // console.log("Alm complte!");
   var jigs = jQuery('.justified-image-grid');
    if(jigs.length !== 0){
       jigs.data('justifiedImageGrid').createGallery('resize');
    }
  };
})(jQuery);

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");
    
 /*  $( 'body' ).on( 'post-load', function() {
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      } ); 
    // type = From which addon (previous-post | seo)
    // permalink = the updated url
    console.log("URL updated to " + permalink + '- dispatched from the '+ type + ' add-on.'); */
  }; 
})(jQuery);

(function($) {
    $(window).load(function(){
  // $('.alm-btn-wrap').appendTo($('.kb-alm-wrap'));
   // console.log("Button moved!");
});
})(jQuery);</script> 
<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-aJ5TJKLfrG9cB",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-aJ5TJKLfrG9cB.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<link rel='stylesheet' id='photoswipe-style-css' href='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/css/photoswipe4.css?ver=4.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/wpdialog.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/sticky-kit.js?ver=1.0.6'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.3'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"9cea16aa01","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/photoswipe4.min.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/jquery.dotdotdot.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js?ver=3.9.5'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://riverheadlocal.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202040.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'77146263',post:'137379',tz:'-4',srv:'riverheadlocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '77146263', '137379' ]);
</script>
</body>
</html>
