<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Focus is on downtown Riverhead this week | RiverheadLOCAL</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="pingback" href="https://riverheadlocal.com/xmlrpc.php" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<meta property="og:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?fit=800%2C534&quality=100&ssl=1" /><link rel="icon" type="image/png" href="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/favicon.png">

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Focus is on downtown Riverhead this week | RiverheadLOCAL" />
<meta property="og:description" content="The future of downtown Riverhead is the subject of a couple of events this week: a public forum with planners and a press conference about a re-imagining of the core of the Main Street business district." />
<meta property="og:url" content="https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/" />
<meta property="og:site_name" content="RiverheadLOCAL" />
<meta property="article:tag" content="featured" />
<meta property="article:tag" content="Top stories" />
<meta property="article:tag" content="weekly roundup" />
<meta property="article:section" content="Weekly Roundup" />
<meta property="article:published_time" content="2020-02-10T10:59:49+00:00" />
<meta property="article:modified_time" content="2020-02-10T11:00:03+00:00" />
<meta property="og:updated_time" content="2020-02-10T11:00:03+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The future of downtown Riverhead is the subject of a couple of events this week: a public forum with planners and a press conference about a re-imagining of the core of the Main Street business district." />
<meta name="twitter:title" content="Focus is on downtown Riverhead this week | RiverheadLOCAL" />
<meta name="twitter:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?fit=800%2C534&#038;quality=100&#038;ssl=1" />
<meta name="twitter:creator" content="@civiletti" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://riverheadlocal.com/#website","url":"https://riverheadlocal.com/","name":"RiverheadLOCAL","description":"News and events for Riverhead, New York","potentialAction":{"@type":"SearchAction","target":"https://riverheadlocal.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/#primaryimage","url":"https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?fit=800%2C534&quality=100&ssl=1","width":800,"height":534},{"@type":"WebPage","@id":"https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/#webpage","url":"https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/","inLanguage":"en-US","name":"Focus is on downtown Riverhead this week | RiverheadLOCAL","isPartOf":{"@id":"https://riverheadlocal.com/#website"},"primaryImageOfPage":{"@id":"https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/#primaryimage"},"datePublished":"2020-02-10T10:59:49+00:00","dateModified":"2020-02-10T11:00:03+00:00","author":{"@id":"https://riverheadlocal.com/#/schema/person/0a12b5636fa3908dcd3ed4af34d1ae3d"}},{"@type":["Person"],"@id":"https://riverheadlocal.com/#/schema/person/0a12b5636fa3908dcd3ed4af34d1ae3d","name":"Denise Civiletti","image":{"@type":"ImageObject","@id":"https://riverheadlocal.com/#authorlogo","url":"https://riverheadlocal.com/wp-content/uploads/2018/09/DC-avatar.png","caption":"Denise Civiletti"},"description":"Denise is a veteran local reporter, editor,  attorney and former Riverhead Town councilwoman. Her work has been recognized with numerous awards, including investigative reporting and writer of the year awards from the N.Y. Press Association. She is a founder, owner and co-publisher of this website.<a href=\"mailto:denise@riverheadlocal.com\">Email Denise.</a>","sameAs":["https://twitter.com/@civiletti"]}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Feed" href="https://riverheadlocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Comments Feed" href="https://riverheadlocal.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/riverheadlocal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='kb-membership-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-membership/inc/style.css?ver=6.1.97' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/jquery-ui-dialog.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fc-form-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/Formcraft/assets/css/form.min.css?ver=3.2.27' type='text/css' media='all' />
<link rel='stylesheet' id='public_notices_css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-public-notices/kb-public-notices.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-top-stories-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-top-stories/style.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='trans-frontend-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-translation/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-min-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/icons/css/weather-icons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-wind-min-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/icons/css/weather-icons-wind.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-weather-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/css/kb-weather.css?ver=1.7.43' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/Newsmag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/style.css?ver=4.5.236' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Lato%3A400%7COpen+Sans%3A300%2C400%2C600%2C700%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic&#038;ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1125px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1124px){
.a2a_floating_style.a2a_default_style{display:none;}
}
.a2a_floating_style {
    padding: 20px;
    border-radius: 0;
    border: 1px solid #bbbbbb;
}
</style>
<link rel='stylesheet' id='js_composer_front-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/style.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-membership/inc/button.js?ver=6.0.1'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/js/modernizr.custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/js/summary-box.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.25'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/common-scripts.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/popup-menu-fix.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://riverheadlocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverheadlocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverheadlocal.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://riverheadlocal.com/?p=133456' />
<link rel="alternate" type="application/json+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color = "#A0A0A0";

a2a_config.templates = {
    email: {
        subject: "RiverheadLOCAL: ${title}",
        body: "Check out this story on RiverheadLOCAL: \n${title}\n${link}"
    }
};

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      }; 
})(jQuery);
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>


<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Focus is on downtown Riverhead this week | RiverheadLOCAL","pagePostType":"post","pagePostType2":"single-post","pageCategory":["weekly-roundup"],"pageAttributes":["featured","top-stories","weekly-roundup"],"pagePostAuthor":"Denise Civiletti","pagePostDate":"Feb 10, 2020, 5:59 am","pagePostDateYear":"2020","pagePostDateMonth":"02","pagePostDateDay":"10"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N97RFZC');//]]>
</script>


<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<script src="https://use.fontawesome.com/b3fb28acc8.js"></script><meta property="fb:app_id" content="105130769527571" /><meta name="google-site-verification" content="7jViI0XrkgkIYGyQD0GNoWcify30WyzN3o4ZHzUGfdo" /><script data-ad-client="ca-pub-6009741394491678" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var adSlotLeaderboard = googletag.defineSlot('/21874054635/Sitewide', [728, 90], 'div-gpt-ad-leaderboard');
    adSlotLeaderboard.addService(googletag.pubads());
    adSlotLeaderboard.setTargeting('position', ['leaderboard']);
    var adSlotSidebar1= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-1');
	    adSlotSidebar1.addService(googletag.pubads());
	    adSlotSidebar1.setTargeting('position', ['sidebar']);
	    var adSlotSidebar2= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-2');
	    adSlotSidebar2.addService(googletag.pubads());
	    adSlotSidebar2.setTargeting('position', ['sidebar']);
	    var adSlotSidebar3= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-3');
	    adSlotSidebar3.addService(googletag.pubads());
	    adSlotSidebar3.setTargeting('position', ['sidebar']);
	    var adSlotSidebar4= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-4');
	    adSlotSidebar4.addService(googletag.pubads());
	    adSlotSidebar4.setTargeting('position', ['sidebar']);
	    var adSlotSidebar5= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-5');
	    adSlotSidebar5.addService(googletag.pubads());
	    adSlotSidebar5.setTargeting('position', ['sidebar']);
	    var adSlotSidebar = googletag.defineSlot('/21874054635/Sitewide', ['fluid'], 'div-gpt-ad-lead-sidebar');
    adSlotSidebar.addService(googletag.pubads());
    adSlotSidebar.setTargeting('position', ['lead-sidebar']);
    
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://riverheadlocal.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '82fba20f-da37-4c38-a7fe-ee7dbe081e0f';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://riverheadlocal.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.370dd028-ab8a-4720-9087-4e2c917686de";
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_ajax_url="https:\/\/riverheadlocal.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=4.3";
var td_get_template_directory_uri="https:\/\/riverheadlocal.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e12025";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://riverheadlocal.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://riverheadlocal.com/news/local-news/",
                                "name": "Local News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://riverheadlocal.com/news/local-news/weekly-roundup/",
                                "name": "Weekly Roundup"                                
                            }
                        },{
                            "@type": "ListItem",
                            "position": 4,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/",
                                "name": "Focus is on downtown Riverhead this week"                                
                            }
                        }    ]
                        }
                       </script><link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=32%2C32&#038;quality=100&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>
<body class="post-template-default single single-post postid-133456 single-format-standard author-denise-civiletti focus-is-on-downtown-riverhead-this-week global-block-template-1 white-menu wpb-js-composer js-comp-ver-6.1 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N97RFZC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '105130769527571',
      xfbml      : true,
      version    : 'v2.9'
    });
    FB.AppEvents.logPageView();
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div class="td-mobile-container">

<div class="kb-menu-socials-wrap">

<div class="kb-menu-socials">
</div>
</div>

<div class="kb-mobile-search-container"><form method="get" class="td-search-form-widget" action="https://riverheadlocal.com/">
<div role="search" class="kb-mobile-search">
<button class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit"><i class="td-icon-search"></i></button>
<div class="kb-search-input-wrap"><input class="td-widget-search-input" type="text" value="Search" name="s" id="s" onfocus="if (this.value=='Search') this.value='';" onblur="if (this.value=='') this.value='Search';" /></div>
</div>
</form>
</div>

<div class="td-mobile-content">
<div class="menu-mobile-container"><ul id="menu-mobile" class="td-mobile-main-menu"><li id="menu-item-116721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-116721"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100685" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-100685"><a href="https://riverheadlocal.com/news/">News</a></li>
<li id="menu-item-100683" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100683"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a></li>
<li id="menu-item-100686" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100686"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100687" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100687"><a href="https://riverheadlocal.com/community/">Community</a></li>
<li id="menu-item-100693" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-100693"><a href="http://eastendlocal.com">Events</a></li>
<li id="menu-item-100688" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100688"><a href="https://riverheadlocal.com/schools/">Schools</a></li>
<li id="menu-item-100684" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100684"><a href="https://riverheadlocal.com/business/business-news/">Business</a></li>
<li id="menu-item-100691" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100691"><a href="https://riverheadlocal.com/living/">Living</a></li>
<li id="menu-item-100692" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100692"><a href="https://riverheadlocal.com/opinion/">Opinion</a></li>
<li id="menu-item-100694" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100694"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-108418" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108418"><a href="https://classifieds.eastendlocal.com">Classifieds</a></li>
<li id="menu-item-100695" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-100695"><a href="https://riverheadlocal.com/contact/">Contact RiverheadLOCAL</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div id="kb-overlay"></div>
<div class="td-header-wrap td-header-style-3">
<div class="td-top-menu-full">
<div class="td-header-row td-header-top-menu td-make-full">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-100681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-100681"><a href="https://riverheadlocal.com/contact/">Contact</a></li>
<li id="menu-item-130976" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-130976"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-100680" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100680"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-24924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24924"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-116691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116691"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-24925" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24925"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/classifieds/">Classifieds</a></li>
<li id="menu-item-129406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129406"><a href="https://riverheadlocal.com/support-local-journalism/">Membership</a></li>
</ul></div></div> </div>

</div>
</div>

<div class="td-header-container">
<div class="td-header-logo-wrap">
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
<span class="td-visual-hidden">RiverheadLOCAL</span>
</a>
</div>
<div class="td-header-right-header">
<div class="td-header-right ">
<div class="textwidget"><h3>Keep local news free.</h3>
<p>Become a member today.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-main-menu">
<div class="td-header-menu-wrap-sub">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-header-right-header mobile-header">
<div class="td-header-right ">
<div class="textwidget"><h3>Keep local news free.</h3>
<p>Become a member today.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main" class="sf-menu"><li id="menu-item-100668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-100668"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100671" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-mega-menu menu-item-100671"><a href="https://riverheadlocal.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_5e4137b96816e = new tdBlock();
block_td_uid_1_5e4137b96816e.id = "td_uid_1_5e4137b96816e";
block_td_uid_1_5e4137b96816e.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"103","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5e4137b96816e_rand","tdc_css_class":"td_uid_1_5e4137b96816e_rand","tdc_css_class_style":"td_uid_1_5e4137b96816e_rand_style"}';
block_td_uid_1_5e4137b96816e.td_column_number = "3";
block_td_uid_1_5e4137b96816e.block_type = "td_block_mega_menu";
block_td_uid_1_5e4137b96816e.post_count = "5";
block_td_uid_1_5e4137b96816e.found_posts = "5924";
block_td_uid_1_5e4137b96816e.header_color = "";
block_td_uid_1_5e4137b96816e.ajax_pagination_infinite_stop = "";
block_td_uid_1_5e4137b96816e.max_num_pages = "1185";
tdBlocksArray.push(block_td_uid_1_5e4137b96816e);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_1_5e4137b96816e_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_5e4137b96816e"><div id=td_uid_1_5e4137b96816e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/" rel="bookmark" class="td-image-wrap" title="Focus is on downtown Riverhead this week"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Focus is on downtown Riverhead this week" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/" rel="bookmark" title="Focus is on downtown Riverhead this week">Focus is on downtown Riverhead this week</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/07/west-main-street-7-eleven-plan-gets-final-approval/" rel="bookmark" class="td-image-wrap" title="West Main Street 7-Eleven site plan gets final approval"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1117_7-Eleven_logo_stripes.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1117_7-Eleven_logo_stripes.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1117_7-Eleven_logo_stripes.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1117_7-Eleven_logo_stripes.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1117_7-Eleven_logo_stripes.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1117_7-Eleven_logo_stripes.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1117_7-Eleven_logo_stripes.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="West Main Street 7-Eleven site plan gets final approval" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/07/west-main-street-7-eleven-plan-gets-final-approval/" rel="bookmark" title="West Main Street 7-Eleven site plan gets final approval">West Main Street 7-Eleven site plan gets final approval</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/06/peconic-bay-medical-center-tests-helipad-atop-new-critical-care-pavilion/" rel="bookmark" class="td-image-wrap" title="Peconic Bay Medical Center tests helipad atop new critical care pavilion"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0206_PBMC-helipad-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Peconic Bay Medical Center tests helipad atop new critical care pavilion" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/06/peconic-bay-medical-center-tests-helipad-atop-new-critical-care-pavilion/" rel="bookmark" title="Peconic Bay Medical Center tests helipad atop new critical care pavilion">Peconic Bay Medical Center tests helipad atop new critical care pavilion</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/05/town-board-creates-joint-task-force-with-school-district-considers-term-limits-for-appointed-boards/" rel="bookmark" class="td-image-wrap" title="Town board creates joint task force with school district, considers term limits for appointed boards"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0103_town-board-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Town board creates joint task force with school district, considers term limits for appointed boards" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/05/town-board-creates-joint-task-force-with-school-district-considers-term-limits-for-appointed-boards/" rel="bookmark" title="Town board creates joint task force with school district, considers term limits for appointed boards">Town board creates joint task force with school district, considers term limits for appointed boards</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/05/no-environmental-impact-statement-for-new-22-9-mw-solar-facility-in-calverton/" rel="bookmark" class="td-image-wrap" title="No environmental impact statement for new 22.9 MW solar facility in Calverton"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0314_sPower_solar_array_edwards_avenue.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0314_sPower_solar_array_edwards_avenue.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0314_sPower_solar_array_edwards_avenue.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0314_sPower_solar_array_edwards_avenue.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0314_sPower_solar_array_edwards_avenue.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0314_sPower_solar_array_edwards_avenue.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0314_sPower_solar_array_edwards_avenue.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="No environmental impact statement for new 22.9 MW solar facility in Calverton" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/05/no-environmental-impact-statement-for-new-22-9-mw-solar-facility-in-calverton/" rel="bookmark" title="No environmental impact statement for new 22.9 MW solar facility in Calverton">No environmental impact statement for new 22.9 MW solar facility in Calverton</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_5e4137b96816e" id="td_uid_2_5e4137b96eb04" data-td_block_id="td_uid_1_5e4137b96816e" data-td_filter_value="" href="https://riverheadlocal.com/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_5e4137b96816e" id="td_uid_3_5e4137b96eb84" data-td_block_id="td_uid_1_5e4137b96816e" data-td_filter_value="105" href="https://riverheadlocal.com/news/local-news/">Local News</a><a class="mega-menu-sub-cat-td_uid_1_5e4137b96816e" id="td_uid_4_5e4137b96ebe1" data-td_block_id="td_uid_1_5e4137b96816e" data-td_filter_value="16007" href="https://riverheadlocal.com/news/local-news/weekly-roundup/">Weekly Roundup</a><a class="mega-menu-sub-cat-td_uid_1_5e4137b96816e" id="td_uid_5_5e4137b96ec4b" data-td_block_id="td_uid_1_5e4137b96816e" data-td_filter_value="108" href="https://riverheadlocal.com/news/public-notices/">Public Notices</a><a class="mega-menu-sub-cat-td_uid_1_5e4137b96816e" id="td_uid_6_5e4137b96ecda" data-td_block_id="td_uid_1_5e4137b96816e" data-td_filter_value="104" href="https://riverheadlocal.com/news/town-hall-notebook/">Town Hall Notebook</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5e4137b96816e" data-td_block_id="td_uid_1_5e4137b96816e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5e4137b96816e" data-td_block_id="td_uid_1_5e4137b96816e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100669" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100669"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_7_5e4137b98a689 = new tdBlock();
block_td_uid_7_5e4137b98a689.id = "td_uid_7_5e4137b98a689";
block_td_uid_7_5e4137b98a689.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_7_5e4137b98a689_rand","tdc_css_class":"td_uid_7_5e4137b98a689_rand","tdc_css_class_style":"td_uid_7_5e4137b98a689_rand_style"}';
block_td_uid_7_5e4137b98a689.td_column_number = "3";
block_td_uid_7_5e4137b98a689.block_type = "td_block_mega_menu";
block_td_uid_7_5e4137b98a689.post_count = "5";
block_td_uid_7_5e4137b98a689.found_posts = "2375";
block_td_uid_7_5e4137b98a689.header_color = "";
block_td_uid_7_5e4137b98a689.ajax_pagination_infinite_stop = "";
block_td_uid_7_5e4137b98a689.max_num_pages = "475";
tdBlocksArray.push(block_td_uid_7_5e4137b98a689);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_7_5e4137b98a689_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_7_5e4137b98a689"><div id=td_uid_7_5e4137b98a689 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/07/riverhead-based-bloods-gang-member-charged-in-2015-riverside-murder-cops-plea/" rel="bookmark" class="td-image-wrap" title="Riverhead-based Bloods gang member charged in 2015 Riverside murder cops plea"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2015/11/2015_1118_homicide_crime-scene.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2015/11/2015_1118_homicide_crime-scene.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2015/11/2015_1118_homicide_crime-scene.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead-based Bloods gang member charged in 2015 Riverside murder cops plea" /></a></div>  </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/07/riverhead-based-bloods-gang-member-charged-in-2015-riverside-murder-cops-plea/" rel="bookmark" title="Riverhead-based Bloods gang member charged in 2015 Riverside murder cops plea">Riverhead-based Bloods gang member charged in 2015 Riverside murder cops plea</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/06/suv-strikes-pole-overturns-in-manorville/" rel="bookmark" class="td-image-wrap" title="SUV strikes pole, overturns in Manorville"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Manorville_Car_Vs_Pole-Lambui-5-copy.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="SUV strikes pole, overturns in Manorville" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/06/suv-strikes-pole-overturns-in-manorville/" rel="bookmark" title="SUV strikes pole, overturns in Manorville">SUV strikes pole, overturns in Manorville</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/06/wrong-way-crash-leaves-car-hanging-over-bridge-on-i-495-in-riverhead/" rel="bookmark" class="td-image-wrap" title="Wrong-way crash leaves car hanging over bridge on I-495 in Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0205_MVA_Calverton_Car_Over_Bridge-Lambui-2.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Wrong-way crash leaves car hanging over bridge on I-495 in Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/06/wrong-way-crash-leaves-car-hanging-over-bridge-on-i-495-in-riverhead/" rel="bookmark" title="Wrong-way crash leaves car hanging over bridge on I-495 in Riverhead">Wrong-way crash leaves car hanging over bridge on I-495 in Riverhead</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/01/police-search-for-missing-girl-15/" rel="bookmark" class="td-image-wrap" title="Update: Police say missing girl located unharmed"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0131_Missing_Maria_Felix.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0131_Missing_Maria_Felix.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0131_Missing_Maria_Felix.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0131_Missing_Maria_Felix.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0131_Missing_Maria_Felix.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0131_Missing_Maria_Felix.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0131_Missing_Maria_Felix.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Update: Police say missing girl located unharmed" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/01/police-search-for-missing-girl-15/" rel="bookmark" title="Update: Police say missing girl located unharmed">Update: Police say missing girl located unharmed</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/24/wally-backman-acquitted-after-trial-riverhead/" rel="bookmark" class="td-image-wrap" title="Wally Backman found not guilty after trial in Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0124_Backman.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Wally Backman found not guilty after trial in Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/24/wally-backman-acquitted-after-trial-riverhead/" rel="bookmark" title="Wally Backman found not guilty after trial in Riverhead">Wally Backman found not guilty after trial in Riverhead</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_7_5e4137b98a689" id="td_uid_8_5e4137b98dcdb" data-td_block_id="td_uid_7_5e4137b98a689" data-td_filter_value="" href="https://riverheadlocal.com/police-fire/">All</a><a class="mega-menu-sub-cat-td_uid_7_5e4137b98a689" id="td_uid_9_5e4137b98dd5b" data-td_block_id="td_uid_7_5e4137b98a689" data-td_filter_value="42" href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a><a class="mega-menu-sub-cat-td_uid_7_5e4137b98a689" id="td_uid_10_5e4137b98ddb4" data-td_block_id="td_uid_7_5e4137b98a689" data-td_filter_value="41" href="https://riverheadlocal.com/police-fire/police-blotter/">Police Reports</a><a class="mega-menu-sub-cat-td_uid_7_5e4137b98a689" id="td_uid_11_5e4137b98de4b" data-td_block_id="td_uid_7_5e4137b98a689" data-td_filter_value="43" href="https://riverheadlocal.com/police-fire/riverhead-justice-court/">Riverhead Justice Court</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_7_5e4137b98a689" data-td_block_id="td_uid_7_5e4137b98a689"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_7_5e4137b98a689" data-td_block_id="td_uid_7_5e4137b98a689"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100672" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100672"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100673" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100673"><a href="https://riverheadlocal.com/community/">Community</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_12_5e4137b9a3a01 = new tdBlock();
block_td_uid_12_5e4137b9a3a01.id = "td_uid_12_5e4137b9a3a01";
block_td_uid_12_5e4137b9a3a01.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"113","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_12_5e4137b9a3a01_rand","tdc_css_class":"td_uid_12_5e4137b9a3a01_rand","tdc_css_class_style":"td_uid_12_5e4137b9a3a01_rand_style"}';
block_td_uid_12_5e4137b9a3a01.td_column_number = "3";
block_td_uid_12_5e4137b9a3a01.block_type = "td_block_mega_menu";
block_td_uid_12_5e4137b9a3a01.post_count = "5";
block_td_uid_12_5e4137b9a3a01.found_posts = "3757";
block_td_uid_12_5e4137b9a3a01.header_color = "";
block_td_uid_12_5e4137b9a3a01.ajax_pagination_infinite_stop = "";
block_td_uid_12_5e4137b9a3a01.max_num_pages = "752";
tdBlocksArray.push(block_td_uid_12_5e4137b9a3a01);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_12_5e4137b9a3a01_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_12_5e4137b9a3a01"><div id=td_uid_12_5e4137b9a3a01 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/08/winterfest-20-kicks-off-with-party-at-hotel-indigo/" rel="bookmark" class="td-image-wrap" title="Winterfest &#8217;20 kicks off with party at Hotel Indigo"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0208_winterfest2-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Winterfest &#8217;20 kicks off with party at Hotel Indigo" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/08/winterfest-20-kicks-off-with-party-at-hotel-indigo/" rel="bookmark" title="Winterfest &#8217;20 kicks off with party at Hotel Indigo">Winterfest &#8217;20 kicks off with party at Hotel Indigo</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/06/twenty-five-bikes-and-five-bike-stations-to-be-deployed-in-riverhead-this-spring/" rel="bookmark" class="td-image-wrap" title="Twenty-five bikes and five bike stations to be deployed in Riverhead this spring"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0919_Zagster_Docking_Station.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Twenty-five bikes and five bike stations to be deployed in Riverhead this spring" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/06/twenty-five-bikes-and-five-bike-stations-to-be-deployed-in-riverhead-this-spring/" rel="bookmark" title="Twenty-five bikes and five bike stations to be deployed in Riverhead this spring">Twenty-five bikes and five bike stations to be deployed in Riverhead this spring</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/04/riverhead-students-take-first-place-in-long-island-auto-tech-competition/" rel="bookmark" class="td-image-wrap" title="Riverhead students take first place in Long Island Auto Tech Competition"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_HB-Ward-auto-tech-winners.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead students take first place in Long Island Auto Tech Competition" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/04/riverhead-students-take-first-place-in-long-island-auto-tech-competition/" rel="bookmark" title="Riverhead students take first place in Long Island Auto Tech Competition">Riverhead students take first place in Long Island Auto Tech Competition</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/02/riverhead-water-district-employee-has-a-heart-for-the-tin-man/" rel="bookmark" class="td-image-wrap" title="Riverhead Water District employee has a heart for the ‘Tin Man’"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0202_Nick_May_Tin-Man-plaque-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead Water District employee has a heart for the ‘Tin Man’" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/02/riverhead-water-district-employee-has-a-heart-for-the-tin-man/" rel="bookmark" title="Riverhead Water District employee has a heart for the ‘Tin Man’">Riverhead Water District employee has a heart for the ‘Tin Man’</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/01/riverhead-students-step-up-to-the-great-kindness-challenge/" rel="bookmark" class="td-image-wrap" title="Riverhead students step up to the Great Kindness Challenge"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?w=640&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead students step up to the Great Kindness Challenge" /></a></div> </div>
<div class="item-details">
 <h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/01/riverhead-students-step-up-to-the-great-kindness-challenge/" rel="bookmark" title="Riverhead students step up to the Great Kindness Challenge">Riverhead students step up to the Great Kindness Challenge</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_12_5e4137b9a3a01" id="td_uid_13_5e4137b9a82c0" data-td_block_id="td_uid_12_5e4137b9a3a01" data-td_filter_value="" href="https://riverheadlocal.com/community/">All</a><a class="mega-menu-sub-cat-td_uid_12_5e4137b9a3a01" id="td_uid_14_5e4137b9a834a" data-td_block_id="td_uid_12_5e4137b9a3a01" data-td_filter_value="128" href="https://riverheadlocal.com/community/announcements/">Announcements</a><a class="mega-menu-sub-cat-td_uid_12_5e4137b9a3a01" id="td_uid_15_5e4137b9a8400" data-td_block_id="td_uid_12_5e4137b9a3a01" data-td_filter_value="126" href="https://riverheadlocal.com/community/community-news/">Community News</a><a class="mega-menu-sub-cat-td_uid_12_5e4137b9a3a01" id="td_uid_16_5e4137b9a8457" data-td_block_id="td_uid_12_5e4137b9a3a01" data-td_filter_value="127" href="https://riverheadlocal.com/community/event-photos/">Event Photos</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_12_5e4137b9a3a01" data-td_block_id="td_uid_12_5e4137b9a3a01"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_12_5e4137b9a3a01" data-td_block_id="td_uid_12_5e4137b9a3a01"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100674" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100674"><a href="https://riverheadlocal.com/schools/">Schools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_17_5e4137b9beca5 = new tdBlock();
block_td_uid_17_5e4137b9beca5.id = "td_uid_17_5e4137b9beca5";
block_td_uid_17_5e4137b9beca5.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"185","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_17_5e4137b9beca5_rand","tdc_css_class":"td_uid_17_5e4137b9beca5_rand","tdc_css_class_style":"td_uid_17_5e4137b9beca5_rand_style"}';
block_td_uid_17_5e4137b9beca5.td_column_number = "3";
block_td_uid_17_5e4137b9beca5.block_type = "td_block_mega_menu";
block_td_uid_17_5e4137b9beca5.post_count = "5";
block_td_uid_17_5e4137b9beca5.found_posts = "1769";
block_td_uid_17_5e4137b9beca5.header_color = "";
block_td_uid_17_5e4137b9beca5.ajax_pagination_infinite_stop = "";
block_td_uid_17_5e4137b9beca5.max_num_pages = "354";
tdBlocksArray.push(block_td_uid_17_5e4137b9beca5);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_17_5e4137b9beca5_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_17_5e4137b9beca5"><div id=td_uid_17_5e4137b9beca5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/03/nysut-officials-on-fund-our-future-tour-in-riverhead-hear-about-overcrowded-under-resourced-public-schools/" rel="bookmark" class="td-image-wrap" title="NYSUT officials on &#8216;Fund Our Future&#8217; tour in Riverhead hear about overcrowded, under-resourced public schools"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_NYSUT_tour-bus-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_NYSUT_tour-bus-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_NYSUT_tour-bus-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_NYSUT_tour-bus-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_NYSUT_tour-bus-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_NYSUT_tour-bus-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0203_NYSUT_tour-bus-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="NYSUT officials on &#8216;Fund Our Future&#8217; tour in Riverhead hear about overcrowded, under-resourced public schools" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/03/nysut-officials-on-fund-our-future-tour-in-riverhead-hear-about-overcrowded-under-resourced-public-schools/" rel="bookmark" title="NYSUT officials on &#8216;Fund Our Future&#8217; tour in Riverhead hear about overcrowded, under-resourced public schools">NYSUT officials on &#8216;Fund Our Future&#8217; tour in Riverhead hear about overcrowded, under-resourced public schools</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/01/riverhead-students-step-up-to-the-great-kindness-challenge/" rel="bookmark" class="td-image-wrap" title="Riverhead students step up to the Great Kindness Challenge"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?w=640&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0201_kindness_challenge-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead students step up to the Great Kindness Challenge" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/01/riverhead-students-step-up-to-the-great-kindness-challenge/" rel="bookmark" title="Riverhead students step up to the Great Kindness Challenge">Riverhead students step up to the Great Kindness Challenge</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/25/three-additional-community-meetings-set-before-school-districts-feb-25-bond-vote/" rel="bookmark" class="td-image-wrap" title="Three additional community meetings set before school district&#8217;s Feb. 25 bond vote"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2019_0519_Riverhead_High_School-2.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Three additional community meetings set before school district&#8217;s Feb. 25 bond vote" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/25/three-additional-community-meetings-set-before-school-districts-feb-25-bond-vote/" rel="bookmark" title="Three additional community meetings set before school district&#8217;s Feb. 25 bond vote">Three additional community meetings set before school district&#8217;s Feb. 25 bond vote</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/23/school-board-wrap-security-technology-update-meeting-videos-social-media-etiquette-and-retirements/" rel="bookmark" class="td-image-wrap" title="School board wrap: security technology update, meeting videos, social media etiquette and retirements"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE4-1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="School board wrap: security technology update, meeting videos, social media etiquette and retirements" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/23/school-board-wrap-security-technology-update-meeting-videos-social-media-etiquette-and-retirements/" rel="bookmark" title="School board wrap: security technology update, meeting videos, social media etiquette and retirements">School board wrap: security technology update, meeting videos, social media etiquette and retirements</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/22/school-district-seeks-to-combat-misinformation-on-bond-proposal-in-advance-of-feb-25-vote/" rel="bookmark" class="td-image-wrap" title="School district seeks to combat misinformation on bond proposal in advance of Feb. 25 vote"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0121_BOE2.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="School district seeks to combat misinformation on bond proposal in advance of Feb. 25 vote" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/22/school-district-seeks-to-combat-misinformation-on-bond-proposal-in-advance-of-feb-25-vote/" rel="bookmark" title="School district seeks to combat misinformation on bond proposal in advance of Feb. 25 vote">School district seeks to combat misinformation on bond proposal in advance of Feb. 25 vote</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_17_5e4137b9beca5" id="td_uid_18_5e4137b9c1bab" data-td_block_id="td_uid_17_5e4137b9beca5" data-td_filter_value="" href="https://riverheadlocal.com/schools/">All</a><a class="mega-menu-sub-cat-td_uid_17_5e4137b9beca5" id="td_uid_19_5e4137b9c1c31" data-td_block_id="td_uid_17_5e4137b9beca5" data-td_filter_value="187" href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a><a class="mega-menu-sub-cat-td_uid_17_5e4137b9beca5" id="td_uid_20_5e4137b9c1c95" data-td_block_id="td_uid_17_5e4137b9beca5" data-td_filter_value="190" href="https://riverheadlocal.com/schools/mcgann-mercy-junior-senior-high-school/">McGann-Mercy Junior-Senior High School</a><a class="mega-menu-sub-cat-td_uid_17_5e4137b9beca5" id="td_uid_21_5e4137b9c1d29" data-td_block_id="td_uid_17_5e4137b9beca5" data-td_filter_value="15377" href="https://riverheadlocal.com/schools/peconic-community-school/">Peconic Community School</a><a class="mega-menu-sub-cat-td_uid_17_5e4137b9beca5" id="td_uid_22_5e4137b9c1db9" data-td_block_id="td_uid_17_5e4137b9beca5" data-td_filter_value="201" href="https://riverheadlocal.com/schools/riverhead-central-school-district/">Riverhead Central School District</a><a class="mega-menu-sub-cat-td_uid_17_5e4137b9beca5" id="td_uid_23_5e4137b9c1e0d" data-td_block_id="td_uid_17_5e4137b9beca5" data-td_filter_value="199" href="https://riverheadlocal.com/schools/riverhead-central-school-district/aquebogue-elementary-school/">Aquebogue Elementary School</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_17_5e4137b9beca5" data-td_block_id="td_uid_17_5e4137b9beca5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_17_5e4137b9beca5" data-td_block_id="td_uid_17_5e4137b9beca5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-120667" class="tablet-hidden menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-120667"><a href="https://riverheadlocal.com/business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_24_5e4137b9dbe3b = new tdBlock();
block_td_uid_24_5e4137b9dbe3b.id = "td_uid_24_5e4137b9dbe3b";
block_td_uid_24_5e4137b9dbe3b.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"205","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_24_5e4137b9dbe3b_rand","tdc_css_class":"td_uid_24_5e4137b9dbe3b_rand","tdc_css_class_style":"td_uid_24_5e4137b9dbe3b_rand_style"}';
block_td_uid_24_5e4137b9dbe3b.td_column_number = "3";
block_td_uid_24_5e4137b9dbe3b.block_type = "td_block_mega_menu";
block_td_uid_24_5e4137b9dbe3b.post_count = "5";
block_td_uid_24_5e4137b9dbe3b.found_posts = "463";
block_td_uid_24_5e4137b9dbe3b.header_color = "";
block_td_uid_24_5e4137b9dbe3b.ajax_pagination_infinite_stop = "";
block_td_uid_24_5e4137b9dbe3b.max_num_pages = "93";
tdBlocksArray.push(block_td_uid_24_5e4137b9dbe3b);
</script><div class="td_block_wrap td_block_mega_menu td_uid_24_5e4137b9dbe3b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_24_5e4137b9dbe3b"><div id=td_uid_24_5e4137b9dbe3b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/11/pier-1-store-in-riverhead-is-closing/" rel="bookmark" class="td-image-wrap" title="Pier 1 store in Riverhead is closing"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=768%2C577&#038;quality=100&#038;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=559%2C420&#038;quality=100&#038;ssl=1 559w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=640%2C481&#038;quality=100&#038;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=681%2C512&#038;quality=100&#038;ssl=1 681w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0111_Pier_1-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Pier 1 store in Riverhead is closing" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/11/pier-1-store-in-riverhead-is-closing/" rel="bookmark" title="Pier 1 store in Riverhead is closing">Pier 1 store in Riverhead is closing</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/06/boutique-with-a-cause-opportunities-for-people-on-the-autism-spectrum/" rel="bookmark" class="td-image-wrap" title="Boutique with a cause:  opportunities for people on the autism spectrum"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0106_BeCause-boutique-5.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Boutique with a cause:  opportunities for people on the autism spectrum" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/06/boutique-with-a-cause-opportunities-for-people-on-the-autism-spectrum/" rel="bookmark" title="Boutique with a cause:  opportunities for people on the autism spectrum">Boutique with a cause: opportunities for people on the autism spectrum</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2019/12/27/trade-unions-announce-apprentice-recruitments/" rel="bookmark" class="td-image-wrap" title="Trade unions announce apprentice recruitments"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/02/2017_0217_operating_engineers.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/02/2017_0217_operating_engineers.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/02/2017_0217_operating_engineers.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Trade unions announce apprentice recruitments" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2019/12/27/trade-unions-announce-apprentice-recruitments/" rel="bookmark" title="Trade unions announce apprentice recruitments">Trade unions announce apprentice recruitments</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2019/12/12/one-stop-shop-for-cbd-products-opens-in-wading-river/" rel="bookmark" class="td-image-wrap" title="One-stop shop for CBD products opens in Wading River"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?w=742&#038;quality=100&#038;ssl=1 742w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=558%2C420&#038;quality=100&#038;ssl=1 558w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=640%2C481&#038;quality=100&#038;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=681%2C512&#038;quality=100&#038;ssl=1 681w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1211_Noid-Botanicals-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="One-stop shop for CBD products opens in Wading River" /></a></div>  </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2019/12/12/one-stop-shop-for-cbd-products-opens-in-wading-river/" rel="bookmark" title="One-stop shop for CBD products opens in Wading River">One-stop shop for CBD products opens in Wading River</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2019/12/02/learn-how-to-put-the-federal-opportunity-zones-program-to-work-for-you/" rel="bookmark" class="td-image-wrap" title="Learn how to put the federal opportunity zones program to work for you"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Learn how to put the federal opportunity zones program to work for you" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2019/12/02/learn-how-to-put-the-federal-opportunity-zones-program-to-work-for-you/" rel="bookmark" title="Learn how to put the federal opportunity zones program to work for you">Learn how to put the federal opportunity zones program to work for you</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_24_5e4137b9dbe3b" data-td_block_id="td_uid_24_5e4137b9dbe3b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_24_5e4137b9dbe3b" data-td_block_id="td_uid_24_5e4137b9dbe3b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100676" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100676"><a href="https://riverheadlocal.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_25_5e4137b9e0985 = new tdBlock();
block_td_uid_25_5e4137b9e0985.id = "td_uid_25_5e4137b9e0985";
block_td_uid_25_5e4137b9e0985.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"81","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_25_5e4137b9e0985_rand","tdc_css_class":"td_uid_25_5e4137b9e0985_rand","tdc_css_class_style":"td_uid_25_5e4137b9e0985_rand_style"}';
block_td_uid_25_5e4137b9e0985.td_column_number = "3";
block_td_uid_25_5e4137b9e0985.block_type = "td_block_mega_menu";
block_td_uid_25_5e4137b9e0985.post_count = "5";
block_td_uid_25_5e4137b9e0985.found_posts = "873";
block_td_uid_25_5e4137b9e0985.header_color = "";
block_td_uid_25_5e4137b9e0985.ajax_pagination_infinite_stop = "";
block_td_uid_25_5e4137b9e0985.max_num_pages = "175";
tdBlocksArray.push(block_td_uid_25_5e4137b9e0985);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_25_5e4137b9e0985_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_25_5e4137b9e0985"><div id=td_uid_25_5e4137b9e0985 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/09/thomas-valva-death-questions-about-failed-syste/" rel="bookmark" class="td-image-wrap" title="Abuse, cruelty and a system that failed a child it was supposed to protect"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0209_Thomas_Valva.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0209_Thomas_Valva.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0209_Thomas_Valva.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0209_Thomas_Valva.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0209_Thomas_Valva.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0209_Thomas_Valva.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0209_Thomas_Valva.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="Thomas Valva murrer charges" title="Abuse, cruelty and a system that failed a child it was supposed to protect" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/09/thomas-valva-death-questions-about-failed-syste/" rel="bookmark" title="Abuse, cruelty and a system that failed a child it was supposed to protect">Abuse, cruelty and a system that failed a child it was supposed to protect</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/06/commonsense-fixes-to-bail-reform-can-protect-our-community/" rel="bookmark" class="td-image-wrap" title="Commonsense fixes to bail reform can protect our community"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2014/06/2014_06_2014_0610_jail_cell.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2014/06/2014_06_2014_0610_jail_cell.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2014/06/2014_06_2014_0610_jail_cell.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="2014 0610 jail cell" title="Commonsense fixes to bail reform can protect our community" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/06/commonsense-fixes-to-bail-reform-can-protect-our-community/" rel="bookmark" title="Commonsense fixes to bail reform can protect our community">Commonsense fixes to bail reform can protect our community</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/04/new-yorks-cashless-bail-handcuffs-justice/" rel="bookmark" class="td-image-wrap" title="New York’s cashless bail handcuffs justice"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0323_Zeldin_Farm_Bureau1-1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="New York’s cashless bail handcuffs justice" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/04/new-yorks-cashless-bail-handcuffs-justice/" rel="bookmark" title="New York’s cashless bail handcuffs justice">New York’s cashless bail handcuffs justice</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/31/suffolk-sheriff-calls-for-bail-reform-changes/" rel="bookmark" class="td-image-wrap" title="Suffolk sheriff calls for bail reform changes"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/12/2017_1015_toulon.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/12/2017_1015_toulon.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/12/2017_1015_toulon.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/12/2017_1015_toulon.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/12/2017_1015_toulon.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/12/2017_1015_toulon.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/12/2017_1015_toulon.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Suffolk sheriff calls for bail reform changes" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/31/suffolk-sheriff-calls-for-bail-reform-changes/" rel="bookmark" title="Suffolk sheriff calls for bail reform changes">Suffolk sheriff calls for bail reform changes</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/26/cbds-are-these-wonder-meds-for-real/" rel="bookmark" class="td-image-wrap" title="CBDs: Are these wonder meds for real?"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0126_CBD-oil-marijuana.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="CBDs: Are these wonder meds for real?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/26/cbds-are-these-wonder-meds-for-real/" rel="bookmark" title="CBDs: Are these wonder meds for real?">CBDs: Are these wonder meds for real?</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_25_5e4137b9e0985" id="td_uid_26_5e4137b9e2a8f" data-td_block_id="td_uid_25_5e4137b9e0985" data-td_filter_value="" href="https://riverheadlocal.com/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_25_5e4137b9e0985" id="td_uid_27_5e4137b9e2b0b" data-td_block_id="td_uid_25_5e4137b9e0985" data-td_filter_value="91" href="https://riverheadlocal.com/opinion/civiletti/">Denise Civiletti</a><a class="mega-menu-sub-cat-td_uid_25_5e4137b9e0985" id="td_uid_28_5e4137b9e2b9d" data-td_block_id="td_uid_25_5e4137b9e0985" data-td_filter_value="12894" href="https://riverheadlocal.com/opinion/greg-blass/">Greg Blass</a><a class="mega-menu-sub-cat-td_uid_25_5e4137b9e0985" id="td_uid_29_5e4137b9e2c21" data-td_block_id="td_uid_25_5e4137b9e0985" data-td_filter_value="99" href="https://riverheadlocal.com/opinion/in-my-opinion/">In My Opinion</a><a class="mega-menu-sub-cat-td_uid_25_5e4137b9e0985" id="td_uid_30_5e4137b9e2c89" data-td_block_id="td_uid_25_5e4137b9e0985" data-td_filter_value="98" href="https://riverheadlocal.com/opinion/java-scripts/">Java Scripts</a><a class="mega-menu-sub-cat-td_uid_25_5e4137b9e0985" id="td_uid_31_5e4137b9e2d5c" data-td_block_id="td_uid_25_5e4137b9e0985" data-td_filter_value="15117" href="https://riverheadlocal.com/opinion/lawrence-street/">Lawrence Street</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5e4137b9e0985" data-td_block_id="td_uid_25_5e4137b9e0985"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_25_5e4137b9e0985" data-td_block_id="td_uid_25_5e4137b9e0985"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100677" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100677"><a href="https://riverheadlocal.com/living/">Living</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_32_5e4137ba0ba9c = new tdBlock();
block_td_uid_32_5e4137ba0ba9c.id = "td_uid_32_5e4137ba0ba9c";
block_td_uid_32_5e4137ba0ba9c.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9530","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_32_5e4137ba0ba9c_rand","tdc_css_class":"td_uid_32_5e4137ba0ba9c_rand","tdc_css_class_style":"td_uid_32_5e4137ba0ba9c_rand_style"}';
block_td_uid_32_5e4137ba0ba9c.td_column_number = "3";
block_td_uid_32_5e4137ba0ba9c.block_type = "td_block_mega_menu";
block_td_uid_32_5e4137ba0ba9c.post_count = "5";
block_td_uid_32_5e4137ba0ba9c.found_posts = "850";
block_td_uid_32_5e4137ba0ba9c.header_color = "";
block_td_uid_32_5e4137ba0ba9c.ajax_pagination_infinite_stop = "";
block_td_uid_32_5e4137ba0ba9c.max_num_pages = "170";
tdBlocksArray.push(block_td_uid_32_5e4137ba0ba9c);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_32_5e4137ba0ba9c_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_32_5e4137ba0ba9c"><div id=td_uid_32_5e4137ba0ba9c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/08/what-is-love-its-complicated/" rel="bookmark" class="td-image-wrap" title="What is love? It&#8217;s complicated."><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0207_neon_hearts.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0207_neon_hearts.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0207_neon_hearts.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0207_neon_hearts.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0207_neon_hearts.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0207_neon_hearts.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0207_neon_hearts.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="What is love? It&#8217;s complicated." /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/08/what-is-love-its-complicated/" rel="bookmark" title="What is love? It&#8217;s complicated.">What is love? It&#8217;s complicated.</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/02/let-your-light-shine/" rel="bookmark" class="td-image-wrap" title="Let your light shine"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/01/2016_0327_sunrise_file.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/01/2016_0327_sunrise_file.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/01/2016_0327_sunrise_file.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/01/2016_0327_sunrise_file.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/01/2016_0327_sunrise_file.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/01/2016_0327_sunrise_file.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/01/2016_0327_sunrise_file.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Let your light shine" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/02/let-your-light-shine/" rel="bookmark" title="Let your light shine">Let your light shine</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/31/new-york-vigilant-against-novel-coronavirus-governor/" rel="bookmark" class="td-image-wrap" title="New York vigilant against novel coronavirus: governor"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/3D_medical_animation_coronavirus_structure.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/3D_medical_animation_coronavirus_structure.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/3D_medical_animation_coronavirus_structure.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/3D_medical_animation_coronavirus_structure.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/3D_medical_animation_coronavirus_structure.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/3D_medical_animation_coronavirus_structure.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/3D_medical_animation_coronavirus_structure.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/3D_medical_animation_coronavirus_structure.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="New York vigilant against novel coronavirus: governor" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/31/new-york-vigilant-against-novel-coronavirus-governor/" rel="bookmark" title="New York vigilant against novel coronavirus: governor">New York vigilant against novel coronavirus: governor</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/20/opening-of-addiction-treatment-and-research-facility-in-calverton-now-slated-for-march/" rel="bookmark" class="td-image-wrap" title="Opening of addiction treatment and research facility in Calverton now slated for March"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?w=800&#038;quality=100&#038;ssl=1 800w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0830_Wellbridge_aerial-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Opening of addiction treatment and research facility in Calverton now slated for March" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/20/opening-of-addiction-treatment-and-research-facility-in-calverton-now-slated-for-march/" rel="bookmark" title="Opening of addiction treatment and research facility in Calverton now slated for March">Opening of addiction treatment and research facility in Calverton now slated for March</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/01/19/think-youre-in-control-think-again/" rel="bookmark" class="td-image-wrap" title="Think you&#8217;re in control? Think again."><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2020_0119_valentine-heart-christmas-tree.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Think you&#8217;re in control? Think again." /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/01/19/think-youre-in-control-think-again/" rel="bookmark" title="Think you&#8217;re in control? Think again.">Think you&#8217;re in control? Think again.</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_32_5e4137ba0ba9c" id="td_uid_33_5e4137ba0da03" data-td_block_id="td_uid_32_5e4137ba0ba9c" data-td_filter_value="" href="https://riverheadlocal.com/living/">All</a><a class="mega-menu-sub-cat-td_uid_32_5e4137ba0ba9c" id="td_uid_34_5e4137ba0da81" data-td_block_id="td_uid_32_5e4137ba0ba9c" data-td_filter_value="100" href="https://riverheadlocal.com/living/bits-and-pieces/">Bits and Pieces</a><a class="mega-menu-sub-cat-td_uid_32_5e4137ba0ba9c" id="td_uid_35_5e4137ba0dadd" data-td_block_id="td_uid_32_5e4137ba0ba9c" data-td_filter_value="32" href="https://riverheadlocal.com/living/health/">Health</a><a class="mega-menu-sub-cat-td_uid_32_5e4137ba0ba9c" id="td_uid_36_5e4137ba0db37" data-td_block_id="td_uid_32_5e4137ba0ba9c" data-td_filter_value="33" href="https://riverheadlocal.com/living/health/health-briefs/">Health Briefs</a><a class="mega-menu-sub-cat-td_uid_32_5e4137ba0ba9c" id="td_uid_37_5e4137ba0dbdb" data-td_block_id="td_uid_32_5e4137ba0ba9c" data-td_filter_value="94" href="https://riverheadlocal.com/living/laurie-nigro/">Laurie Nigro</a><a class="mega-menu-sub-cat-td_uid_32_5e4137ba0ba9c" id="td_uid_38_5e4137ba0dc64" data-td_block_id="td_uid_32_5e4137ba0ba9c" data-td_filter_value="38" href="https://riverheadlocal.com/living/life-on-purpose/">Life On Purpose</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_32_5e4137ba0ba9c" data-td_block_id="td_uid_32_5e4137ba0ba9c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_32_5e4137ba0ba9c" data-td_block_id="td_uid_32_5e4137ba0ba9c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-76334" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76334"><a target="_blank" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-100679" class="more-menu-item menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-mega-menu td-mega-menu-page menu-item-100679"><a href="#">More</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div id="td_uid_1_5e4137ba2b242" class="tdc-row"><div class="vc_row td_uid_39_5e4137ba2b24a_rand mega-menu-row wpb_row td-pb-row">
<style scoped>

/* custom css */
.td_uid_39_5e4137ba2b24a_rand {
                    min-height: 0;
                }
</style><div class="vc_column td_uid_40_5e4137ba2b3f7_rand  wpb_column vc_column_container tdc-column td-pb-span3"><div class="wpb_wrapper"><div class="wpb_wrapper wpb_text_column td_block_wrap td_block_wrap vc_column_text vc_custom_1554994944284 td_uid_41_5e4137ba2b453_rand mega-menu-list td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_41_5e4137ba2b453" "><div class="td-block-title-wrap"></div><div class="td-fix-index"><p><a href="/news">News</a><br />
&nbsp; &nbsp;<a href="/news/local-news">Local News</a><br />
&nbsp; &nbsp;<a href="/news/town-hall-notebook">Town Hall Notebook</a><br />
<a href="/obituaries">Obituaries</a><br />
<a href="/police-fire-news/breaking-news">Police and Fire</a><br />
&nbsp;&nbsp;<a href="/police-fire-news/breaking-news">Breaking News</a><br />
&nbsp; <a href="/police-fire-news/police-blotter">Police Blotter</a><br />
<a href="/business">Business</a></p>
</div></div></div></div><div class="vc_column td_uid_42_5e4137ba309ea_rand  wpb_column vc_column_container tdc-column td-pb-span3"><div class="wpb_wrapper"><div class="wpb_wrapper wpb_text_column td_block_wrap td_block_wrap vc_column_text td_uid_43_5e4137ba30a4c_rand mega-menu-list td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_43_5e4137ba30a4c" "><div class="td-block-title-wrap"></div><div class="td-fix-index"><p><a href="/category/community">Community</a><br />
&nbsp;&nbsp;<a href="/community/community-news">Community News</a><br />
&nbsp;&nbsp;<a href="/community/announcements">Announcements</a><br />
&nbsp;&nbsp;<a href="/community/event-photos">Event Photos</a><br />
<a href="eastendlocal.com">Events</a><br />
<a href="/schools">Schools</a><br />
&nbsp;&nbsp;<a href="/schools/board-of-education">Board of Education</a><br />
&nbsp;&nbsp;<a href="/schools/sports">Sports</a>&nbsp;<br />
<a href="/living/health">Health</a></p>
</div></div></div></div><div class="vc_column td_uid_44_5e4137ba36317_rand  wpb_column vc_column_container tdc-column td-pb-span3"><div class="wpb_wrapper"><div class="wpb_wrapper wpb_text_column td_block_wrap td_block_wrap vc_column_text td_uid_45_5e4137ba36385_rand mega-menu-list td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_45_5e4137ba36385" "><div class="td-block-title-wrap"></div><div class="td-fix-index"><p><a href="/category/opinion">Opinion</a><br />
<a href="/category/living">Living</a><br />
&nbsp; <a href="/living/life">Life</a><br />
&nbsp; <a href="/living/spirtuality">Spirituality</a><br />
<a href="/real-estate">Real Estate</a><br />
<a href="/weather">Weather</a></p>
</div></div></div></div><div class="vc_column td_uid_46_5e4137ba3b8fa_rand  wpb_column vc_column_container tdc-column td-pb-span3"><div class="wpb_wrapper"><div class="wpb_wrapper wpb_text_column td_block_wrap td_block_wrap vc_column_text vc_custom_1554994818746 td_uid_47_5e4137ba3b969_rand mega-menu-list td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_47_5e4137ba3b969" "><div class="td-block-title-wrap"></div><div class="td-fix-index"><p><a href="https://classifieds.eastendlocal.com">Classifieds</a><br />
<a href="/public-notices">Public Notices</a><br />
<a href="https://youtube.com/riverheadlocal">Video</a><br />
<a href="/contact">Contact</a><br />
<a href="/about-us">About Us</a></p>
</div></div></div></div></div></div>
<script>

			jQuery(window).load(function () {
				jQuery('body').find('#td_uid_1_5e4137ba2b242 .td-element-style').each(function (index, element) {
					jQuery(element).css('opacity', 1);
					return;
				});
			});

		</script>
<script>

				jQuery(window).ready(function () {

					// We need timeout because the content must be rendered and interpreted on client
					setTimeout(function () {

						var $content = jQuery('body').find('#tdc-live-iframe'),
							refWindow = undefined;

						if ($content.length) {
							$content = $content.contents();
							refWindow = document.getElementById('tdc-live-iframe').contentWindow || document.getElementById('tdc-live-iframe').contentDocument;

						} else {
							$content = jQuery('body');
							refWindow = window;
						}

						$content.find('#td_uid_1_5e4137ba2b242 .td-element-style').each(function (index, element) {
							jQuery(element).css('opacity', 1);
							return;
						});
					});

				}, 200);
			</script>
<broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone><div class="kb-member-content-box"><p>This story is free to read thanks in part to the generous support of readers like you. <strong>Keep local news free. <a href="/support-local-journalism">Become a member</a> today.</strong></p></div></div></div></li>
</ul>
</li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
</div>
</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap broadstreet banner ">
<div class="kb-header-ad"><span class="text"></span> <div class="textwidget"><broadstreet-zone zone-id="68458" count="1"></broadstreet-zone></div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-container td-post-template-3">
<div class="td-container-border">
<article id="post-133456" class="post-133456 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-roundup tag-featured tag-top-stories tag-weekly-roundup author-denise-civiletti" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header td-pb-padding-side">
<div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://riverheadlocal.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Local News" class="entry-crumb" href="https://riverheadlocal.com/news/local-news/">Local News</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Weekly Roundup" class="entry-crumb" href="https://riverheadlocal.com/news/local-news/weekly-roundup/">Weekly Roundup</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Focus is on downtown Riverhead this week</span></div>
<ul class="td-category"><li class="entry-category"><a href="https://riverheadlocal.com/news/local-news/">Local News</a></li><li class="entry-category"><a href="https://riverheadlocal.com/news/local-news/weekly-roundup/">Weekly Roundup</a></li></ul>
<header>
<h1 class="entry-title">Focus is on downtown Riverhead this week</h1>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://riverheadlocal.com/author/denise-2/" title="Posts by Denise Civiletti" class="author url fn" rel="author">Denise Civiletti</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-02-10T05:59:49+00:00">Feb 10, 2020, 5:59 am</time></span>  </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-featured-image"><figure><a href="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?fit=800%2C534&quality=100&ssl=1" data-caption="Riverhead&#039;s East Main Street still has several large vacant spaces. Photo: Denise Civiletti"><img width="681" height="455" class="entry-thumb td-modal-image" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=681%2C455&quality=100&ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?w=800&quality=100&ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=270%2C180&quality=100&ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=768%2C513&quality=100&ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=629%2C420&quality=100&ssl=1 629w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=537%2C360&quality=100&ssl=1 537w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=640%2C427&quality=100&ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?resize=681%2C455&quality=100&ssl=1 681w" sizes="(max-width: 681px) 100vw, 681px" alt="" title="2019_1130_East_Main_Street" /></a><figcaption class="wp-caption-text">Riverhead's East Main Street still has several large vacant spaces. Photo: Denise Civiletti</figcaption></figure></div>
<div class="td-post-content td-pb-padding-side">
<p>Here’s what’s going on this week in Riverhead.
<p>The future of downtown Riverhead is the subject of a couple of events this week. The second downtown forum will take place on Thursday at 6 p.m. at the Riverhead Senior and Human Resource Center on Shade Tree Lane in Aquebogue. The town’s planning consultants will discuss the <a href="https://riverheadlocal.com/2019/11/15/assessing-our-downtown-residents-weigh-in-at-community-forum/" target="_blank" rel="noreferrer noopener" aria-label="feedback they’ve gotten so far (opens in a new tab)">feedback they’ve gotten so far</a> from various community stakeholders on what the future of downtown Riverhead should look like. <br>
<p>Have you taken the town’s online survey on this subject? The town is seeking input from all residents. <a rel="noreferrer noopener" aria-label="Take the downtown survey here (opens in a new tab)" href="https://www.surveymonkey.com/r/DowntownRiverheadPB" target="_blank">Take the downtown survey here</a>. The survey closes on Friday, Feb. 14.
<figure class="wp-block-image size-large"><img src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0725_downtown_rendering.jpg?resize=640%2C388&#038;quality=100&#038;ssl=1" alt="" class="wp-image-130089" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0725_downtown_rendering.jpg?w=1024&amp;quality=100&amp;ssl=1 1024w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0725_downtown_rendering.jpg?resize=270%2C163&amp;quality=100&amp;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0725_downtown_rendering.jpg?resize=768%2C465&amp;quality=100&amp;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0725_downtown_rendering.jpg?resize=694%2C420&amp;quality=100&amp;ssl=1 694w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0725_downtown_rendering.jpg?resize=640%2C388&amp;quality=100&amp;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0725_downtown_rendering.jpg?resize=681%2C412&amp;quality=100&amp;ssl=1 681w" sizes="(max-width: 640px) 100vw, 640px" data-recalc-dims="1" /><figcaption>Artist&#8217;s rendering of riverfront &#8216;town square&#8217;. Image courtesy of Town of Riverhead</figcaption></figure>
<p>Town officials will reveal some details of their plans for a town square on East Main Street, with adjacent development of a new location of Long Island Science Center, which is purchasing the building at 111 E. Main Street. Officials have called a press conference on Friday at 2 p.m. to describe their plans.
<p>The annual Black History Month Celebration takes place at Riverhead High School on Wednesday, from 6 to 8 p.m. Free and open to the public the event includes a review of important figures in black history, music, dance and vocal performances and guest speakers.
<p>For a complete rundown of events and happenings in the week ahead, check out the <a href="https://eastendlocal.com/events/" target="_blank" rel="noreferrer noopener" aria-label="RiverheadLOCAL events calendar (opens in a new tab)">RiverheadLOCAL events calendar</a>.
<h4>Public Meetings </h4>
<p><strong>Monday</strong><br> Agricultural Advisory Committee, 7 p.m., Town Hall<broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<p><strong>Tuesday</strong><br> County legislature, 9:30 a.m., Hauppauge<br> Business Advisory Committee, 4 p.m., Town Hall<br> Board of Ethics, 5 p.m., Town Hall<br> Recreation Advisory Committee, 5:30 p.m., Town Hall<br> Farmland Committee, 7 p.m., Town Hall
<p><strong>Thursday</strong><br> Town board work session 10 a.m., Town Hall<br> Zoning Board of Appeals 6:30 p.m., Town Hall<br> Future of Downtown Forum, 6:30 p.m., Riverhead Senior &amp; Human Resources Center, 60 Shade Tree Lane, Aquebogue
<p><strong>Friday</strong><br> Alternative Transportation Committee, 10:30 a.m., Town Hall
<p><a href="https://riverheadlocal.com/public-notices/" target="_blank" rel="noreferrer noopener" aria-label="RiverheadLOCAL's online public notices  (opens in a new tab)">RiverheadLOCAL&#8217;s online public notices </a><broadstreet-zone alt-zone-id="68459" class="mobile-ad" count="1"></broadstreet-zone>
<h4>In case you missed it</h4>
<p>RiverheadLOCAL had 83,434 page views last week (Feb. 2-8) from 33,246 unique visitors. (Source: Google Analytics) Thanks for reading!
<p>As always, we appreciate your feedback. Let us know what you like or what we could do better. Send us a news tip. Submit a letter to the editor. <a href="https://riverheadlocal.com/contact/" target="_blank" rel="noreferrer noopener" aria-label="Contact links are located here (opens in a new tab)">Contact links are located here</a>.
<p><strong>Here are RiverheadLOCAL’s top stories of the week just ended:</strong>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="VE5kZzJEtb"><a href="https://riverheadlocal.com/2020/02/06/wrong-way-crash-leaves-car-hanging-over-bridge-on-i-495-in-riverhead/">Wrong-way crash leaves car hanging over bridge on I-495 in Riverhead</a></blockquote><iframe title="&#8220;Wrong-way crash leaves car hanging over bridge on I-495 in Riverhead&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/06/wrong-way-crash-leaves-car-hanging-over-bridge-on-i-495-in-riverhead/embed/#?secret=VE5kZzJEtb" data-secret="VE5kZzJEtb" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="cHzBh7KNWE"><a href="https://riverheadlocal.com/2020/02/06/suv-strikes-pole-overturns-in-manorville/">SUV strikes pole, overturns in Manorville</a></blockquote><iframe title="&#8220;SUV strikes pole, overturns in Manorville&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/06/suv-strikes-pole-overturns-in-manorville/embed/#?secret=cHzBh7KNWE" data-secret="cHzBh7KNWE" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="u9lT4DlISP"><a href="https://riverheadlocal.com/2020/02/07/riverhead-based-bloods-gang-member-charged-in-2015-riverside-murder-cops-plea/">Riverhead-based Bloods gang member charged in 2015 Riverside murder cops plea</a></blockquote><iframe title="&#8220;Riverhead-based Bloods gang member charged in 2015 Riverside murder cops plea&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/07/riverhead-based-bloods-gang-member-charged-in-2015-riverside-murder-cops-plea/embed/#?secret=u9lT4DlISP" data-secret="u9lT4DlISP" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="n0CEO3MVJH"><a href="https://riverheadlocal.com/2020/02/04/long-island-science-center-buying-former-swezeys-building-on-east-main-street/">Long Island Science Center buying former Swezey&#8217;s building on East Main Street</a></blockquote><iframe title="&#8220;Long Island Science Center buying former Swezey&#8217;s building on East Main Street&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/04/long-island-science-center-buying-former-swezeys-building-on-east-main-street/embed/#?secret=n0CEO3MVJH" data-secret="n0CEO3MVJH" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="D0X86nzL3Y"><a href="https://riverheadlocal.com/2020/02/04/fearing-grumman-water-contamination-frustrated-manorville-residents-without-access-to-public-water-ask-navy-for-relief/">Fearing Grumman water contamination, frustrated Manorville residents without access to public water ask Navy for relief</a></blockquote><iframe title="&#8220;Fearing Grumman water contamination, frustrated Manorville residents without access to public water ask Navy for relief&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/04/fearing-grumman-water-contamination-frustrated-manorville-residents-without-access-to-public-water-ask-navy-for-relief/embed/#?secret=D0X86nzL3Y" data-secret="D0X86nzL3Y" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="MMT1aqdhpf"><a href="https://riverheadlocal.com/2020/02/02/riverhead-water-district-employee-has-a-heart-for-the-tin-man/">Riverhead Water District employee has a heart for the ‘Tin Man’</a></blockquote><iframe title="&#8220;Riverhead Water District employee has a heart for the ‘Tin Man’&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/02/riverhead-water-district-employee-has-a-heart-for-the-tin-man/embed/#?secret=MMT1aqdhpf" data-secret="MMT1aqdhpf" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="uRtU8o8MqO"><a href="https://riverheadlocal.com/2020/02/01/whats-the-future-of-downtown-riverhead-tell-the-town-what-you-think-in-this-online-survey/">What&#8217;s the future of downtown Riverhead? Tell the town what you think in this online survey</a></blockquote><iframe title="&#8220;What&#8217;s the future of downtown Riverhead?  Tell the town what you think in this online survey&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/01/whats-the-future-of-downtown-riverhead-tell-the-town-what-you-think-in-this-online-survey/embed/#?secret=uRtU8o8MqO" data-secret="uRtU8o8MqO" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="pRjC1yiqsP"><a href="https://riverheadlocal.com/2020/02/07/west-main-street-7-eleven-plan-gets-final-approval/">West Main Street 7-Eleven site plan gets final approval</a></blockquote><iframe title="&#8220;West Main Street 7-Eleven site plan gets final approval&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/07/west-main-street-7-eleven-plan-gets-final-approval/embed/#?secret=pRjC1yiqsP" data-secret="pRjC1yiqsP" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="jvIXuvwI1l"><a href="https://riverheadlocal.com/2020/02/05/town-board-creates-joint-task-force-with-school-district-considers-term-limits-for-appointed-boards/">Town board creates joint task force with school district, considers term limits for appointed boards</a></blockquote><iframe title="&#8220;Town board creates joint task force with school district, considers term limits for appointed boards&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/05/town-board-creates-joint-task-force-with-school-district-considers-term-limits-for-appointed-boards/embed/#?secret=jvIXuvwI1l" data-secret="jvIXuvwI1l" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<figure class="wp-block-embed-wordpress wp-block-embed is-type-wp-embed is-provider-riverheadlocal"><div class="wp-block-embed__wrapper">
<blockquote class="wp-embedded-content" data-secret="7nHeWyt1UJ"><a href="https://riverheadlocal.com/2020/02/03/nysut-officials-on-fund-our-future-tour-in-riverhead-hear-about-overcrowded-under-resourced-public-schools/">NYSUT officials on &#8216;Fund Our Future&#8217; tour in Riverhead hear about overcrowded, under-resourced public schools</a></blockquote><iframe title="&#8220;NYSUT officials on &#8216;Fund Our Future&#8217; tour in Riverhead hear about overcrowded, under-resourced public schools&#8221; &#8212; RiverheadLOCAL" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://riverheadlocal.com/2020/02/03/nysut-officials-on-fund-our-future-tour-in-riverhead-hear-about-overcrowded-under-resourced-public-schools/embed/#?secret=7nHeWyt1UJ" data-secret="7nHeWyt1UJ" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div></figure>
<div class="kb-member-content-box"><p>This story is free to read thanks in part to the generous support of readers like you. <strong>Keep local news free. <a href="/support-local-journalism">Become a member</a> today.</strong></p></div> </div>
<footer>
<div class="td-post-source-tags td-pb-padding-side">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://riverheadlocal.com/tag/featured/">featured</a></li><li><a href="https://riverheadlocal.com/tag/top-stories/">Top stories</a></li><li><a href="https://riverheadlocal.com/tag/weekly-roundup/">weekly roundup</a></li></ul> </div>
<div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-twitter" style="overflow: visible;"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/" data-text="Focus is on downtown Riverhead this week" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li class="td-classic-facebook" style="overflow: visible;"><div class="fb-like" data-href="https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/" data-layout="button_count" data-action="like" data-show-faces="false"></div></li></ul></div></div> <div class="author-box-wrap"><a href="https://riverheadlocal.com/author/denise-2/"><img src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/09/DC-avatar.png?fit=96%2C96&quality=100&ssl=1" width="96" height="96" alt="Denise Civiletti" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://riverheadlocal.com/author/denise-2/">Denise Civiletti</a></span></div><div class="td-author-description">Denise is a veteran local reporter, editor, attorney and former Riverhead Town councilwoman. Her work has been recognized with numerous awards, including investigative reporting and writer of the year awards from the N.Y. Press Association. She is a founder, owner and co-publisher of this website.<a href="/cdn-cgi/l/email-protection#c9adaca7a0baac89bba0bfacbba1aca8ada5a6aaa8a5e7aaa6a4">Email Denise.</a></div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/civiletti" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Denise Civiletti"></span><meta itemprop="datePublished" content="2020-02-10T05:59:49+00:00"><meta itemprop="dateModified" content="2020-02-10T06:00:03-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png"></span><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="headline " content="Focus is on downtown Riverhead this week"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/2019_1130_East_Main_Street.jpeg?fit=800%2C534&quality=100&ssl=1"><meta itemprop="width" content="800"><meta itemprop="height" content="534"></span> </footer>
<div class="fb-comments" data-href="https://riverheadlocal.com/2020/02/10/focus-is-on-downtown-riverhead-this-week/" data-width="100%" data-mobile="true" data-numposts="10" data-order-by="social" data-colorscheme="light"></div> </div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68459" count="1"></broadstreet-zone></div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="kb-popout-content td-pb-row">
<div class="wpb_wrapper">
<div class="wpb_text_column block-header">
<p>Daily Newsletter</p>
</div>
<div class="wpb_wrapper wpb_text_column td-pb-border-top">
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://riverheadlocal.us6.list-manage.com/subscribe/post?u=47e88a318d72559c43e4b77bc&amp;id=8118172d70" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div class="mc-field-group first-name"><label for="mce-FNAME">First Name </label><br />
<input id="mce-FNAME" class="required" name="FNAME" type="text" value="" /></div>
<div class="mc-field-group last-name"><label for="mce-LNAME">Last Name </label><br />
<input id="mce-LNAME" class="required" name="LNAME" type="text" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_47e88a318d72559c43e4b77bc_8118172d70" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p>
</div>
</div>
</div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68461" count="1"></broadstreet-zone></div>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div>
</div> 


<div class="td-footer-container td-container td-footer-template-10">
<div class="footer-social-wrap td-social-style2 td-footer-full">
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer1-container"><ul id="menu-footer1" class="td-subfooter-menu"><li id="menu-item-132939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-132939"><a href="https://riverheadlocal.com/copyright-notice/">© 2010-2020 East End Local Media Corp</a></li>
<li id="menu-item-132941" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132941"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-132940" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132940"><a href="https://riverheadlocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-132944" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132944"><a href="https://riverheadlocal.com/comments-policy/">Comments Policy</a></li>
<li id="menu-item-132945" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132945"><a href="https://riverheadlocal.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
<div class="td-pb-span4 td-sub-footer-copy">
<div class="td-pb-padding-side">
</div>
</div>
</div>
</div>
</div>
</div>
<div class="a2a_kit a2a_kit_size_36 a2a_floating_style a2a_vertical_style" style="left:0px;top:400px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;left:5px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F02%2F10%2Ffocus-is-on-downtown-riverhead-this-week%2F&amp;linkname=Focus%20is%20on%20downtown%20Riverhead%20this%20week%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><a rel="nofollow" style="display:none;" href="https://riverheadlocal.com/?blackhole=8245a3b43a" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','weekly-roundup','local-news','focus-is-on-downtown-riverhead-this-week','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["weekly-roundup","local-news","focus-is-on-downtown-riverhead-this-week","post"],"url":"focus-is-on-downtown-riverhead-this-week"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({"useAltZone":767,"altZoneWhitelist":[71281],"networkId":"4821","targets":{"pagetype":["post","not_home_page"],"category":["weekly-roundup","local-news","focus-is-on-downtown-riverhead-this-week","post"],"url":"focus-is-on-downtown-riverhead-this-week"}});
 });</script>

<script type="text/javascript">(function($) {
  $.fn.almComplete = function(alm){
    
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");


      

    var $pageNumber;
    if ($('.kb-alm-wrap-page-3').length) {
        $pageNumber = 3; 
       // console.log("We're on page 3");
    } else if ($('.kb-alm-wrap-page-2').length) {
        $pageNumber = 2;
        // console.log("We're on page 2");
    } else {
        $pageNumber = 1;
        // console.log("We're on page 1");
    }
    
    // Parse FB comments code
    
    var $newContainerString = '.alm-page-' + $pageNumber;
    var $newContainer = $($newContainerString).parent();

    FB.XFBML.parse($newContainer[0]);
    
    // Append alm button to wrapper
    
    var $new_name = '.kb-alm-wrap-page-' + $pageNumber;
    // $('.alm-btn-wrap').detach();
    // $('.alm-btn-wrap').appendTo($new_name);
  
    // console.log("Button moved!");
    
    for ( var i = 0; i < tdSmartSidebar.items.length; i++ ) {
                    if ( 'case_3_bottom_of_content' === tdSmartSidebar.items[ i ].sidebar_state ) {
                        tdSmartSidebar.items[ i ].sidebar_state = 'case_1_fixed_down';
                       //  console.log("fixed down!");
                    }
                }
                
    var base_url = "https://riverheadlocal.com";
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.js" );
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js" );
//    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/jquery-3.1.1.min.js" );

   // console.log("Alm complte!");
   var jigs = jQuery('.justified-image-grid');
    if(jigs.length !== 0){
       jigs.data('justifiedImageGrid').createGallery('resize');
    }
  };
})(jQuery);

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");
    
 /*  $( 'body' ).on( 'post-load', function() {
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      } ); 
    // type = From which addon (previous-post | seo)
    // permalink = the updated url
    console.log("URL updated to " + permalink + '- dispatched from the '+ type + ' add-on.'); */
  }; 
})(jQuery);

(function($) {
    $(window).load(function(){
  // $('.alm-btn-wrap').appendTo($('.kb-alm-wrap'));
   // console.log("Button moved!");
});
})(jQuery);</script> 
<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-aJ5TJKLfrG9cB",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-aJ5TJKLfrG9cB.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<link rel='stylesheet' id='photoswipe-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/css/photoswipe4.css?ver=4.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/wpdialog.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/sticky-kit.js?ver=1.0.6'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"4fda78d3f4","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/photoswipe4.min.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/jquery.dotdotdot.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js?ver=3.9.5'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://riverheadlocal.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
</body>
</html>