<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Tropical storm watch issued for most of Long Island ahead of Elsa&#039;s arrival Friday | RiverheadLOCAL</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="pingback" href="https://riverheadlocal.com/xmlrpc.php" />
<meta name='robots' content='max-image-preview:large' />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<meta property="og:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?fit=1744%2C1406&quality=100&ssl=1" /><link rel="icon" type="image/png" href="https://riverheadlocal.com/wp-content/uploads/2021/06/Pindot-fav.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://riverheadlocal.com/wp-content/uploads/2021/06/Pindot-White-BG.jpeg" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://riverheadlocal.com/wp-content/uploads/2021/06/Pindot-White-BG.jpeg" />

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Tropical storm watch issued for most of Long Island ahead of Elsa&#039;s arrival Friday | RiverheadLOCAL" />
<meta property="og:description" content="The National Weather Service has issued a tropical storm watch for most of Long Island ahead of Tropical Storm Elsa&#039;s arrival in the region Friday morning." />
<meta property="og:url" content="https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/" />
<meta property="og:site_name" content="RiverheadLOCAL" />
<meta property="article:author" content="https://www.facebook.com/katiemorosky" />
<meta property="article:tag" content="featured" />
<meta property="article:tag" content="tropical storm" />
<meta property="article:tag" content="Tropical Storm Elsa" />
<meta property="article:section" content="Weather" />
<meta property="article:published_time" content="2021-07-07T22:14:26+00:00" />
<meta property="article:modified_time" content="2021-07-07T22:14:57+00:00" />
<meta property="og:updated_time" content="2021-07-07T22:14:57+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The National Weather Service has issued a tropical storm watch for most of Long Island ahead of Tropical Storm Elsa&#039;s arrival in the region Friday morning." />
<meta name="twitter:title" content="Tropical storm watch issued for most of Long Island ahead of Elsa&#039;s arrival Friday | RiverheadLOCAL" />
<meta name="twitter:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?fit=1744%2C1406&#038;quality=100&#038;ssl=1" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://riverheadlocal.com/#website","url":"https://riverheadlocal.com/","name":"RiverheadLOCAL","inLanguage":"en-US","description":"News and events for Riverhead, New York","potentialAction":[{"@type":"SearchAction","target":"https://riverheadlocal.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?fit=1744%2C1406&quality=100&ssl=1","width":1744,"height":1406},{"@type":"WebPage","@id":"https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/#webpage","url":"https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/","name":"Tropical storm watch issued for most of Long Island ahead of Elsa&#039;s arrival Friday | RiverheadLOCAL","isPartOf":{"@id":"https://riverheadlocal.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/#primaryimage"},"datePublished":"2021-07-07T22:14:26+00:00","dateModified":"2021-07-07T22:14:57+00:00","author":{"@id":"https://riverheadlocal.com/#/schema/person/3bc9a8244567551204d9c050cbab926f"},"potentialAction":[{"@type":"ReadAction","target":["https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/"]}]},{"@type":["Person"],"@id":"https://riverheadlocal.com/#/schema/person/3bc9a8244567551204d9c050cbab926f","name":"Katie Morosky","image":{"@type":"ImageObject","@id":"https://riverheadlocal.com/#authorlogo","inLanguage":"en-US","url":"https://riverheadlocal.com/wp-content/uploads/2020/04/IMG_1879_Facetune_28-08-2019-15-44-58.jpeg","caption":"Katie Morosky"},"description":"Katie, winner of the 2016 James Murphy Cub Reporter of the Year award from the L.I. Press Club, is a co-publisher of RiverheadLOCAL. A Riverhead native, she is a 2014 graduate of Stony Brook University.\r\n<a href=\"mailto:katie@riverheadlocal.com\">Email Katie</a>","sameAs":["https://www.facebook.com/katiemorosky"]}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Feed" href="https://riverheadlocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Comments Feed" href="https://riverheadlocal.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='kb-membership-style-css' href='https://riverheadlocal.com/wp-content/plugins/kb-membership/inc/style.css?ver=6.2.01' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://riverheadlocal.com/wp-includes/css/dashicons.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='https://riverheadlocal.com/wp-includes/css/jquery-ui-dialog.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://riverheadlocal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fc-form-css-css' href='https://riverheadlocal.com/wp-content/plugins/Formcraft/assets/css/form.min.css?ver=3.2.27' type='text/css' media='all' />
<link rel='stylesheet' id='kb-liveblog-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-liveblog/style.css?ver=6.0.200' type='text/css' media='all' />
<link rel='stylesheet' id='public_notices_css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-public-notices/kb-public-notices.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='kb-top-stories-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-top-stories/style.css?ver=3.0.12' type='text/css' media='all' />
<link rel='stylesheet' id='trans-frontend-css' href='https://riverheadlocal.com/wp-content/plugins/kb-translation/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-min-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/icons/css/weather-icons.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-wind-min-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/icons/css/weather-icons-wind.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='kb-weather-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/css/kb-weather.css?ver=3.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://riverheadlocal.com/wp-content/themes/Newsmag/style.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css?ver=5.0.03' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C100%2C100italic%2C200%2C200italic%2C300italic%2C400italic%2C500%2C500italic%2C600italic%2C700italic%2C800%2C800italic%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C100%2C100italic%2C200%2C200italic%2C500%2C500italic%2C600%2C600italic%2C800%2C800italic&#038;ver=4.3&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://riverheadlocal.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1125px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1124px){
.a2a_floating_style.a2a_default_style{display:none;}
}
.a2a_floating_style {
    padding: 20px;
    border-radius: 0;
    border: 1px solid #bbbbbb;
}
</style>
<link rel='stylesheet' id='js_composer_front-css' href='https://riverheadlocal.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://riverheadlocal.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-membership/inc/button.js?ver=6.0.1' id='kb-membership-button-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.7.1' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-liveblog/scripts.js?ver=5.7.1' id='liveblog_scripts-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-weather/js/modernizr.custom.js?ver=5.7.1' id='modernizr_custom-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-weather/js/summary-box.js?ver=5.7.1' id='summary-box-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.29' id='stop-user-enumeration-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.13.1' id='gtm4wp-form-move-tracker-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/common-scripts.js?ver=1.1.0' id='common_scripts-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/popup-menu-fix.js?ver=5.7.1' id='popup-menu-fix-js'></script>
<link rel="https://api.w.org/" href="https://riverheadlocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://riverheadlocal.com/wp-json/wp/v2/posts/141132" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverheadlocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverheadlocal.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://riverheadlocal.com/?p=141132' />
<link rel="alternate" type="application/json+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color = "#A0A0A0";

a2a_config.templates = {
    email: {
        subject: "RiverheadLOCAL: ${title}",
        body: "Check out this story on RiverheadLOCAL: \n${title}\n${link}"
    }
};

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      }; 
})(jQuery);
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Tropical storm watch issued for most of Long Island ahead of Elsa&#039;s arrival Friday | RiverheadLOCAL","pagePostType":"post","pagePostType2":"single-post","pageCategory":["weather"],"pageAttributes":["featured","tropical-storm","tropical-storm-elsa"],"pagePostAuthorID":1,"pagePostAuthor":"Katie Morosky","pagePostDate":"Jul 7, 2021, 6:14 pm","pagePostDateYear":"2021","pagePostDateMonth":"07","pagePostDateDay":"07","postID":141132};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N97RFZC');//]]>
</script>

<script src="https://use.fontawesome.com/b3fb28acc8.js"></script><script src="https://cdn.jsdelivr.net/npm/chart.js@2.8.0"></script><meta property="fb:app_id" content="105130769527571" /><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://riverheadlocal.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '82fba20f-da37-4c38-a7fe-ee7dbe081e0f';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://riverheadlocal.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.370dd028-ab8a-4720-9087-4e2c917686de";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_ajax_url="https:\/\/riverheadlocal.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=4.3";
var td_get_template_directory_uri="https:\/\/riverheadlocal.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e12025";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=32%2C32&#038;quality=100&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>
<body class="post-template-default single single-post postid-141132 single-format-standard author-katie-morosky tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday global-block-template-1 white-menu wpb-js-composer js-comp-ver-6.6.0 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N97RFZC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '105130769527571',
      autoLogAppEvents : true,
      xfbml      : true,
      version    : 'v10.0'
    });
};
</script>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js"></script>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div class="td-mobile-container">

<div class="kb-menu-socials-wrap">

<div class="kb-menu-socials">
</div>
</div>

<div class="kb-mobile-search-container"><form method="get" class="td-search-form-widget" action="https://riverheadlocal.com/">
<div role="search" class="kb-mobile-search">
<button class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit"><i class="td-icon-search"></i></button>
<div class="kb-search-input-wrap"><input class="td-widget-search-input" type="text" value="Search" name="s" id="s" onfocus="if (this.value=='Search') this.value='';" onblur="if (this.value=='') this.value='Search';" /></div>
</div>
</form>
</div>

<div class="td-mobile-content">
<div class="menu-mobile-container"><ul id="menu-mobile" class="td-mobile-main-menu"><li id="menu-item-116721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-116721"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100685" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100685"><a href="https://riverheadlocal.com/news/">News</a></li>
<li id="menu-item-100683" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100683"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a></li>
<li id="menu-item-100686" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100686"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100692" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100692"><a href="https://riverheadlocal.com/opinion/">Opinion</a></li>
<li id="menu-item-100687" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100687"><a href="https://riverheadlocal.com/community/">Community</a></li>
<li id="menu-item-100693" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-100693"><a href="http://eastendlocal.com">Events</a></li>
<li id="menu-item-100688" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100688"><a href="https://riverheadlocal.com/schools/">Schools</a></li>
<li id="menu-item-100684" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100684"><a href="https://riverheadlocal.com/business/business-news/">Business</a></li>
<li id="menu-item-108418" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108418"><a href="https://classifieds.eastendlocal.com">Classifieds</a></li>
<li id="menu-item-136097" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-136097"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-100694" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-100694"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-139558" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-139558"><a href="https://riverheadlocal.com/newsletter/">Newsletter</a></li>
<li id="menu-item-100695" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-100695"><a href="https://riverheadlocal.com/contact/">Contact RiverheadLOCAL</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div id="kb-overlay"></div>
<div class="td-header-wrap td-header-style-3">
<div class="td-top-menu-full">
<div class="td-header-row td-header-top-menu td-make-full">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-100681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-100681"><a href="https://riverheadlocal.com/contact/">Contact</a></li>
<li id="menu-item-130976" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-130976"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-100680" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-100680"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-24924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24924"><a target="_blank" rel="noopener" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-116691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116691"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-24925" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24925"><a target="_blank" rel="noopener" href="http://eastendlocal.com/classifieds/">Classifieds</a></li>
<li id="menu-item-129406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129406"><a href="https://riverheadlocal.com/support-local-journalism/">Membership</a></li>
</ul></div></div> </div>

</div>
</div>

<div class="td-header-container">
<div class="td-header-logo-wrap">
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="riverhead local logo" title="riverhead local logo" />
<span class="td-visual-hidden">RiverheadLOCAL</span>
</a>
</div>
<div class="td-header-right-header">
<div class="td-header-right ">
<div class="textwidget"><h3>Support local journalism.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-main-menu">
<div class="td-header-menu-wrap-sub">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-header-right-header mobile-header">
<div class="td-header-right ">
<div class="textwidget"><h3>Support local journalism.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="riverhead local logo" title="riverhead local logo" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main" class="sf-menu"><li id="menu-item-100668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-100668"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100671" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100671"><a href="https://riverheadlocal.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_60e6276395e2f = new tdBlock();
block_td_uid_1_60e6276395e2f.id = "td_uid_1_60e6276395e2f";
block_td_uid_1_60e6276395e2f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"103","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_60e6276395e2f_rand","tdc_css_class":"td_uid_1_60e6276395e2f_rand","tdc_css_class_style":"td_uid_1_60e6276395e2f_rand_style"}';
block_td_uid_1_60e6276395e2f.td_column_number = "3";
block_td_uid_1_60e6276395e2f.block_type = "td_block_mega_menu";
block_td_uid_1_60e6276395e2f.post_count = "5";
block_td_uid_1_60e6276395e2f.found_posts = "7001";
block_td_uid_1_60e6276395e2f.header_color = "";
block_td_uid_1_60e6276395e2f.ajax_pagination_infinite_stop = "";
block_td_uid_1_60e6276395e2f.max_num_pages = "1401";
tdBlocksArray.push(block_td_uid_1_60e6276395e2f);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_1_60e6276395e2f_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_60e6276395e2f"><div id=td_uid_1_60e6276395e2f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/07/riverheads-proposed-ban-on-retail-marijuana-sales-fails/" rel="bookmark" class="td-image-wrap" title="Riverhead&#8217;s proposed ban on retail marijuana sales fails"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0707-town-board.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0707-town-board.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0707-town-board.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0707-town-board.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0707-town-board.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0707-town-board.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0707-town-board.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0707-town-board.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead&#8217;s proposed ban on retail marijuana sales fails" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/07/riverheads-proposed-ban-on-retail-marijuana-sales-fails/" rel="bookmark" title="Riverhead&#8217;s proposed ban on retail marijuana sales fails">Riverhead&#8217;s proposed ban on retail marijuana sales fails</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/06/downtown-riverhead-parking-lot-work-begins-tomorrow-closures-to-take-place-through-july-14/" rel="bookmark" class="td-image-wrap" title="Downtown Riverhead parking lot work begins Wednesday, closures to take place through July 14"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_First-Street-Parking-Lot-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Downtown Riverhead parking lot work begins Wednesday, closures to take place through July 14" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/06/downtown-riverhead-parking-lot-work-begins-tomorrow-closures-to-take-place-through-july-14/" rel="bookmark" title="Downtown Riverhead parking lot work begins Wednesday, closures to take place through July 14">Downtown Riverhead parking lot work begins Wednesday, closures to take place through July 14</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/04/the-5th-of-july-whats-open-whats-closed/" rel="bookmark" class="td-image-wrap" title="The 5th of July: What&#8217;s open, what&#8217;s closed"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/06/2018_0630_fireworks_file_2012.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/06/2018_0630_fireworks_file_2012.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/06/2018_0630_fireworks_file_2012.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/06/2018_0630_fireworks_file_2012.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/06/2018_0630_fireworks_file_2012.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/06/2018_0630_fireworks_file_2012.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/06/2018_0630_fireworks_file_2012.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="The 5th of July: What&#8217;s open, what&#8217;s closed" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/04/the-5th-of-july-whats-open-whats-closed/" rel="bookmark" title="The 5th of July: What&#8217;s open, what&#8217;s closed">The 5th of July: What&#8217;s open, what&#8217;s closed</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/03/impact-statement-filed-for-massive-industrial-park-in-calverton-public-hearing-set/" rel="bookmark" class="td-image-wrap" title="Impact statement filed for massive industrial park in Calverton, public hearing set"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_HK-Ventures-Calverton-Industrial-Park.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_HK-Ventures-Calverton-Industrial-Park.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_HK-Ventures-Calverton-Industrial-Park.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_HK-Ventures-Calverton-Industrial-Park.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_HK-Ventures-Calverton-Industrial-Park.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_HK-Ventures-Calverton-Industrial-Park.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_HK-Ventures-Calverton-Industrial-Park.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Impact statement filed for massive industrial park in Calverton, public hearing set" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/03/impact-statement-filed-for-massive-industrial-park-in-calverton-public-hearing-set/" rel="bookmark" title="Impact statement filed for massive industrial park in Calverton, public hearing set">Impact statement filed for massive industrial park in Calverton, public hearing set</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/02/outdoor-dining-to-continue-in-downtown-riverhead-this-summer/" rel="bookmark" class="td-image-wrap" title="Outdoor dining to continue in downtown Riverhead this summer"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Outdoor dining to continue in downtown Riverhead this summer" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/02/outdoor-dining-to-continue-in-downtown-riverhead-this-summer/" rel="bookmark" title="Outdoor dining to continue in downtown Riverhead this summer">Outdoor dining to continue in downtown Riverhead this summer</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_60e6276395e2f" id="td_uid_2_60e62763a2b29" data-td_block_id="td_uid_1_60e6276395e2f" data-td_filter_value="" href="https://riverheadlocal.com/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_60e6276395e2f" id="td_uid_3_60e62763a2b9f" data-td_block_id="td_uid_1_60e6276395e2f" data-td_filter_value="105" href="https://riverheadlocal.com/news/local-news/">Local News</a><a class="mega-menu-sub-cat-td_uid_1_60e6276395e2f" id="td_uid_4_60e62763a2c01" data-td_block_id="td_uid_1_60e6276395e2f" data-td_filter_value="32" href="https://riverheadlocal.com/news/local-news/health/">Health</a><a class="mega-menu-sub-cat-td_uid_1_60e6276395e2f" id="td_uid_5_60e62763a2ca0" data-td_block_id="td_uid_1_60e6276395e2f" data-td_filter_value="108" href="https://riverheadlocal.com/news/public-notices/">Public Notices</a><a class="mega-menu-sub-cat-td_uid_1_60e6276395e2f" id="td_uid_6_60e62763a2d1d" data-td_block_id="td_uid_1_60e6276395e2f" data-td_filter_value="13" href="https://riverheadlocal.com/news/real-estate-news/">Real Estate</a><a class="mega-menu-sub-cat-td_uid_1_60e6276395e2f" id="td_uid_7_60e62763a2d95" data-td_block_id="td_uid_1_60e6276395e2f" data-td_filter_value="104" href="https://riverheadlocal.com/news/town-hall-notebook/">Town Hall Notebook</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_60e6276395e2f" data-td_block_id="td_uid_1_60e6276395e2f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_60e6276395e2f" data-td_block_id="td_uid_1_60e6276395e2f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100669" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100669"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_8_60e62763e6cd1 = new tdBlock();
block_td_uid_8_60e62763e6cd1.id = "td_uid_8_60e62763e6cd1";
block_td_uid_8_60e62763e6cd1.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_8_60e62763e6cd1_rand","tdc_css_class":"td_uid_8_60e62763e6cd1_rand","tdc_css_class_style":"td_uid_8_60e62763e6cd1_rand_style"}';
block_td_uid_8_60e62763e6cd1.td_column_number = "3";
block_td_uid_8_60e62763e6cd1.block_type = "td_block_mega_menu";
block_td_uid_8_60e62763e6cd1.post_count = "5";
block_td_uid_8_60e62763e6cd1.found_posts = "2553";
block_td_uid_8_60e62763e6cd1.header_color = "";
block_td_uid_8_60e62763e6cd1.ajax_pagination_infinite_stop = "";
block_td_uid_8_60e62763e6cd1.max_num_pages = "511";
tdBlocksArray.push(block_td_uid_8_60e62763e6cd1);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_8_60e62763e6cd1_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_8_60e62763e6cd1"><div id=td_uid_8_60e62763e6cd1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/06/riverhead-police-investigate-commercial-burglary-seek-information/" rel="bookmark" class="td-image-wrap" title="Riverhead Police investigate commercial burglary, seek information"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead Police investigate commercial burglary, seek information" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/06/riverhead-police-investigate-commercial-burglary-seek-information/" rel="bookmark" title="Riverhead Police investigate commercial burglary, seek information">Riverhead Police investigate commercial burglary, seek information</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/06/police-investigate-vehicle-fire-at-neighborhood-park-in-riverhead/" rel="bookmark" class="td-image-wrap" title="Police investigate vehicle fire at neighborhood park in Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0706-Lewis-Street-park.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0706-Lewis-Street-park.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0706-Lewis-Street-park.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0706-Lewis-Street-park.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0706-Lewis-Street-park.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0706-Lewis-Street-park.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0706-Lewis-Street-park.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021-0706-Lewis-Street-park.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Police investigate vehicle fire at neighborhood park in Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/06/police-investigate-vehicle-fire-at-neighborhood-park-in-riverhead/" rel="bookmark" title="Police investigate vehicle fire at neighborhood park in Riverhead">Police investigate vehicle fire at neighborhood park in Riverhead</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/06/car-crashes-through-storefront-at-tanger-outlets/" rel="bookmark" class="td-image-wrap" title="Car crashes through storefront at Tanger Outlets"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_MVA_tanger-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_MVA_tanger-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_MVA_tanger-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_MVA_tanger-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_MVA_tanger-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_MVA_tanger-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_MVA_tanger-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_MVA_tanger-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Car crashes through storefront at Tanger Outlets" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/06/car-crashes-through-storefront-at-tanger-outlets/" rel="bookmark" title="Car crashes through storefront at Tanger Outlets">Car crashes through storefront at Tanger Outlets</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/06/police-search-for-special-needs-child-missing-from-little-flower-childrens-services/" rel="bookmark" class="td-image-wrap" title="Update: Missing child located, returned to Little Flower, police say"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706-Aiden-Mariana.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706-Aiden-Mariana.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706-Aiden-Mariana.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706-Aiden-Mariana.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706-Aiden-Mariana.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706-Aiden-Mariana.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706-Aiden-Mariana.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Update: Missing child located, returned to Little Flower, police say" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/06/police-search-for-special-needs-child-missing-from-little-flower-childrens-services/" rel="bookmark" title="Update: Missing child located, returned to Little Flower, police say">Update: Missing child located, returned to Little Flower, police say</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/29/cops-56-year-old-woman-found-drowned-in-vehicle-off-iron-pier-beach-in-riverhead/" rel="bookmark" class="td-image-wrap" title="Cops: 56-year-old woman found drowned in vehicle off Iron Pier Beach in Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0629-Iron-Pier-Beach.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0629-Iron-Pier-Beach.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0629-Iron-Pier-Beach.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0629-Iron-Pier-Beach.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0629-Iron-Pier-Beach.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0629-Iron-Pier-Beach.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0629-Iron-Pier-Beach.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0629-Iron-Pier-Beach.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Cops: 56-year-old woman found drowned in vehicle off Iron Pier Beach in Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/29/cops-56-year-old-woman-found-drowned-in-vehicle-off-iron-pier-beach-in-riverhead/" rel="bookmark" title="Cops: 56-year-old woman found drowned in vehicle off Iron Pier Beach in Riverhead">Cops: 56-year-old woman found drowned in vehicle off Iron Pier Beach in Riverhead</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_8_60e62763e6cd1" id="td_uid_9_60e62763ee766" data-td_block_id="td_uid_8_60e62763e6cd1" data-td_filter_value="" href="https://riverheadlocal.com/police-fire/">All</a><a class="mega-menu-sub-cat-td_uid_8_60e62763e6cd1" id="td_uid_10_60e62763ee7e1" data-td_block_id="td_uid_8_60e62763e6cd1" data-td_filter_value="42" href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a><a class="mega-menu-sub-cat-td_uid_8_60e62763e6cd1" id="td_uid_11_60e62763ee843" data-td_block_id="td_uid_8_60e62763e6cd1" data-td_filter_value="41" href="https://riverheadlocal.com/police-fire/police-blotter/">Police Reports</a><a class="mega-menu-sub-cat-td_uid_8_60e62763e6cd1" id="td_uid_12_60e62763ee907" data-td_block_id="td_uid_8_60e62763e6cd1" data-td_filter_value="43" href="https://riverheadlocal.com/police-fire/riverhead-justice-court/">Riverhead Justice Court</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_8_60e62763e6cd1" data-td_block_id="td_uid_8_60e62763e6cd1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_8_60e62763e6cd1" data-td_block_id="td_uid_8_60e62763e6cd1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100672" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100672"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100673" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100673"><a href="https://riverheadlocal.com/community/">Community</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_13_60e627644574b = new tdBlock();
block_td_uid_13_60e627644574b.id = "td_uid_13_60e627644574b";
block_td_uid_13_60e627644574b.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"113","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_60e627644574b_rand","tdc_css_class":"td_uid_13_60e627644574b_rand","tdc_css_class_style":"td_uid_13_60e627644574b_rand_style"}';
block_td_uid_13_60e627644574b.td_column_number = "3";
block_td_uid_13_60e627644574b.block_type = "td_block_mega_menu";
block_td_uid_13_60e627644574b.post_count = "5";
block_td_uid_13_60e627644574b.found_posts = "4079";
block_td_uid_13_60e627644574b.header_color = "";
block_td_uid_13_60e627644574b.ajax_pagination_infinite_stop = "";
block_td_uid_13_60e627644574b.max_num_pages = "816";
tdBlocksArray.push(block_td_uid_13_60e627644574b);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_13_60e627644574b_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_60e627644574b"><div id=td_uid_13_60e627644574b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/03/let-freedom-ring-independence-day-celebrated-in-jamesport/" rel="bookmark" class="td-image-wrap" title="Let freedom ring: Independence Day celebrated in Jamesport"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_Independence-Day-Jamesport-13.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_Independence-Day-Jamesport-13.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_Independence-Day-Jamesport-13.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_Independence-Day-Jamesport-13.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_Independence-Day-Jamesport-13.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_Independence-Day-Jamesport-13.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_Independence-Day-Jamesport-13.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0703_Independence-Day-Jamesport-13.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Let freedom ring: Independence Day celebrated in Jamesport" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/03/let-freedom-ring-independence-day-celebrated-in-jamesport/" rel="bookmark" title="Let freedom ring: Independence Day celebrated in Jamesport">Let freedom ring: Independence Day celebrated in Jamesport</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/03/flanders-fire-department-to-host-blood-drive-july-10/" rel="bookmark" class="td-image-wrap" title="Flanders Fire Department to host blood drive July 10"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/05/2015_0625_blood_drive.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/05/2015_0625_blood_drive.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/05/2015_0625_blood_drive.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Flanders Fire Department to host blood drive July 10" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/03/flanders-fire-department-to-host-blood-drive-july-10/" rel="bookmark" title="Flanders Fire Department to host blood drive July 10">Flanders Fire Department to host blood drive July 10</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/03/pal-soccer-registration-is-now-open/" rel="bookmark" class="td-image-wrap" title="PAL soccer registration is now open"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0703-youth-soccer.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0703-youth-soccer.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0703-youth-soccer.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0703-youth-soccer.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0703-youth-soccer.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0703-youth-soccer.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0703-youth-soccer.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0703-youth-soccer.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="PAL soccer registration is now open" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/03/pal-soccer-registration-is-now-open/" rel="bookmark" title="PAL soccer registration is now open">PAL soccer registration is now open</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/02/cruise-night-rescheduled-to-july-15-kids-zone-returns-to-alive-on-25-on-july-29/" rel="bookmark" class="td-image-wrap" title="&#8216;Cruise Night&#8217; rescheduled to July 15, &#8216;Kids Zone&#8217; returns to Alive on 25 on July 29"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/nggallery_import/2017_0811_alive_on-25-38.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/nggallery_import/2017_0811_alive_on-25-38.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/nggallery_import/2017_0811_alive_on-25-38.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/nggallery_import/2017_0811_alive_on-25-38.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/nggallery_import/2017_0811_alive_on-25-38.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/nggallery_import/2017_0811_alive_on-25-38.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/nggallery_import/2017_0811_alive_on-25-38.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="&#8216;Cruise Night&#8217; rescheduled to July 15, &#8216;Kids Zone&#8217; returns to Alive on 25 on July 29" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/02/cruise-night-rescheduled-to-july-15-kids-zone-returns-to-alive-on-25-on-july-29/" rel="bookmark" title="&#8216;Cruise Night&#8217; rescheduled to July 15, &#8216;Kids Zone&#8217; returns to Alive on 25 on July 29">&#8216;Cruise Night&#8217; rescheduled to July 15, &#8216;Kids Zone&#8217; returns to Alive on 25 on July 29</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_module_no_thumb td_mod_mega_menu">
<div class="td-module-image">
 </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/30/independence-day-celebration-held-by-greater-jamesport-civic-association/" rel="bookmark" title="Independence Day celebration held by Greater Jamesport Civic Association">Independence Day celebration held by Greater Jamesport Civic Association</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_60e627644574b" id="td_uid_14_60e6276456463" data-td_block_id="td_uid_13_60e627644574b" data-td_filter_value="" href="https://riverheadlocal.com/community/">All</a><a class="mega-menu-sub-cat-td_uid_13_60e627644574b" id="td_uid_15_60e6276456565" data-td_block_id="td_uid_13_60e627644574b" data-td_filter_value="128" href="https://riverheadlocal.com/community/announcements/">Announcements</a><a class="mega-menu-sub-cat-td_uid_13_60e627644574b" id="td_uid_16_60e6276456623" data-td_block_id="td_uid_13_60e627644574b" data-td_filter_value="126" href="https://riverheadlocal.com/community/community-news/">Community News</a><a class="mega-menu-sub-cat-td_uid_13_60e627644574b" id="td_uid_17_60e62764566b4" data-td_block_id="td_uid_13_60e627644574b" data-td_filter_value="127" href="https://riverheadlocal.com/community/event-photos/">Event Photos</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_60e627644574b" data-td_block_id="td_uid_13_60e627644574b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_60e627644574b" data-td_block_id="td_uid_13_60e627644574b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100674" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100674"><a href="https://riverheadlocal.com/schools/">Schools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_18_60e6276495126 = new tdBlock();
block_td_uid_18_60e6276495126.id = "td_uid_18_60e6276495126";
block_td_uid_18_60e6276495126.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"185","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_60e6276495126_rand","tdc_css_class":"td_uid_18_60e6276495126_rand","tdc_css_class_style":"td_uid_18_60e6276495126_rand_style"}';
block_td_uid_18_60e6276495126.td_column_number = "3";
block_td_uid_18_60e6276495126.block_type = "td_block_mega_menu";
block_td_uid_18_60e6276495126.post_count = "5";
block_td_uid_18_60e6276495126.found_posts = "1928";
block_td_uid_18_60e6276495126.header_color = "";
block_td_uid_18_60e6276495126.ajax_pagination_infinite_stop = "";
block_td_uid_18_60e6276495126.max_num_pages = "386";
tdBlocksArray.push(block_td_uid_18_60e6276495126);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_18_60e6276495126_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_18_60e6276495126"><div id=td_uid_18_60e6276495126 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/07/downs-returned-to-school-board-president-post-but-board-fails-to-agree-on-vp/" rel="bookmark" class="td-image-wrap" title="Downs returned to school board president post, but board fails to agree on VP"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_Downs-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_Downs-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_Downs-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_Downs-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_Downs-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_Downs-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_Downs-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_Downs-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Downs returned to school board president post, but board fails to agree on VP" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/07/downs-returned-to-school-board-president-post-but-board-fails-to-agree-on-vp/" rel="bookmark" title="Downs returned to school board president post, but board fails to agree on VP">Downs returned to school board president post, but board fails to agree on VP</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/01/meet-and-greet-with-new-school-superintendent-set-for-tuesday-evening/" rel="bookmark" class="td-image-wrap" title="Meet and greet with new school superintendent set for Tuesday evening"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/04/2021_0427_Tornatore_Augustine-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/04/2021_0427_Tornatore_Augustine-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/04/2021_0427_Tornatore_Augustine-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/04/2021_0427_Tornatore_Augustine-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/04/2021_0427_Tornatore_Augustine-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/04/2021_0427_Tornatore_Augustine-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/04/2021_0427_Tornatore_Augustine-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/04/2021_0427_Tornatore_Augustine-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Meet and greet with new school superintendent set for Tuesday evening" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/01/meet-and-greet-with-new-school-superintendent-set-for-tuesday-evening/" rel="bookmark" title="Meet and greet with new school superintendent set for Tuesday evening">Meet and greet with new school superintendent set for Tuesday evening</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/26/congratulations-to-the-class-of-2021-an-inspiration-in-a-year-of-adversity/" rel="bookmark" class="td-image-wrap" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0625-RHS-graduation-cover-e1624729629492.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/26/congratulations-to-the-class-of-2021-an-inspiration-in-a-year-of-adversity/" rel="bookmark" title="Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity">Congratulations to the Class of 2021, &#8216;inspiration&#8217; in a year of adversity</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/21/riverhead-school-trustee-elect-is-first-democratic-socialist-party-member-to-win-elective-office-in-suffolk-county/" rel="bookmark" class="td-image-wrap" title="Riverhead school trustee-elect is first Democratic-Socialist member to win elective office in Suffolk County"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2021_0511_-Palmer.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead school trustee-elect is first Democratic-Socialist member to win elective office in Suffolk County" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/21/riverhead-school-trustee-elect-is-first-democratic-socialist-party-member-to-win-elective-office-in-suffolk-county/" rel="bookmark" title="Riverhead school trustee-elect is first Democratic-Socialist member to win elective office in Suffolk County">Riverhead school trustee-elect is first Democratic-Socialist member to win elective office in Suffolk County</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/19/celebrating-the-class-of-2021-with-a-parade/" rel="bookmark" class="td-image-wrap" title="Celebrating the Class of 2021 with a parade"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0618_RHS-senior-parade_01-1-e1624113569104.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0618_RHS-senior-parade_01-1-e1624113569104.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0618_RHS-senior-parade_01-1-e1624113569104.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Celebrating the Class of 2021 with a parade" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/19/celebrating-the-class-of-2021-with-a-parade/" rel="bookmark" title="Celebrating the Class of 2021 with a parade">Celebrating the Class of 2021 with a parade</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_18_60e6276495126" id="td_uid_19_60e62764a25a2" data-td_block_id="td_uid_18_60e6276495126" data-td_filter_value="" href="https://riverheadlocal.com/schools/">All</a><a class="mega-menu-sub-cat-td_uid_18_60e6276495126" id="td_uid_20_60e62764a2664" data-td_block_id="td_uid_18_60e6276495126" data-td_filter_value="187" href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a><a class="mega-menu-sub-cat-td_uid_18_60e6276495126" id="td_uid_21_60e62764a2714" data-td_block_id="td_uid_18_60e6276495126" data-td_filter_value="190" href="https://riverheadlocal.com/schools/mcgann-mercy-junior-senior-high-school/">McGann-Mercy Junior-Senior High School</a><a class="mega-menu-sub-cat-td_uid_18_60e6276495126" id="td_uid_22_60e62764a2819" data-td_block_id="td_uid_18_60e6276495126" data-td_filter_value="15377" href="https://riverheadlocal.com/schools/peconic-community-school/">Peconic Community School</a><a class="mega-menu-sub-cat-td_uid_18_60e6276495126" id="td_uid_23_60e62764a290d" data-td_block_id="td_uid_18_60e6276495126" data-td_filter_value="201" href="https://riverheadlocal.com/schools/riverhead-central-school-district/">Riverhead Central School District</a><a class="mega-menu-sub-cat-td_uid_18_60e6276495126" id="td_uid_24_60e62764a2a14" data-td_block_id="td_uid_18_60e6276495126" data-td_filter_value="199" href="https://riverheadlocal.com/schools/riverhead-central-school-district/aquebogue-elementary-school/">Aquebogue Elementary School</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_60e6276495126" data-td_block_id="td_uid_18_60e6276495126"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_18_60e6276495126" data-td_block_id="td_uid_18_60e6276495126"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-120667" class="tablet-hidden menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-120667"><a href="https://riverheadlocal.com/business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_25_60e62764d884b = new tdBlock();
block_td_uid_25_60e62764d884b.id = "td_uid_25_60e62764d884b";
block_td_uid_25_60e62764d884b.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"205","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_25_60e62764d884b_rand","tdc_css_class":"td_uid_25_60e62764d884b_rand","tdc_css_class_style":"td_uid_25_60e62764d884b_rand_style"}';
block_td_uid_25_60e62764d884b.td_column_number = "3";
block_td_uid_25_60e62764d884b.block_type = "td_block_mega_menu";
block_td_uid_25_60e62764d884b.post_count = "5";
block_td_uid_25_60e62764d884b.found_posts = "558";
block_td_uid_25_60e62764d884b.header_color = "";
block_td_uid_25_60e62764d884b.ajax_pagination_infinite_stop = "";
block_td_uid_25_60e62764d884b.max_num_pages = "112";
tdBlocksArray.push(block_td_uid_25_60e62764d884b);
</script><div class="td_block_wrap td_block_mega_menu td_uid_25_60e62764d884b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_25_60e62764d884b"><div id=td_uid_25_60e62764d884b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/06/all-vegan-brewery-ubergeek-enters-riverheads-tasting-room-scene-with-fresh-brews-and-fresh-ideas/" rel="bookmark" class="td-image-wrap" title="All-vegan brewery Übergeek enters Riverhead’s tasting room scene with fresh brews and fresh ideas"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_ubergeek-scaled.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_ubergeek-scaled.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_ubergeek-scaled.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_ubergeek-scaled.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_ubergeek-scaled.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_ubergeek-scaled.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_ubergeek-scaled.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0706_ubergeek-scaled.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="All-vegan brewery Übergeek enters Riverhead’s tasting room scene with fresh brews and fresh ideas" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/06/all-vegan-brewery-ubergeek-enters-riverheads-tasting-room-scene-with-fresh-brews-and-fresh-ideas/" rel="bookmark" title="All-vegan brewery Übergeek enters Riverhead’s tasting room scene with fresh brews and fresh ideas">All-vegan brewery Übergeek enters Riverhead’s tasting room scene with fresh brews and fresh ideas</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/02/perabell-food-bar-closes-riverhead-location/" rel="bookmark" class="td-image-wrap" title="PeraBell Food Bar closes Riverhead location"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/2021_0702_PeraBell-closed-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="PeraBell Food Bar closes Riverhead location" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/02/perabell-food-bar-closes-riverhead-location/" rel="bookmark" title="PeraBell Food Bar closes Riverhead location">PeraBell Food Bar closes Riverhead location</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/02/outdoor-dining-to-continue-in-downtown-riverhead-this-summer/" rel="bookmark" class="td-image-wrap" title="Outdoor dining to continue in downtown Riverhead this summer"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/2020_0603_outdoor_dining.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Outdoor dining to continue in downtown Riverhead this summer" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/02/outdoor-dining-to-continue-in-downtown-riverhead-this-summer/" rel="bookmark" title="Outdoor dining to continue in downtown Riverhead this summer">Outdoor dining to continue in downtown Riverhead this summer</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/30/lidl-opens-its-doors-in-riverhead-with-music-giveaways-and-a-grand-opening-celebration/" rel="bookmark" class="td-image-wrap" title="Lidl opens its doors in Riverhead with music, giveaways and a grand-opening celebration"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_Lidl-ribbon-cutting-.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_Lidl-ribbon-cutting-.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_Lidl-ribbon-cutting-.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_Lidl-ribbon-cutting-.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_Lidl-ribbon-cutting-.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_Lidl-ribbon-cutting-.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_Lidl-ribbon-cutting-.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0630_Lidl-ribbon-cutting-.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Lidl opens its doors in Riverhead with music, giveaways and a grand-opening celebration" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/30/lidl-opens-its-doors-in-riverhead-with-music-giveaways-and-a-grand-opening-celebration/" rel="bookmark" title="Lidl opens its doors in Riverhead with music, giveaways and a grand-opening celebration">Lidl opens its doors in Riverhead with music, giveaways and a grand-opening celebration</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/27/deep-discount-german-grocer-lidl-readies-for-june-30-grand-opening-in-riverhead/" rel="bookmark" class="td-image-wrap" title="Deep-discount German grocer Lidl readies for June 30 grand opening in Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0627-Lidl-Riverhead-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Deep-discount German grocer Lidl readies for June 30 grand opening in Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/27/deep-discount-german-grocer-lidl-readies-for-june-30-grand-opening-in-riverhead/" rel="bookmark" title="Deep-discount German grocer Lidl readies for June 30 grand opening in Riverhead">Deep-discount German grocer Lidl readies for June 30 grand opening in Riverhead</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_60e62764d884b" data-td_block_id="td_uid_25_60e62764d884b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_25_60e62764d884b" data-td_block_id="td_uid_25_60e62764d884b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100676" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100676"><a href="https://riverheadlocal.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_26_60e62764df84f = new tdBlock();
block_td_uid_26_60e62764df84f.id = "td_uid_26_60e62764df84f";
block_td_uid_26_60e62764df84f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"81","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_26_60e62764df84f_rand","tdc_css_class":"td_uid_26_60e62764df84f_rand","tdc_css_class_style":"td_uid_26_60e62764df84f_rand_style"}';
block_td_uid_26_60e62764df84f.td_column_number = "3";
block_td_uid_26_60e62764df84f.block_type = "td_block_mega_menu";
block_td_uid_26_60e62764df84f.post_count = "5";
block_td_uid_26_60e62764df84f.found_posts = "977";
block_td_uid_26_60e62764df84f.header_color = "";
block_td_uid_26_60e62764df84f.ajax_pagination_infinite_stop = "";
block_td_uid_26_60e62764df84f.max_num_pages = "196";
tdBlocksArray.push(block_td_uid_26_60e62764df84f);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_26_60e62764df84f_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_26_60e62764df84f"><div id=td_uid_26_60e62764df84f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/21/riverhead-must-address-its-litter-problem/" rel="bookmark" class="td-image-wrap" title="Riverhead must address its litter problem"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead must address its litter problem" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/21/riverhead-must-address-its-litter-problem/" rel="bookmark" title="Riverhead must address its litter problem">Riverhead must address its litter problem</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/21/constituent-responds-to-zeldin-newsletter/" rel="bookmark" class="td-image-wrap" title="Constituent responds to Zeldin newsletter"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Constituent responds to Zeldin newsletter" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/21/constituent-responds-to-zeldin-newsletter/" rel="bookmark" title="Constituent responds to Zeldin newsletter">Constituent responds to Zeldin newsletter</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/20/a-fathers-day-reflection-on-fatherhood/" rel="bookmark" class="td-image-wrap" title="A Father&#8217;s Day reflection on fatherhood"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0620_Fathers-Day_Greg-Blass-1.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="A Father&#8217;s Day reflection on fatherhood" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/20/a-fathers-day-reflection-on-fatherhood/" rel="bookmark" title="A Father&#8217;s Day reflection on fatherhood">A Father&#8217;s Day reflection on fatherhood</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/02/we-can-all-take-steps-to-help-protect-wildlife/" rel="bookmark" class="td-image-wrap" title="We can all take steps to help protect wildlife"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021_0602_deer-in-net.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="We can all take steps to help protect wildlife" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/02/we-can-all-take-steps-to-help-protect-wildlife/" rel="bookmark" title="We can all take steps to help protect wildlife">We can all take steps to help protect wildlife</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/05/28/we-must-never-forget-what-happened-to-michael-and-why/" rel="bookmark" class="td-image-wrap" title="We must never forget what happened to Michael — and why"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2021/05/2011_0529_Hubbard.png?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="We must never forget what happened to Michael — and why" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/05/28/we-must-never-forget-what-happened-to-michael-and-why/" rel="bookmark" title="We must never forget what happened to Michael — and why">We must never forget what happened to Michael — and why</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_26_60e62764df84f" id="td_uid_27_60e62764e3edc" data-td_block_id="td_uid_26_60e62764df84f" data-td_filter_value="" href="https://riverheadlocal.com/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_26_60e62764df84f" id="td_uid_28_60e62764e3f80" data-td_block_id="td_uid_26_60e62764df84f" data-td_filter_value="91" href="https://riverheadlocal.com/opinion/civiletti/">Denise Civiletti</a><a class="mega-menu-sub-cat-td_uid_26_60e62764df84f" id="td_uid_29_60e62764e4035" data-td_block_id="td_uid_26_60e62764df84f" data-td_filter_value="12894" href="https://riverheadlocal.com/opinion/greg-blass/">Greg Blass</a><a class="mega-menu-sub-cat-td_uid_26_60e62764df84f" id="td_uid_30_60e62764e40db" data-td_block_id="td_uid_26_60e62764df84f" data-td_filter_value="99" href="https://riverheadlocal.com/opinion/in-my-opinion/">In My Opinion</a><a class="mega-menu-sub-cat-td_uid_26_60e62764df84f" id="td_uid_31_60e62764e417a" data-td_block_id="td_uid_26_60e62764df84f" data-td_filter_value="98" href="https://riverheadlocal.com/opinion/java-scripts/">Java Scripts</a><a class="mega-menu-sub-cat-td_uid_26_60e62764df84f" id="td_uid_32_60e62764e428c" data-td_block_id="td_uid_26_60e62764df84f" data-td_filter_value="16086" href="https://riverheadlocal.com/opinion/katie-blasl/">Katie Blasl</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_26_60e62764df84f" data-td_block_id="td_uid_26_60e62764df84f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_26_60e62764df84f" data-td_block_id="td_uid_26_60e62764df84f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100677" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100677"><a href="https://riverheadlocal.com/living/">Living</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_33_60e6276520947 = new tdBlock();
block_td_uid_33_60e6276520947.id = "td_uid_33_60e6276520947";
block_td_uid_33_60e6276520947.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9530","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_33_60e6276520947_rand","tdc_css_class":"td_uid_33_60e6276520947_rand","tdc_css_class_style":"td_uid_33_60e6276520947_rand_style"}';
block_td_uid_33_60e6276520947.td_column_number = "3";
block_td_uid_33_60e6276520947.block_type = "td_block_mega_menu";
block_td_uid_33_60e6276520947.post_count = "5";
block_td_uid_33_60e6276520947.found_posts = "3444";
block_td_uid_33_60e6276520947.header_color = "";
block_td_uid_33_60e6276520947.ajax_pagination_infinite_stop = "";
block_td_uid_33_60e6276520947.max_num_pages = "689";
tdBlocksArray.push(block_td_uid_33_60e6276520947);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_33_60e6276520947_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_33_60e6276520947"><div id=td_uid_33_60e6276520947 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/04/141086/" rel="bookmark" class="td-image-wrap" title=""><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?w=640&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/04/141086/" rel="bookmark" title=""></a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/07/04/an-independence-day-reflection-on-the-many-different-meanings-of-independence/" rel="bookmark" class="td-image-wrap" title="An Independence Day reflection on the many different meanings of &#8216;independence&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/2019_0217_LOP_Jo_working.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/2019_0217_LOP_Jo_working.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/2019_0217_LOP_Jo_working.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/2019_0217_LOP_Jo_working.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/2019_0217_LOP_Jo_working.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/2019_0217_LOP_Jo_working.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/2019_0217_LOP_Jo_working.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="An Independence Day reflection on the many different meanings of &#8216;independence&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/07/04/an-independence-day-reflection-on-the-many-different-meanings-of-independence/" rel="bookmark" title="An Independence Day reflection on the many different meanings of &#8216;independence&#8217;">An Independence Day reflection on the many different meanings of &#8216;independence&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/20/140802/" rel="bookmark" class="td-image-wrap" title=""><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?w=640&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/20/140802/" rel="bookmark" title=""></a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/20/you-can-decide-to-be-happy/" rel="bookmark" class="td-image-wrap" title="You can decide to be happy"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/11/2017_1112_woman_beach.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="You can decide to be happy" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/20/you-can-decide-to-be-happy/" rel="bookmark" title="You can decide to be happy">You can decide to be happy</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2021/06/12/its-time-to-recalibrate-normal/" rel="bookmark" class="td-image-wrap" title="It&#8217;s time to recalibrate &#8216;normal&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2021/06/2021-0612-woman-with-camera-no-mask.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="It&#8217;s time to recalibrate &#8216;normal&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2021/06/12/its-time-to-recalibrate-normal/" rel="bookmark" title="It&#8217;s time to recalibrate &#8216;normal&#8217;">It&#8217;s time to recalibrate &#8216;normal&#8217;</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_33_60e6276520947" id="td_uid_34_60e6276527901" data-td_block_id="td_uid_33_60e6276520947" data-td_filter_value="" href="https://riverheadlocal.com/living/">All</a><a class="mega-menu-sub-cat-td_uid_33_60e6276520947" id="td_uid_35_60e6276527981" data-td_block_id="td_uid_33_60e6276520947" data-td_filter_value="100" href="https://riverheadlocal.com/living/bits-and-pieces/">Bits and Pieces</a><a class="mega-menu-sub-cat-td_uid_33_60e6276520947" id="td_uid_36_60e62765279eb" data-td_block_id="td_uid_33_60e6276520947" data-td_filter_value="94" href="https://riverheadlocal.com/living/laurie-nigro/">Laurie Nigro</a><a class="mega-menu-sub-cat-td_uid_33_60e6276520947" id="td_uid_37_60e6276527a9e" data-td_block_id="td_uid_33_60e6276520947" data-td_filter_value="38" href="https://riverheadlocal.com/living/life-on-purpose/">Life On Purpose</a><a class="mega-menu-sub-cat-td_uid_33_60e6276520947" id="td_uid_38_60e6276527b11" data-td_block_id="td_uid_33_60e6276520947" data-td_filter_value="119" href="https://riverheadlocal.com/living/town-crier/">Town Crier</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_33_60e6276520947" data-td_block_id="td_uid_33_60e6276520947"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_33_60e6276520947" data-td_block_id="td_uid_33_60e6276520947"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-76334" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76334"><a target="_blank" href="http://eastendlocal.com/events">Events</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
<div class="breaking-menu-wrap">
<div class="menu-coronavirus-container"><ul id="menu-coronavirus" class="breaking-menu sf-menu"><li id="menu-item-134795" class="breaking-main menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-134795"><a href="https://riverheadlocal.com/coronavirus/">Coronavirus</a></li>
<li id="menu-item-134924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-134924"><a href="https://riverheadlocal.com/coronavirus/#latest-news">Latest updates</a></li>
<li id="menu-item-134797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134797"><a href="https://riverheadlocal.com/coronavirus/">Maps &#038; charts</a></li>
<li id="menu-item-139226" class="menu-item menu-item-type-post_type menu-item-object-post td-menu-item td-normal-menu menu-item-139226"><a href="https://riverheadlocal.com/2021/03/13/covid-19-vaccinations-who-is-eligible-and-how-to-get-one/">Vaccines</a></li>
</ul></div> </div>
</div>
</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap broadstreet banner ">
<div class="kb-header-ad"><span class="text"></span> <div class="textwidget"><broadstreet-zone zone-id="68458" count="1"></broadstreet-zone></div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-container td-post-template-3">
<div class="td-container-border">
<article id="post-141132" class="post-141132 post type-post status-publish format-standard has-post-thumbnail hentry category-weather tag-featured tag-tropical-storm tag-tropical-storm-elsa author-katie-morosky" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header td-pb-padding-side">
<ul class="td-category"><li class="entry-category"><a href="https://riverheadlocal.com/weather/">Weather</a></li></ul>
<header>
<h1 class="entry-title">Tropical storm watch issued for most of Long Island ahead of Elsa&#8217;s arrival Friday</h1>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://riverheadlocal.com/author/katie-blasl/" title="Posts by Katie Morosky" class="author url fn" rel="author">Katie Morosky</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2021-07-07T18:14:26+00:00">Jul 7, 2021, 6:14 pm</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-featured-image"><figure><a href="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?fit=1744%2C1406&quality=100&ssl=1" data-caption="Source: National Hurricane Center"><img width="681" height="549" class="entry-thumb td-modal-image" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?resize=681%2C549&quality=100&ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?w=1744&quality=100&ssl=1 1744w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?resize=270%2C218&quality=100&ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?resize=1024%2C826&quality=100&ssl=1 1024w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?resize=768%2C619&quality=100&ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?resize=1536%2C1238&quality=100&ssl=1 1536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?resize=521%2C420&quality=100&ssl=1 521w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?resize=640%2C516&quality=100&ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?resize=681%2C549&quality=100&ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?w=1280&quality=100&ssl=1 1280w" sizes="(max-width: 681px) 100vw, 681px" alt="" title="Screen Shot 2021-07-07 at 17.19.11" /></a><figcaption class="wp-caption-text">Source: National Hurricane Center</figcaption></figure></div>
<div class="td-post-content td-pb-padding-side">
<p>The National Weather Service has issued a tropical storm watch for most of Long Island ahead of Tropical Storm Elsa&#8217;s arrival in the region Friday morning.
<p>A tropical storm watch means that tropical storm-force conditions are possible in the next 48 hours. A tropical storm is a tropical cyclone that has maximum sustained winds between 39 and 73 miles per hour.<broadstreet-zone alt-zone-id="68459" class="mobile-ad" count="1"></broadstreet-zone>
<p>Following the storm&#8217;s landfall in Florida this morning, Elsa is next expected to move up the coast and into our area Friday. Flooding rain and high winds from the storm could impact Long Island from early Friday morning to late Friday afternoon.
<p>All of Long Island except for northwestern Nassau County is currently under the tropical storm watch.
<p>The highest risk of sustained tropical storm force winds will be along the south shore, according to the National Weather Service, though the possibility exists for all areas within the tropical storm watch. The storm could also bring flooding rain, with totals between one and three inches currently forecast and locally higher amounts possible.<broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<p>Storm surge is not expected to be an issue with this storm, with little to no threat of storm surge flooding in the forecast.
<broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone><div class="kb-member-content-box"><p><strong><span style="font-size:20px; line-height: 40px;">Support local journalism.</span></strong><br />Now more than ever, the survival of quality local journalism depends on your support. Our community faces unprecedented economic disruption, and the future of many small businesses are under threat, including our own. It takes time and resources to provide this service. We are a small family-owned operation, and we will do everything in our power to keep it going. But today more than ever before, we will depend on your support to continue. <strong><a href="/support-local-journalism">Support RiverheadLOCAL today.</a></strong> You rely on us to stay informed and we depend on you to make our work possible.</p></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
</div> </div>
<footer>
<div class="td-post-source-tags td-pb-padding-side">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://riverheadlocal.com/topic/featured/">featured</a></li><li><a href="https://riverheadlocal.com/topic/tropical-storm/">tropical storm</a></li><li><a href="https://riverheadlocal.com/topic/tropical-storm-elsa/">Tropical Storm Elsa</a></li></ul> </div>
<div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-twitter" style="overflow: visible;"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/" data-text="Tropical storm watch issued for most of Long Island ahead of Elsa&#8217;s arrival Friday" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li class="td-classic-facebook" style="overflow: visible;"><div class="fb-like" data-href="https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/" data-layout="button_count" data-action="like" data-show-faces="false"></div></li></ul></div></div> <div class="author-box-wrap"><a href="https://riverheadlocal.com/author/katie-blasl/"><img src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/IMG_1879_Facetune_28-08-2019-15-44-58.jpeg?fit=96%2C88&quality=100&ssl=1" width="96" height="88" alt="Katie Morosky" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://riverheadlocal.com/author/katie-blasl/">Katie Morosky</a></span></div><div class="td-author-description">Katie, winner of the 2016 James Murphy Cub Reporter of the Year award from the L.I. Press Club, is a co-publisher of RiverheadLOCAL. A Riverhead native, she is a 2014 graduate of Stony Brook University.
<a href="/cdn-cgi/l/email-protection#a6cdc7d2cfc3e6d4cfd0c3d4cec3c7c2cac9c5c7ca88c5c9cb">Email Katie</a></div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/katiemorosky" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Katie Morosky"></span><meta itemprop="datePublished" content="2021-07-07T18:14:26+00:00"><meta itemprop="dateModified" content="2021-07-07T18:14:57-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png"></span><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="headline " content="Tropical storm watch issued for most of Long Island ahead of Elsa&#039;s arrival Friday"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2021/07/Screen-Shot-2021-07-07-at-17.19.11.png?fit=1744%2C1406&quality=100&ssl=1"><meta itemprop="width" content="1744"><meta itemprop="height" content="1406"></span> </footer>
<div class="fb-comments" data-href="https://riverheadlocal.com/2021/07/07/tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday/" data-width="100%" data-mobile="true" data-numposts="10" data-order-by="social" data-colorscheme="light"></div> </div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><broadstreet-zone zone-id="68498" count="1"></broadstreet-zone><br />
<broadstreet-zone zone-id="68459" count="1"></broadstreet-zone></p>
<div class="kb-popout-content td-pb-row">
<div class="wpb_wrapper">
<div class="wpb_text_column block-header">
<p>Daily Newsletter</p>
</div>
<div class="wpb_wrapper wpb_text_column td-pb-border-top">
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://riverheadlocal.us6.list-manage.com/subscribe/post?u=47e88a318d72559c43e4b77bc&amp;id=8118172d70" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div class="mc-field-group first-name"><label for="mce-FNAME">First Name </label><br />
<input id="mce-FNAME" class="required" name="FNAME" type="text" value="" /></div>
<div class="mc-field-group last-name"><label for="mce-LNAME">Last Name </label><br />
<input id="mce-LNAME" class="required" name="LNAME" type="text" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_47e88a318d72559c43e4b77bc_8118172d70" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p></p>
</div>
</div>
</div>
<div class="broadstreet"><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68461" count="1"></broadstreet-zone></div>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div>
</div> 


<div class="td-footer-container td-container td-footer-template-10">
<div class="footer-social-wrap td-social-style2 td-footer-full">
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer1-container"><ul id="menu-footer1" class="td-subfooter-menu"><li id="menu-item-132941" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-132941"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-132940" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132940"><a href="https://riverheadlocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-132944" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132944"><a href="https://riverheadlocal.com/comments-policy/">Comments Policy</a></li>
<li id="menu-item-132945" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132945"><a href="https://riverheadlocal.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-138664" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-138664"><a href="https://riverheadlocal.com/correction-policy/">Correction Policy</a></li>
</ul></div> </div>
</div>
<div class="td-pb-span4 td-sub-footer-copy">
 <div class="td-pb-padding-side">
&copy; <a href="https://riverheadlocal.com/copyright-notice/">2010-2021 East End Local Media Corp</a> </div>
</div>
</div>
</div>
</div>
</div>
<div class="a2a_kit a2a_kit_size_36 a2a_floating_style a2a_vertical_style" style="left:0px;top:400px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;left:5px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2021%2F07%2F07%2Ftropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday%2F&amp;linkname=Tropical%20storm%20watch%20issued%20for%20most%20of%20Long%20Island%20ahead%20of%20Elsa%26%23039%3Bs%20arrival%20Friday%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><a rel="nofollow" style="display:none;" href="https://riverheadlocal.com/?blackhole=58166ade11" title="Do NOT follow this link or you will be banned from the site!">RiverheadLOCAL</a>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','weather','tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["weather","tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday","post"],"url":"tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({"useAltZone":767,"altZoneWhitelist":[71281],"networkId":"4821","targets":{"pagetype":["post","not_home_page"],"category":["weather","tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday","post"],"url":"tropical-storm-watch-issued-for-most-of-long-island-ahead-of-elsas-arrival-friday"}});
 });</script>

<script type="text/javascript">(function($) {
  $.fn.almComplete = function(alm){
    
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");


      

    var $pageNumber;
    if ($('.kb-alm-wrap-page-3').length) {
        $pageNumber = 3; 
       // console.log("We're on page 3");
    } else if ($('.kb-alm-wrap-page-2').length) {
        $pageNumber = 2;
        // console.log("We're on page 2");
    } else {
        $pageNumber = 1;
        // console.log("We're on page 1");
    }
    
    // Parse FB comments code
    
    var $newContainerString = '.alm-page-' + $pageNumber;
    var $newContainer = $($newContainerString).parent();

    FB.XFBML.parse($newContainer[0]);
    
    // Append alm button to wrapper
    
    var $new_name = '.kb-alm-wrap-page-' + $pageNumber;
    // $('.alm-btn-wrap').detach();
    // $('.alm-btn-wrap').appendTo($new_name);
  
    // console.log("Button moved!");
    
    for ( var i = 0; i < tdSmartSidebar.items.length; i++ ) {
                    if ( 'case_3_bottom_of_content' === tdSmartSidebar.items[ i ].sidebar_state ) {
                        tdSmartSidebar.items[ i ].sidebar_state = 'case_1_fixed_down';
                       //  console.log("fixed down!");
                    }
                }
                
    var base_url = "https://riverheadlocal.com";
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.js" );
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js" );
//    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/jquery-3.1.1.min.js" );

   // console.log("Alm complte!");
   var jigs = jQuery('.justified-image-grid');
    if(jigs.length !== 0){
       jigs.data('justifiedImageGrid').createGallery('resize');
    }
  };
})(jQuery);

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");
    
 /*  $( 'body' ).on( 'post-load', function() {
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      } ); 
    // type = From which addon (previous-post | seo)
    // permalink = the updated url
    console.log("URL updated to " + permalink + '- dispatched from the '+ type + ' add-on.'); */
  }; 
})(jQuery);

(function($) {
    $(window).load(function(){
  // $('.alm-btn-wrap').appendTo($('.kb-alm-wrap'));
   // console.log("Button moved!");
});
})(jQuery);</script> 
<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-aJ5TJKLfrG9cB",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-aJ5TJKLfrG9cB.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<link rel='stylesheet' id='photoswipe-style-css' href='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/css/photoswipe4.min.css?ver=4.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id='jquery-ui-mouse-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.12.1' id='jquery-ui-resizable-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.12.1' id='jquery-ui-draggable-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/controlgroup.min.js?ver=1.12.1' id='jquery-ui-controlgroup-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/checkboxradio.min.js?ver=1.12.1' id='jquery-ui-checkboxradio-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/button.min.js?ver=1.12.1' id='jquery-ui-button-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.12.1' id='jquery-ui-dialog-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/wpdialog.min.js?ver=5.7.1' id='wpdialogs-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/sticky-kit.js?ver=1.0.6' id='sticky_kit-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.3' id='td-site-min-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/photoswipe4.min.js?ver=4.1.3' id='photoswipe-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/jquery.dotdotdot.js?ver=3.0.3' id='dotdotdot-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js?ver=4.1.1' id='justified-image-grid-js'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.7.1' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210604' id='jetpack_related-posts-js'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://riverheadlocal.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script src='https://stats.wp.com/e-202127.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8.1',blog:'77146263',post:'141132',tz:'-4',srv:'riverheadlocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '77146263', '141132' ]);
</script>
</body>
</html>
