<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Riverhead school board to hold first in-person public meeting since COVID shutdown | RiverheadLOCAL</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="pingback" href="https://riverheadlocal.com/xmlrpc.php" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<meta property="og:image" content="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?fit=800%2C479&quality=100&ssl=1" /><link rel="icon" type="image/png" href="https://riverheadlocal.com/wp-content/uploads/2017/04/favicon.png">

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Riverhead school board to hold first in-person public meeting since COVID shutdown | RiverheadLOCAL" />
<meta property="og:description" content="The Riverhead school board will meet in person and allow public attendance at its meeting for the first time since the coronavirus pandemic surged in New York and the governor implemented shutdown measures in March." />
<meta property="og:url" content="https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/" />
<meta property="og:site_name" content="RiverheadLOCAL" />
<meta property="article:tag" content="Coronavirus" />
<meta property="article:tag" content="featured" />
<meta property="article:tag" content="Riverhead school board" />
<meta property="article:section" content="Board of Education" />
<meta property="article:published_time" content="2020-10-12T11:36:23+00:00" />
<meta property="article:modified_time" content="2020-10-12T12:47:26+00:00" />
<meta property="og:updated_time" content="2020-10-12T12:47:26+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The Riverhead school board will meet in person and allow public attendance at its meeting for the first time since the coronavirus pandemic surged in New York and the governor implemented shutdown measures in March." />
<meta name="twitter:title" content="Riverhead school board to hold first in-person public meeting since COVID shutdown | RiverheadLOCAL" />
<meta name="twitter:image" content="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?fit=800%2C479&#038;quality=100&#038;ssl=1" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://riverheadlocal.com/#website","url":"https://riverheadlocal.com/","name":"RiverheadLOCAL","inLanguage":"en-US","description":"News and events for Riverhead, New York","potentialAction":[{"@type":"SearchAction","target":"https://riverheadlocal.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?fit=800%2C479&quality=100&ssl=1","width":800,"height":479},{"@type":"WebPage","@id":"https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/#webpage","url":"https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/","name":"Riverhead school board to hold first in-person public meeting since COVID shutdown | RiverheadLOCAL","isPartOf":{"@id":"https://riverheadlocal.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/#primaryimage"},"datePublished":"2020-10-12T11:36:23+00:00","dateModified":"2020-10-12T12:47:26+00:00","author":{"@id":"https://riverheadlocal.com/#/schema/person/d176783e504eaed24b0e395623cb4932"},"potentialAction":[{"@type":"ReadAction","target":["https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/"]}]},{"@type":["Person"],"@id":"https://riverheadlocal.com/#/schema/person/d176783e504eaed24b0e395623cb4932","name":"RiverheadLOCAL","image":{"@type":"ImageObject","@id":"https://riverheadlocal.com/#authorlogo","inLanguage":"en-US","url":"https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/Local_Black_Flat_130.png?fit=96%2C34&quality=100&ssl=1","caption":"RiverheadLOCAL"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Feed" href="https://riverheadlocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Comments Feed" href="https://riverheadlocal.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='kb-membership-style-css' href='https://riverheadlocal.com/wp-content/plugins/kb-membership/inc/style.css?ver=6.1.991' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://riverheadlocal.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='https://riverheadlocal.com/wp-includes/css/jquery-ui-dialog.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://riverheadlocal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fc-form-css-css' href='https://riverheadlocal.com/wp-content/plugins/Formcraft/assets/css/form.min.css?ver=3.2.27' type='text/css' media='all' />
<link rel='stylesheet' id='kb-liveblog-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-liveblog/style.css?ver=6.0.200' type='text/css' media='all' />
<link rel='stylesheet' id='public_notices_css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-public-notices/kb-public-notices.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-top-stories-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-top-stories/style.css?ver=1.1.735' type='text/css' media='all' />
<link rel='stylesheet' id='trans-frontend-css' href='https://riverheadlocal.com/wp-content/plugins/kb-translation/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-min-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/icons/css/weather-icons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-wind-min-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/icons/css/weather-icons-wind.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-weather-css-css' href='https://riverheadlocal.com/wp-content/plugins/kb-weather/css/kb-weather.css?ver=1.7.434' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://riverheadlocal.com/wp-content/themes/Newsmag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css?ver=5.0.0219' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C100%2C100italic%2C200%2C200italic%2C300italic%2C400italic%2C500%2C500italic%2C600italic%2C700italic%2C800%2C800italic%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C100%2C100italic%2C200%2C200italic%2C500%2C500italic%2C600%2C600italic%2C800%2C800italic&#038;ver=4.3&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css' href='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css' href='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css' href='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://riverheadlocal.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1125px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1124px){
.a2a_floating_style.a2a_default_style{display:none;}
}
.a2a_floating_style {
    padding: 20px;
    border-radius: 0;
    border: 1px solid #bbbbbb;
}
</style>
<link rel='stylesheet' id='js_composer_front-css' href='https://riverheadlocal.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://riverheadlocal.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-membership/inc/button.js?ver=6.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-liveblog/scripts.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-weather/js/modernizr.custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/kb-weather/js/summary-box.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.25'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/common-scripts.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/popup-menu-fix.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://riverheadlocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverheadlocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverheadlocal.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://riverheadlocal.com/?p=137500' />
<link rel="alternate" type="application/json+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color = "#A0A0A0";

a2a_config.templates = {
    email: {
        subject: "RiverheadLOCAL: ${title}",
        body: "Check out this story on RiverheadLOCAL: \n${title}\n${link}"
    }
};

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      }; 
})(jQuery);
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>


<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Riverhead school board to hold first in-person public meeting since COVID shutdown | RiverheadLOCAL","pagePostType":"post","pagePostType2":"single-post","pageCategory":["board-of-education"],"pageAttributes":["coronavirus-outbreak-latest-news","featured","riverhead-school-board"],"pagePostAuthor":"RiverheadLOCAL","pagePostDate":"Oct 12, 2020, 7:36 am","pagePostDateYear":"2020","pagePostDateMonth":"10","pagePostDateDay":"12"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N97RFZC');//]]>
</script>


<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<script src="https://use.fontawesome.com/b3fb28acc8.js"></script><meta property="fb:app_id" content="105130769527571" /><meta name="google-site-verification" content="7jViI0XrkgkIYGyQD0GNoWcify30WyzN3o4ZHzUGfdo" /><script data-ad-client="ca-pub-6009741394491678" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var adSlotLeaderboard = googletag.defineSlot('/21874054635/Sitewide', [728, 90], 'div-gpt-ad-leaderboard');
    adSlotLeaderboard.addService(googletag.pubads());
    adSlotLeaderboard.setTargeting('position', ['leaderboard']);
    var adSlotSidebar1= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-1');
	    adSlotSidebar1.addService(googletag.pubads());
	    adSlotSidebar1.setTargeting('position', ['sidebar']);
	    var adSlotSidebar2= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-2');
	    adSlotSidebar2.addService(googletag.pubads());
	    adSlotSidebar2.setTargeting('position', ['sidebar']);
	    var adSlotSidebar3= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-3');
	    adSlotSidebar3.addService(googletag.pubads());
	    adSlotSidebar3.setTargeting('position', ['sidebar']);
	    var adSlotSidebar4= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-4');
	    adSlotSidebar4.addService(googletag.pubads());
	    adSlotSidebar4.setTargeting('position', ['sidebar']);
	    var adSlotSidebar5= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-5');
	    adSlotSidebar5.addService(googletag.pubads());
	    adSlotSidebar5.setTargeting('position', ['sidebar']);
	    var adSlotSidebar = googletag.defineSlot('/21874054635/Sitewide', ['fluid'], 'div-gpt-ad-lead-sidebar');
    adSlotSidebar.addService(googletag.pubads());
    adSlotSidebar.setTargeting('position', ['lead-sidebar']);
    
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://riverheadlocal.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '82fba20f-da37-4c38-a7fe-ee7dbe081e0f';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://riverheadlocal.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.370dd028-ab8a-4720-9087-4e2c917686de";
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_ajax_url="https:\/\/riverheadlocal.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=4.3";
var td_get_template_directory_uri="https:\/\/riverheadlocal.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e12025";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=32%2C32&#038;quality=100&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>
<body class="post-template-default single single-post postid-137500 single-format-standard author-riverheadlocal riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown global-block-template-1 white-menu wpb-js-composer js-comp-ver-6.1 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N97RFZC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '105130769527571',
      xfbml      : true,
      version    : 'v2.9'
    });
    FB.AppEvents.logPageView();
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div class="td-mobile-container">

<div class="kb-menu-socials-wrap">

<div class="kb-menu-socials">
</div>
</div>

<div class="kb-mobile-search-container"><form method="get" class="td-search-form-widget" action="https://riverheadlocal.com/">
<div role="search" class="kb-mobile-search">
<button class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit"><i class="td-icon-search"></i></button>
<div class="kb-search-input-wrap"><input class="td-widget-search-input" type="text" value="Search" name="s" id="s" onfocus="if (this.value=='Search') this.value='';" onblur="if (this.value=='') this.value='Search';" /></div>
</div>
</form>
</div>

<div class="td-mobile-content">
<div class="menu-mobile-container"><ul id="menu-mobile" class="td-mobile-main-menu"><li id="menu-item-116721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-116721"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100685" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100685"><a href="https://riverheadlocal.com/news/">News</a></li>
<li id="menu-item-100683" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100683"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a></li>
<li id="menu-item-100686" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100686"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100687" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100687"><a href="https://riverheadlocal.com/community/">Community</a></li>
<li id="menu-item-100693" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-100693"><a href="http://eastendlocal.com">Events</a></li>
<li id="menu-item-100688" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-100688"><a href="https://riverheadlocal.com/schools/">Schools</a></li>
<li id="menu-item-100684" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100684"><a href="https://riverheadlocal.com/business/business-news/">Business</a></li>
<li id="menu-item-100691" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100691"><a href="https://riverheadlocal.com/living/">Living</a></li>
<li id="menu-item-100692" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100692"><a href="https://riverheadlocal.com/opinion/">Opinion</a></li>
<li id="menu-item-100694" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100694"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-108418" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108418"><a href="https://classifieds.eastendlocal.com">Classifieds</a></li>
<li id="menu-item-136097" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-136097"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-100695" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-100695"><a href="https://riverheadlocal.com/contact/">Contact RiverheadLOCAL</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div id="kb-overlay"></div>
<div class="td-header-wrap td-header-style-3">
<div class="td-top-menu-full">
<div class="td-header-row td-header-top-menu td-make-full">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-100681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-100681"><a href="https://riverheadlocal.com/contact/">Contact</a></li>
<li id="menu-item-130976" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-130976"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-100680" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100680"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-24924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24924"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-116691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116691"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-24925" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24925"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/classifieds/">Classifieds</a></li>
<li id="menu-item-129406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129406"><a href="https://riverheadlocal.com/support-local-journalism/">Membership</a></li>
</ul></div></div> </div>

</div>
</div>

<div class="td-header-container">
<div class="td-header-logo-wrap">
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
<span class="td-visual-hidden">RiverheadLOCAL</span>
</a>
</div>
<div class="td-header-right-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-main-menu">
<div class="td-header-menu-wrap-sub">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-header-right-header mobile-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main" class="sf-menu"><li id="menu-item-100668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-100668"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100671" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100671"><a href="https://riverheadlocal.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_5f850515e3431 = new tdBlock();
block_td_uid_1_5f850515e3431.id = "td_uid_1_5f850515e3431";
block_td_uid_1_5f850515e3431.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"103","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5f850515e3431_rand","tdc_css_class":"td_uid_1_5f850515e3431_rand","tdc_css_class_style":"td_uid_1_5f850515e3431_rand_style"}';
block_td_uid_1_5f850515e3431.td_column_number = "3";
block_td_uid_1_5f850515e3431.block_type = "td_block_mega_menu";
block_td_uid_1_5f850515e3431.post_count = "5";
block_td_uid_1_5f850515e3431.found_posts = "6516";
block_td_uid_1_5f850515e3431.header_color = "";
block_td_uid_1_5f850515e3431.ajax_pagination_infinite_stop = "";
block_td_uid_1_5f850515e3431.max_num_pages = "1304";
tdBlocksArray.push(block_td_uid_1_5f850515e3431);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_1_5f850515e3431_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_5f850515e3431"><div id=td_uid_1_5f850515e3431 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/12/columbus-day-whats-closed-whats-open/" rel="bookmark" class="td-image-wrap" title="Columbus Day: what&#8217;s closed, what&#8217;s open"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1009_Columbus_Day.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1009_Columbus_Day.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1009_Columbus_Day.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1009_Columbus_Day.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1009_Columbus_Day.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1009_Columbus_Day.jpg?resize=511%2C384&#038;quality=100&#038;ssl=1 511w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1009_Columbus_Day.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Columbus Day: what&#8217;s closed, what&#8217;s open" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/12/columbus-day-whats-closed-whats-open/" rel="bookmark" title="Columbus Day: what&#8217;s closed, what&#8217;s open">Columbus Day: what&#8217;s closed, what&#8217;s open</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/11/riverhead-supervisor-extends-emergency-restrictions-through-oct-31/" rel="bookmark" class="td-image-wrap" title="Riverhead supervisor extends emergency restrictions through Oct. 31"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=1376%2C1028&#038;quality=100&#038;ssl=1 1376w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0911_Aguiar.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead supervisor extends emergency restrictions through Oct. 31" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/11/riverhead-supervisor-extends-emergency-restrictions-through-oct-31/" rel="bookmark" title="Riverhead supervisor extends emergency restrictions through Oct. 31">Riverhead supervisor extends emergency restrictions through Oct. 31</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/09/democrat-ahearn-holds-fundraising-edge-over-republican-palumbo-in-state-senate-race/" rel="bookmark" class="td-image-wrap" title="Democrat Ahearn holds fundraising edge over Republican Palumbo in State Senate race"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Ahearn_Palumbo.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Ahearn_Palumbo.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Ahearn_Palumbo.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Ahearn_Palumbo.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Ahearn_Palumbo.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Ahearn_Palumbo.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Ahearn_Palumbo.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Democrat Ahearn holds fundraising edge over Republican Palumbo in State Senate race" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/09/democrat-ahearn-holds-fundraising-edge-over-republican-palumbo-in-state-senate-race/" rel="bookmark" title="Democrat Ahearn holds fundraising edge over Republican Palumbo in State Senate race">Democrat Ahearn holds fundraising edge over Republican Palumbo in State Senate race</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/08/apartment-building-site-plan-approved-police-union-contracts-extended-town-board-wrap-up/" rel="bookmark" class="td-image-wrap" title="Apartment building site plan approved, police union contracts extended: town board wrap-up"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=632%2C470&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Apartment building site plan approved, police union contracts extended: town board wrap-up" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/08/apartment-building-site-plan-approved-police-union-contracts-extended-town-board-wrap-up/" rel="bookmark" title="Apartment building site plan approved, police union contracts extended: town board wrap-up">Apartment building site plan approved, police union contracts extended: town board wrap-up</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/07/town-board-and-highway-superintendent-spar-over-loose-leaf-pickup/" rel="bookmark" class="td-image-wrap" title="Town board and highway superintendent spar over loose leaf pickup"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2011_1128_leaf-pickup-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2011_1128_leaf-pickup-copy.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2011_1128_leaf-pickup-copy.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2011_1128_leaf-pickup-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2011_1128_leaf-pickup-copy.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2011_1128_leaf-pickup-copy.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2011_1128_leaf-pickup-copy.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Town board and highway superintendent spar over loose leaf pickup" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/07/town-board-and-highway-superintendent-spar-over-loose-leaf-pickup/" rel="bookmark" title="Town board and highway superintendent spar over loose leaf pickup">Town board and highway superintendent spar over loose leaf pickup</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_5f850515e3431" id="td_uid_2_5f850515e9be3" data-td_block_id="td_uid_1_5f850515e3431" data-td_filter_value="" href="https://riverheadlocal.com/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_5f850515e3431" id="td_uid_3_5f850515e9c8a" data-td_block_id="td_uid_1_5f850515e3431" data-td_filter_value="105" href="https://riverheadlocal.com/news/local-news/">Local News</a><a class="mega-menu-sub-cat-td_uid_1_5f850515e3431" id="td_uid_4_5f850515e9d1d" data-td_block_id="td_uid_1_5f850515e3431" data-td_filter_value="32" href="https://riverheadlocal.com/news/local-news/health/">Health</a><a class="mega-menu-sub-cat-td_uid_1_5f850515e3431" id="td_uid_5_5f850515e9dfc" data-td_block_id="td_uid_1_5f850515e3431" data-td_filter_value="16007" href="https://riverheadlocal.com/news/local-news/weekly-roundup/">Weekend Roundup</a><a class="mega-menu-sub-cat-td_uid_1_5f850515e3431" id="td_uid_6_5f850515e9eca" data-td_block_id="td_uid_1_5f850515e3431" data-td_filter_value="108" href="https://riverheadlocal.com/news/public-notices/">Public Notices</a><a class="mega-menu-sub-cat-td_uid_1_5f850515e3431" id="td_uid_7_5f850515e9f97" data-td_block_id="td_uid_1_5f850515e3431" data-td_filter_value="104" href="https://riverheadlocal.com/news/town-hall-notebook/">Town Hall Notebook</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5f850515e3431" data-td_block_id="td_uid_1_5f850515e3431"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5f850515e3431" data-td_block_id="td_uid_1_5f850515e3431"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100669" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100669"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_8_5f85051622bfc = new tdBlock();
block_td_uid_8_5f85051622bfc.id = "td_uid_8_5f85051622bfc";
block_td_uid_8_5f85051622bfc.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_8_5f85051622bfc_rand","tdc_css_class":"td_uid_8_5f85051622bfc_rand","tdc_css_class_style":"td_uid_8_5f85051622bfc_rand_style"}';
block_td_uid_8_5f85051622bfc.td_column_number = "3";
block_td_uid_8_5f85051622bfc.block_type = "td_block_mega_menu";
block_td_uid_8_5f85051622bfc.post_count = "5";
block_td_uid_8_5f85051622bfc.found_posts = "2461";
block_td_uid_8_5f85051622bfc.header_color = "";
block_td_uid_8_5f85051622bfc.ajax_pagination_infinite_stop = "";
block_td_uid_8_5f85051622bfc.max_num_pages = "493";
tdBlocksArray.push(block_td_uid_8_5f85051622bfc);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_8_5f85051622bfc_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_8_5f85051622bfc"><div id=td_uid_8_5f85051622bfc class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/10/cops-audi-convertible-swiped-from-pump-at-route-58-gas-station/" rel="bookmark" class="td-image-wrap" title="Cops: Audi convertible swiped from pump at Route 58 gas station"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2015_0322_police_lights.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Cops: Audi convertible swiped from pump at Route 58 gas station" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/10/cops-audi-convertible-swiped-from-pump-at-route-58-gas-station/" rel="bookmark" title="Cops: Audi convertible swiped from pump at Route 58 gas station">Cops: Audi convertible swiped from pump at Route 58 gas station</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/07/alleged-gang-member-gets-20-year-sentence-for-racketeering/" rel="bookmark" class="td-image-wrap" title="Alleged gang member gets 20-year sentence for racketeering"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=687%2C513&#038;quality=100&#038;ssl=1 687w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0226_US-Distirct-courthouse-central-islip-1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="federal-courthouse-central-islip" title="Alleged gang member gets 20-year sentence for racketeering" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/07/alleged-gang-member-gets-20-year-sentence-for-racketeering/" rel="bookmark" title="Alleged gang member gets 20-year sentence for racketeering">Alleged gang member gets 20-year sentence for racketeering</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/05/riverhead-police-report-august-2020/" rel="bookmark" class="td-image-wrap" title="Riverhead Police Report: August 2020"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/07/2019_0718_Rivrehead_Police_vehicle-1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead Police Report: August 2020" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/05/riverhead-police-report-august-2020/" rel="bookmark" title="Riverhead Police Report: August 2020">Riverhead Police Report: August 2020</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/05/riverhead-man-killed-in-three-car-crash-sunday/" rel="bookmark" class="td-image-wrap" title="Riverhead man killed in three-car crash Sunday"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?w=800&#038;quality=100&#038;ssl=1 800w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/03/2019_0315_Riverhead-police-vehicle-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead man killed in three-car crash Sunday" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/05/riverhead-man-killed-in-three-car-crash-sunday/" rel="bookmark" title="Riverhead man killed in three-car crash Sunday">Riverhead man killed in three-car crash Sunday</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/02/manorville-man-charged-with-murder/" rel="bookmark" class="td-image-wrap" title="Manorville man charged with murder"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=687%2C512&#038;quality=100&#038;ssl=1 687w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0731_dead-body-manorville-satellite.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Manorville man charged with murder" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/02/manorville-man-charged-with-murder/" rel="bookmark" title="Manorville man charged with murder">Manorville man charged with murder</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_8_5f85051622bfc" id="td_uid_9_5f850516269bf" data-td_block_id="td_uid_8_5f85051622bfc" data-td_filter_value="" href="https://riverheadlocal.com/police-fire/">All</a><a class="mega-menu-sub-cat-td_uid_8_5f85051622bfc" id="td_uid_10_5f85051626aae" data-td_block_id="td_uid_8_5f85051622bfc" data-td_filter_value="42" href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a><a class="mega-menu-sub-cat-td_uid_8_5f85051622bfc" id="td_uid_11_5f85051626b6c" data-td_block_id="td_uid_8_5f85051622bfc" data-td_filter_value="41" href="https://riverheadlocal.com/police-fire/police-blotter/">Police Reports</a><a class="mega-menu-sub-cat-td_uid_8_5f85051622bfc" id="td_uid_12_5f85051626c15" data-td_block_id="td_uid_8_5f85051622bfc" data-td_filter_value="43" href="https://riverheadlocal.com/police-fire/riverhead-justice-court/">Riverhead Justice Court</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_8_5f85051622bfc" data-td_block_id="td_uid_8_5f85051622bfc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_8_5f85051622bfc" data-td_block_id="td_uid_8_5f85051622bfc"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100672" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100672"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100673" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100673"><a href="https://riverheadlocal.com/community/">Community</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_13_5f8505163cd07 = new tdBlock();
block_td_uid_13_5f8505163cd07.id = "td_uid_13_5f8505163cd07";
block_td_uid_13_5f8505163cd07.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"113","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_5f8505163cd07_rand","tdc_css_class":"td_uid_13_5f8505163cd07_rand","tdc_css_class_style":"td_uid_13_5f8505163cd07_rand_style"}';
block_td_uid_13_5f8505163cd07.td_column_number = "3";
block_td_uid_13_5f8505163cd07.block_type = "td_block_mega_menu";
block_td_uid_13_5f8505163cd07.post_count = "5";
block_td_uid_13_5f8505163cd07.found_posts = "3919";
block_td_uid_13_5f8505163cd07.header_color = "";
block_td_uid_13_5f8505163cd07.ajax_pagination_infinite_stop = "";
block_td_uid_13_5f8505163cd07.max_num_pages = "784";
tdBlocksArray.push(block_td_uid_13_5f8505163cd07);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_13_5f8505163cd07_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_5f8505163cd07"><div id=td_uid_13_5f8505163cd07 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/09/popular-downtown-riverhead-halloween-events-canceled-due-to-covid-restrictions/" rel="bookmark" class="td-image-wrap" title="Popular Downtown Riverhead Halloween events canceled due to COVID restrictions"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1026_coffin_races_main-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Popular Downtown Riverhead Halloween events canceled due to COVID restrictions" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/09/popular-downtown-riverhead-halloween-events-canceled-due-to-covid-restrictions/" rel="bookmark" title="Popular Downtown Riverhead Halloween events canceled due to COVID restrictions">Popular Downtown Riverhead Halloween events canceled due to COVID restrictions</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/07/tanger-5k-to-benefit-north-fork-breast-health-coalition-goes-virtual/" rel="bookmark" class="td-image-wrap" title="Tanger 5K to benefit North Fork Breast Health Coalition goes virtual"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/09/2019_0922_NFBHC_Tanger_5K-9.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Tanger 5K to benefit North Fork Breast Health Coalition goes virtual" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/07/tanger-5k-to-benefit-north-fork-breast-health-coalition-goes-virtual/" rel="bookmark" title="Tanger 5K to benefit North Fork Breast Health Coalition goes virtual">Tanger 5K to benefit North Fork Breast Health Coalition goes virtual</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/05/gospel-road-ensemble-to-perform-in-rites-of-spring-music-festival-concert-at-hallockville-oct-10/" rel="bookmark" class="td-image-wrap" title="Gospel Road Ensemble to perform in Rites of Spring Music Festival concert at Hallockville Oct. 10"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?w=1000&#038;quality=100&#038;ssl=1 1000w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/gospel-road-picture_orig.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Gospel Road Ensemble to perform in Rites of Spring Music Festival concert at Hallockville Oct. 10" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/05/gospel-road-ensemble-to-perform-in-rites-of-spring-music-festival-concert-at-hallockville-oct-10/" rel="bookmark" title="Gospel Road Ensemble to perform in Rites of Spring Music Festival concert at Hallockville Oct. 10">Gospel Road Ensemble to perform in Rites of Spring Music Festival concert at Hallockville Oct. 10</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/05/haunted-hallway-display-at-suffolk-county-historical-society/" rel="bookmark" class="td-image-wrap" title="Haunted Hallway display at Suffolk County Historical Society"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/01/2016_0711_suffolk_county_historical_society-2.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Haunted Hallway display at Suffolk County Historical Society" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/05/haunted-hallway-display-at-suffolk-county-historical-society/" rel="bookmark" title="Haunted Hallway display at Suffolk County Historical Society">Haunted Hallway display at Suffolk County Historical Society</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/05/virtual-run-for-ridley-5k-to-be-held-during-october/" rel="bookmark" class="td-image-wrap" title="Virtual Run for Ridley 5K to be held during October"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/10/2016_1022_ridley_5K.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/10/2016_1022_ridley_5K.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2016/10/2016_1022_ridley_5K.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Virtual Run for Ridley 5K to be held during October" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/05/virtual-run-for-ridley-5k-to-be-held-during-october/" rel="bookmark" title="Virtual Run for Ridley 5K to be held during October">Virtual Run for Ridley 5K to be held during October</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_5f8505163cd07" id="td_uid_14_5f850516410e5" data-td_block_id="td_uid_13_5f8505163cd07" data-td_filter_value="" href="https://riverheadlocal.com/community/">All</a><a class="mega-menu-sub-cat-td_uid_13_5f8505163cd07" id="td_uid_15_5f85051641166" data-td_block_id="td_uid_13_5f8505163cd07" data-td_filter_value="128" href="https://riverheadlocal.com/community/announcements/">Announcements</a><a class="mega-menu-sub-cat-td_uid_13_5f8505163cd07" id="td_uid_16_5f850516411c7" data-td_block_id="td_uid_13_5f8505163cd07" data-td_filter_value="126" href="https://riverheadlocal.com/community/community-news/">Community News</a><a class="mega-menu-sub-cat-td_uid_13_5f8505163cd07" id="td_uid_17_5f85051641226" data-td_block_id="td_uid_13_5f8505163cd07" data-td_filter_value="127" href="https://riverheadlocal.com/community/event-photos/">Event Photos</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_5f8505163cd07" data-td_block_id="td_uid_13_5f8505163cd07"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_5f8505163cd07" data-td_block_id="td_uid_13_5f8505163cd07"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100674" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-mega-menu menu-item-100674"><a href="https://riverheadlocal.com/schools/">Schools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_18_5f8505165662b = new tdBlock();
block_td_uid_18_5f8505165662b.id = "td_uid_18_5f8505165662b";
block_td_uid_18_5f8505165662b.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"185","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_5f8505165662b_rand","tdc_css_class":"td_uid_18_5f8505165662b_rand","tdc_css_class_style":"td_uid_18_5f8505165662b_rand_style"}';
block_td_uid_18_5f8505165662b.td_column_number = "3";
block_td_uid_18_5f8505165662b.block_type = "td_block_mega_menu";
block_td_uid_18_5f8505165662b.post_count = "5";
block_td_uid_18_5f8505165662b.found_posts = "1841";
block_td_uid_18_5f8505165662b.header_color = "";
block_td_uid_18_5f8505165662b.ajax_pagination_infinite_stop = "";
block_td_uid_18_5f8505165662b.max_num_pages = "369";
tdBlocksArray.push(block_td_uid_18_5f8505165662b);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_18_5f8505165662b_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_18_5f8505165662b"><div id=td_uid_18_5f8505165662b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/" rel="bookmark" class="td-image-wrap" title="Riverhead school board to hold first in-person public meeting since COVID shutdown"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead school board to hold first in-person public meeting since COVID shutdown" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/" rel="bookmark" title="Riverhead school board to hold first in-person public meeting since COVID shutdown">Riverhead school board to hold first in-person public meeting since COVID shutdown</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/27/pulaski-street-elementary-school-students-receive-book-donation-from-riverhead-community-awareness-program/" rel="bookmark" class="td-image-wrap" title="Pulaski Street Elementary School students receive book donation from Riverhead Community Awareness Program"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=1376%2C1032&#038;quality=100&#038;ssl=1 1376w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/RHCAPBooks-scaled.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Pulaski Street Elementary School students receive book donation from Riverhead Community Awareness Program" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/27/pulaski-street-elementary-school-students-receive-book-donation-from-riverhead-community-awareness-program/" rel="bookmark" title="Pulaski Street Elementary School students receive book donation from Riverhead Community Awareness Program">Pulaski Street Elementary School students receive book donation from Riverhead Community Awareness Program</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/25/riverhead-high-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" class="td-image-wrap" title="Riverhead High School staff member tests positive for COVID-19"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0725_Riverhead-High-School-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead High School staff member tests positive for COVID-19" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/25/riverhead-high-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" title="Riverhead High School staff member tests positive for COVID-19">Riverhead High School staff member tests positive for COVID-19</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/23/covid-shutdown-did-not-feather-school-districts-nest-officials-say/" rel="bookmark" class="td-image-wrap" title="COVID shutdown did not feather school district&#8217;s nest, officials say"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0923_schools-closed-sign-3.21.20-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="COVID shutdown did not feather school district&#8217;s nest, officials say" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/23/covid-shutdown-did-not-feather-school-districts-nest-officials-say/" rel="bookmark" title="COVID shutdown did not feather school district&#8217;s nest, officials say">COVID shutdown did not feather school district&#8217;s nest, officials say</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/22/riverhead-middle-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" class="td-image-wrap" title="Riverhead Middle School staff member tests positive for COVID-19"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0922_Riverhead-Middle-School-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead Middle School staff member tests positive for COVID-19" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/22/riverhead-middle-school-staff-member-tests-positive-for-covid-19/" rel="bookmark" title="Riverhead Middle School staff member tests positive for COVID-19">Riverhead Middle School staff member tests positive for COVID-19</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_18_5f8505165662b" id="td_uid_19_5f85051658fb4" data-td_block_id="td_uid_18_5f8505165662b" data-td_filter_value="" href="https://riverheadlocal.com/schools/">All</a><a class="mega-menu-sub-cat-td_uid_18_5f8505165662b" id="td_uid_20_5f8505165902c" data-td_block_id="td_uid_18_5f8505165662b" data-td_filter_value="187" href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a><a class="mega-menu-sub-cat-td_uid_18_5f8505165662b" id="td_uid_21_5f8505165908c" data-td_block_id="td_uid_18_5f8505165662b" data-td_filter_value="190" href="https://riverheadlocal.com/schools/mcgann-mercy-junior-senior-high-school/">McGann-Mercy Junior-Senior High School</a><a class="mega-menu-sub-cat-td_uid_18_5f8505165662b" id="td_uid_22_5f8505165912a" data-td_block_id="td_uid_18_5f8505165662b" data-td_filter_value="15377" href="https://riverheadlocal.com/schools/peconic-community-school/">Peconic Community School</a><a class="mega-menu-sub-cat-td_uid_18_5f8505165662b" id="td_uid_23_5f850516591a8" data-td_block_id="td_uid_18_5f8505165662b" data-td_filter_value="201" href="https://riverheadlocal.com/schools/riverhead-central-school-district/">Riverhead Central School District</a><a class="mega-menu-sub-cat-td_uid_18_5f8505165662b" id="td_uid_24_5f85051659224" data-td_block_id="td_uid_18_5f8505165662b" data-td_filter_value="199" href="https://riverheadlocal.com/schools/riverhead-central-school-district/aquebogue-elementary-school/">Aquebogue Elementary School</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_5f8505165662b" data-td_block_id="td_uid_18_5f8505165662b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_18_5f8505165662b" data-td_block_id="td_uid_18_5f8505165662b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-120667" class="tablet-hidden menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-120667"><a href="https://riverheadlocal.com/business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_25_5f85051673006 = new tdBlock();
block_td_uid_25_5f85051673006.id = "td_uid_25_5f85051673006";
block_td_uid_25_5f85051673006.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"205","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_25_5f85051673006_rand","tdc_css_class":"td_uid_25_5f85051673006_rand","tdc_css_class_style":"td_uid_25_5f85051673006_rand_style"}';
block_td_uid_25_5f85051673006.td_column_number = "3";
block_td_uid_25_5f85051673006.block_type = "td_block_mega_menu";
block_td_uid_25_5f85051673006.post_count = "5";
block_td_uid_25_5f85051673006.found_posts = "517";
block_td_uid_25_5f85051673006.header_color = "";
block_td_uid_25_5f85051673006.ajax_pagination_infinite_stop = "";
block_td_uid_25_5f85051673006.max_num_pages = "104";
tdBlocksArray.push(block_td_uid_25_5f85051673006);
</script><div class="td_block_wrap td_block_mega_menu td_uid_25_5f85051673006_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_25_5f85051673006"><div id=td_uid_25_5f85051673006 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/24/riverheads-unemployment-rate-drops-below-10-for-the-first-time-since-pandemic-struck/" rel="bookmark" class="td-image-wrap" title="Riverhead&#8217;s unemployment rate drops below 10% for the first time since pandemic struck"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/06/woman-paying-bills-Adobe-Stock.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead&#8217;s unemployment rate drops below 10% for the first time since pandemic struck" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/24/riverheads-unemployment-rate-drops-below-10-for-the-first-time-since-pandemic-struck/" rel="bookmark" title="Riverhead&#8217;s unemployment rate drops below 10% for the first time since pandemic struck">Riverhead&#8217;s unemployment rate drops below 10% for the first time since pandemic struck</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/15/coping-with-the-pandemic-and-new-ag-worker-labor-standards-local-farmers-worry-state-may-now-lower-threshold-for-overtime-pay/" rel="bookmark" class="td-image-wrap" title="Coping with the pandemic and new ag worker labor standards, local farmers worry state may now lower threshold for overtime pay"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0915_Bill-Zalakar-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Coping with the pandemic and new ag worker labor standards, local farmers worry state may now lower threshold for overtime pay" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/15/coping-with-the-pandemic-and-new-ag-worker-labor-standards-local-farmers-worry-state-may-now-lower-threshold-for-overtime-pay/" rel="bookmark" title="Coping with the pandemic and new ag worker labor standards, local farmers worry state may now lower threshold for overtime pay">Coping with the pandemic and new ag worker labor standards, local farmers worry state may now lower threshold for overtime pay</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/15/countys-online-portal-offers-employment-assistance-virtual-job-fairs/" rel="bookmark" class="td-image-wrap" title="County&#8217;s online portal offers employment assistance, virtual job fairs"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/02/04_04_2019_butterflyeffect_jobfairannouncement.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="County&#8217;s online portal offers employment assistance, virtual job fairs" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/15/countys-online-portal-offers-employment-assistance-virtual-job-fairs/" rel="bookmark" title="County&#8217;s online portal offers employment assistance, virtual job fairs">County&#8217;s online portal offers employment assistance, virtual job fairs</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/04/riverhead-gun-shop-gains-approval-for-indoor-testing-range/" rel="bookmark" class="td-image-wrap" title="Riverhead gun shop gains approval for indoor firearms testing range"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0321_Baits_and_Barrels-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead gun shop gains approval for indoor firearms testing range" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/04/riverhead-gun-shop-gains-approval-for-indoor-testing-range/" rel="bookmark" title="Riverhead gun shop gains approval for indoor firearms testing range">Riverhead gun shop gains approval for indoor firearms testing range</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/03/after-news-that-suffolk-unemployment-rate-climbed-to-13-6-in-july-state-assembly-candidates-call-for-unemployment-benefit-reform/" rel="bookmark" class="td-image-wrap" title="After news that Suffolk unemployment rate climbed to 13.6% in July, State Assembly candidates call for unemployment benefit reform"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/05/2020_0514_closed-sign.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="After news that Suffolk unemployment rate climbed to 13.6% in July, State Assembly candidates call for unemployment benefit reform" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/03/after-news-that-suffolk-unemployment-rate-climbed-to-13-6-in-july-state-assembly-candidates-call-for-unemployment-benefit-reform/" rel="bookmark" title="After news that Suffolk unemployment rate climbed to 13.6% in July, State Assembly candidates call for unemployment benefit reform">After news that Suffolk unemployment rate climbed to 13.6% in July, State Assembly candidates call for unemployment benefit reform</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5f85051673006" data-td_block_id="td_uid_25_5f85051673006"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_25_5f85051673006" data-td_block_id="td_uid_25_5f85051673006"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100676" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100676"><a href="https://riverheadlocal.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_26_5f85051677916 = new tdBlock();
block_td_uid_26_5f85051677916.id = "td_uid_26_5f85051677916";
block_td_uid_26_5f85051677916.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"81","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_26_5f85051677916_rand","tdc_css_class":"td_uid_26_5f85051677916_rand","tdc_css_class_style":"td_uid_26_5f85051677916_rand_style"}';
block_td_uid_26_5f85051677916.td_column_number = "3";
block_td_uid_26_5f85051677916.block_type = "td_block_mega_menu";
block_td_uid_26_5f85051677916.post_count = "5";
block_td_uid_26_5f85051677916.found_posts = "933";
block_td_uid_26_5f85051677916.header_color = "";
block_td_uid_26_5f85051677916.ajax_pagination_infinite_stop = "";
block_td_uid_26_5f85051677916.max_num_pages = "187";
tdBlocksArray.push(block_td_uid_26_5f85051677916);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_26_5f85051677916_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_26_5f85051677916"><div id=td_uid_26_5f85051677916 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/11/responsible-lawmakers-do-their-homework-giglio-isnt-ready-for-albany/" rel="bookmark" class="td-image-wrap" title="Responsible lawmakers do their homework: Giglio isn&#8217;t ready for Albany"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0404_state_capitol_legislature_matt_wade.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0404_state_capitol_legislature_matt_wade.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0404_state_capitol_legislature_matt_wade.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0404_state_capitol_legislature_matt_wade.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0404_state_capitol_legislature_matt_wade.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0404_state_capitol_legislature_matt_wade.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0404_state_capitol_legislature_matt_wade.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0404_state_capitol_legislature_matt_wade.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Responsible lawmakers do their homework: Giglio isn&#8217;t ready for Albany" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/11/responsible-lawmakers-do-their-homework-giglio-isnt-ready-for-albany/" rel="bookmark" title="Responsible lawmakers do their homework: Giglio isn&#8217;t ready for Albany">Responsible lawmakers do their homework: Giglio isn&#8217;t ready for Albany</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/08/today-is-organ-donor-day-sign-up/" rel="bookmark" class="td-image-wrap" title="Today is Organ Donor Day — sign up"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2019_0308_Schaefer_Ed.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Today is Organ Donor Day — sign up" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/08/today-is-organ-donor-day-sign-up/" rel="bookmark" title="Today is Organ Donor Day — sign up">Today is Organ Donor Day — sign up</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/04/covid-is-a-convenient-scapegoat-for-countys-fiscal-mismanagement/" rel="bookmark" class="td-image-wrap" title="COVID is a convenient scapegoat for county&#8217;s fiscal mismanagement"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1004_Bellone_presser-9.25.20.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1004_Bellone_presser-9.25.20.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1004_Bellone_presser-9.25.20.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1004_Bellone_presser-9.25.20.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1004_Bellone_presser-9.25.20.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1004_Bellone_presser-9.25.20.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1004_Bellone_presser-9.25.20.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="COVID is a convenient scapegoat for county&#8217;s fiscal mismanagement" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/04/covid-is-a-convenient-scapegoat-for-countys-fiscal-mismanagement/" rel="bookmark" title="COVID is a convenient scapegoat for county&#8217;s fiscal mismanagement">COVID is a convenient scapegoat for county&#8217;s fiscal mismanagement</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/26/giglio-c-o-proposal-is-withdrawn/" rel="bookmark" class="td-image-wrap" title="Giglio: C.O. proposal is withdrawn"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2019/12/Mail_Envelope_letter.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Giglio: C.O. proposal is withdrawn" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/26/giglio-c-o-proposal-is-withdrawn/" rel="bookmark" title="Giglio: C.O. proposal is withdrawn">Giglio: C.O. proposal is withdrawn</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/20/a-cashless-economy-will-hurt-the-working-poor/" rel="bookmark" class="td-image-wrap" title="A cashless economy will hurt the working poor"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/20200920_mobile_payment_Adobe.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="A cashless economy will hurt the working poor" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/20/a-cashless-economy-will-hurt-the-working-poor/" rel="bookmark" title="A cashless economy will hurt the working poor">A cashless economy will hurt the working poor</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_26_5f85051677916" id="td_uid_27_5f85051679bfb" data-td_block_id="td_uid_26_5f85051677916" data-td_filter_value="" href="https://riverheadlocal.com/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_26_5f85051677916" id="td_uid_28_5f85051679c73" data-td_block_id="td_uid_26_5f85051677916" data-td_filter_value="91" href="https://riverheadlocal.com/opinion/civiletti/">Denise Civiletti</a><a class="mega-menu-sub-cat-td_uid_26_5f85051677916" id="td_uid_29_5f85051679d1d" data-td_block_id="td_uid_26_5f85051677916" data-td_filter_value="12894" href="https://riverheadlocal.com/opinion/greg-blass/">Greg Blass</a><a class="mega-menu-sub-cat-td_uid_26_5f85051677916" id="td_uid_30_5f85051679d7c" data-td_block_id="td_uid_26_5f85051677916" data-td_filter_value="99" href="https://riverheadlocal.com/opinion/in-my-opinion/">In My Opinion</a><a class="mega-menu-sub-cat-td_uid_26_5f85051677916" id="td_uid_31_5f85051679dd6" data-td_block_id="td_uid_26_5f85051677916" data-td_filter_value="98" href="https://riverheadlocal.com/opinion/java-scripts/">Java Scripts</a><a class="mega-menu-sub-cat-td_uid_26_5f85051677916" id="td_uid_32_5f85051679e60" data-td_block_id="td_uid_26_5f85051677916" data-td_filter_value="16086" href="https://riverheadlocal.com/opinion/katie-blasl/">Katie Blasl</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_26_5f85051677916" data-td_block_id="td_uid_26_5f85051677916"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_26_5f85051677916" data-td_block_id="td_uid_26_5f85051677916"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100677" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100677"><a href="https://riverheadlocal.com/living/">Living</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_33_5f8505169009a = new tdBlock();
block_td_uid_33_5f8505169009a.id = "td_uid_33_5f8505169009a";
block_td_uid_33_5f8505169009a.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9530","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_33_5f8505169009a_rand","tdc_css_class":"td_uid_33_5f8505169009a_rand","tdc_css_class_style":"td_uid_33_5f8505169009a_rand_style"}';
block_td_uid_33_5f8505169009a.td_column_number = "3";
block_td_uid_33_5f8505169009a.block_type = "td_block_mega_menu";
block_td_uid_33_5f8505169009a.post_count = "5";
block_td_uid_33_5f8505169009a.found_posts = "3401";
block_td_uid_33_5f8505169009a.header_color = "";
block_td_uid_33_5f8505169009a.ajax_pagination_infinite_stop = "";
block_td_uid_33_5f8505169009a.max_num_pages = "681";
tdBlocksArray.push(block_td_uid_33_5f8505169009a);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_33_5f8505169009a_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_33_5f8505169009a"><div id=td_uid_33_5f8505169009a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/10/a-lifetime-burning-in-every-moment/" rel="bookmark" class="td-image-wrap" title="&#8216;A lifetime burning in every moment&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1010_hourglass-AdobeStock.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="&#8216;A lifetime burning in every moment&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/10/a-lifetime-burning-in-every-moment/" rel="bookmark" title="&#8216;A lifetime burning in every moment&#8217;">&#8216;A lifetime burning in every moment&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/10/05/happenings-around-town/" rel="bookmark" class="td-image-wrap" title="Happenings &#8216;Around Town&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?w=640&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/Around-Town-copy.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Happenings &#8216;Around Town&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/10/05/happenings-around-town/" rel="bookmark" title="Happenings &#8216;Around Town&#8217;">Happenings &#8216;Around Town&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/27/more-than-ever-this-is-a-time-for-prayer/" rel="bookmark" class="td-image-wrap" title="More than ever, this is a time for prayer"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0927_Trump_supporters_protesters_police-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="More than ever, this is a time for prayer" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/27/more-than-ever-this-is-a-time-for-prayer/" rel="bookmark" title="More than ever, this is a time for prayer">More than ever, this is a time for prayer</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/13/can-america-regain-the-unity-that-prevailed-after-sept-11-2001/" rel="bookmark" class="td-image-wrap" title="Can America regain the unity that prevailed after Sept. 11, 2001?"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=1104%2C825&#038;quality=100&#038;ssl=1 1104w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/Tribute-in-Light-Wtc-2004-memorial.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Can America regain the unity that prevailed after Sept. 11, 2001?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/13/can-america-regain-the-unity-that-prevailed-after-sept-11-2001/" rel="bookmark" title="Can America regain the unity that prevailed after Sept. 11, 2001?">Can America regain the unity that prevailed after Sept. 11, 2001?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/09/12/learning-to-let-go-of-negativity/" rel="bookmark" class="td-image-wrap" title="Learning to let go of negativity"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/09/2020_0912_woman_yoga_water.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Learning to let go of negativity" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/09/12/learning-to-let-go-of-negativity/" rel="bookmark" title="Learning to let go of negativity">Learning to let go of negativity</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_33_5f8505169009a" id="td_uid_34_5f85051694fc7" data-td_block_id="td_uid_33_5f8505169009a" data-td_filter_value="" href="https://riverheadlocal.com/living/">All</a><a class="mega-menu-sub-cat-td_uid_33_5f8505169009a" id="td_uid_35_5f8505169506d" data-td_block_id="td_uid_33_5f8505169009a" data-td_filter_value="100" href="https://riverheadlocal.com/living/bits-and-pieces/">Bits and Pieces</a><a class="mega-menu-sub-cat-td_uid_33_5f8505169009a" id="td_uid_36_5f85051695100" data-td_block_id="td_uid_33_5f8505169009a" data-td_filter_value="94" href="https://riverheadlocal.com/living/laurie-nigro/">Laurie Nigro</a><a class="mega-menu-sub-cat-td_uid_33_5f8505169009a" id="td_uid_37_5f850516951c5" data-td_block_id="td_uid_33_5f8505169009a" data-td_filter_value="38" href="https://riverheadlocal.com/living/life-on-purpose/">Life On Purpose</a><a class="mega-menu-sub-cat-td_uid_33_5f8505169009a" id="td_uid_38_5f85051695250" data-td_block_id="td_uid_33_5f8505169009a" data-td_filter_value="119" href="https://riverheadlocal.com/living/town-crier/">Town Crier</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_33_5f8505169009a" data-td_block_id="td_uid_33_5f8505169009a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_33_5f8505169009a" data-td_block_id="td_uid_33_5f8505169009a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-76334" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76334"><a target="_blank" href="http://eastendlocal.com/events">Events</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
<div class="breaking-menu-wrap">
<div class="menu-coronavirus-container"><ul id="menu-coronavirus" class="breaking-menu sf-menu"><li id="menu-item-134795" class="breaking-main menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-134795"><a href="https://riverheadlocal.com/coronavirus/">Coronavirus</a></li>
<li id="menu-item-134924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-134924"><a href="https://riverheadlocal.com/coronavirus/#latest-news">Latest updates</a></li>
<li id="menu-item-134797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134797"><a href="https://riverheadlocal.com/coronavirus/">Maps &#038; charts</a></li>
</ul></div> </div>
</div>
</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap broadstreet banner ">
<div class="kb-header-ad"><span class="text"></span> <div class="textwidget"><broadstreet-zone zone-id="68458" count="1"></broadstreet-zone></div>
</div>

</div> </div>
</div>
</div>
</div><div class="td-container td-post-template-3">
<div class="td-container-border">
<article id="post-137500" class="post-137500 post type-post status-publish format-standard has-post-thumbnail hentry category-board-of-education tag-coronavirus-outbreak-latest-news tag-featured tag-riverhead-school-board author-riverheadlocal" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header td-pb-padding-side">
<ul class="td-category"><li class="entry-category"><a href="https://riverheadlocal.com/schools/">Schools</a></li><li class="entry-category"><a href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a></li></ul>
<header>
<h1 class="entry-title">Riverhead school board to hold first in-person public meeting since COVID shutdown</h1>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://riverheadlocal.com/author/rlocal/" title="Posts by RiverheadLOCAL" class="author url fn" rel="author">RiverheadLOCAL</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-10-12T07:36:23+00:00">Oct 12, 2020, 7:36 am</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-featured-image"><figure><a href="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?fit=800%2C479&quality=100&ssl=1" data-caption="Riverhead High School. File photo: Denise Civiletti"><img width="681" height="408" class="entry-thumb td-modal-image" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=681%2C408&quality=100&ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?w=800&quality=100&ssl=1 800w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=270%2C162&quality=100&ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=768%2C460&quality=100&ssl=1 768w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=701%2C420&quality=100&ssl=1 701w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=640%2C383&quality=100&ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?resize=681%2C408&quality=100&ssl=1 681w" sizes="(max-width: 681px) 100vw, 681px" alt="" title="2020_1012_RHS_front_sign_safe_distancing_message - 1" /></a><figcaption class="wp-caption-text">Riverhead High School. File photo: Denise Civiletti</figcaption></figure></div>
<div class="td-post-content td-pb-padding-side">
<p>The Riverhead school board will meet in person and allow public attendance at its meeting for the first time since the coronavirus pandemic surged in New York and the governor implemented shutdown measures in March.
<p>The school board will meet in the high school gymnasium at 7 p.m. tomorrow. On the board’s <a href="https://go.boarddocs.com/ny/rcsd/Board.nsf/Public" target="_blank" rel="noreferrer noopener" aria-label="agenda (opens in a new tab)">agenda</a> tomorrow night is a public hearing on the district’s 2020-2021 <a rel="noreferrer noopener" aria-label="emergency management plan (opens in a new tab)" href="https://go.boarddocs.com/ny/rcsd/Board.nsf/files/BU7S4L685820/$file/EMERGENCY%20MANAGEMENT%20PLAN-2020-2021.pdf" target="_blank">emergency management plan</a>.
<p>Maximum capacity in the gymnasium is limited to 50 people, according to a notice issued by the district clerk. Members of the public will be admitted on a first-come, first-serve basis, the notice said. <broadstreet-zone alt-zone-id="68459" class="mobile-ad" count="1"></broadstreet-zone>
<p>“All attendees will be required to comply with applicable executive orders, CDC and department of health guidelines and local rules, including but not limited to social distancing, the wearing of masks, temperature checks and room capacity limitations,” the notice stated.
<p>Anyone who has tested positive for COVID-19 within the past 14 days or who has symptoms of the disease, or has been in contact with any individual who has tested positive for COVID-19 within the past 14 days or has symptoms of the disease, or has traveled to any of the states on New York State’s travel advisory list within the past 14 days is asked not to enter the building, the district said.
<p>The board meeting can be viewed online here: <a href="https://youtu.be/G6uxuVGPRgE">https://youtu.be/G6uxuVGPRgE</a>. Anyone watching remotely who wants to comment for the record during the meeting should submit comments using this link: <a rel="noreferrer noopener" aria-label="https://forms.gle/pgnndBtcD59o41UD6 (opens in a new tab)" href="https://forms.gle/pgnndBtcD59o41UD6" target="_blank">https://forms.gle/pgnndBtcD59o41UD6</a>.
<p>The last in-person public meeting of the Riverhead Board of Education took place on March 10. Two days later, on March 12, Gov. Andrew Cuomo signed Executive Order 202.1 which suspended portions of the New York State Public Officers Law to allow any public body to meet and take action remotely and without permitting in-person, public access to meetings — &#8220;provided that the public has the ability to view or listen to such proceeding and that such meetings are recorded and later transcribed.&#8221; <broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<p>The executive order, which remains in effect, does not require the public body to prohibit in-person public access to meetings, but rather allows it. However, the state-mandated occupancy and public gathering limits affect the total number of people, including board members and staff, that can attend a meeting in-person.
<div class="kb-member-content-box"><p><strong><span style="font-size:20px; line-height: 40px;">We need your help.</span></strong><br />Now more than ever, the survival of quality local journalism depends on your support. Our community faces unprecedented economic disruption, and the future of many small businesses are under threat, including our own. It takes time and resources to provide this service. We are a small family-owned operation, and we will do everything in our power to keep it going. But today more than ever before, we will depend on your support to continue. <strong><a href="/support-local-journalism">Support RiverheadLOCAL today.</a></strong> You rely on us to stay informed and we depend on you to make our work possible.</p></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
</div> </div>
<footer>
<div class="td-post-source-tags td-pb-padding-side">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://riverheadlocal.com/topic/coronavirus-outbreak-latest-news/">Coronavirus</a></li><li><a href="https://riverheadlocal.com/topic/featured/">featured</a></li><li><a href="https://riverheadlocal.com/topic/riverhead-school-board/">Riverhead school board</a></li></ul> </div>
<div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-twitter" style="overflow: visible;"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/" data-text="Riverhead school board to hold first in-person public meeting since COVID shutdown" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li class="td-classic-facebook" style="overflow: visible;"><div class="fb-like" data-href="https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/" data-layout="button_count" data-action="like" data-show-faces="false"></div></li></ul></div></div> <div class="author-box-wrap"><a href="https://riverheadlocal.com/author/rlocal/"><img src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/Local_Black_Flat_130.png?fit=96%2C34&quality=100&ssl=1" width="96" height="34" alt="Avatar" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://riverheadlocal.com/author/rlocal/">RiverheadLOCAL</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="datePublished" content="2020-10-12T07:36:23+00:00"><meta itemprop="dateModified" content="2020-10-12T08:47:26-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png"></span><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="headline " content="Riverhead school board to hold first in-person public meeting since COVID shutdown"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/10/2020_1012_RHS_front_sign_safe_distancing_message-1.jpeg?fit=800%2C479&quality=100&ssl=1"><meta itemprop="width" content="800"><meta itemprop="height" content="479"></span> </footer>
<div class="fb-comments" data-href="https://riverheadlocal.com/2020/10/12/riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown/" data-width="100%" data-mobile="true" data-numposts="10" data-order-by="social" data-colorscheme="light"></div> </div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68459" count="1"></broadstreet-zone></div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="kb-popout-content td-pb-row">
<div class="wpb_wrapper">
<div class="wpb_text_column block-header">
<p>Daily Newsletter</p>
</div>
<div class="wpb_wrapper wpb_text_column td-pb-border-top">
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://riverheadlocal.us6.list-manage.com/subscribe/post?u=47e88a318d72559c43e4b77bc&amp;id=8118172d70" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div class="mc-field-group first-name"><label for="mce-FNAME">First Name </label><br />
<input id="mce-FNAME" class="required" name="FNAME" type="text" value="" /></div>
<div class="mc-field-group last-name"><label for="mce-LNAME">Last Name </label><br />
<input id="mce-LNAME" class="required" name="LNAME" type="text" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_47e88a318d72559c43e4b77bc_8118172d70" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p>
</div>
</div>
</div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68461" count="1"></broadstreet-zone></div>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div>
</div> 


<div class="td-footer-container td-container td-footer-template-10">
<div class="footer-social-wrap td-social-style2 td-footer-full">
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer1-container"><ul id="menu-footer1" class="td-subfooter-menu"><li id="menu-item-132939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-132939"><a href="https://riverheadlocal.com/copyright-notice/">© 2010-2020 East End Local Media Corp</a></li>
<li id="menu-item-132941" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132941"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-132940" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132940"><a href="https://riverheadlocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-132944" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132944"><a href="https://riverheadlocal.com/comments-policy/">Comments Policy</a></li>
<li id="menu-item-132945" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132945"><a href="https://riverheadlocal.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
<div class="td-pb-span4 td-sub-footer-copy">
<div class="td-pb-padding-side">
</div>
</div>
</div>
</div>
</div>
</div>
<div class="a2a_kit a2a_kit_size_36 a2a_floating_style a2a_vertical_style" style="left:0px;top:400px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;left:5px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F10%2F12%2Friverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown%2F&amp;linkname=Riverhead%20school%20board%20to%20hold%20first%20in-person%20public%20meeting%20since%20COVID%20shutdown%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><a rel="nofollow" style="display:none;" href="https://riverheadlocal.com/?blackhole=a3237a139e" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','board-of-education','schools','riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["board-of-education","schools","riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown","post"],"url":"riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({"useAltZone":767,"altZoneWhitelist":[71281],"networkId":"4821","targets":{"pagetype":["post","not_home_page"],"category":["board-of-education","schools","riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown","post"],"url":"riverhead-school-board-to-hold-first-in-person-public-meeting-since-covid-shutdown"}});
 });</script>

<script type="text/javascript">(function($) {
  $.fn.almComplete = function(alm){
    
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");


      

    var $pageNumber;
    if ($('.kb-alm-wrap-page-3').length) {
        $pageNumber = 3; 
       // console.log("We're on page 3");
    } else if ($('.kb-alm-wrap-page-2').length) {
        $pageNumber = 2;
        // console.log("We're on page 2");
    } else {
        $pageNumber = 1;
        // console.log("We're on page 1");
    }
    
    // Parse FB comments code
    
    var $newContainerString = '.alm-page-' + $pageNumber;
    var $newContainer = $($newContainerString).parent();

    FB.XFBML.parse($newContainer[0]);
    
    // Append alm button to wrapper
    
    var $new_name = '.kb-alm-wrap-page-' + $pageNumber;
    // $('.alm-btn-wrap').detach();
    // $('.alm-btn-wrap').appendTo($new_name);
  
    // console.log("Button moved!");
    
    for ( var i = 0; i < tdSmartSidebar.items.length; i++ ) {
                    if ( 'case_3_bottom_of_content' === tdSmartSidebar.items[ i ].sidebar_state ) {
                        tdSmartSidebar.items[ i ].sidebar_state = 'case_1_fixed_down';
                       //  console.log("fixed down!");
                    }
                }
                
    var base_url = "https://riverheadlocal.com";
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.js" );
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js" );
//    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/jquery-3.1.1.min.js" );

   // console.log("Alm complte!");
   var jigs = jQuery('.justified-image-grid');
    if(jigs.length !== 0){
       jigs.data('justifiedImageGrid').createGallery('resize');
    }
  };
})(jQuery);

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");
    
 /*  $( 'body' ).on( 'post-load', function() {
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      } ); 
    // type = From which addon (previous-post | seo)
    // permalink = the updated url
    console.log("URL updated to " + permalink + '- dispatched from the '+ type + ' add-on.'); */
  }; 
})(jQuery);

(function($) {
    $(window).load(function(){
  // $('.alm-btn-wrap').appendTo($('.kb-alm-wrap'));
   // console.log("Button moved!");
});
})(jQuery);</script> 
<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-aJ5TJKLfrG9cB",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-aJ5TJKLfrG9cB.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<link rel='stylesheet' id='photoswipe-style-css' href='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/css/photoswipe4.css?ver=4.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/wpdialog.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/newsmag-child/js/sticky-kit.js?ver=1.0.6'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.3'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"caccdc57c7","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/photoswipe4.min.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/jquery.dotdotdot.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js?ver=3.9.5'></script>
<script type='text/javascript' src='https://riverheadlocal.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://riverheadlocal.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202042.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'77146263',post:'137500',tz:'-4',srv:'riverheadlocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '77146263', '137500' ]);
</script>
</body>
</html>
