<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Zeldin introduces resolution urging creation of law enforcement &#039;bill of rights&#039; | RiverheadLOCAL</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="pingback" href="https://riverheadlocal.com/xmlrpc.php" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<meta property="og:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?fit=800%2C533&quality=100&ssl=1" /><link rel="icon" type="image/png" href="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/favicon.png">

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Zeldin introduces resolution urging creation of law enforcement &#039;bill of rights&#039; | RiverheadLOCAL" />
<meta property="og:description" content="Denouncing calls to defund the police, Rep. Lee Zeldin sponsors a House resolution urging states to adopt a law enforcement &#039;bill of rights.&#039;" />
<meta property="og:url" content="https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/" />
<meta property="og:site_name" content="RiverheadLOCAL" />
<meta property="article:tag" content="Black Lives Matter" />
<meta property="article:tag" content="featured" />
<meta property="article:tag" content="law enforcement bill of rights" />
<meta property="article:tag" content="Lee Zeldin" />
<meta property="article:section" content="Local News" />
<meta property="article:published_time" content="2020-08-25T22:13:41+00:00" />
<meta property="article:modified_time" content="2020-08-25T22:13:50+00:00" />
<meta property="og:updated_time" content="2020-08-25T22:13:50+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Denouncing calls to defund the police, Rep. Lee Zeldin sponsors a House resolution urging states to adopt a law enforcement &#039;bill of rights.&#039;" />
<meta name="twitter:title" content="Zeldin introduces resolution urging creation of law enforcement &#039;bill of rights&#039; | RiverheadLOCAL" />
<meta name="twitter:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?fit=800%2C533&#038;quality=100&#038;ssl=1" />
<meta name="twitter:creator" content="@civiletti" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://riverheadlocal.com/#website","url":"https://riverheadlocal.com/","name":"RiverheadLOCAL","inLanguage":"en-US","description":"News and events for Riverhead, New York","potentialAction":[{"@type":"SearchAction","target":"https://riverheadlocal.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?fit=800%2C533&quality=100&ssl=1","width":800,"height":533},{"@type":"WebPage","@id":"https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/#webpage","url":"https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/","name":"Zeldin introduces resolution urging creation of law enforcement &#039;bill of rights&#039; | RiverheadLOCAL","isPartOf":{"@id":"https://riverheadlocal.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/#primaryimage"},"datePublished":"2020-08-25T22:13:41+00:00","dateModified":"2020-08-25T22:13:50+00:00","author":{"@id":"https://riverheadlocal.com/#/schema/person/0a12b5636fa3908dcd3ed4af34d1ae3d"},"potentialAction":[{"@type":"ReadAction","target":["https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/"]}]},{"@type":["Person"],"@id":"https://riverheadlocal.com/#/schema/person/0a12b5636fa3908dcd3ed4af34d1ae3d","name":"Denise Civiletti","image":{"@type":"ImageObject","@id":"https://riverheadlocal.com/#authorlogo","inLanguage":"en-US","url":"https://riverheadlocal.com/wp-content/uploads/2018/09/DC-avatar.png","caption":"Denise Civiletti"},"description":"Denise is a veteran local reporter, editor,  attorney and former Riverhead Town councilwoman. Her work has been recognized with numerous awards, including investigative reporting and writer of the year awards from the N.Y. Press Association. She is a founder, owner and co-publisher of this website.<a href=\"mailto:denise@riverheadlocal.com\">Email Denise.</a>","sameAs":["https://twitter.com/@civiletti"]}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Feed" href="https://riverheadlocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Comments Feed" href="https://riverheadlocal.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='kb-membership-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-membership/inc/style.css?ver=6.1.991' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/jquery-ui-dialog.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fc-form-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/Formcraft/assets/css/form.min.css?ver=3.2.27' type='text/css' media='all' />
<link rel='stylesheet' id='kb-liveblog-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-liveblog/style.css?ver=6.0.200' type='text/css' media='all' />
<link rel='stylesheet' id='public_notices_css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-public-notices/kb-public-notices.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-top-stories-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-top-stories/style.css?ver=1.1.735' type='text/css' media='all' />
<link rel='stylesheet' id='trans-frontend-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-translation/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-min-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/icons/css/weather-icons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-wind-min-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/icons/css/weather-icons-wind.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-weather-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/css/kb-weather.css?ver=1.7.434' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/Newsmag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/style.css?ver=5.0.0219' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C100%2C100italic%2C200%2C200italic%2C300italic%2C400italic%2C500%2C500italic%2C600italic%2C700italic%2C800%2C800italic%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C100%2C100italic%2C200%2C200italic%2C500%2C500italic%2C600%2C600italic%2C800%2C800italic&#038;ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1125px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1124px){
.a2a_floating_style.a2a_default_style{display:none;}
}
.a2a_floating_style {
    padding: 20px;
    border-radius: 0;
    border: 1px solid #bbbbbb;
}
</style>
<link rel='stylesheet' id='js_composer_front-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/style.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-membership/inc/button.js?ver=6.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-liveblog/scripts.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/js/modernizr.custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/js/summary-box.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.25'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/common-scripts.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/popup-menu-fix.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://riverheadlocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverheadlocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverheadlocal.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://riverheadlocal.com/?p=136985' />
<link rel="alternate" type="application/json+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color = "#A0A0A0";

a2a_config.templates = {
    email: {
        subject: "RiverheadLOCAL: ${title}",
        body: "Check out this story on RiverheadLOCAL: \n${title}\n${link}"
    }
};

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      }; 
})(jQuery);
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>


<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Zeldin introduces resolution urging creation of law enforcement &#039;bill of rights&#039; | RiverheadLOCAL","pagePostType":"post","pagePostType2":"single-post","pageCategory":["local-news"],"pageAttributes":["black-lives-matter","featured","law-enforcement-bill-of-rights","lee-zeldin"],"pagePostAuthor":"Denise Civiletti","pagePostDate":"Aug 25, 2020, 6:13 pm","pagePostDateYear":"2020","pagePostDateMonth":"08","pagePostDateDay":"25"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N97RFZC');//]]>
</script>


<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<script src="https://use.fontawesome.com/b3fb28acc8.js"></script><meta property="fb:app_id" content="105130769527571" /><meta name="google-site-verification" content="7jViI0XrkgkIYGyQD0GNoWcify30WyzN3o4ZHzUGfdo" /><script data-ad-client="ca-pub-6009741394491678" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var adSlotLeaderboard = googletag.defineSlot('/21874054635/Sitewide', [728, 90], 'div-gpt-ad-leaderboard');
    adSlotLeaderboard.addService(googletag.pubads());
    adSlotLeaderboard.setTargeting('position', ['leaderboard']);
    var adSlotSidebar1= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-1');
	    adSlotSidebar1.addService(googletag.pubads());
	    adSlotSidebar1.setTargeting('position', ['sidebar']);
	    var adSlotSidebar2= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-2');
	    adSlotSidebar2.addService(googletag.pubads());
	    adSlotSidebar2.setTargeting('position', ['sidebar']);
	    var adSlotSidebar3= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-3');
	    adSlotSidebar3.addService(googletag.pubads());
	    adSlotSidebar3.setTargeting('position', ['sidebar']);
	    var adSlotSidebar4= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-4');
	    adSlotSidebar4.addService(googletag.pubads());
	    adSlotSidebar4.setTargeting('position', ['sidebar']);
	    var adSlotSidebar5= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-5');
	    adSlotSidebar5.addService(googletag.pubads());
	    adSlotSidebar5.setTargeting('position', ['sidebar']);
	    var adSlotSidebar = googletag.defineSlot('/21874054635/Sitewide', ['fluid'], 'div-gpt-ad-lead-sidebar');
    adSlotSidebar.addService(googletag.pubads());
    adSlotSidebar.setTargeting('position', ['lead-sidebar']);
    
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://riverheadlocal.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '82fba20f-da37-4c38-a7fe-ee7dbe081e0f';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://riverheadlocal.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.370dd028-ab8a-4720-9087-4e2c917686de";
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_ajax_url="https:\/\/riverheadlocal.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=4.3";
var td_get_template_directory_uri="https:\/\/riverheadlocal.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e12025";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=32%2C32&#038;quality=100&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>
<body class="post-template-default single single-post postid-136985 single-format-standard author-denise-civiletti zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights global-block-template-1 white-menu wpb-js-composer js-comp-ver-6.1 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N97RFZC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '105130769527571',
      xfbml      : true,
      version    : 'v2.9'
    });
    FB.AppEvents.logPageView();
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div class="td-mobile-container">

<div class="kb-menu-socials-wrap">

<div class="kb-menu-socials">
</div>
</div>

<div class="kb-mobile-search-container"><form method="get" class="td-search-form-widget" action="https://riverheadlocal.com/">
<div role="search" class="kb-mobile-search">
<button class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit"><i class="td-icon-search"></i></button>
<div class="kb-search-input-wrap"><input class="td-widget-search-input" type="text" value="Search" name="s" id="s" onfocus="if (this.value=='Search') this.value='';" onblur="if (this.value=='') this.value='Search';" /></div>
</div>
</form>
</div>

<div class="td-mobile-content">
<div class="menu-mobile-container"><ul id="menu-mobile" class="td-mobile-main-menu"><li id="menu-item-116721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-116721"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100685" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-100685"><a href="https://riverheadlocal.com/news/">News</a></li>
<li id="menu-item-100683" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100683"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a></li>
<li id="menu-item-100686" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100686"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100687" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100687"><a href="https://riverheadlocal.com/community/">Community</a></li>
<li id="menu-item-100693" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-100693"><a href="http://eastendlocal.com">Events</a></li>
<li id="menu-item-100688" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100688"><a href="https://riverheadlocal.com/schools/">Schools</a></li>
<li id="menu-item-100684" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100684"><a href="https://riverheadlocal.com/business/business-news/">Business</a></li>
<li id="menu-item-100691" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100691"><a href="https://riverheadlocal.com/living/">Living</a></li>
<li id="menu-item-100692" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100692"><a href="https://riverheadlocal.com/opinion/">Opinion</a></li>
<li id="menu-item-100694" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100694"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-108418" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108418"><a href="https://classifieds.eastendlocal.com">Classifieds</a></li>
<li id="menu-item-136097" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-136097"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-100695" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-100695"><a href="https://riverheadlocal.com/contact/">Contact RiverheadLOCAL</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div id="kb-overlay"></div>
<div class="td-header-wrap td-header-style-3">
<div class="td-top-menu-full">
<div class="td-header-row td-header-top-menu td-make-full">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-100681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-100681"><a href="https://riverheadlocal.com/contact/">Contact</a></li>
<li id="menu-item-130976" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-130976"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-100680" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100680"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-24924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24924"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-116691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116691"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-24925" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24925"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/classifieds/">Classifieds</a></li>
<li id="menu-item-129406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129406"><a href="https://riverheadlocal.com/support-local-journalism/">Membership</a></li>
</ul></div></div> </div>

</div>
</div>

<div class="td-header-container">
<div class="td-header-logo-wrap">
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
<span class="td-visual-hidden">RiverheadLOCAL</span>
</a>
</div>
<div class="td-header-right-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-main-menu">
<div class="td-header-menu-wrap-sub">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-header-right-header mobile-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main" class="sf-menu"><li id="menu-item-100668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-100668"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100671" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-mega-menu menu-item-100671"><a href="https://riverheadlocal.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_5f45f4d5b6a88 = new tdBlock();
block_td_uid_1_5f45f4d5b6a88.id = "td_uid_1_5f45f4d5b6a88";
block_td_uid_1_5f45f4d5b6a88.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"103","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5f45f4d5b6a88_rand","tdc_css_class":"td_uid_1_5f45f4d5b6a88_rand","tdc_css_class_style":"td_uid_1_5f45f4d5b6a88_rand_style"}';
block_td_uid_1_5f45f4d5b6a88.td_column_number = "3";
block_td_uid_1_5f45f4d5b6a88.block_type = "td_block_mega_menu";
block_td_uid_1_5f45f4d5b6a88.post_count = "5";
block_td_uid_1_5f45f4d5b6a88.found_posts = "6454";
block_td_uid_1_5f45f4d5b6a88.header_color = "";
block_td_uid_1_5f45f4d5b6a88.ajax_pagination_infinite_stop = "";
block_td_uid_1_5f45f4d5b6a88.max_num_pages = "1291";
tdBlocksArray.push(block_td_uid_1_5f45f4d5b6a88);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_1_5f45f4d5b6a88_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_5f45f4d5b6a88"><div id=td_uid_1_5f45f4d5b6a88 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/" rel="bookmark" class="td-image-wrap" title="Zeldin introduces resolution urging creation of law enforcement &#8216;bill of rights&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Zeldin introduces resolution urging creation of law enforcement &#8216;bill of rights&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/" rel="bookmark" title="Zeldin introduces resolution urging creation of law enforcement &#8216;bill of rights&#8217;">Zeldin introduces resolution urging creation of law enforcement &#8216;bill of rights&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/25/market-rate-apartment-developer-makes-pitch-for-ida-benefits/" rel="bookmark" class="td-image-wrap" title="Market-rate apartment developer makes pitch for IDA benefits"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=632%2C470&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0825-331-E-Main-rendering.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Market-rate apartment developer makes pitch for IDA benefits" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/25/market-rate-apartment-developer-makes-pitch-for-ida-benefits/" rel="bookmark" title="Market-rate apartment developer makes pitch for IDA benefits">Market-rate apartment developer makes pitch for IDA benefits</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/24/arrests-post-covid-in-riverhead-lag-more-than-86-behind-same-period-last-year/" rel="bookmark" class="td-image-wrap" title="Arrests post-COVID in Riverhead lag more than 86% behind same period last year"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Arrests post-COVID in Riverhead lag more than 86% behind same period last year" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/24/arrests-post-covid-in-riverhead-lag-more-than-86-behind-same-period-last-year/" rel="bookmark" title="Arrests post-COVID in Riverhead lag more than 86% behind same period last year">Arrests post-COVID in Riverhead lag more than 86% behind same period last year</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/24/storm-debris-pick-up-continues-in-riverhead/" rel="bookmark" class="td-image-wrap" title="Storm debris pick-up continues in Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0824_Isaias-cleanup-Aquebogue.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Storm debris pick-up continues in Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/24/storm-debris-pick-up-continues-in-riverhead/" rel="bookmark" title="Storm debris pick-up continues in Riverhead">Storm debris pick-up continues in Riverhead</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/23/a-most-unusual-summer-winds-down-covid-update-reopening-news-isaias-cleanup-continues/" rel="bookmark" class="td-image-wrap" title="A most unusual summer winds down: COVID update, reopening news, Isaias cleanup continues"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?w=1024&#038;quality=100&#038;ssl=1 1024w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0823-chairs-at-roanoke-landing.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="A most unusual summer winds down: COVID update, reopening news, Isaias cleanup continues" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/23/a-most-unusual-summer-winds-down-covid-update-reopening-news-isaias-cleanup-continues/" rel="bookmark" title="A most unusual summer winds down: COVID update, reopening news, Isaias cleanup continues">A most unusual summer winds down: COVID update, reopening news, Isaias cleanup continues</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_5f45f4d5b6a88" id="td_uid_2_5f45f4d5c03eb" data-td_block_id="td_uid_1_5f45f4d5b6a88" data-td_filter_value="" href="https://riverheadlocal.com/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_5f45f4d5b6a88" id="td_uid_3_5f45f4d5c046a" data-td_block_id="td_uid_1_5f45f4d5b6a88" data-td_filter_value="105" href="https://riverheadlocal.com/news/local-news/">Local News</a><a class="mega-menu-sub-cat-td_uid_1_5f45f4d5b6a88" id="td_uid_4_5f45f4d5c04c2" data-td_block_id="td_uid_1_5f45f4d5b6a88" data-td_filter_value="32" href="https://riverheadlocal.com/news/local-news/health/">Health</a><a class="mega-menu-sub-cat-td_uid_1_5f45f4d5b6a88" id="td_uid_5_5f45f4d5c055e" data-td_block_id="td_uid_1_5f45f4d5b6a88" data-td_filter_value="16007" href="https://riverheadlocal.com/news/local-news/weekly-roundup/">Weekend Roundup</a><a class="mega-menu-sub-cat-td_uid_1_5f45f4d5b6a88" id="td_uid_6_5f45f4d5c05c1" data-td_block_id="td_uid_1_5f45f4d5b6a88" data-td_filter_value="108" href="https://riverheadlocal.com/news/public-notices/">Public Notices</a><a class="mega-menu-sub-cat-td_uid_1_5f45f4d5b6a88" id="td_uid_7_5f45f4d5c0636" data-td_block_id="td_uid_1_5f45f4d5b6a88" data-td_filter_value="104" href="https://riverheadlocal.com/news/town-hall-notebook/">Town Hall Notebook</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5f45f4d5b6a88" data-td_block_id="td_uid_1_5f45f4d5b6a88"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5f45f4d5b6a88" data-td_block_id="td_uid_1_5f45f4d5b6a88"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100669" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100669"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_8_5f45f4d5e0510 = new tdBlock();
block_td_uid_8_5f45f4d5e0510.id = "td_uid_8_5f45f4d5e0510";
block_td_uid_8_5f45f4d5e0510.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_8_5f45f4d5e0510_rand","tdc_css_class":"td_uid_8_5f45f4d5e0510_rand","tdc_css_class_style":"td_uid_8_5f45f4d5e0510_rand_style"}';
block_td_uid_8_5f45f4d5e0510.td_column_number = "3";
block_td_uid_8_5f45f4d5e0510.block_type = "td_block_mega_menu";
block_td_uid_8_5f45f4d5e0510.post_count = "5";
block_td_uid_8_5f45f4d5e0510.found_posts = "2444";
block_td_uid_8_5f45f4d5e0510.header_color = "";
block_td_uid_8_5f45f4d5e0510.ajax_pagination_infinite_stop = "";
block_td_uid_8_5f45f4d5e0510.max_num_pages = "489";
tdBlocksArray.push(block_td_uid_8_5f45f4d5e0510);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_8_5f45f4d5e0510_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_8_5f45f4d5e0510"><div id=td_uid_8_5f45f4d5e0510 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/24/arrests-post-covid-in-riverhead-lag-more-than-86-behind-same-period-last-year/" rel="bookmark" class="td-image-wrap" title="Arrests post-COVID in Riverhead lag more than 86% behind same period last year"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2015_0312_man_handcuffs.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Arrests post-COVID in Riverhead lag more than 86% behind same period last year" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/24/arrests-post-covid-in-riverhead-lag-more-than-86-behind-same-period-last-year/" rel="bookmark" title="Arrests post-COVID in Riverhead lag more than 86% behind same period last year">Arrests post-COVID in Riverhead lag more than 86% behind same period last year</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/22/worker-at-jamesport-farm-seriously-injured-in-industrial-accident/" rel="bookmark" class="td-image-wrap" title="Worker at Jamesport farm seriously injured in industrial accident"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0822_shade-trees-nursery-map.png?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Worker at Jamesport farm seriously injured in industrial accident" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/22/worker-at-jamesport-farm-seriously-injured-in-industrial-accident/" rel="bookmark" title="Worker at Jamesport farm seriously injured in industrial accident">Worker at Jamesport farm seriously injured in industrial accident</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/21/flanders-man-21-seriously-injured-in-sunrise-highway-crash-thursday-morning/" rel="bookmark" class="td-image-wrap" title="Flanders man, 21, seriously injured in Sunrise Highway crash Thursday morning"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Flanders man, 21, seriously injured in Sunrise Highway crash Thursday morning" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/21/flanders-man-21-seriously-injured-in-sunrise-highway-crash-thursday-morning/" rel="bookmark" title="Flanders man, 21, seriously injured in Sunrise Highway crash Thursday morning">Flanders man, 21, seriously injured in Sunrise Highway crash Thursday morning</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/16/cops-drunk-driver-in-crash-with-marked-police-unit-saturday-night-in-riverhead/" rel="bookmark" class="td-image-wrap" title="Cops: Drunk driver in crash with marked police unit Saturday night in Riverhead"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/02/2016_0726_police_car_lights.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Cops: Drunk driver in crash with marked police unit Saturday night in Riverhead" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/16/cops-drunk-driver-in-crash-with-marked-police-unit-saturday-night-in-riverhead/" rel="bookmark" title="Cops: Drunk driver in crash with marked police unit Saturday night in Riverhead">Cops: Drunk driver in crash with marked police unit Saturday night in Riverhead</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/13/argument-leads-to-machete-attack-in-riverside-police/" rel="bookmark" class="td-image-wrap" title="Argument leads to machete attack in Riverside: police"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0813_Old-Quogue-Road-machete.png?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0813_Old-Quogue-Road-machete.png?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0813_Old-Quogue-Road-machete.png?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0813_Old-Quogue-Road-machete.png?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0813_Old-Quogue-Road-machete.png?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0813_Old-Quogue-Road-machete.png?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0813_Old-Quogue-Road-machete.png?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Argument leads to machete attack in Riverside: police" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/13/argument-leads-to-machete-attack-in-riverside-police/" rel="bookmark" title="Argument leads to machete attack in Riverside: police">Argument leads to machete attack in Riverside: police</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_8_5f45f4d5e0510" id="td_uid_9_5f45f4d5e45b5" data-td_block_id="td_uid_8_5f45f4d5e0510" data-td_filter_value="" href="https://riverheadlocal.com/police-fire/">All</a><a class="mega-menu-sub-cat-td_uid_8_5f45f4d5e0510" id="td_uid_10_5f45f4d5e4627" data-td_block_id="td_uid_8_5f45f4d5e0510" data-td_filter_value="42" href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a><a class="mega-menu-sub-cat-td_uid_8_5f45f4d5e0510" id="td_uid_11_5f45f4d5e467d" data-td_block_id="td_uid_8_5f45f4d5e0510" data-td_filter_value="41" href="https://riverheadlocal.com/police-fire/police-blotter/">Police Reports</a><a class="mega-menu-sub-cat-td_uid_8_5f45f4d5e0510" id="td_uid_12_5f45f4d5e46e9" data-td_block_id="td_uid_8_5f45f4d5e0510" data-td_filter_value="43" href="https://riverheadlocal.com/police-fire/riverhead-justice-court/">Riverhead Justice Court</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_8_5f45f4d5e0510" data-td_block_id="td_uid_8_5f45f4d5e0510"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_8_5f45f4d5e0510" data-td_block_id="td_uid_8_5f45f4d5e0510"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100672" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100672"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100673" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100673"><a href="https://riverheadlocal.com/community/">Community</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_13_5f45f4d6033a5 = new tdBlock();
block_td_uid_13_5f45f4d6033a5.id = "td_uid_13_5f45f4d6033a5";
block_td_uid_13_5f45f4d6033a5.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"113","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_5f45f4d6033a5_rand","tdc_css_class":"td_uid_13_5f45f4d6033a5_rand","tdc_css_class_style":"td_uid_13_5f45f4d6033a5_rand_style"}';
block_td_uid_13_5f45f4d6033a5.td_column_number = "3";
block_td_uid_13_5f45f4d6033a5.block_type = "td_block_mega_menu";
block_td_uid_13_5f45f4d6033a5.post_count = "5";
block_td_uid_13_5f45f4d6033a5.found_posts = "3887";
block_td_uid_13_5f45f4d6033a5.header_color = "";
block_td_uid_13_5f45f4d6033a5.ajax_pagination_infinite_stop = "";
block_td_uid_13_5f45f4d6033a5.max_num_pages = "778";
tdBlocksArray.push(block_td_uid_13_5f45f4d6033a5);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_13_5f45f4d6033a5_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_5f45f4d6033a5"><div id=td_uid_13_5f45f4d6033a5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/21/eighth-annual-rubber-duckie-race-scheduled-for-aug-22/" rel="bookmark" class="td-image-wrap" title="Eighth annual Rubber Duckie Race scheduled for Aug. 22"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Big_Duck_masked_Retouched.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Eighth annual Rubber Duckie Race scheduled for Aug. 22" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/21/eighth-annual-rubber-duckie-race-scheduled-for-aug-22/" rel="bookmark" title="Eighth annual Rubber Duckie Race scheduled for Aug. 22">Eighth annual Rubber Duckie Race scheduled for Aug. 22</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/16/life-before-the-pandemic-a-year-in-the-life-of-our-community-in-pictures/" rel="bookmark" class="td-image-wrap" title="Life before the pandemic: A year in the life of our community in pictures"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=912%2C683&#038;quality=100&#038;ssl=1 912w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0816_cardboard-boat-race-hoola-hoops-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Life before the pandemic: A year in the life of our community in pictures" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/16/life-before-the-pandemic-a-year-in-the-life-of-our-community-in-pictures/" rel="bookmark" title="Life before the pandemic: A year in the life of our community in pictures">Life before the pandemic: A year in the life of our community in pictures</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/13/dine-on-25-returns-to-downtown-riverhead-tonight/" rel="bookmark" class="td-image-wrap" title="&#8216;Dine on 25&#8217; returns to downtown Riverhead tonight"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0716_Dine-on-25-2.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="&#8216;Dine on 25&#8217; returns to downtown Riverhead tonight" /></a></div> </div>
<div class="item-details">
 <h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/13/dine-on-25-returns-to-downtown-riverhead-tonight/" rel="bookmark" title="&#8216;Dine on 25&#8217; returns to downtown Riverhead tonight">&#8216;Dine on 25&#8217; returns to downtown Riverhead tonight</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/12/donations-for-back-to-school-drive-being-accepted-through-virtual-registry/" rel="bookmark" class="td-image-wrap" title="Donations for Back-to-school drive being accepted through virtual registry"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2014/09/2014_zzsite_graphics_00_badges_2014_0914_NL_school_supplies.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2014/09/2014_zzsite_graphics_00_badges_2014_0914_NL_school_supplies.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2014/09/2014_zzsite_graphics_00_badges_2014_0914_NL_school_supplies.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="2014 0914 NL school supplies" title="Donations for Back-to-school drive being accepted through virtual registry" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/12/donations-for-back-to-school-drive-being-accepted-through-virtual-registry/" rel="bookmark" title="Donations for Back-to-school drive being accepted through virtual registry">Donations for Back-to-school drive being accepted through virtual registry</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/10/apple-honda-donates-to-bread-and-more-kitchen-as-part-of-its-first-responder-fridays-program/" rel="bookmark" class="td-image-wrap" title="Apple Honda donates to Bread and More Kitchen as part of its &#8216;First Responder Fridays&#8217; program"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?w=2560&#038;quality=100&#038;ssl=1 2560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=1024%2C768&#038;quality=100&#038;ssl=1 1024w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=1536%2C1152&#038;quality=100&#038;ssl=1 1536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=2048%2C1536&#038;quality=100&#038;ssl=1 2048w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=1832%2C1374&#038;quality=100&#038;ssl=1 1832w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=1376%2C1032&#038;quality=100&#038;ssl=1 1376w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?w=1280&#038;quality=100&#038;ssl=1 1280w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/IMG-1408-scaled.jpg?w=1920&#038;quality=100&#038;ssl=1 1920w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Apple Honda donates to Bread and More Kitchen as part of its &#8216;First Responder Fridays&#8217; program" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/10/apple-honda-donates-to-bread-and-more-kitchen-as-part-of-its-first-responder-fridays-program/" rel="bookmark" title="Apple Honda donates to Bread and More Kitchen as part of its &#8216;First Responder Fridays&#8217; program">Apple Honda donates to Bread and More Kitchen as part of its &#8216;First Responder Fridays&#8217; program</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_5f45f4d6033a5" id="td_uid_14_5f45f4d609614" data-td_block_id="td_uid_13_5f45f4d6033a5" data-td_filter_value="" href="https://riverheadlocal.com/community/">All</a><a class="mega-menu-sub-cat-td_uid_13_5f45f4d6033a5" id="td_uid_15_5f45f4d6096a1" data-td_block_id="td_uid_13_5f45f4d6033a5" data-td_filter_value="128" href="https://riverheadlocal.com/community/announcements/">Announcements</a><a class="mega-menu-sub-cat-td_uid_13_5f45f4d6033a5" id="td_uid_16_5f45f4d60970d" data-td_block_id="td_uid_13_5f45f4d6033a5" data-td_filter_value="126" href="https://riverheadlocal.com/community/community-news/">Community News</a><a class="mega-menu-sub-cat-td_uid_13_5f45f4d6033a5" id="td_uid_17_5f45f4d60976b" data-td_block_id="td_uid_13_5f45f4d6033a5" data-td_filter_value="127" href="https://riverheadlocal.com/community/event-photos/">Event Photos</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_5f45f4d6033a5" data-td_block_id="td_uid_13_5f45f4d6033a5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_5f45f4d6033a5" data-td_block_id="td_uid_13_5f45f4d6033a5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100674" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100674"><a href="https://riverheadlocal.com/schools/">Schools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_18_5f45f4d623edd = new tdBlock();
block_td_uid_18_5f45f4d623edd.id = "td_uid_18_5f45f4d623edd";
block_td_uid_18_5f45f4d623edd.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"185","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_5f45f4d623edd_rand","tdc_css_class":"td_uid_18_5f45f4d623edd_rand","tdc_css_class_style":"td_uid_18_5f45f4d623edd_rand_style"}';
block_td_uid_18_5f45f4d623edd.td_column_number = "3";
block_td_uid_18_5f45f4d623edd.block_type = "td_block_mega_menu";
block_td_uid_18_5f45f4d623edd.post_count = "5";
block_td_uid_18_5f45f4d623edd.found_posts = "1825";
block_td_uid_18_5f45f4d623edd.header_color = "";
block_td_uid_18_5f45f4d623edd.ajax_pagination_infinite_stop = "";
block_td_uid_18_5f45f4d623edd.max_num_pages = "365";
tdBlocksArray.push(block_td_uid_18_5f45f4d623edd);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_18_5f45f4d623edd_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_18_5f45f4d623edd"><div id=td_uid_18_5f45f4d623edd class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/11/sports-clubs-musical-performances-field-trips-and-more-cut-from-2020-2021-contingent-budget/" rel="bookmark" class="td-image-wrap" title="Sports, clubs, musical performances, field trips and more cut from 2020-2021 contingent budget"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/04/IMG_4446.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Sports, clubs, musical performances, field trips and more cut from 2020-2021 contingent budget" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/11/sports-clubs-musical-performances-field-trips-and-more-cut-from-2020-2021-contingent-budget/" rel="bookmark" title="Sports, clubs, musical performances, field trips and more cut from 2020-2021 contingent budget">Sports, clubs, musical performances, field trips and more cut from 2020-2021 contingent budget</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/07/school-board-looks-to-preserve-varsity-sports-music-performances-as-it-carves-2-3-million-out-of-budget/" rel="bookmark" class="td-image-wrap" title="School board looks to preserve varsity sports, music performances as it carves $2.3 million out of budget"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1014_Riverhead_football.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1014_Riverhead_football.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1014_Riverhead_football.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1014_Riverhead_football.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1014_Riverhead_football.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1014_Riverhead_football.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1014_Riverhead_football.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/10/2017_1014_Riverhead_football.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="School board looks to preserve varsity sports, music performances as it carves $2.3 million out of budget" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/07/school-board-looks-to-preserve-varsity-sports-music-performances-as-it-carves-2-3-million-out-of-budget/" rel="bookmark" title="School board looks to preserve varsity sports, music performances as it carves $2.3 million out of budget">School board looks to preserve varsity sports, music performances as it carves $2.3 million out of budget</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/07/long-island-school-districts-can-reopen-for-in-person-instruction-this-september-cuomo-announces/" rel="bookmark" class="td-image-wrap" title="Long Island school districts can reopen for in-person instruction this September, Cuomo announces"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=1832%2C1374&#038;quality=100&#038;ssl=1 1832w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=1376%2C1032&#038;quality=100&#038;ssl=1 1376w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_359436314-scaled.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="2020_0713_school_face_masks_covid" title="Long Island school districts can reopen for in-person instruction this September, Cuomo announces" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/07/long-island-school-districts-can-reopen-for-in-person-instruction-this-september-cuomo-announces/" rel="bookmark" title="Long Island school districts can reopen for in-person instruction this September, Cuomo announces">Long Island school districts can reopen for in-person instruction this September, Cuomo announces</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/07/31/riverhead-school-reopening-plan-two-days-in-school-masks-required-opt-in-for-fully-remote/" rel="bookmark" class="td-image-wrap" title="Riverhead school reopening plan: Two days in school, masks required, opt-in for fully remote"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=1832%2C1374&#038;quality=100&#038;ssl=1 1832w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=1376%2C1032&#038;quality=100&#038;ssl=1 1376w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/AdobeStock_349237830-scaled.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead school reopening plan: Two days in school, masks required, opt-in for fully remote" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/07/31/riverhead-school-reopening-plan-two-days-in-school-masks-required-opt-in-for-fully-remote/" rel="bookmark" title="Riverhead school reopening plan: Two days in school, masks required, opt-in for fully remote">Riverhead school reopening plan: Two days in school, masks required, opt-in for fully remote</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/07/23/riverhead-high-school-earns-scholar-athlete-school-of-excellence-award/" rel="bookmark" class="td-image-wrap" title="Riverhead High School earns Scholar-Athlete School of Excellence award"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=687%2C514&#038;quality=100&#038;ssl=1 687w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0723_Riverhead-High-School-March-28-2020-file-photo-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead High School earns Scholar-Athlete School of Excellence award" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/07/23/riverhead-high-school-earns-scholar-athlete-school-of-excellence-award/" rel="bookmark" title="Riverhead High School earns Scholar-Athlete School of Excellence award">Riverhead High School earns Scholar-Athlete School of Excellence award</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_18_5f45f4d623edd" id="td_uid_19_5f45f4d627906" data-td_block_id="td_uid_18_5f45f4d623edd" data-td_filter_value="" href="https://riverheadlocal.com/schools/">All</a><a class="mega-menu-sub-cat-td_uid_18_5f45f4d623edd" id="td_uid_20_5f45f4d6279a2" data-td_block_id="td_uid_18_5f45f4d623edd" data-td_filter_value="187" href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a><a class="mega-menu-sub-cat-td_uid_18_5f45f4d623edd" id="td_uid_21_5f45f4d627a29" data-td_block_id="td_uid_18_5f45f4d623edd" data-td_filter_value="190" href="https://riverheadlocal.com/schools/mcgann-mercy-junior-senior-high-school/">McGann-Mercy Junior-Senior High School</a><a class="mega-menu-sub-cat-td_uid_18_5f45f4d623edd" id="td_uid_22_5f45f4d627ae2" data-td_block_id="td_uid_18_5f45f4d623edd" data-td_filter_value="15377" href="https://riverheadlocal.com/schools/peconic-community-school/">Peconic Community School</a><a class="mega-menu-sub-cat-td_uid_18_5f45f4d623edd" id="td_uid_23_5f45f4d627b8a" data-td_block_id="td_uid_18_5f45f4d623edd" data-td_filter_value="201" href="https://riverheadlocal.com/schools/riverhead-central-school-district/">Riverhead Central School District</a><a class="mega-menu-sub-cat-td_uid_18_5f45f4d623edd" id="td_uid_24_5f45f4d627c0c" data-td_block_id="td_uid_18_5f45f4d623edd" data-td_filter_value="199" href="https://riverheadlocal.com/schools/riverhead-central-school-district/aquebogue-elementary-school/">Aquebogue Elementary School</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_5f45f4d623edd" data-td_block_id="td_uid_18_5f45f4d623edd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_18_5f45f4d623edd" data-td_block_id="td_uid_18_5f45f4d623edd"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-120667" class="tablet-hidden menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-120667"><a href="https://riverheadlocal.com/business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_25_5f45f4d6460a1 = new tdBlock();
block_td_uid_25_5f45f4d6460a1.id = "td_uid_25_5f45f4d6460a1";
block_td_uid_25_5f45f4d6460a1.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"205","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_25_5f45f4d6460a1_rand","tdc_css_class":"td_uid_25_5f45f4d6460a1_rand","tdc_css_class_style":"td_uid_25_5f45f4d6460a1_rand_style"}';
block_td_uid_25_5f45f4d6460a1.td_column_number = "3";
block_td_uid_25_5f45f4d6460a1.block_type = "td_block_mega_menu";
block_td_uid_25_5f45f4d6460a1.post_count = "5";
block_td_uid_25_5f45f4d6460a1.found_posts = "511";
block_td_uid_25_5f45f4d6460a1.header_color = "";
block_td_uid_25_5f45f4d6460a1.ajax_pagination_infinite_stop = "";
block_td_uid_25_5f45f4d6460a1.max_num_pages = "103";
tdBlocksArray.push(block_td_uid_25_5f45f4d6460a1);
</script><div class="td_block_wrap td_block_mega_menu td_uid_25_5f45f4d6460a1_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_25_5f45f4d6460a1"><div id=td_uid_25_5f45f4d6460a1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/19/commercial-gyms-can-reopen-monday-in-suffolk-county-announces-procedures-and-guidelines-for-reopening/" rel="bookmark" class="td-image-wrap" title="Commercial gyms can reopen Monday in Suffolk; county announces procedures and guidelines for reopening"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0819_gym_workout_COVID_mask.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Commercial gyms can reopen Monday in Suffolk; county announces procedures and guidelines for reopening" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/19/commercial-gyms-can-reopen-monday-in-suffolk-county-announces-procedures-and-guidelines-for-reopening/" rel="bookmark" title="Commercial gyms can reopen Monday in Suffolk; county announces procedures and guidelines for reopening">Commercial gyms can reopen Monday in Suffolk; county announces procedures and guidelines for reopening</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/17/planet-fitness-gets-ready-to-open-its-new-riverhead-location/" rel="bookmark" class="td-image-wrap" title="Planet Fitness gets ready to open its new Riverhead location"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=912%2C679&#038;quality=100&#038;ssl=1 912w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0817_Planet-Fitness_2-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Planet Fitness gets ready to open its new Riverhead location" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/17/planet-fitness-gets-ready-to-open-its-new-riverhead-location/" rel="bookmark" title="Planet Fitness gets ready to open its new Riverhead location">Planet Fitness gets ready to open its new Riverhead location</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/17/gyms-can-start-reopening-as-soon-as-next-week-with-restrictions-cuomo-says/" rel="bookmark" class="td-image-wrap" title="Gyms can start reopening as soon as next week with restrictions, Cuomo says"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0708_gym_fitness.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Gyms can start reopening as soon as next week with restrictions, Cuomo says" /></a></div> </div>
<div class="item-details">
 <h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/17/gyms-can-start-reopening-as-soon-as-next-week-with-restrictions-cuomo-says/" rel="bookmark" title="Gyms can start reopening as soon as next week with restrictions, Cuomo says">Gyms can start reopening as soon as next week with restrictions, Cuomo says</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/14/pandemic-brought-radical-changes-for-long-islands-last-surviving-duck-farm/" rel="bookmark" class="td-image-wrap" title="Pandemic brought &#8216;radical changes&#8217; for Long Island&#8217;s last surviving duck farm"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=687%2C520&#038;quality=100&#038;ssl=1 687w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_crescent-duck-farm-duck-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Pandemic brought &#8216;radical changes&#8217; for Long Island&#8217;s last surviving duck farm" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/14/pandemic-brought-radical-changes-for-long-islands-last-surviving-duck-farm/" rel="bookmark" title="Pandemic brought &#8216;radical changes&#8217; for Long Island&#8217;s last surviving duck farm">Pandemic brought &#8216;radical changes&#8217; for Long Island&#8217;s last surviving duck farm</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/14/bowling-alleys-can-reopen-monday-with-guidance-on-gyms-to-follow-cuomo-says/" rel="bookmark" class="td-image-wrap" title="Bowling alleys can reopen Monday, with guidance on gyms to follow, Cuomo says"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0814_All-Star-8.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Bowling alleys can reopen Monday, with guidance on gyms to follow, Cuomo says" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/14/bowling-alleys-can-reopen-monday-with-guidance-on-gyms-to-follow-cuomo-says/" rel="bookmark" title="Bowling alleys can reopen Monday, with guidance on gyms to follow, Cuomo says">Bowling alleys can reopen Monday, with guidance on gyms to follow, Cuomo says</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5f45f4d6460a1" data-td_block_id="td_uid_25_5f45f4d6460a1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_25_5f45f4d6460a1" data-td_block_id="td_uid_25_5f45f4d6460a1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100676" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100676"><a href="https://riverheadlocal.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_26_5f45f4d64ab5e = new tdBlock();
block_td_uid_26_5f45f4d64ab5e.id = "td_uid_26_5f45f4d64ab5e";
block_td_uid_26_5f45f4d64ab5e.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"81","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_26_5f45f4d64ab5e_rand","tdc_css_class":"td_uid_26_5f45f4d64ab5e_rand","tdc_css_class_style":"td_uid_26_5f45f4d64ab5e_rand_style"}';
block_td_uid_26_5f45f4d64ab5e.td_column_number = "3";
block_td_uid_26_5f45f4d64ab5e.block_type = "td_block_mega_menu";
block_td_uid_26_5f45f4d64ab5e.post_count = "5";
block_td_uid_26_5f45f4d64ab5e.found_posts = "921";
block_td_uid_26_5f45f4d64ab5e.header_color = "";
block_td_uid_26_5f45f4d64ab5e.ajax_pagination_infinite_stop = "";
block_td_uid_26_5f45f4d64ab5e.max_num_pages = "185";
tdBlocksArray.push(block_td_uid_26_5f45f4d64ab5e);
</script>  <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_26_5f45f4d64ab5e_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_26_5f45f4d64ab5e"><div id=td_uid_26_5f45f4d64ab5e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/23/to-mask-or-not-to-mask/" rel="bookmark" class="td-image-wrap" title="To mask or not to mask?"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0823_1918_flu-masks.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0823_1918_flu-masks.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0823_1918_flu-masks.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0823_1918_flu-masks.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0823_1918_flu-masks.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0823_1918_flu-masks.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0823_1918_flu-masks.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0823_1918_flu-masks.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="To mask or not to mask?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/23/to-mask-or-not-to-mask/" rel="bookmark" title="To mask or not to mask?">To mask or not to mask?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/19/riverhead-teacher-and-covid-survivor-urges-kindness-respect-and-trust/" rel="bookmark" class="td-image-wrap" title="Riverhead teacher and COVID survivor urges kindness,  respect and trust"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_332255285-scaled-e1597840125529.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_332255285-scaled-e1597840125529.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_332255285-scaled-e1597840125529.jpeg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead teacher and COVID survivor urges kindness,  respect and trust" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/19/riverhead-teacher-and-covid-survivor-urges-kindness-respect-and-trust/" rel="bookmark" title="Riverhead teacher and COVID survivor urges kindness,  respect and trust">Riverhead teacher and COVID survivor urges kindness, respect and trust</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/19/long-islanders-deserve-real-lipa-pseg-li-reform/" rel="bookmark" class="td-image-wrap" title="Long Islanders deserve real LIPA/PSEG-LI reform"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0808_Isaias_BESCO-crews-from-Tennessee_Osprey-Avenue-Riverhead-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Long Islanders deserve real LIPA/PSEG-LI reform" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/19/long-islanders-deserve-real-lipa-pseg-li-reform/" rel="bookmark" title="Long Islanders deserve real LIPA/PSEG-LI reform">Long Islanders deserve real LIPA/PSEG-LI reform</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/19/libertarian-candidate-put-country-before-party/" rel="bookmark" class="td-image-wrap" title="Libertarian candidate: Put country before party"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/08/2019_0819_Van_HelmondJuly-4-2019-1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Libertarian candidate: Put country before party" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/19/libertarian-candidate-put-country-before-party/" rel="bookmark" title="Libertarian candidate: Put country before party">Libertarian candidate: Put country before party</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/09/honor-his-honors-memory-replace-that-court/" rel="bookmark" class="td-image-wrap" title="Honor his honor&#8217;s memory: Replace that court"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2014_1110_justice_court.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2014_1110_justice_court.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2014_1110_justice_court.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2014_1110_justice_court.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2014_1110_justice_court.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2014_1110_justice_court.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/05/2014_1110_justice_court.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Honor his honor&#8217;s memory: Replace that court" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/09/honor-his-honors-memory-replace-that-court/" rel="bookmark" title="Honor his honor&#8217;s memory: Replace that court">Honor his honor&#8217;s memory: Replace that court</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_26_5f45f4d64ab5e" id="td_uid_27_5f45f4d64cf35" data-td_block_id="td_uid_26_5f45f4d64ab5e" data-td_filter_value="" href="https://riverheadlocal.com/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_26_5f45f4d64ab5e" id="td_uid_28_5f45f4d64cfa3" data-td_block_id="td_uid_26_5f45f4d64ab5e" data-td_filter_value="91" href="https://riverheadlocal.com/opinion/civiletti/">Denise Civiletti</a><a class="mega-menu-sub-cat-td_uid_26_5f45f4d64ab5e" id="td_uid_29_5f45f4d64d02a" data-td_block_id="td_uid_26_5f45f4d64ab5e" data-td_filter_value="12894" href="https://riverheadlocal.com/opinion/greg-blass/">Greg Blass</a><a class="mega-menu-sub-cat-td_uid_26_5f45f4d64ab5e" id="td_uid_30_5f45f4d64d07e" data-td_block_id="td_uid_26_5f45f4d64ab5e" data-td_filter_value="99" href="https://riverheadlocal.com/opinion/in-my-opinion/">In My Opinion</a><a class="mega-menu-sub-cat-td_uid_26_5f45f4d64ab5e" id="td_uid_31_5f45f4d64d0ce" data-td_block_id="td_uid_26_5f45f4d64ab5e" data-td_filter_value="98" href="https://riverheadlocal.com/opinion/java-scripts/">Java Scripts</a><a class="mega-menu-sub-cat-td_uid_26_5f45f4d64ab5e" id="td_uid_32_5f45f4d64d14a" data-td_block_id="td_uid_26_5f45f4d64ab5e" data-td_filter_value="16086" href="https://riverheadlocal.com/opinion/katie-blasl/">Katie Blasl</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_26_5f45f4d64ab5e" data-td_block_id="td_uid_26_5f45f4d64ab5e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_26_5f45f4d64ab5e" data-td_block_id="td_uid_26_5f45f4d64ab5e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100677" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100677"><a href="https://riverheadlocal.com/living/">Living</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_33_5f45f4d662026 = new tdBlock();
block_td_uid_33_5f45f4d662026.id = "td_uid_33_5f45f4d662026";
block_td_uid_33_5f45f4d662026.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9530","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_33_5f45f4d662026_rand","tdc_css_class":"td_uid_33_5f45f4d662026_rand","tdc_css_class_style":"td_uid_33_5f45f4d662026_rand_style"}';
block_td_uid_33_5f45f4d662026.td_column_number = "3";
block_td_uid_33_5f45f4d662026.block_type = "td_block_mega_menu";
block_td_uid_33_5f45f4d662026.post_count = "5";
block_td_uid_33_5f45f4d662026.found_posts = "583";
block_td_uid_33_5f45f4d662026.header_color = "";
block_td_uid_33_5f45f4d662026.ajax_pagination_infinite_stop = "";
block_td_uid_33_5f45f4d662026.max_num_pages = "117";
tdBlocksArray.push(block_td_uid_33_5f45f4d662026);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_33_5f45f4d662026_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_33_5f45f4d662026"><div id=td_uid_33_5f45f4d662026 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/16/one-day-at-a-time-takes-on-new-meaning-in-pandemic-life/" rel="bookmark" class="td-image-wrap" title="One day at a time takes on new meaning in pandemic life"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020-0802_-sunrise_roanoke-landing.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="One day at a time takes on new meaning in pandemic life" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/16/one-day-at-a-time-takes-on-new-meaning-in-pandemic-life/" rel="bookmark" title="One day at a time takes on new meaning in pandemic life">One day at a time takes on new meaning in pandemic life</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/09/in-the-new-normal-where-would-we-be-without-video/" rel="bookmark" class="td-image-wrap" title="In the new normal, where would we be without video?"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/Grandmother-child-video-chat.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="In the new normal, where would we be without video?" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/09/in-the-new-normal-where-would-we-be-without-video/" rel="bookmark" title="In the new normal, where would we be without video?">In the new normal, where would we be without video?</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/08/02/pandemic-life-simple-things-bring-great-joy/" rel="bookmark" class="td-image-wrap" title="Pandemic life: Simple things bring great joy"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/08/2020_0802_Benthal_chickens.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Pandemic life: Simple things bring great joy" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/08/02/pandemic-life-simple-things-bring-great-joy/" rel="bookmark" title="Pandemic life: Simple things bring great joy">Pandemic life: Simple things bring great joy</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/07/19/yes-you-should-wear-a-mask/" rel="bookmark" class="td-image-wrap" title="Yes, you should wear a mask"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/2020_0719_Benthals_Masked.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Yes, you should wear a mask" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/07/19/yes-you-should-wear-a-mask/" rel="bookmark" title="Yes, you should wear a mask">Yes, you should wear a mask</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/07/11/lessons-learned-while-covid-binge-watching/" rel="bookmark" class="td-image-wrap" title="Lessons learned while COVID binge-watching"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/07/Woman-watching-TV-Adobe-Stock-7.11.2020.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Lessons learned while COVID binge-watching" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/07/11/lessons-learned-while-covid-binge-watching/" rel="bookmark" title="Lessons learned while COVID binge-watching">Lessons learned while COVID binge-watching</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_33_5f45f4d662026" id="td_uid_34_5f45f4d66354e" data-td_block_id="td_uid_33_5f45f4d662026" data-td_filter_value="" href="https://riverheadlocal.com/living/">All</a><a class="mega-menu-sub-cat-td_uid_33_5f45f4d662026" id="td_uid_35_5f45f4d6635b8" data-td_block_id="td_uid_33_5f45f4d662026" data-td_filter_value="100" href="https://riverheadlocal.com/living/bits-and-pieces/">Bits and Pieces</a><a class="mega-menu-sub-cat-td_uid_33_5f45f4d662026" id="td_uid_36_5f45f4d66360f" data-td_block_id="td_uid_33_5f45f4d662026" data-td_filter_value="94" href="https://riverheadlocal.com/living/laurie-nigro/">Laurie Nigro</a><a class="mega-menu-sub-cat-td_uid_33_5f45f4d662026" id="td_uid_37_5f45f4d6636a1" data-td_block_id="td_uid_33_5f45f4d662026" data-td_filter_value="38" href="https://riverheadlocal.com/living/life-on-purpose/">Life On Purpose</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_33_5f45f4d662026" data-td_block_id="td_uid_33_5f45f4d662026"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_33_5f45f4d662026" data-td_block_id="td_uid_33_5f45f4d662026"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-76334" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76334"><a target="_blank" href="http://eastendlocal.com/events">Events</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
<div class="breaking-menu-wrap">
<div class="menu-coronavirus-container"><ul id="menu-coronavirus" class="breaking-menu sf-menu"><li id="menu-item-134795" class="breaking-main menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-134795"><a href="https://riverheadlocal.com/coronavirus/">Coronavirus</a></li>
<li id="menu-item-134924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-134924"><a href="https://riverheadlocal.com/coronavirus/#latest-news">Latest updates</a></li>
<li id="menu-item-134797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134797"><a href="https://riverheadlocal.com/coronavirus/">Maps &#038; charts</a></li>
</ul></div> </div>
</div>
</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap broadstreet banner ">
<div class="kb-header-ad"><span class="text"></span> <div class="textwidget"><broadstreet-zone zone-id="68458" count="1"></broadstreet-zone></div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-container td-post-template-3">
<div class="td-container-border">
<article id="post-136985" class="post-136985 post type-post status-publish format-standard has-post-thumbnail hentry category-local-news tag-black-lives-matter tag-featured tag-law-enforcement-bill-of-rights tag-lee-zeldin author-denise-civiletti" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header td-pb-padding-side">
<ul class="td-category"><li class="entry-category"><a href="https://riverheadlocal.com/news/">News</a></li><li class="entry-category"><a href="https://riverheadlocal.com/news/local-news/">Local News</a></li></ul>
<header>
<h1 class="entry-title">Zeldin introduces resolution urging creation of law enforcement &#8216;bill of rights&#8217;</h1>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://riverheadlocal.com/author/denise-2/" title="Posts by Denise Civiletti" class="author url fn" rel="author">Denise Civiletti</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-08-25T18:13:41+00:00">Aug 25, 2020, 6:13 pm</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-featured-image"><figure><a href="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?fit=800%2C533&quality=100&ssl=1" data-caption="NYPD officers Peter Cybulski (left), and Harmeed Armani (right)  with Rep. Lee Zeldin at the 2017 Riverhead Kiwanis Breakfast of Stars.    File photo: April Pokorny"><img width="681" height="454" class="entry-thumb td-modal-image" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=681%2C454&quality=100&ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?w=800&quality=100&ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=270%2C180&quality=100&ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=768%2C512&quality=100&ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=630%2C420&quality=100&ssl=1 630w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=640%2C426&quality=100&ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?resize=681%2C454&quality=100&ssl=1 681w" sizes="(max-width: 681px) 100vw, 681px" alt="" title="2017_0424_Kiwanis_Breakfast_of_Stars-Zeldin_Lee_Cybulski_peter" /></a><figcaption class="wp-caption-text">NYPD officers Peter Cybulski (left), and Harmeed Armani (right) with Rep. Lee Zeldin at the 2017 Riverhead Kiwanis Breakfast of Stars. File photo: April Pokorny</figcaption></figure></div>
<div class="td-post-content td-pb-padding-side">
<p>First Congressional District Rep. Lee Zeldin (R-Shirley) has introduced a resolution in the House of Representatives denouncing calls to “defund, disband, dismantle or abolish” law enforcement and encouraging states to adopt statutes to establish &#8220;essential rights for law enforcement officers.&#8221;
<p>Zeldin’s resolution comes after a wave of national protests against police brutality, set off by the death of George Floyd, a Minneapolis man who died in police custody on May 25. Floyd’s killing has provoked outrage across the country and around the world, leading to widespread protests that still continue months later.
<p>Black Lives Matter, one of the groups organizing the protests, <a href="https://blacklivesmatter.com/defundthepolice/">began a petition</a> on May 30 calling to defund the police.<broadstreet-zone alt-zone-id="68459" class="mobile-ad" count="1"></broadstreet-zone>
<p>“We call for a national defunding of police. We demand investment in our communities and the resources to ensure Black people not only survive, but thrive,” Black Lives Matter’s website reads.
<p>Most elected officials — Democrats and Republicans alike — at all levels of government, have rebuffed calls to defund or dismantle police departments.
<p>Zeldin’s resolution urges establishing a “bill of rights” for law enforcement officers. Currently, 16 states have adopted similar laws.
<p>“Our nation’s law enforcement officers put their lives on the line each and every day to defend ours, and they have earned nothing but our full support. In doing so, we must ensure that both our great law enforcement officers and the people they serve are protected,” Zeldin said in a statement. <broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<p>The resolution states:
<ol><li>The law enforcement officer should have an inherent right to self-defense against physical threats; </li><li>The law enforcement officer should have the right to legal recourse if a civilian attempts to assault the law enforcement officer; </li><li>Physical harassment targeting the law enforcement officer should not be permitted; </li><li>The law enforcement officer should have the right to equipment necessary for personal protection; </li><li>The law enforcement officer should have the right to counsel and/or a union representative present at any interview conducted as part of an investigation;</li><li>The law enforcement officer should have a right to be informed of the nature of the investigation before any interview commences, including the name of the complainant and sufficient information to reasonably apprise the officer of the allegations; </li><li>During questioning in the course of an investigation, the law enforcement officer should not be subjected to any offensive language, nor should be threatened with departmental, civil or criminal charges, nor receive financial or promotional inducement: </li><li>The law enforcement officer should be entitled to a hearing, with notification in advance of the date, access to transcripts and other relevant documents and evidence; </li><li>The law enforcement officer should have the opportunity to respond to adverse accusations; </li><li>The law enforcement officer should not be disciplined for exercising a Fifth Amendment right to remain silent unless granted immunity that such statements will not be used against the officer in any criminal proceeding; </li></ol>
<p>“This resolution makes it clear we will not stand idly by while some attempt to ‘defund’ and ‘abolish’ our law enforcement officers. We must defend our great law enforcement officers, while recognizing the important relationship between law enforcement and the communities they serve,” Zeldin said.
<p>Zeldin introduced the resolution on Aug. 22. It was referred to the Judiciary Committee for consideration.
<p>The congressman announced the resolution in a press release this afternoon. He said it has been endorsed by the Suffolk County Police Benevolent Association, the National Association for Police Officers, the National Sheriffs Association and the Fraternal Order of Police. <broadstreet-zone alt-zone-id="68460" class="mobile-ad" count="1"></broadstreet-zone>
<p>Zeldin&#8217;s announcement came two days after police in Kenosha, Wisconsin, shot a Black man in the back multiple times at close range Sunday afternoon. The shooting was captured on video from a nearby apartment building. Jake Blake, 29, survived the shooting and is in serious but stable condition in a Milwaukee hospital, where he has undergone surgery. The shooting touched off protests in Kenosha, Wisconsin and across the country. Protests in Kenosha started out peacefully but turned violent, with looting and fires destroying some stores.
<p>The congressman is currently seeking his fourth term of office. His re-election bid has been endorsed by numerous law enforcement agencies on Long Island and in New York State, including: Suffolk County PBA, Suffolk County Superior Officers Association, Suffolk County Probation Officers Association, Suffolk County Police Conference, Suffolk County Detective Association, Suffolk County Detective Investigators PBA, Police Benevolent Association of New York State, New York State Association of PBAs, Suffolk County Deputy Sheriffs&#8217; PBA, Suffolk County Correction Officers Association, Nassau County PBA and Police Conference of New York.
<div class="kb-member-content-box"><p><strong><span style="font-size:20px; line-height: 40px;">We need your help.</span></strong><br />Now more than ever, the survival of quality local journalism depends on your support. Our community faces unprecedented economic disruption, and the future of many small businesses are under threat, including our own. It takes time and resources to provide this service. We are a small family-owned operation, and we will do everything in our power to keep it going. But today more than ever before, we will depend on your support to continue. <strong><a href="/support-local-journalism">Support RiverheadLOCAL today.</a></strong> You rely on us to stay informed and we depend on you to make our work possible.</p></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
</div> </div>
<footer>
<div class="td-post-source-tags td-pb-padding-side">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://riverheadlocal.com/topic/black-lives-matter/">Black Lives Matter</a></li><li><a href="https://riverheadlocal.com/topic/featured/">featured</a></li><li><a href="https://riverheadlocal.com/topic/law-enforcement-bill-of-rights/">law enforcement bill of rights</a></li><li><a href="https://riverheadlocal.com/topic/lee-zeldin/">Lee Zeldin</a></li></ul> </div>
<div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-twitter" style="overflow: visible;"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/" data-text="Zeldin introduces resolution urging creation of law enforcement &#8216;bill of rights&#8217;" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li class="td-classic-facebook" style="overflow: visible;"><div class="fb-like" data-href="https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/" data-layout="button_count" data-action="like" data-show-faces="false"></div></li></ul></div></div> <div class="author-box-wrap"><a href="https://riverheadlocal.com/author/denise-2/"><img src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/09/DC-avatar.png?fit=96%2C96&quality=100&ssl=1" width="96" height="96" alt="Denise Civiletti" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://riverheadlocal.com/author/denise-2/">Denise Civiletti</a></span></div><div class="td-author-description">Denise is a veteran local reporter, editor, attorney and former Riverhead Town councilwoman. Her work has been recognized with numerous awards, including investigative reporting and writer of the year awards from the N.Y. Press Association. She is a founder, owner and co-publisher of this website.<a href="/cdn-cgi/l/email-protection#7d191813140e183d0f140b180f15181c1911121e1c11531e1210">Email Denise.</a></div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/civiletti" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Denise Civiletti"></span><meta itemprop="datePublished" content="2020-08-25T18:13:41+00:00"><meta itemprop="dateModified" content="2020-08-25T18:13:50-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png"></span><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="headline " content="Zeldin introduces resolution urging creation of law enforcement &#039;bill of rights&#039;"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Kiwanis_Breakfast_of_Stars-05.jpg?fit=800%2C533&quality=100&ssl=1"><meta itemprop="width" content="800"><meta itemprop="height" content="533"></span> </footer>
<div class="fb-comments" data-href="https://riverheadlocal.com/2020/08/25/zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights/" data-width="100%" data-mobile="true" data-numposts="10" data-order-by="social" data-colorscheme="light"></div> </div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68459" count="1"></broadstreet-zone></div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="kb-popout-content td-pb-row">
<div class="wpb_wrapper">
<div class="wpb_text_column block-header">
<p>Daily Newsletter</p>
</div>
<div class="wpb_wrapper wpb_text_column td-pb-border-top">
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://riverheadlocal.us6.list-manage.com/subscribe/post?u=47e88a318d72559c43e4b77bc&amp;id=8118172d70" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div class="mc-field-group first-name"><label for="mce-FNAME">First Name </label><br />
<input id="mce-FNAME" class="required" name="FNAME" type="text" value="" /></div>
<div class="mc-field-group last-name"><label for="mce-LNAME">Last Name </label><br />
<input id="mce-LNAME" class="required" name="LNAME" type="text" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_47e88a318d72559c43e4b77bc_8118172d70" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p>
</div>
</div>
</div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68461" count="1"></broadstreet-zone></div>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div>
</div> 


<div class="td-footer-container td-container td-footer-template-10">
<div class="footer-social-wrap td-social-style2 td-footer-full">
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer1-container"><ul id="menu-footer1" class="td-subfooter-menu"><li id="menu-item-132939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-132939"><a href="https://riverheadlocal.com/copyright-notice/">© 2010-2020 East End Local Media Corp</a></li>
<li id="menu-item-132941" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132941"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-132940" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132940"><a href="https://riverheadlocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-132944" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132944"><a href="https://riverheadlocal.com/comments-policy/">Comments Policy</a></li>
<li id="menu-item-132945" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132945"><a href="https://riverheadlocal.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
 <div class="td-pb-span4 td-sub-footer-copy">
<div class="td-pb-padding-side">
</div>
</div>
</div>
</div>
</div>
</div>
<div class="a2a_kit a2a_kit_size_36 a2a_floating_style a2a_vertical_style" style="left:0px;top:400px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;left:5px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F08%2F25%2Fzeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights%2F&amp;linkname=Zeldin%20introduces%20resolution%20urging%20creation%20of%20law%20enforcement%20%26%23039%3Bbill%20of%20rights%26%23039%3B%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><a rel="nofollow" style="display:none;" href="https://riverheadlocal.com/?blackhole=0e5efc40a0" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','local-news','news','zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["local-news","news","zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights","post"],"url":"zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({"useAltZone":767,"altZoneWhitelist":[71281],"networkId":"4821","targets":{"pagetype":["post","not_home_page"],"category":["local-news","news","zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights","post"],"url":"zeldin-introduces-resolution-urging-creation-of-law-enforcement-bill-of-rights"}});
 });</script>

<script type="text/javascript">(function($) {
  $.fn.almComplete = function(alm){
    
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");


      

    var $pageNumber;
    if ($('.kb-alm-wrap-page-3').length) {
        $pageNumber = 3; 
       // console.log("We're on page 3");
    } else if ($('.kb-alm-wrap-page-2').length) {
        $pageNumber = 2;
        // console.log("We're on page 2");
    } else {
        $pageNumber = 1;
        // console.log("We're on page 1");
    }
    
    // Parse FB comments code
    
    var $newContainerString = '.alm-page-' + $pageNumber;
    var $newContainer = $($newContainerString).parent();

    FB.XFBML.parse($newContainer[0]);
    
    // Append alm button to wrapper
    
    var $new_name = '.kb-alm-wrap-page-' + $pageNumber;
    // $('.alm-btn-wrap').detach();
    // $('.alm-btn-wrap').appendTo($new_name);
  
    // console.log("Button moved!");
    
    for ( var i = 0; i < tdSmartSidebar.items.length; i++ ) {
                    if ( 'case_3_bottom_of_content' === tdSmartSidebar.items[ i ].sidebar_state ) {
                        tdSmartSidebar.items[ i ].sidebar_state = 'case_1_fixed_down';
                       //  console.log("fixed down!");
                    }
                }
                
    var base_url = "https://riverheadlocal.com";
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.js" );
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js" );
//    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/jquery-3.1.1.min.js" );

   // console.log("Alm complte!");
   var jigs = jQuery('.justified-image-grid');
    if(jigs.length !== 0){
       jigs.data('justifiedImageGrid').createGallery('resize');
    }
  };
})(jQuery);

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");
    
 /*  $( 'body' ).on( 'post-load', function() {
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      } ); 
    // type = From which addon (previous-post | seo)
    // permalink = the updated url
    console.log("URL updated to " + permalink + '- dispatched from the '+ type + ' add-on.'); */
  }; 
})(jQuery);

(function($) {
    $(window).load(function(){
  // $('.alm-btn-wrap').appendTo($('.kb-alm-wrap'));
   // console.log("Button moved!");
});
})(jQuery);</script> 
<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-aJ5TJKLfrG9cB",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-aJ5TJKLfrG9cB.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<link rel='stylesheet' id='photoswipe-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/css/photoswipe4.css?ver=4.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/wpdialog.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/sticky-kit.js?ver=1.0.6'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"496bb17f48","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/photoswipe4.min.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/jquery.dotdotdot.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js?ver=3.9.5'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://riverheadlocal.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202035.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'77146263',post:'136985',tz:'-4',srv:'riverheadlocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '77146263', '136985' ]);
</script>
</body>
</html>