<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Man involved in high-speed chase that led to police crash is arrested: Southold Police | RiverheadLOCAL</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<link rel="pingback" href="https://riverheadlocal.com/xmlrpc.php" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<meta property="og:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?fit=747%2C533&quality=100&ssl=1" /><link rel="icon" type="image/png" href="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/04/favicon.png">

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Man involved in high-speed chase that led to police crash is arrested: Southold Police | RiverheadLOCAL" />
<meta property="og:description" content="A Middle Island man, 40, is facing burglary and other charges after leading police on high-speed chase Tuesday afternoon. He abandoned the vehicle in a downtown Riverhead parking lot and fled on foot, police said." />
<meta property="og:url" content="https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/" />
<meta property="og:site_name" content="RiverheadLOCAL" />
<meta property="article:tag" content="featured" />
<meta property="article:tag" content="Riverhead Town Police" />
<meta property="article:tag" content="Southold Town police" />
<meta property="article:section" content="Breaking News" />
<meta property="article:published_time" content="2020-04-03T13:40:19+00:00" />
<meta property="article:modified_time" content="2020-04-03T20:02:23+00:00" />
<meta property="og:updated_time" content="2020-04-03T20:02:23+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="A Middle Island man, 40, is facing burglary and other charges after leading police on high-speed chase Tuesday afternoon. He abandoned the vehicle in a downtown Riverhead parking lot and fled on foot, police said." />
<meta name="twitter:title" content="Man involved in high-speed chase that led to police crash is arrested: Southold Police | RiverheadLOCAL" />
<meta name="twitter:image" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?fit=747%2C533&#038;quality=100&#038;ssl=1" />
<meta name="twitter:creator" content="@civiletti" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://riverheadlocal.com/#website","url":"https://riverheadlocal.com/","name":"RiverheadLOCAL","inLanguage":"en-US","description":"News and events for Riverhead, New York","potentialAction":[{"@type":"SearchAction","target":"https://riverheadlocal.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?fit=747%2C533&quality=100&ssl=1","width":747,"height":533},{"@type":"WebPage","@id":"https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/#webpage","url":"https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/","name":"Man involved in high-speed chase that led to police crash is arrested: Southold Police | RiverheadLOCAL","isPartOf":{"@id":"https://riverheadlocal.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/#primaryimage"},"datePublished":"2020-04-03T13:40:19+00:00","dateModified":"2020-04-03T20:02:23+00:00","author":{"@id":"https://riverheadlocal.com/#/schema/person/0a12b5636fa3908dcd3ed4af34d1ae3d"},"potentialAction":[{"@type":"ReadAction","target":["https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/"]}]},{"@type":["Person"],"@id":"https://riverheadlocal.com/#/schema/person/0a12b5636fa3908dcd3ed4af34d1ae3d","name":"Denise Civiletti","image":{"@type":"ImageObject","@id":"https://riverheadlocal.com/#authorlogo","inLanguage":"en-US","url":"https://riverheadlocal.com/wp-content/uploads/2018/09/DC-avatar.png","caption":"Denise Civiletti"},"description":"Denise is a veteran local reporter, editor,  attorney and former Riverhead Town councilwoman. Her work has been recognized with numerous awards, including investigative reporting and writer of the year awards from the N.Y. Press Association. She is a founder, owner and co-publisher of this website.<a href=\"mailto:denise@riverheadlocal.com\">Email Denise.</a>","sameAs":["https://twitter.com/@civiletti"]}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Feed" href="https://riverheadlocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RiverheadLOCAL &raquo; Comments Feed" href="https://riverheadlocal.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='kb-membership-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-membership/inc/style.css?ver=6.1.991' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/jquery-ui-dialog.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='fc-form-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/Formcraft/assets/css/form.min.css?ver=3.2.27' type='text/css' media='all' />
<link rel='stylesheet' id='kb-liveblog-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-liveblog/style.css?ver=6.0.200' type='text/css' media='all' />
<link rel='stylesheet' id='public_notices_css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-public-notices/kb-public-notices.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-top-stories-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-top-stories/style.css?ver=1.1.735' type='text/css' media='all' />
<link rel='stylesheet' id='trans-frontend-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-translation/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-min-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/icons/css/weather-icons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-wind-min-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/icons/css/weather-icons-wind.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kb-weather-css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/css/kb-weather.css?ver=1.7.434' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/Newsmag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/style.css?ver=5.0.0210' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%2C100%2C100italic%2C200%2C200italic%2C300italic%2C400italic%2C500%2C500italic%2C600italic%2C700italic%2C800%2C800italic%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C100%2C100italic%2C200%2C200italic%2C500%2C500italic%2C600%2C600italic%2C800%2C800italic&#038;ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.22' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1125px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1124px){
.a2a_floating_style.a2a_default_style{display:none;}
}
.a2a_floating_style {
    padding: 20px;
    border-radius: 0;
    border: 1px solid #bbbbbb;
}
</style>
<link rel='stylesheet' id='js_composer_front-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/style.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-membership/inc/button.js?ver=6.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-liveblog/scripts.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/js/modernizr.custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/kb-weather/js/summary-box.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.25'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/common-scripts.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/popup-menu-fix.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://riverheadlocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverheadlocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverheadlocal.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://riverheadlocal.com/?p=134893' />
<link rel="alternate" type="application/json+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverheadlocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color = "#A0A0A0";

a2a_config.templates = {
    email: {
        subject: "RiverheadLOCAL: ${title}",
        body: "Check out this story on RiverheadLOCAL: \n${title}\n${link}"
    }
};

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      }; 
})(jQuery);
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>


<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Man involved in high-speed chase that led to police crash is arrested: Southold Police | RiverheadLOCAL","pagePostType":"post","pagePostType2":"single-post","pageCategory":["breaking-news"],"pageAttributes":["featured","riverhead-town-police","southold-town-police"],"pagePostAuthor":"Denise Civiletti","pagePostDate":"Apr 3, 2020, 9:40 am","pagePostDateYear":"2020","pagePostDateMonth":"04","pagePostDateDay":"03"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N97RFZC');//]]>
</script>


<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<script src="https://use.fontawesome.com/b3fb28acc8.js"></script><meta property="fb:app_id" content="105130769527571" /><meta name="google-site-verification" content="7jViI0XrkgkIYGyQD0GNoWcify30WyzN3o4ZHzUGfdo" /><script data-ad-client="ca-pub-6009741394491678" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var adSlotLeaderboard = googletag.defineSlot('/21874054635/Sitewide', [728, 90], 'div-gpt-ad-leaderboard');
    adSlotLeaderboard.addService(googletag.pubads());
    adSlotLeaderboard.setTargeting('position', ['leaderboard']);
    var adSlotSidebar1= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-1');
	    adSlotSidebar1.addService(googletag.pubads());
	    adSlotSidebar1.setTargeting('position', ['sidebar']);
	    var adSlotSidebar2= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-2');
	    adSlotSidebar2.addService(googletag.pubads());
	    adSlotSidebar2.setTargeting('position', ['sidebar']);
	    var adSlotSidebar3= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-3');
	    adSlotSidebar3.addService(googletag.pubads());
	    adSlotSidebar3.setTargeting('position', ['sidebar']);
	    var adSlotSidebar4= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-4');
	    adSlotSidebar4.addService(googletag.pubads());
	    adSlotSidebar4.setTargeting('position', ['sidebar']);
	    var adSlotSidebar5= googletag.defineSlot('/21874054635/Sitewide',[[300, 250],[300, 300],[300, 215],[300, 225],[300, 350],[300, 275],[300, 150]], 'div-gpt-ad-sidebar-5');
	    adSlotSidebar5.addService(googletag.pubads());
	    adSlotSidebar5.setTargeting('position', ['sidebar']);
	    var adSlotSidebar = googletag.defineSlot('/21874054635/Sitewide', ['fluid'], 'div-gpt-ad-lead-sidebar');
    adSlotSidebar.addService(googletag.pubads());
    adSlotSidebar.setTargeting('position', ['lead-sidebar']);
    
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://riverheadlocal.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '82fba20f-da37-4c38-a7fe-ee7dbe081e0f';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://riverheadlocal.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.370dd028-ab8a-4720-9087-4e2c917686de";
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

	        if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

	        if ( navigator.userAgent.indexOf("Edge") > -1 ) {
                htmlTag.className += ' ieEdge';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_ajax_url="https:\/\/riverheadlocal.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=4.3";
var td_get_template_directory_uri="https:\/\/riverheadlocal.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e12025";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<style>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</style>
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=32%2C32&#038;quality=100&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/favicon.png?fit=40%2C40&#038;quality=100&#038;ssl=1" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>
<body class="post-template-default single single-post postid-134893 single-format-standard author-denise-civiletti man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police global-block-template-1 white-menu wpb-js-composer js-comp-ver-6.1 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N97RFZC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="fb-root"></div>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '105130769527571',
      xfbml      : true,
      version    : 'v2.9'
    });
    FB.AppEvents.logPageView();
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div class="td-mobile-container">

<div class="kb-menu-socials-wrap">

<div class="kb-menu-socials">
</div>
</div>

<div class="kb-mobile-search-container"><form method="get" class="td-search-form-widget" action="https://riverheadlocal.com/">
<div role="search" class="kb-mobile-search">
<button class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit"><i class="td-icon-search"></i></button>
<div class="kb-search-input-wrap"><input class="td-widget-search-input" type="text" value="Search" name="s" id="s" onfocus="if (this.value=='Search') this.value='';" onblur="if (this.value=='') this.value='Search';" /></div>
</div>
</form>
</div>

<div class="td-mobile-content">
<div class="menu-mobile-container"><ul id="menu-mobile" class="td-mobile-main-menu"><li id="menu-item-116721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-116721"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100685" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100685"><a href="https://riverheadlocal.com/news/">News</a></li>
<li id="menu-item-100683" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-100683"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a></li>
<li id="menu-item-100686" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100686"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100687" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100687"><a href="https://riverheadlocal.com/community/">Community</a></li>
<li id="menu-item-100693" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-100693"><a href="http://eastendlocal.com">Events</a></li>
<li id="menu-item-100688" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100688"><a href="https://riverheadlocal.com/schools/">Schools</a></li>
<li id="menu-item-100684" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100684"><a href="https://riverheadlocal.com/business/business-news/">Business</a></li>
<li id="menu-item-100691" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100691"><a href="https://riverheadlocal.com/living/">Living</a></li>
<li id="menu-item-100692" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100692"><a href="https://riverheadlocal.com/opinion/">Opinion</a></li>
<li id="menu-item-100694" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100694"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-108418" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108418"><a href="https://classifieds.eastendlocal.com">Classifieds</a></li>
<li id="menu-item-100695" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-100695"><a href="https://riverheadlocal.com/contact/">Contact RiverheadLOCAL</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap">
<div class="td-outer-container">

<div id="kb-overlay"></div>
<div class="td-header-wrap td-header-style-3">
<div class="td-top-menu-full">
<div class="td-header-row td-header-top-menu td-make-full">
<div class="td-top-bar-container top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-100681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-100681"><a href="https://riverheadlocal.com/contact/">Contact</a></li>
<li id="menu-item-130976" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-130976"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-100680" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100680"><a href="https://riverheadlocal.com/weather/">Weather</a></li>
<li id="menu-item-24924" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24924"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/events">Events</a></li>
<li id="menu-item-116691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-116691"><a href="https://riverheadlocal.com/public-notices/">Public Notices</a></li>
<li id="menu-item-24925" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-24925"><a target="_blank" rel="noopener noreferrer" href="http://eastendlocal.com/classifieds/">Classifieds</a></li>
<li id="menu-item-129406" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129406"><a href="https://riverheadlocal.com/support-local-journalism/">Membership</a></li>
</ul></div></div> </div>

</div>
</div>

<div class="td-header-container">
<div class="td-header-logo-wrap">
<div class="td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
<span class="td-visual-hidden">RiverheadLOCAL</span>
</a>
</div>
<div class="td-header-right-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap">
<div class="td-header-row td-header-main-menu">
<div class="td-header-menu-wrap-sub">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-header-right-header mobile-header">
<div class="td-header-right ">
<div class="textwidget"><h3>We need your help.</h3>
<p>Now more than ever, local news matters.</p>
<p class="mobile-true"><a href="/support-local-journalism"><button>Support us</button></a></p>
</div>
</div> </div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://riverheadlocal.com/">
<img class="td-retina-data" data-retina="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" src="https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png" alt="" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main" class="sf-menu"><li id="menu-item-100668" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-100668"><a href="https://riverheadlocal.com/">Home</a></li>
<li id="menu-item-100671" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100671"><a href="https://riverheadlocal.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_1_5e87c3a7ab397 = new tdBlock();
block_td_uid_1_5e87c3a7ab397.id = "td_uid_1_5e87c3a7ab397";
block_td_uid_1_5e87c3a7ab397.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"103","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5e87c3a7ab397_rand","tdc_css_class":"td_uid_1_5e87c3a7ab397_rand","tdc_css_class_style":"td_uid_1_5e87c3a7ab397_rand_style"}';
block_td_uid_1_5e87c3a7ab397.td_column_number = "3";
block_td_uid_1_5e87c3a7ab397.block_type = "td_block_mega_menu";
block_td_uid_1_5e87c3a7ab397.post_count = "5";
block_td_uid_1_5e87c3a7ab397.found_posts = "6180";
block_td_uid_1_5e87c3a7ab397.header_color = "";
block_td_uid_1_5e87c3a7ab397.ajax_pagination_infinite_stop = "";
block_td_uid_1_5e87c3a7ab397.max_num_pages = "1236";
tdBlocksArray.push(block_td_uid_1_5e87c3a7ab397);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_1_5e87c3a7ab397_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_5e87c3a7ab397"><div id=td_uid_1_5e87c3a7ab397 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/03/suffolk-county-tops-10000-coronavirus-cases-with-local-hospitals-running-out-of-icu-beds/" rel="bookmark" class="td-image-wrap" title="Suffolk County tops 10,000 coronavirus cases with local hospitals running out of ICU beds"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/Coronavirus-Graphic-7.png?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Suffolk County tops 10,000 coronavirus cases with local hospitals running out of ICU beds" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/03/suffolk-county-tops-10000-coronavirus-cases-with-local-hospitals-running-out-of-icu-beds/" rel="bookmark" title="Suffolk County tops 10,000 coronavirus cases with local hospitals running out of ICU beds">Suffolk County tops 10,000 coronavirus cases with local hospitals running out of ICU beds</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/03/coronavirus-scams-prey-on-anxious-residents-promising-fake-cures-stimulus-checks/" rel="bookmark" class="td-image-wrap" title="Coronavirus scams prey on anxious residents promising fake cures, stimulus checks"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/03/2018_0311_smart_phone.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Coronavirus scams prey on anxious residents promising fake cures, stimulus checks" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/03/coronavirus-scams-prey-on-anxious-residents-promising-fake-cures-stimulus-checks/" rel="bookmark" title="Coronavirus scams prey on anxious residents promising fake cures, stimulus checks">Coronavirus scams prey on anxious residents promising fake cures, stimulus checks</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/03/town-board-cda-meetings-tuesday-will-be-held-behind-closed-doors-due-to-coronavirus-pandemic/" rel="bookmark" class="td-image-wrap" title="Town board, CDA meetings Tuesday will be held behind closed doors due to coronavirus pandemic"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Riverhead-Town-Hall-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Town board, CDA meetings Tuesday will be held behind closed doors due to coronavirus pandemic" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/03/town-board-cda-meetings-tuesday-will-be-held-behind-closed-doors-due-to-coronavirus-pandemic/" rel="bookmark" title="Town board, CDA meetings Tuesday will be held behind closed doors due to coronavirus pandemic">Town board, CDA meetings Tuesday will be held behind closed doors due to coronavirus pandemic</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/02/riverhead-suffolk-libraries-use-3d-printers-to-make-face-shields-for-local-hospitals-battling-equipment-shortages/" rel="bookmark" class="td-image-wrap" title="Riverhead, Suffolk libraries use 3D printers to make face shields for local hospitals battling equipment shortages"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_3d_printers_face_masks_library.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_3d_printers_face_masks_library.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_3d_printers_face_masks_library.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_3d_printers_face_masks_library.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_3d_printers_face_masks_library.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_3d_printers_face_masks_library.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_3d_printers_face_masks_library.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_3d_printers_face_masks_library.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead, Suffolk libraries use 3D printers to make face shields for local hospitals battling equipment shortages" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/02/riverhead-suffolk-libraries-use-3d-printers-to-make-face-shields-for-local-hospitals-battling-equipment-shortages/" rel="bookmark" title="Riverhead, Suffolk libraries use 3D printers to make face shields for local hospitals battling equipment shortages">Riverhead, Suffolk libraries use 3D printers to make face shields for local hospitals battling equipment shortages</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/02/suffolk-coronavirus-cases-increase-by-1000-in-24-hours-long-island-numbers-are-troubling-news-cuomo-says/" rel="bookmark" class="td-image-wrap" title="Suffolk coronavirus cases increase by 1,000+ in 24 hours, Long Island numbers are &#8216;troubling news,&#8217; Cuomo says"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=1832%2C1374&#038;quality=100&#038;ssl=1 1832w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=1376%2C1032&#038;quality=100&#038;ssl=1 1376w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/AdobeStock_206584658-scaled.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Suffolk coronavirus cases increase by 1,000+ in 24 hours, Long Island numbers are &#8216;troubling news,&#8217; Cuomo says" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/02/suffolk-coronavirus-cases-increase-by-1000-in-24-hours-long-island-numbers-are-troubling-news-cuomo-says/" rel="bookmark" title="Suffolk coronavirus cases increase by 1,000+ in 24 hours, Long Island numbers are &#8216;troubling news,&#8217; Cuomo says">Suffolk coronavirus cases increase by 1,000+ in 24 hours, Long Island numbers are &#8216;troubling news,&#8217; Cuomo says</a></h3> </div>
 </div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_5e87c3a7ab397" id="td_uid_2_5e87c3a7b42c4" data-td_block_id="td_uid_1_5e87c3a7ab397" data-td_filter_value="" href="https://riverheadlocal.com/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_5e87c3a7ab397" id="td_uid_3_5e87c3a7b433d" data-td_block_id="td_uid_1_5e87c3a7ab397" data-td_filter_value="105" href="https://riverheadlocal.com/news/local-news/">Local News</a><a class="mega-menu-sub-cat-td_uid_1_5e87c3a7ab397" id="td_uid_4_5e87c3a7b4397" data-td_block_id="td_uid_1_5e87c3a7ab397" data-td_filter_value="32" href="https://riverheadlocal.com/news/local-news/health/">Health</a><a class="mega-menu-sub-cat-td_uid_1_5e87c3a7ab397" id="td_uid_5_5e87c3a7b4408" data-td_block_id="td_uid_1_5e87c3a7ab397" data-td_filter_value="16007" href="https://riverheadlocal.com/news/local-news/weekly-roundup/">Weekly Roundup</a><a class="mega-menu-sub-cat-td_uid_1_5e87c3a7ab397" id="td_uid_6_5e87c3a7b44f8" data-td_block_id="td_uid_1_5e87c3a7ab397" data-td_filter_value="108" href="https://riverheadlocal.com/news/public-notices/">Public Notices</a><a class="mega-menu-sub-cat-td_uid_1_5e87c3a7ab397" id="td_uid_7_5e87c3a7b457a" data-td_block_id="td_uid_1_5e87c3a7ab397" data-td_filter_value="104" href="https://riverheadlocal.com/news/town-hall-notebook/">Town Hall Notebook</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5e87c3a7ab397" data-td_block_id="td_uid_1_5e87c3a7ab397"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5e87c3a7ab397" data-td_block_id="td_uid_1_5e87c3a7ab397"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100669" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-100669"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Police</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_8_5e87c3a7d4d21 = new tdBlock();
block_td_uid_8_5e87c3a7d4d21.id = "td_uid_8_5e87c3a7d4d21";
block_td_uid_8_5e87c3a7d4d21.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_8_5e87c3a7d4d21_rand","tdc_css_class":"td_uid_8_5e87c3a7d4d21_rand","tdc_css_class_style":"td_uid_8_5e87c3a7d4d21_rand_style"}';
block_td_uid_8_5e87c3a7d4d21.td_column_number = "3";
block_td_uid_8_5e87c3a7d4d21.block_type = "td_block_mega_menu";
block_td_uid_8_5e87c3a7d4d21.post_count = "5";
block_td_uid_8_5e87c3a7d4d21.found_posts = "2405";
block_td_uid_8_5e87c3a7d4d21.header_color = "";
block_td_uid_8_5e87c3a7d4d21.ajax_pagination_infinite_stop = "";
block_td_uid_8_5e87c3a7d4d21.max_num_pages = "481";
tdBlocksArray.push(block_td_uid_8_5e87c3a7d4d21);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_8_5e87c3a7d4d21_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_8_5e87c3a7d4d21"><div id=td_uid_8_5e87c3a7d4d21 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/03/cops-pair-swiped-large-traffic-sign-at-outlet-mall/" rel="bookmark" class="td-image-wrap" title="Cops: Pair swiped large traffic sign at outlet mall"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Empty-Spaces_3_Tanger.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Cops: Pair swiped large traffic sign at outlet mall" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/03/cops-pair-swiped-large-traffic-sign-at-outlet-mall/" rel="bookmark" title="Cops: Pair swiped large traffic sign at outlet mall">Cops: Pair swiped large traffic sign at outlet mall</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/" rel="bookmark" class="td-image-wrap" title="Man involved in high-speed chase that led to police crash is arrested: Southold Police"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Man involved in high-speed chase that led to police crash is arrested: Southold Police" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/" rel="bookmark" title="Man involved in high-speed chase that led to police crash is arrested: Southold Police">Man involved in high-speed chase that led to police crash is arrested: Southold Police</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/01/riverhead-police-officer-seriously-injured-in-crash/" rel="bookmark" class="td-image-wrap" title="Riverhead police officer seriously injured in crash"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=1832%2C1374&#038;quality=100&#038;ssl=1 1832w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=1376%2C1032&#038;quality=100&#038;ssl=1 1376w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0331_Police-MVA_3-scaled.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead police officer seriously injured in crash" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/01/riverhead-police-officer-seriously-injured-in-crash/" rel="bookmark" title="Riverhead police officer seriously injured in crash">Riverhead police officer seriously injured in crash</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/31/riverhead-police-officer-injured-in-crash-on-osborn-avenue/" rel="bookmark" class="td-image-wrap" title="Riverhead police officer injured in crash on Osborn Avenue"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0331_Police-MVA.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0331_Police-MVA.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0331_Police-MVA.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0331_Police-MVA.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0331_Police-MVA.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0331_Police-MVA.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0331_Police-MVA.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0331_Police-MVA.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead police officer injured in crash on Osborn Avenue" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/31/riverhead-police-officer-injured-in-crash-on-osborn-avenue/" rel="bookmark" title="Riverhead police officer injured in crash on Osborn Avenue">Riverhead police officer injured in crash on Osborn Avenue</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/31/police-seek-missing-teen/" rel="bookmark" class="td-image-wrap" title="Police seek missing teen"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0330_Missing-Xiamari-Diaz.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0330_Missing-Xiamari-Diaz.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0330_Missing-Xiamari-Diaz.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0330_Missing-Xiamari-Diaz.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0330_Missing-Xiamari-Diaz.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0330_Missing-Xiamari-Diaz.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0330_Missing-Xiamari-Diaz.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Police seek missing teen" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/31/police-seek-missing-teen/" rel="bookmark" title="Police seek missing teen">Police seek missing teen</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_8_5e87c3a7d4d21" id="td_uid_9_5e87c3a7d89c0" data-td_block_id="td_uid_8_5e87c3a7d4d21" data-td_filter_value="" href="https://riverheadlocal.com/police-fire/">All</a><a class="mega-menu-sub-cat-td_uid_8_5e87c3a7d4d21" id="td_uid_10_5e87c3a7d8a32" data-td_block_id="td_uid_8_5e87c3a7d4d21" data-td_filter_value="42" href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a><a class="mega-menu-sub-cat-td_uid_8_5e87c3a7d4d21" id="td_uid_11_5e87c3a7d8a98" data-td_block_id="td_uid_8_5e87c3a7d4d21" data-td_filter_value="41" href="https://riverheadlocal.com/police-fire/police-blotter/">Police Reports</a><a class="mega-menu-sub-cat-td_uid_8_5e87c3a7d4d21" id="td_uid_12_5e87c3a7d8bc4" data-td_block_id="td_uid_8_5e87c3a7d4d21" data-td_filter_value="43" href="https://riverheadlocal.com/police-fire/riverhead-justice-court/">Riverhead Justice Court</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_8_5e87c3a7d4d21" data-td_block_id="td_uid_8_5e87c3a7d4d21"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_8_5e87c3a7d4d21" data-td_block_id="td_uid_8_5e87c3a7d4d21"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100672" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-100672"><a href="https://riverheadlocal.com/obituaries/">Obituaries</a></li>
<li id="menu-item-100673" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100673"><a href="https://riverheadlocal.com/community/">Community</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_13_5e87c3a7f20f1 = new tdBlock();
block_td_uid_13_5e87c3a7f20f1.id = "td_uid_13_5e87c3a7f20f1";
block_td_uid_13_5e87c3a7f20f1.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"113","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_5e87c3a7f20f1_rand","tdc_css_class":"td_uid_13_5e87c3a7f20f1_rand","tdc_css_class_style":"td_uid_13_5e87c3a7f20f1_rand_style"}';
block_td_uid_13_5e87c3a7f20f1.td_column_number = "3";
block_td_uid_13_5e87c3a7f20f1.block_type = "td_block_mega_menu";
block_td_uid_13_5e87c3a7f20f1.post_count = "5";
block_td_uid_13_5e87c3a7f20f1.found_posts = "3797";
block_td_uid_13_5e87c3a7f20f1.header_color = "";
block_td_uid_13_5e87c3a7f20f1.ajax_pagination_infinite_stop = "";
block_td_uid_13_5e87c3a7f20f1.max_num_pages = "760";
tdBlocksArray.push(block_td_uid_13_5e87c3a7f20f1);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_13_5e87c3a7f20f1_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_5e87c3a7f20f1"><div id=td_uid_13_5e87c3a7f20f1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/02/riverhead-police-officer-injured-in-crash-is-recovering-at-stony-brook-university-hospital/" rel="bookmark" class="td-image-wrap" title="Riverhead police officer injured in crash is recovering at Stony Brook University Hospital"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0402_sproston_robert.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead police officer injured in crash is recovering at Stony Brook University Hospital" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/02/riverhead-police-officer-injured-in-crash-is-recovering-at-stony-brook-university-hospital/" rel="bookmark" title="Riverhead police officer injured in crash is recovering at Stony Brook University Hospital">Riverhead police officer injured in crash is recovering at Stony Brook University Hospital</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/04/01/in-coronavirus-crisis-food-pantries-face-increased-demand-with-depleted-resources/" rel="bookmark" class="td-image-wrap" title="In coronavirus crisis, food pantries face increased demand with depleted resources"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0326_Open_Arms_pantry-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="In coronavirus crisis, food pantries face increased demand with depleted resources" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/04/01/in-coronavirus-crisis-food-pantries-face-increased-demand-with-depleted-resources/" rel="bookmark" title="In coronavirus crisis, food pantries face increased demand with depleted resources">In coronavirus crisis, food pantries face increased demand with depleted resources</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/30/during-coronavirus-school-closures-riverhead-teachers-find-creative-ways-to-cheer-up-students-stuck-at-home/" rel="bookmark" class="td-image-wrap" title="During coronavirus school closures, Riverhead teachers find creative ways to cheer up students stuck at home"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=536%2C400&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="During coronavirus school closures, Riverhead teachers find creative ways to cheer up students stuck at home" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/30/during-coronavirus-school-closures-riverhead-teachers-find-creative-ways-to-cheer-up-students-stuck-at-home/" rel="bookmark" title="During coronavirus school closures, Riverhead teachers find creative ways to cheer up students stuck at home">During coronavirus school closures, Riverhead teachers find creative ways to cheer up students stuck at home</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/28/teachers-spearhead-effort-to-buy-chromebook-computers-for-students/" rel="bookmark" class="td-image-wrap" title="Teachers spearhead effort to buy Chromebook computers for students"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_chromebook.png?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_chromebook.png?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_chromebook.png?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_chromebook.png?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_chromebook.png?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_chromebook.png?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_chromebook.png?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_chromebook.png?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Teachers spearhead effort to buy Chromebook computers for students" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/28/teachers-spearhead-effort-to-buy-chromebook-computers-for-students/" rel="bookmark" title="Teachers spearhead effort to buy Chromebook computers for students">Teachers spearhead effort to buy Chromebook computers for students</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/27/meet-the-local-healthcare-heroes-on-the-front-line-of-the-coronavirus-war/" rel="bookmark" class="td-image-wrap" title="Meet the local healthcare heroes on the front line of the coronavirus war"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0327_PBMC-nurses-1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Meet the local healthcare heroes on the front line of the coronavirus war" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/27/meet-the-local-healthcare-heroes-on-the-front-line-of-the-coronavirus-war/" rel="bookmark" title="Meet the local healthcare heroes on the front line of the coronavirus war">Meet the local healthcare heroes on the front line of the coronavirus war</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_5e87c3a7f20f1" id="td_uid_14_5e87c3a803244" data-td_block_id="td_uid_13_5e87c3a7f20f1" data-td_filter_value="" href="https://riverheadlocal.com/community/">All</a><a class="mega-menu-sub-cat-td_uid_13_5e87c3a7f20f1" id="td_uid_15_5e87c3a8032b0" data-td_block_id="td_uid_13_5e87c3a7f20f1" data-td_filter_value="128" href="https://riverheadlocal.com/community/announcements/">Announcements</a><a class="mega-menu-sub-cat-td_uid_13_5e87c3a7f20f1" id="td_uid_16_5e87c3a803347" data-td_block_id="td_uid_13_5e87c3a7f20f1" data-td_filter_value="126" href="https://riverheadlocal.com/community/community-news/">Community News</a><a class="mega-menu-sub-cat-td_uid_13_5e87c3a7f20f1" id="td_uid_17_5e87c3a80339e" data-td_block_id="td_uid_13_5e87c3a7f20f1" data-td_filter_value="127" href="https://riverheadlocal.com/community/event-photos/">Event Photos</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_5e87c3a7f20f1" data-td_block_id="td_uid_13_5e87c3a7f20f1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_5e87c3a7f20f1" data-td_block_id="td_uid_13_5e87c3a7f20f1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100674" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100674"><a href="https://riverheadlocal.com/schools/">Schools</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_18_5e87c3a81ba19 = new tdBlock();
block_td_uid_18_5e87c3a81ba19.id = "td_uid_18_5e87c3a81ba19";
block_td_uid_18_5e87c3a81ba19.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"185","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_5e87c3a81ba19_rand","tdc_css_class":"td_uid_18_5e87c3a81ba19_rand","tdc_css_class_style":"td_uid_18_5e87c3a81ba19_rand_style"}';
block_td_uid_18_5e87c3a81ba19.td_column_number = "3";
block_td_uid_18_5e87c3a81ba19.block_type = "td_block_mega_menu";
block_td_uid_18_5e87c3a81ba19.post_count = "5";
block_td_uid_18_5e87c3a81ba19.found_posts = "1787";
block_td_uid_18_5e87c3a81ba19.header_color = "";
block_td_uid_18_5e87c3a81ba19.ajax_pagination_infinite_stop = "";
block_td_uid_18_5e87c3a81ba19.max_num_pages = "358";
tdBlocksArray.push(block_td_uid_18_5e87c3a81ba19);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_18_5e87c3a81ba19_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_18_5e87c3a81ba19"><div id=td_uid_18_5e87c3a81ba19 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/30/during-coronavirus-school-closures-riverhead-teachers-find-creative-ways-to-cheer-up-students-stuck-at-home/" rel="bookmark" class="td-image-wrap" title="During coronavirus school closures, Riverhead teachers find creative ways to cheer up students stuck at home"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?resize=536%2C400&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_aquebogue_signs.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="During coronavirus school closures, Riverhead teachers find creative ways to cheer up students stuck at home" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/30/during-coronavirus-school-closures-riverhead-teachers-find-creative-ways-to-cheer-up-students-stuck-at-home/" rel="bookmark" title="During coronavirus school closures, Riverhead teachers find creative ways to cheer up students stuck at home">During coronavirus school closures, Riverhead teachers find creative ways to cheer up students stuck at home</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/30/governor-postpones-may-school-board-elections-until-at-least-june-1/" rel="bookmark" class="td-image-wrap" title="School board elections postponed by governor until &#8216;at least June 1&#8217;"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?w=640&#038;quality=100&#038;ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/05/2018_0513_budget_vote_sign_RHS-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="School board elections postponed by governor until &#8216;at least June 1&#8217;" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/30/governor-postpones-may-school-board-elections-until-at-least-june-1/" rel="bookmark" title="School board elections postponed by governor until &#8216;at least June 1&#8217;">School board elections postponed by governor until &#8216;at least June 1&#8217;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/30/two-more-riverhead-school-employees-test-positive-for-coronavirus-district-will-no-longer-report-individual-cases-to-parents/" rel="bookmark" class="td-image-wrap" title="Two more Riverhead school employees test positive for coronavirus, district will no longer report individual cases to parents"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2019/10/2019_1027_Pulaski-Street-School-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Two more Riverhead school employees test positive for coronavirus, district will no longer report individual cases to parents" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/30/two-more-riverhead-school-employees-test-positive-for-coronavirus-district-will-no-longer-report-individual-cases-to-parents/" rel="bookmark" title="Two more Riverhead school employees test positive for coronavirus, district will no longer report individual cases to parents">Two more Riverhead school employees test positive for coronavirus, district will no longer report individual cases to parents</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/24/riverhead-school-board-to-conduct-virtual-meeting-this-afternoon/" rel="bookmark" class="td-image-wrap" title="Riverhead school board to conduct &#8216;virtual&#8217; meeting Tuesday afternoon"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Riverhead_school_district_offices_RCSD-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Riverhead_school_district_offices_RCSD-1.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Riverhead_school_district_offices_RCSD-1.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Riverhead_school_district_offices_RCSD-1.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Riverhead_school_district_offices_RCSD-1.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Riverhead_school_district_offices_RCSD-1.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Riverhead_school_district_offices_RCSD-1.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2017/04/2017_0424_Riverhead_school_district_offices_RCSD-1.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead school board to conduct &#8216;virtual&#8217; meeting Tuesday afternoon" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/24/riverhead-school-board-to-conduct-virtual-meeting-this-afternoon/" rel="bookmark" title="Riverhead school board to conduct &#8216;virtual&#8217; meeting Tuesday afternoon">Riverhead school board to conduct &#8216;virtual&#8217; meeting Tuesday afternoon</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/16/riverhead-school-district-announces-plans-for-meals-academic-work-during-shutdown/" rel="bookmark" class="td-image-wrap" title="Riverhead school district announces plans for meals, academic work during shutdown"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0316_school_cafeteria.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead school district announces plans for meals, academic work during shutdown" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/16/riverhead-school-district-announces-plans-for-meals-academic-work-during-shutdown/" rel="bookmark" title="Riverhead school district announces plans for meals, academic work during shutdown">Riverhead school district announces plans for meals, academic work during shutdown</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_18_5e87c3a81ba19" id="td_uid_19_5e87c3a81f148" data-td_block_id="td_uid_18_5e87c3a81ba19" data-td_filter_value="" href="https://riverheadlocal.com/schools/">All</a><a class="mega-menu-sub-cat-td_uid_18_5e87c3a81ba19" id="td_uid_20_5e87c3a81f1d6" data-td_block_id="td_uid_18_5e87c3a81ba19" data-td_filter_value="187" href="https://riverheadlocal.com/schools/board-of-education/">Board of Education</a><a class="mega-menu-sub-cat-td_uid_18_5e87c3a81ba19" id="td_uid_21_5e87c3a81f290" data-td_block_id="td_uid_18_5e87c3a81ba19" data-td_filter_value="190" href="https://riverheadlocal.com/schools/mcgann-mercy-junior-senior-high-school/">McGann-Mercy Junior-Senior High School</a><a class="mega-menu-sub-cat-td_uid_18_5e87c3a81ba19" id="td_uid_22_5e87c3a81f35c" data-td_block_id="td_uid_18_5e87c3a81ba19" data-td_filter_value="15377" href="https://riverheadlocal.com/schools/peconic-community-school/">Peconic Community School</a><a class="mega-menu-sub-cat-td_uid_18_5e87c3a81ba19" id="td_uid_23_5e87c3a81f421" data-td_block_id="td_uid_18_5e87c3a81ba19" data-td_filter_value="201" href="https://riverheadlocal.com/schools/riverhead-central-school-district/">Riverhead Central School District</a><a class="mega-menu-sub-cat-td_uid_18_5e87c3a81ba19" id="td_uid_24_5e87c3a81f4be" data-td_block_id="td_uid_18_5e87c3a81ba19" data-td_filter_value="199" href="https://riverheadlocal.com/schools/riverhead-central-school-district/aquebogue-elementary-school/">Aquebogue Elementary School</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_5e87c3a81ba19" data-td_block_id="td_uid_18_5e87c3a81ba19"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_18_5e87c3a81ba19" data-td_block_id="td_uid_18_5e87c3a81ba19"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-120667" class="tablet-hidden menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-120667"><a href="https://riverheadlocal.com/business/">Business</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_25_5e87c3a83908c = new tdBlock();
block_td_uid_25_5e87c3a83908c.id = "td_uid_25_5e87c3a83908c";
block_td_uid_25_5e87c3a83908c.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"205","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_25_5e87c3a83908c_rand","tdc_css_class":"td_uid_25_5e87c3a83908c_rand","tdc_css_class_style":"td_uid_25_5e87c3a83908c_rand_style"}';
block_td_uid_25_5e87c3a83908c.td_column_number = "3";
block_td_uid_25_5e87c3a83908c.block_type = "td_block_mega_menu";
block_td_uid_25_5e87c3a83908c.post_count = "5";
block_td_uid_25_5e87c3a83908c.found_posts = "475";
block_td_uid_25_5e87c3a83908c.header_color = "";
block_td_uid_25_5e87c3a83908c.ajax_pagination_infinite_stop = "";
block_td_uid_25_5e87c3a83908c.max_num_pages = "95";
tdBlocksArray.push(block_td_uid_25_5e87c3a83908c);
</script><div class="td_block_wrap td_block_mega_menu td_uid_25_5e87c3a83908c_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_25_5e87c3a83908c"><div id=td_uid_25_5e87c3a83908c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/20/riverhead-distillery-offering-free-hand-sanitizer-to-the-community/" rel="bookmark" class="td-image-wrap" title="Riverhead distillery offering free hand-sanitizer to the community"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0320_Twin_Stills_sanitizer_1-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Riverhead distillery offering free hand-sanitizer to the community" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/20/riverhead-distillery-offering-free-hand-sanitizer-to-the-community/" rel="bookmark" title="Riverhead distillery offering free hand-sanitizer to the community">Riverhead distillery offering free hand-sanitizer to the community</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/20/new-york-orders-more-businesses-closed-barber-shops-nail-salons-haircutters-tattoo-parlors/" rel="bookmark" class="td-image-wrap" title="New York orders more businesses closed: Barber shops, nail salons, haircutters, tattoo parlors"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=1376%2C1032&#038;quality=100&#038;ssl=1 1376w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=1044%2C783&#038;quality=100&#038;ssl=1 1044w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/AdobeStock_296490758-scaled.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="New York orders more businesses closed: Barber shops, nail salons, haircutters, tattoo parlors" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/20/new-york-orders-more-businesses-closed-barber-shops-nail-salons-haircutters-tattoo-parlors/" rel="bookmark" title="New York orders more businesses closed: Barber shops, nail salons, haircutters, tattoo parlors">New York orders more businesses closed: Barber shops, nail salons, haircutters, tattoo parlors</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/19/cooperage-inn-donating-dinners-for-pbmc-command-center-staff-during-coronavirus-crisis/" rel="bookmark" class="td-image-wrap" title="Cooperage Inn donating dinners for PBMC command center  staff during coronavirus crisis"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0319_cooperage_perkins.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Cooperage Inn donating dinners for PBMC command center  staff during coronavirus crisis" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/19/cooperage-inn-donating-dinners-for-pbmc-command-center-staff-during-coronavirus-crisis/" rel="bookmark" title="Cooperage Inn donating dinners for PBMC command center  staff during coronavirus crisis">Cooperage Inn donating dinners for PBMC command center staff during coronavirus crisis</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/19/new-york-waives-mortgage-payments-for-90-days-based-on-hardship/" rel="bookmark" class="td-image-wrap" title="New York waives mortgage payments for 90 days based on hardship"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020-0319-mortgage-payment.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="New York waives mortgage payments for 90 days based on hardship" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/19/new-york-waives-mortgage-payments-for-90-days-based-on-hardship/" rel="bookmark" title="New York waives mortgage payments for 90 days based on hardship">New York waives mortgage payments for 90 days based on hardship</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/18/as-coronavirus-infections-continue-to-surge-new-york-orders-private-business-to-cut-on-site-workforce-by-half/" rel="bookmark" class="td-image-wrap" title="As coronavirus infections continue to surge, New York orders private business to cut on-site workforce by half"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0318_coronavirus_numbers-by-county.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0318_coronavirus_numbers-by-county.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0318_coronavirus_numbers-by-county.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0318_coronavirus_numbers-by-county.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0318_coronavirus_numbers-by-county.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0318_coronavirus_numbers-by-county.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0318_coronavirus_numbers-by-county.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0318_coronavirus_numbers-by-county.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="As coronavirus infections continue to surge, New York orders private business to cut on-site workforce by half" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/18/as-coronavirus-infections-continue-to-surge-new-york-orders-private-business-to-cut-on-site-workforce-by-half/" rel="bookmark" title="As coronavirus infections continue to surge, New York orders private business to cut on-site workforce by half">As coronavirus infections continue to surge, New York orders private business to cut on-site workforce by half</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5e87c3a83908c" data-td_block_id="td_uid_25_5e87c3a83908c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_25_5e87c3a83908c" data-td_block_id="td_uid_25_5e87c3a83908c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100676" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100676"><a href="https://riverheadlocal.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_26_5e87c3a83f538 = new tdBlock();
block_td_uid_26_5e87c3a83f538.id = "td_uid_26_5e87c3a83f538";
block_td_uid_26_5e87c3a83f538.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"81","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_26_5e87c3a83f538_rand","tdc_css_class":"td_uid_26_5e87c3a83f538_rand","tdc_css_class_style":"td_uid_26_5e87c3a83f538_rand_style"}';
block_td_uid_26_5e87c3a83f538.td_column_number = "3";
block_td_uid_26_5e87c3a83f538.block_type = "td_block_mega_menu";
block_td_uid_26_5e87c3a83f538.post_count = "5";
block_td_uid_26_5e87c3a83f538.found_posts = "888";
block_td_uid_26_5e87c3a83f538.header_color = "";
block_td_uid_26_5e87c3a83f538.ajax_pagination_infinite_stop = "";
block_td_uid_26_5e87c3a83f538.max_num_pages = "178";
tdBlocksArray.push(block_td_uid_26_5e87c3a83f538);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_26_5e87c3a83f538_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_26_5e87c3a83f538"><div id=td_uid_26_5e87c3a83f538 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/24/no-information-on-covid-19-in-spanish-is-dangerous-to-all/" rel="bookmark" class="td-image-wrap" title="No local information on COVID-19 for non-English speakers is dangerous to all"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0324_handwashing.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="No local information on COVID-19 for non-English speakers is dangerous to all" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/24/no-information-on-covid-19-in-spanish-is-dangerous-to-all/" rel="bookmark" title="No local information on COVID-19 for non-English speakers is dangerous to all">No local information on COVID-19 for non-English speakers is dangerous to all</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/23/we-need-your-help/" rel="bookmark" class="td-image-wrap" title="We need your help."><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?w=800&#038;quality=100&#038;ssl=1 800w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0323_Riverhead_Local-pitch-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="We need your help." /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/23/we-need-your-help/" rel="bookmark" title="We need your help.">We need your help.</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/22/hunkered-down-waiting-to-hear-that-the-worst-is-over/" rel="bookmark" class="td-image-wrap" title="Hunkered down, waiting to hear that the worst is over"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0321_Route-58-empty-1.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Hunkered down, waiting to hear that the worst is over" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/22/hunkered-down-waiting-to-hear-that-the-worst-is-over/" rel="bookmark" title="Hunkered down, waiting to hear that the worst is over">Hunkered down, waiting to hear that the worst is over</a></h3> </div>
</div>
 </div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/19/2020-0318-thompson-op-ed/" rel="bookmark" class="td-image-wrap" title="Graduation requirements should address relevant skills for all students"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/2017_0624_Riverhead_graduation-38.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/2017_0624_Riverhead_graduation-38.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/2017_0624_Riverhead_graduation-38.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/2017_0624_Riverhead_graduation-38.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/2017_0624_Riverhead_graduation-38.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/2017_0624_Riverhead_graduation-38.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/2017_0624_Riverhead_graduation-38.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2017/06/2017_0624_Riverhead_graduation-38.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Graduation requirements should address relevant skills for all students" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/19/2020-0318-thompson-op-ed/" rel="bookmark" title="Graduation requirements should address relevant skills for all students">Graduation requirements should address relevant skills for all students</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/18/gershon-leadership-in-a-crisis/" rel="bookmark" class="td-image-wrap" title="Gershon: Leadership in a crisis"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/08/2018_0813_Perry_Gershon.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/08/2018_0813_Perry_Gershon.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/08/2018_0813_Perry_Gershon.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/08/2018_0813_Perry_Gershon.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/08/2018_0813_Perry_Gershon.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/08/2018_0813_Perry_Gershon.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/08/2018_0813_Perry_Gershon.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2018/08/2018_0813_Perry_Gershon.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Gershon: Leadership in a crisis" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/18/gershon-leadership-in-a-crisis/" rel="bookmark" title="Gershon: Leadership in a crisis">Gershon: Leadership in a crisis</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_26_5e87c3a83f538" id="td_uid_27_5e87c3a841a0f" data-td_block_id="td_uid_26_5e87c3a83f538" data-td_filter_value="" href="https://riverheadlocal.com/opinion/">All</a><a class="mega-menu-sub-cat-td_uid_26_5e87c3a83f538" id="td_uid_28_5e87c3a841aa5" data-td_block_id="td_uid_26_5e87c3a83f538" data-td_filter_value="91" href="https://riverheadlocal.com/opinion/civiletti/">Denise Civiletti</a><a class="mega-menu-sub-cat-td_uid_26_5e87c3a83f538" id="td_uid_29_5e87c3a841b42" data-td_block_id="td_uid_26_5e87c3a83f538" data-td_filter_value="12894" href="https://riverheadlocal.com/opinion/greg-blass/">Greg Blass</a><a class="mega-menu-sub-cat-td_uid_26_5e87c3a83f538" id="td_uid_30_5e87c3a841bd8" data-td_block_id="td_uid_26_5e87c3a83f538" data-td_filter_value="99" href="https://riverheadlocal.com/opinion/in-my-opinion/">In My Opinion</a><a class="mega-menu-sub-cat-td_uid_26_5e87c3a83f538" id="td_uid_31_5e87c3a841c6d" data-td_block_id="td_uid_26_5e87c3a83f538" data-td_filter_value="98" href="https://riverheadlocal.com/opinion/java-scripts/">Java Scripts</a><a class="mega-menu-sub-cat-td_uid_26_5e87c3a83f538" id="td_uid_32_5e87c3a841d4c" data-td_block_id="td_uid_26_5e87c3a83f538" data-td_filter_value="16086" href="https://riverheadlocal.com/opinion/katie-blasl/">Katie Blasl</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_26_5e87c3a83f538" data-td_block_id="td_uid_26_5e87c3a83f538"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_26_5e87c3a83f538" data-td_block_id="td_uid_26_5e87c3a83f538"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-100677" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-100677"><a href="https://riverheadlocal.com/living/">Living</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><script>var block_td_uid_33_5e87c3a860eea = new tdBlock();
block_td_uid_33_5e87c3a860eea.id = "td_uid_33_5e87c3a860eea";
block_td_uid_33_5e87c3a860eea.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9530","show_child_cat":5,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_33_5e87c3a860eea_rand","tdc_css_class":"td_uid_33_5e87c3a860eea_rand","tdc_css_class_style":"td_uid_33_5e87c3a860eea_rand_style"}';
block_td_uid_33_5e87c3a860eea.td_column_number = "3";
block_td_uid_33_5e87c3a860eea.block_type = "td_block_mega_menu";
block_td_uid_33_5e87c3a860eea.post_count = "5";
block_td_uid_33_5e87c3a860eea.found_posts = "567";
block_td_uid_33_5e87c3a860eea.header_color = "";
block_td_uid_33_5e87c3a860eea.ajax_pagination_infinite_stop = "";
block_td_uid_33_5e87c3a860eea.max_num_pages = "114";
tdBlocksArray.push(block_td_uid_33_5e87c3a860eea);
</script> <script>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</script>
<div class="td_block_wrap td_block_mega_menu td_uid_33_5e87c3a860eea_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_33_5e87c3a860eea"><div id=td_uid_33_5e87c3a860eea class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/29/heroes-and-hope-in-a-pandemic/" rel="bookmark" class="td-image-wrap" title="Heroes and hope in a pandemic"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?w=1024&#038;quality=100&#038;ssl=1 1024w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=270%2C203&#038;quality=100&#038;ssl=1 270w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=768%2C576&#038;quality=100&#038;ssl=1 768w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=560%2C420&#038;quality=100&#038;ssl=1 560w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=640%2C480&#038;quality=100&#038;ssl=1 640w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=681%2C511&#038;quality=100&#038;ssl=1 681w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0328_HOPE-by-Johanna.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Heroes and hope in a pandemic" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/29/heroes-and-hope-in-a-pandemic/" rel="bookmark" title="Heroes and hope in a pandemic">Heroes and hope in a pandemic</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/21/know-and-take-care-of-yourself/" rel="bookmark" class="td-image-wrap" title="Know — and take care of — yourself"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2019/11/2019_1108_bits_and_pieces.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Know — and take care of — yourself" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/21/know-and-take-care-of-yourself/" rel="bookmark" title="Know — and take care of — yourself">Know — and take care of — yourself</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/15/with-coronavirus-the-reality-for-those-in-the-vulnerable-20-is-very-different/" rel="bookmark" class="td-image-wrap" title="With coronavirus, the reality for those in the vulnerable 20% is very different"><img width="180" height="135" class="entry-thumb" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?resize=632%2C474&#038;quality=100&#038;ssl=1 632w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2020_0315_woman_beach_sunset.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="With coronavirus, the reality for those in the vulnerable 20% is very different" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/15/with-coronavirus-the-reality-for-those-in-the-vulnerable-20-is-very-different/" rel="bookmark" title="With coronavirus, the reality for those in the vulnerable 20% is very different">With coronavirus, the reality for those in the vulnerable 20% is very different</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/03/01/rare-indeed-the-hidden-gifts-of-belonging-to-a-club-no-parent-wants-to-join/" rel="bookmark" class="td-image-wrap" title="Rare indeed: the hidden gifts of belonging to a club no parent wants to join"><img width="180" height="135" class="entry-thumb" src="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2019_0901_LOP_Jamesport_5K-FB.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2019_0901_LOP_Jamesport_5K-FB.jpg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2019_0901_LOP_Jamesport_5K-FB.jpg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2019_0901_LOP_Jamesport_5K-FB.jpg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2019_0901_LOP_Jamesport_5K-FB.jpg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2019_0901_LOP_Jamesport_5K-FB.jpg?resize=470%2C354&#038;quality=100&#038;ssl=1 470w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2019_0901_LOP_Jamesport_5K-FB.jpg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w, https://i0.wp.com/riverheadlocal.com/wp-content/uploads/2020/03/2019_0901_LOP_Jamesport_5K-FB.jpg?zoom=3&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Rare indeed: the hidden gifts of belonging to a club no parent wants to join" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/03/01/rare-indeed-the-hidden-gifts-of-belonging-to-a-club-no-parent-wants-to-join/" rel="bookmark" title="Rare indeed: the hidden gifts of belonging to a club no parent wants to join">Rare indeed: the hidden gifts of belonging to a club no parent wants to join</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://riverheadlocal.com/2020/02/16/life-is-unpredictable-but-how-we-respond-to-life-is-within-our-control/" rel="bookmark" class="td-image-wrap" title="Life is unpredictable, but how we respond to life is within our control"><img width="180" height="135" class="entry-thumb" src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0216_woman_beach.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1" srcset="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0216_woman_beach.jpeg?resize=80%2C60&#038;quality=100&#038;ssl=1 80w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0216_woman_beach.jpeg?resize=100%2C75&#038;quality=100&#038;ssl=1 100w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0216_woman_beach.jpeg?resize=180%2C135&#038;quality=100&#038;ssl=1 180w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0216_woman_beach.jpeg?resize=238%2C178&#038;quality=100&#038;ssl=1 238w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0216_woman_beach.jpeg?resize=536%2C402&#038;quality=100&#038;ssl=1 536w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0216_woman_beach.jpeg?resize=600%2C450&#038;quality=100&#038;ssl=1 600w, https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2020/02/2020_0216_woman_beach.jpeg?zoom=2&#038;resize=180%2C135&#038;quality=100&#038;ssl=1 360w" sizes="(max-width: 180px) 100vw, 180px" alt="" title="Life is unpredictable, but how we respond to life is within our control" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://riverheadlocal.com/2020/02/16/life-is-unpredictable-but-how-we-respond-to-life-is-within-our-control/" rel="bookmark" title="Life is unpredictable, but how we respond to life is within our control">Life is unpredictable, but how we respond to life is within our control</a></h3> </div>
</div>
</div></div></div><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_33_5e87c3a860eea" id="td_uid_34_5e87c3a862f93" data-td_block_id="td_uid_33_5e87c3a860eea" data-td_filter_value="" href="https://riverheadlocal.com/living/">All</a><a class="mega-menu-sub-cat-td_uid_33_5e87c3a860eea" id="td_uid_35_5e87c3a86302a" data-td_block_id="td_uid_33_5e87c3a860eea" data-td_filter_value="100" href="https://riverheadlocal.com/living/bits-and-pieces/">Bits and Pieces</a><a class="mega-menu-sub-cat-td_uid_33_5e87c3a860eea" id="td_uid_36_5e87c3a8630d3" data-td_block_id="td_uid_33_5e87c3a860eea" data-td_filter_value="94" href="https://riverheadlocal.com/living/laurie-nigro/">Laurie Nigro</a><a class="mega-menu-sub-cat-td_uid_33_5e87c3a860eea" id="td_uid_37_5e87c3a8631b9" data-td_block_id="td_uid_33_5e87c3a860eea" data-td_filter_value="38" href="https://riverheadlocal.com/living/life-on-purpose/">Life On Purpose</a></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_33_5e87c3a860eea" data-td_block_id="td_uid_33_5e87c3a860eea"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_33_5e87c3a860eea" data-td_block_id="td_uid_33_5e87c3a860eea"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li id="menu-item-76334" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-76334"><a target="_blank" href="http://eastendlocal.com/events">Events</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://riverheadlocal.com/">
<div role="search" class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
<div class="breaking-menu-wrap">
<div class="menu-coronavirus-container"><ul id="menu-coronavirus" class="breaking-menu sf-menu"><li id="menu-item-134795" class="breaking-main menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-134795"><a href="https://riverheadlocal.com/coronavirus/">Coronavirus</a></li>
<li id="menu-item-134797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134797"><a href="https://riverheadlocal.com/coronavirus/">Live updates</a></li>
<li id="menu-item-134796" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134796"><a href="https://riverheadlocal.com/coronavirus-maps-and-charts/">Maps &#038; Charts</a></li>
<li id="menu-item-134798" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-134798"><a href="https://riverheadlocal.com/coronavirus-businesses-still-open/">What&#8217;s still open?</a></li>
</ul></div> </div>
</div>
</div>
<div class="td-header-row td-header-header">
<div class="td-header-sp-rec">
<div class="td-header-ad-wrap broadstreet banner ">
<div class="kb-header-ad"><span class="text"></span> <div class="textwidget"><broadstreet-zone zone-id="68458" count="1"></broadstreet-zone></div>
</div>
</div> </div>
</div>
</div>
</div><div class="td-container td-post-template-3">
<div class="td-container-border">
<article id="post-134893" class="post-134893 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news tag-featured tag-riverhead-town-police tag-southold-town-police author-denise-civiletti" itemscope itemtype="https://schema.org/Article">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-post-header td-pb-padding-side">
<ul class="td-category"><li class="entry-category"><a href="https://riverheadlocal.com/police-fire/">Police &amp; Fire</a></li><li class="entry-category"><a href="https://riverheadlocal.com/police-fire/breaking-news/">Breaking News</a></li></ul>
<header>
<h1 class="entry-title">Man involved in high-speed chase that led to police crash is arrested: Southold Police</h1>
<p class="td-post-sub-title">Middle Island man, 40, facing burglary and other charges after leading police on high-speed chase Tuesday afternoon</p>
<div class="meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://riverheadlocal.com/author/denise-2/" title="Posts by Denise Civiletti" class="author url fn" rel="author">Denise Civiletti</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-04-03T09:40:19+00:00">Apr 3, 2020, 9:40 am</time></span> </div>
</header>
</div>
</div>
</div> 
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-featured-image"><figure><a href="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?fit=747%2C533&quality=100&ssl=1" data-caption="The vehicle involved in a high-speed chase was abandoned in a downtown Riverhead parking lot Tuesday afternoon. The operator fled on foot. police said. Photo: Stringer News Service"><img width="681" height="486" class="entry-thumb td-modal-image" src="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=681%2C486&quality=100&ssl=1" srcset="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?w=747&quality=100&ssl=1 747w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=270%2C193&quality=100&ssl=1 270w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=589%2C420&quality=100&ssl=1 589w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=640%2C457&quality=100&ssl=1 640w, https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?resize=681%2C486&quality=100&ssl=1 681w" sizes="(max-width: 681px) 100vw, 681px" alt="" title="2020_0403_car chase" /></a><figcaption class="wp-caption-text">The vehicle involved in a high-speed chase was abandoned in a downtown Riverhead parking lot Tuesday afternoon. The operator fled on foot. police said. Photo: Stringer News Service</figcaption></figure></div>
<div class="td-post-content td-pb-padding-side">
<p><em>Updated 4 p.m. </em>— A man Southold Police say led officers on a high-speed chase Tuesday afternoon, resulting in the <a rel="noreferrer noopener" aria-label="crash of a Riverhead Police cruiser (opens in a new tab)" href="https://riverheadlocal.com/2020/04/01/riverhead-police-officer-seriously-injured-in-crash/" target="_blank">crash of a Riverhead Police cruiser</a> that seriously injured an officer, has been arrested by Southold police on multiple charges.
<p>Southold Police charged Alfred A. Cowell, 40, of Middle Island, with Burglary, Unauthorized Use of a Motor Vehicle, Unlawfully Fleeing Police, Reckless Driving, Aggravated Unlicensed Operation of a Motor Vehicle and a number of traffic infractions, according to a press release issued late last night.
<p>Cowell was arrested yesterday after being spotted at a county park by a Suffolk Sheriff’s surveillance unit, Southold Police said.
<p>Sheriff&#8217;s deputies took him into custody and brought him to Riverhead Police Department headquarters, where Southold Town Police placed him under arrest.<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<div class="google-mobile-ad"><ins class="adsbygoogle mobile-only" data-ad-client="ca-pub-6009741394491678" data-ad-slot="1558404070" data-ad-format="auto" data-full-width-responsive="true"></ins></div>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<p>Police said Cowell removed keys from a Greenport home in order to take the resident’s vehicle without permission. The resident notified police and Cowell was spotted by an off-duty Southold police officer who radioed in the location of the vehicle a blue 2020 Nissan Rogue, police said.
<p>A patrol officer saw the vehicle and attempted to stop the vehicle by activating the emergency lights and sirens of his marked police car, according to the press release. Cowell refused to stop and sped away in a westerly direction on Route 48 in Southold, police said.
<p>Other units arrived in the area while Cowell reached speeds over 100 mph and at one point crossed over into the eastbound lane of Route 48 while continuing westbound, nearly colliding with several other vehicles before the pursuit was terminated by a police sergeant, according to the Southold Police press release.
<p>Cowell continued into Riverhead on Sound Avenue, where he was “encountered by State Police,” Southold police said.
<p>Riverhead Police Officer Robert Sproston was responding to Sound Avenue by way of Osborn Avenue, with his emergency lights activated. He was attempting to pass another northbound vehicle on Osborn Avenue when the other vehicle attempted to turn left onto Youngs Avenue. The two vehicles collided and the police cruiser crashed into a fence. Sproston was seriously injured in the accident. He was transported by ambulance to Peconic Bay Medical Center and then flown by Northwell SkyHealth helicopter to Stony Brook University Hospital. <a href="https://riverheadlocal.com/2020/04/02/riverhead-police-officer-injured-in-crash-is-recovering-at-stony-brook-university-hospital/" target="_blank" rel="noreferrer noopener" aria-label="He is recovering there (opens in a new tab)">He is recovering there</a> and listed in serious but stable condition, according to Riverhead Police.<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<div class="google-mobile-ad"><ins class="adsbygoogle mobile-only" data-ad-client="ca-pub-6009741394491678" data-ad-slot="1558404070" data-ad-format="auto" data-full-width-responsive="true"></ins></div>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<p>In a press release Tuesday night, police said the vehicle being pursued turned south onto Doctors Path and continued southbound on Northville Turnpike and then south onto Roanoke Avenue. The operator left the vehicle in the vicinity of the First Street parking lot and fled on foot, police said.
<p>Cowell was held for arraignment due to the felony burglary charge and the victim having requested an order of protection, Southold Police said.
<p>&#8220;This is a fine example of interagency collaboration that ultimately led to the arrest of this suspect whose callous actions caused life-threatening injuries to an officer,&#8221; Suffolk Sheriff Errol Toulon Jr. said. &#8220;I am proud of the deputies for their excellent work and role in bringing this individual to justice.”
<p><strong>Editor&#8217;s note: A criminal charge is an accusation. A person charged with a crime is presumed innocent unless proven guilty in a court of law.</strong>
<div style="height:100px" aria-hidden="true" class="wp-block-spacer"></div>
<div class="kb-member-content-box"><p><strong><span style="font-size:20px; line-height: 40px;">We need your help.</span></strong><br />Now more than ever, the survival of quality local journalism depends on your support. Our community faces unprecedented economic disruption, and the future of many small businesses are under threat, including our own. It takes time and resources to provide this service. We are a small family-owned operation, and we will do everything in our power to keep it going. But today more than ever before, we will depend on your support to continue. <strong><a href="/support-local-journalism">Support RiverheadLOCAL today.</a></strong> You rely on us to stay informed and we depend on you to make our work possible.</p></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
</div> </div>
<footer>
<div class="td-post-source-tags td-pb-padding-side">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://riverheadlocal.com/topic/featured/">featured</a></li><li><a href="https://riverheadlocal.com/topic/riverhead-town-police/">Riverhead Town Police</a></li><li><a href="https://riverheadlocal.com/topic/southold-town-police/">Southold Town police</a></li></ul> </div>
<div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span><div class="td-classic-sharing"><ul><li class="td-classic-twitter" style="overflow: visible;"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/" data-text="Man involved in high-speed chase that led to police crash is arrested: Southold Police" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li class="td-classic-facebook" style="overflow: visible;"><div class="fb-like" data-href="https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/" data-layout="button_count" data-action="like" data-show-faces="false"></div></li></ul></div></div> <div class="author-box-wrap"><a href="https://riverheadlocal.com/author/denise-2/"><img src="https://i2.wp.com/riverheadlocal.com/wp-content/uploads/2018/09/DC-avatar.png?fit=96%2C96&quality=100&ssl=1" width="96" height="96" alt="Denise Civiletti" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://riverheadlocal.com/author/denise-2/">Denise Civiletti</a></span></div><div class="td-author-description">Denise is a veteran local reporter, editor, attorney and former Riverhead Town councilwoman. Her work has been recognized with numerous awards, including investigative reporting and writer of the year awards from the N.Y. Press Association. She is a founder, owner and co-publisher of this website.<a href="/cdn-cgi/l/email-protection#1d797873746e785d6f746b786f75787c7971727e7c71337e7270">Email Denise.</a></div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/civiletti" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Denise Civiletti"></span><meta itemprop="datePublished" content="2020-04-03T09:40:19+00:00"><meta itemprop="dateModified" content="2020-04-03T16:02:23-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://riverheadlocal.com/wp-content/uploads/2017/06/RiverheadLocal_Black_Flat.png"></span><meta itemprop="name" content="RiverheadLOCAL"></span><meta itemprop="headline " content="Man involved in high-speed chase that led to police crash is arrested: Southold Police"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/riverheadlocal.com/wp-content/uploads/2020/04/2020_0403_car-chase.jpg?fit=747%2C533&quality=100&ssl=1"><meta itemprop="width" content="747"><meta itemprop="height" content="533"></span> </footer>
<div class="fb-comments" data-href="https://riverheadlocal.com/2020/04/03/man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police/" data-width="100%" data-mobile="true" data-numposts="10" data-order-by="social" data-colorscheme="light"></div> </div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68459" count="1"></broadstreet-zone></div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="kb-popout-content td-pb-row">
<div class="wpb_wrapper">
<div class="wpb_text_column block-header">
<p>Daily Newsletter</p>
</div>
<div class="wpb_wrapper wpb_text_column td-pb-border-top">
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://riverheadlocal.us6.list-manage.com/subscribe/post?u=47e88a318d72559c43e4b77bc&amp;id=8118172d70" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div class="mc-field-group first-name"><label for="mce-FNAME">First Name </label><br />
<input id="mce-FNAME" class="required" name="FNAME" type="text" value="" /></div>
<div class="mc-field-group last-name"><label for="mce-LNAME">Last Name </label><br />
<input id="mce-LNAME" class="required" name="LNAME" type="text" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_47e88a318d72559c43e4b77bc_8118172d70" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form>
</div>
<p>
</div>
</div>
</div>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
</p>
<div class="google-desktop-ad mobile-hidden"><ins class="adsbygoogle mobile-hidden" data-ad-client="ca-pub-6009741394491678" data-ad-slot="1558404070" data-ad-format="horizontal,rectangle" data-full-width-responsive="true"></ins></div>
<p><script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</aside><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><div class="broadstreet"><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68460" count="1"></broadstreet-zone><broadstreet-zone zone-id="68461" count="1"></broadstreet-zone></div>
</div>
</aside> </div>
</div>
</div> 
</article> 
</div>
</div> 


<div class="td-footer-container td-container td-footer-template-10">
<div class="footer-social-wrap td-social-style2 td-footer-full">
</div>
</div>

<div class="td-sub-footer-container td-container td-container-border ">
<div class="td-pb-row">
<div class="td-pb-span8 td-sub-footer-menu">
<div class="td-pb-padding-side">
<div class="menu-footer1-container"><ul id="menu-footer1" class="td-subfooter-menu"><li id="menu-item-132939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-132939"><a href="https://riverheadlocal.com/copyright-notice/">© 2010-2020 East End Local Media Corp</a></li>
<li id="menu-item-132941" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132941"><a href="https://riverheadlocal.com/about-us/">About Us</a></li>
<li id="menu-item-132940" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132940"><a href="https://riverheadlocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-132944" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132944"><a href="https://riverheadlocal.com/comments-policy/">Comments Policy</a></li>
<li id="menu-item-132945" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132945"><a href="https://riverheadlocal.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
<div class="td-pb-span4 td-sub-footer-copy">
<div class="td-pb-padding-side">
</div>
</div>
</div>
</div>
</div>
</div>
<div class="a2a_kit a2a_kit_size_36 a2a_floating_style a2a_vertical_style" style="left:0px;top:400px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;left:5px;background-color:#ffffff;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Friverheadlocal.com%2F2020%2F04%2F03%2Fman-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police%2F&amp;linkname=Man%20involved%20in%20high-speed%20chase%20that%20led%20to%20police%20crash%20is%20arrested%3A%20Southold%20Police%20%7C%20RiverheadLOCAL" title="Copy Link" rel="nofollow noopener" target="_blank"></a></div><a rel="nofollow" style="display:none;" href="https://riverheadlocal.com/?blackhole=89ac1837fa" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','breaking-news','police-fire','man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["breaking-news","police-fire","man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police","post"],"url":"man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({"useAltZone":767,"altZoneWhitelist":[71281],"networkId":"4821","targets":{"pagetype":["post","not_home_page"],"category":["breaking-news","police-fire","man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police","post"],"url":"man-involved-in-high-speed-chase-that-led-to-police-crash-is-arrested-southold-police"}});
 });</script>

<script type="text/javascript">(function($) {
  $.fn.almComplete = function(alm){
    
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");


      

    var $pageNumber;
    if ($('.kb-alm-wrap-page-3').length) {
        $pageNumber = 3; 
       // console.log("We're on page 3");
    } else if ($('.kb-alm-wrap-page-2').length) {
        $pageNumber = 2;
        // console.log("We're on page 2");
    } else {
        $pageNumber = 1;
        // console.log("We're on page 1");
    }
    
    // Parse FB comments code
    
    var $newContainerString = '.alm-page-' + $pageNumber;
    var $newContainer = $($newContainerString).parent();

    FB.XFBML.parse($newContainer[0]);
    
    // Append alm button to wrapper
    
    var $new_name = '.kb-alm-wrap-page-' + $pageNumber;
    // $('.alm-btn-wrap').detach();
    // $('.alm-btn-wrap').appendTo($new_name);
  
    // console.log("Button moved!");
    
    for ( var i = 0; i < tdSmartSidebar.items.length; i++ ) {
                    if ( 'case_3_bottom_of_content' === tdSmartSidebar.items[ i ].sidebar_state ) {
                        tdSmartSidebar.items[ i ].sidebar_state = 'case_1_fixed_down';
                       //  console.log("fixed down!");
                    }
                }
                
    var base_url = "https://riverheadlocal.com";
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.js" );
    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js" );
//    $.getScript( base_url + "/wp-content/plugins/justified-image-grid/js/jquery-3.1.1.min.js" );

   // console.log("Alm complte!");
   var jigs = jQuery('.justified-image-grid');
    if(jigs.length !== 0){
       jigs.data('justifiedImageGrid').createGallery('resize');
    }
  };
})(jQuery);

(function($) {
  $.fn.almUrlUpdate = function(permalink, type){
      
    $( document.body ).trigger( 'post-load' );
    window.a2a&&a2a.init_all("page");
    
 /*  $( 'body' ).on( 'post-load', function() {
          // Init all uninitiated AddToAny instances
          if ( window.wpa2a ) {
              if ( wpa2a.script_ready ) wpa2a.init();
              wpa2a.script_load();
          }
      } ); 
    // type = From which addon (previous-post | seo)
    // permalink = the updated url
    console.log("URL updated to " + permalink + '- dispatched from the '+ type + ' add-on.'); */
  }; 
})(jQuery);

(function($) {
    $(window).load(function(){
  // $('.alm-btn-wrap').appendTo($('.kb-alm-wrap'));
   // console.log("Button moved!");
});
})(jQuery);</script> 
<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-aJ5TJKLfrG9cB",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-aJ5TJKLfrG9cB.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<link rel='stylesheet' id='photoswipe-style-css' href='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/css/photoswipe4.css?ver=4.1.3' type='text/css' media='all' />
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/wpdialog.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/newsmag-child/js/sticky-kit.js?ver=1.0.6'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/themes/Newsmag/js/tagdiv_theme.min.js?ver=4.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.22'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"9e3caafb09","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.22'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/photoswipe4.min.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/jquery.dotdotdot.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-content/plugins/justified-image-grid/js/justified-image-grid.min.js?ver=3.9.5'></script>
<script type='text/javascript' src='https://1zuv8210sddy2fu0621yu9bt-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://riverheadlocal.com/wp-content/themes/newsmag-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://riverheadlocal.com/wp-content/themes/Newsmag';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202014.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'77146263',post:'134893',tz:'-4',srv:'riverheadlocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '77146263', '134893' ]);
</script>
</body>
</html>